Change log for ruby-excon package in Ubuntu

115 of 15 results
Published in hirsute-proposed on 2021-02-07
ruby-excon (0.79.0-1) unstable; urgency=medium

  * Team upload

  [ Debian Janitor ]
  * Trim trailing whitespace.
  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
    Repository-Browse.

  [ C├ędric Boutillier ]
  * Update team name
  * Add .gitattributes to keep unwanted files out of the source package

  [ Antonio Terceiro ]
  * New upstream version 0.79.0
  * Refresh packaging files with dh-make-ruby
    - debian/control:
      - order fields like dh-make-ruby does
      - bump debhelper compat level to 13
      - Drop explicit dependency on ruby, add ${ruby:Depends}
    - debian/rules:
      - drop old comments produced by old dh-make-ruby
      - install using Rubygems layout
  * Also run rspec tests, reusing upstream's Rakefile
    - the upstream Rakefile is reasonable enough that we can just use it.
    - add new build dependency, needed by test suite: puma
  * debian/control: Depends: drop unused ${shlibs:Depends}
  * debian/patches/04_gemspec-don-t-reference-lib-directory-explicitly.patch:
    make dependency checking under autopkgtest work

 -- Antonio Terceiro <email address hidden>  Sun, 07 Feb 2021 13:04:35 -0300
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-04-24
Published in focal-release on 2020-04-06
Deleted in focal-proposed (Reason: moved to Release)
ruby-excon (0.72.0-2) unstable; urgency=medium

  * Reupload to unstable

 -- Pirate Praveen <email address hidden>  Mon, 30 Mar 2020 21:53:13 +0530

Available diffs

Superseded in focal-release on 2020-04-06
Deleted in focal-proposed on 2020-04-07 (Reason: moved to Release)
ruby-excon (0.60.0-2) unstable; urgency=medium

  * Add patch to fix leftover data with interrupted persistent
    connections. (Fixes: CVE-2019-19779) (Closes: #946904)
  * Add patch to update expired certs
  * Refresh d/patches
  * Fix package wrt cme
  * Add salsa-ci.yml
  * Move debian/watch to gemwatch.debian.net

 -- Utkarsh Gupta <email address hidden>  Sun, 19 Jan 2020 01:47:37 +0530

Available diffs

Superseded in focal-release on 2020-01-19
Obsolete in eoan-release on 2020-12-29
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2018-02-24
Deleted in bionic-proposed (Reason: moved to release)
ruby-excon (0.60.0-1) unstable; urgency=medium

  * New upstream version 0.60.0
  * Bump standards version to 4.1.3 and debhelper compat to 11

 -- Pirate Praveen <email address hidden>  Fri, 23 Feb 2018 20:40:31 +0530

Available diffs

Superseded in bionic-release on 2018-02-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2020-07-10 (Reason: moved to release)
ruby-excon (0.54.0-1) unstable; urgency=medium

  * Team upload
  * New upstream release

 -- Micah Anderson <email address hidden>  Tue, 15 Nov 2016 09:23:26 -0500

Available diffs

Superseded in zesty-release on 2016-11-15
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
ruby-excon (0.49.0-2) unstable; urgency=medium

  * Team upload
  * New Build-Depends: ruby-sinatra-contrib
  * Remove patches/04_disable-test-Excon-redirecting-with-cookie-preser.patch 

 -- Abhijith PA <email address hidden>  Sun, 12 Jun 2016 20:57:00 +0530

Available diffs

Superseded in yakkety-release on 2016-06-14
Deleted in yakkety-proposed on 2016-06-15 (Reason: moved to release)
ruby-excon (0.49.0-1) unstable; urgency=medium

  [ Abhijith PA ]
  * Team upload
  * New upstream release
  * Bump Standards-Version to 3.9.8
  * Refresh patches
  * debian/patches/04_disable-test-Excon-redirecting-with-cookie-preser.patch:
    Disabling a test 

  [ Laurent Bigonville ]                                              
  * Remove myself from the uploaders

 -- Abhijith PA <email address hidden>  Fri, 10 Jun 2016 13:32:58 +0530

Available diffs

Superseded in yakkety-release on 2016-06-12
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
ruby-excon (0.45.1-2) unstable; urgency=medium

  * Re-upload to unstable 

 -- Pirate Praveen <email address hidden>  Tue, 28 Apr 2015 10:22:47 +0530

Available diffs

Superseded in wily-release on 2015-05-06
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
ruby-excon (0.33.0-2) unstable; urgency=medium


  * Team upload
  * Skip local ports reuse tests (Closes: #751037)

 -- Pirate Praveen <email address hidden>  Fri, 27 Jun 2014 20:32:33 +0530

Available diffs

Superseded in utopic-proposed on 2014-06-27
ruby-excon (0.33.0-1) unstable; urgency=low


  * Team upload
  * New upstream release
  * Add unicorn as build dep (Closes: 746079)

 -- Pirate Praveen <email address hidden>  Tue, 20 May 2014 15:01:06 +0530

Available diffs

Superseded in utopic-release on 2014-06-28
Deleted in utopic-proposed on 2014-06-29 (Reason: moved to release)
ruby-excon (0.32.1-1) unstable; urgency=low


  * Team upload
  * New upstream release
  * Build dep on ruby-activesupport instead of ruby-activesupport-3.2

 -- Pirate Praveen <email address hidden>  Mon, 14 Apr 2014 10:58:32 +0530

Available diffs

Superseded in utopic-release on 2014-04-27
Published in trusty-release on 2014-01-14
Deleted in trusty-proposed (Reason: moved to release)
ruby-excon (0.31.0-1) unstable; urgency=low


  * Team upload
  * New upstream release
  * Refresh patches
  * Bump standards version to 3.9.5 (no changes)

 -- Praveen Arimbrathodiyil <email address hidden>  Tue, 14 Jan 2014 18:44:24 +0530

Available diffs

Superseded in trusty-release on 2014-01-14
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
ruby-excon (0.25.1-1) unstable; urgency=low


  * New upstream release

 -- Laurent Bigonville <email address hidden>  Sat, 06 Jul 2013 23:48:43 +0200

Available diffs

Superseded in saucy-release on 2013-07-07
Deleted in saucy-proposed on 2013-07-08 (Reason: moved to release)
ruby-excon (0.21.0-1) unstable; urgency=low


  * Team upload
  * New upstream release
  * std version bunped to 3.9.4
  * Update build dependencies (gem2deb (>= 0.3.0~), rake, ruby-rspec, 
    ruby-chronic, ruby-shindo, ruby-sinatra, ruby-open4, ruby-activesupport,
     ruby-delorean, ruby-eventmachine)
  * debian/patches/02_remove_gemfile_lock.patch: Remove Gemfile.lock
  * debian/patches/03_remove_rubygems_bundler_add_requires_from_gemspec.patch:
    Remove rubygems and bundler, add require lines instead of Bundler.require

 -- Praveen Arimbrathodiyil <email address hidden>  Thu, 16 May 2013 20:49:12 +0530

Available diffs

Superseded in saucy-release on 2013-05-30
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
ruby-excon (0.13.4-1) unstable; urgency=low


  * New upstream release
  * debian/patches/01_use_ca-certificate.patch: Use SSL certificates from
    ca-certificate package
  * debian/control: Recommends ca-certificates package

 -- Laurent Bigonville <email address hidden>  Tue, 17 Apr 2012 17:46:25 +0200
115 of 15 results