ruby-nokogiri 1.6.7.2-3ubuntu0.1 source package in Ubuntu

Changelog

ruby-nokogiri (1.6.7.2-3ubuntu0.1) xenial-security; urgency=medium

  * SECURITY UPDATE: Command injection vulnerability.
    - debian/patches/CVE-2019-5477.patch: prefer File.open to Kernel.open.
    - CVE-2019-5477

 -- Eduardo Barretto <email address hidden>  Mon, 04 Nov 2019 11:28:45 -0300

Upload details

Uploaded by:
Eduardo dos Santos Barretto on 2019-11-04
Uploaded to:
Xenial
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
ruby
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Xenial updates on 2019-11-05 universe ruby
Xenial security on 2019-11-05 universe ruby

Downloads

File Size SHA-256 Checksum
ruby-nokogiri_1.6.7.2.orig.tar.gz 448.9 KiB e5ecc5baaec1095d4a6c6fbf6e18eff115e51b4ff6fc16bfd223f1cad0251347
ruby-nokogiri_1.6.7.2-3ubuntu0.1.debian.tar.xz 7.6 KiB b4d295702c9859c42746eaf69fd54324eb356a1f1229529138dd8205295632d3
ruby-nokogiri_1.6.7.2-3ubuntu0.1.dsc 2.3 KiB 0cc2f044139e53113c9251afa0b2a48d4bb2d14e139190151e86e663c855da55

View changes file

Binary packages built by this source

ruby-nokogiri: HTML, XML, SAX, and Reader parser for Ruby

 Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. It is able to
 search documents via XPath or CSS3 selectors, and is a drop-in replacement
 for Hpricot (though not bug for bug).

ruby-nokogiri-dbgsym: debug symbols for package ruby-nokogiri

 Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. It is able to
 search documents via XPath or CSS3 selectors, and is a drop-in replacement
 for Hpricot (though not bug for bug).