ruby1.8 1.8.7.352-2ubuntu0.3 source package in Ubuntu

Changelog

ruby1.8 (1.8.7.352-2ubuntu0.3) oneiric-security; urgency=low

  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.patch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821
 -- Marc Deslauriers <email address hidden>   Fri, 22 Mar 2013 14:57:47 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2013-03-22
Uploaded to:
Oneiric
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any
Section:
ruby
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
ruby1.8_1.8.7.352.orig.tar.gz 4.7 MiB 0c33f663a10a540ea65677bb755e57a7
ruby1.8_1.8.7.352-2ubuntu0.3.debian.tar.gz 56.1 KiB 20d5cd4518ab9c7e74ee0422f3496cf3
ruby1.8_1.8.7.352-2ubuntu0.3.dsc 2.2 KiB 4bef4a6fe35c7f3678107d8b174ffa33

View changes file

Binary packages built by this source

libruby1.8: No summary available for libruby1.8 in ubuntu oneiric.

No description available for libruby1.8 in ubuntu oneiric.

libruby1.8-dbg: No summary available for libruby1.8-dbg in ubuntu oneiric.

No description available for libruby1.8-dbg in ubuntu oneiric.

libtcltk-ruby1.8: No summary available for libtcltk-ruby1.8 in ubuntu oneiric.

No description available for libtcltk-ruby1.8 in ubuntu oneiric.

ri1.8: No summary available for ri1.8 in ubuntu oneiric.

No description available for ri1.8 in ubuntu oneiric.

ruby1.8: No summary available for ruby1.8 in ubuntu oneiric.

No description available for ruby1.8 in ubuntu oneiric.

ruby1.8-dev: No summary available for ruby1.8-dev in ubuntu oneiric.

No description available for ruby1.8-dev in ubuntu oneiric.

ruby1.8-examples: No summary available for ruby1.8-examples in ubuntu oneiric.

No description available for ruby1.8-examples in ubuntu oneiric.

ruby1.8-full: No summary available for ruby1.8-full in ubuntu oneiric.

No description available for ruby1.8-full in ubuntu oneiric.