Ubuntu

“ruby1.9.1” 1.9.3.0-1ubuntu2.4 source package in Ubuntu

Changelog

ruby1.9.1 (1.9.3.0-1ubuntu2.4) precise-security; urgency=low

  * SECURITY UPDATE: Missing input sanitization of file paths
    - debian/patches/CVE-2012-4522.patch: NUL characters are not
      valid filename characters, so ensure that Ruby strings used for file
      paths do not contain NUL characters. Based on upstream patch.
 -- Tyler Hicks <email address hidden>   Tue, 16 Oct 2012 09:39:05 -0700

Upload details

Uploaded by:
Tyler Hicks on 2012-10-16
Uploaded to:
Precise
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any all
Section:
ruby
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
ruby1.9.1_1.9.3.0.orig.tar.gz 11.7 MiB 8e2fef56185cfbaf29d0c8329fc77c05
ruby1.9.1_1.9.3.0-1ubuntu2.4.debian.tar.gz 55.8 KiB e9fb3742c2ddc67a919e8ea2d93cd7f1
ruby1.9.1_1.9.3.0-1ubuntu2.4.dsc 2.6 KiB 147ff4384f36287b7ade26ec54483480

Binary packages built by this source

libruby1.9.1: Libraries necessary to run Ruby 1.9.1

 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 .
 This package includes the 'libruby-1.9.1' library, necessary to run Ruby 1.9.
 (API version 1.9.1)

libruby1.9.1-dbg: Debugging symbols for Ruby 1.9.1

 Contains debugging symbols for libruby1.9.1.
 .
 This package is provided primarily to provide a backtrace with names
 in a debugger, this makes it somewhat easier to interpret core
 dumps. Most people will not need this package.

libtcltk-ruby1.9.1: Tcl/Tk interface for Ruby 1.9.1

 tcltklib is an extension library for Ruby 1.9.1. It makes Ruby 1.9.1
 programs to be able to use low level interface for the Tcl/Tk.

ri1.9.1: Ruby Interactive reference (for Ruby 1.9.1)

 ri is a command line tool that displays descriptions of built-in Ruby
 methods, classes, and modules. For methods, it shows you the calling
 sequence and a description. For classes and modules, it shows a
 synopsis along with a list of the methods the class or module
 implements.
 .
 This package provides ri command and descriptions about Ruby 1.9.1.
 This package provides the ri documentation for the Ruby 1.9.1 standard library.
 The ri1.9.1 executable itself is in the ruby1.9.1 package.

ruby1.9.1: Interpreter of object-oriented scripting language Ruby

 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 .
 In the name of this package, `1.9.1' indicates the Ruby library
 compatibility version. This package currently provides the `1.9.3'
 branch of Ruby, which is compatible with the `1.9.1' branch.

ruby1.9.1-dev: Header files for compiling extension modules for the Ruby 1.9.1

 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 .
 This package contains the header files and the mkmf library, necessary
 to make extension library for Ruby 1.9.1. It is also required to build
 many gems.

ruby1.9.1-examples: Examples for Ruby 1.9

 This package provides example programs about Ruby 1.9.1.
 .
 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.

ruby1.9.1-full: Ruby 1.9.1 full installation

 For many good reasons, the Ruby programming language is split in many
 small different packages. Installing this package will make sure you have
 all the packages that add up to a full Ruby installation, with the exception
 of the Tcl/Tk bindings for Ruby, which are only recommended.
 .
 This package installs the dependencies for Ruby compatibility version 1.9.1
 (currently Ruby 1.9.3).

ruby1.9.3: Interpreter of object-oriented scripting language Ruby, version 1.9.3

 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 .
 Ruby uses two parallel versioning schemes: the `Ruby library compatibility
 version' (1.9.1 for this package), which is similar to a library SONAME, and
 the `Ruby version' (1.9.3 for this package). Ruby packages in Debian are
 named using the Ruby library compatibility version, which is sometimes
 confusing for users who do not follow Ruby development closely. This package
 depends on the ruby1.9.1 package, and provides compatibility symbolic links
 from 1.9.3 executables and manual pages to their 1.9.1 counterparts.