ruby1.9 1.9.0.2-7 source package in Ubuntu

Changelog

ruby1.9 (1.9.0.2-7) unstable; urgency=low

  * debian/rules: Fixed a FTBFS on hurd-i386: failure of 
    cat /proc/cpuinfo no more stops the build process.
    (Closes: #497737)

ruby1.9 (1.9.0.2-6) unstable; urgency=low

  * Added patches under debian/patches which were backported from the
    upstream and fixed multiple vulnerabilities: 
    - 301_dns_spoofing_r18424.dpatch: fixed DNS spoofing vulnerability 
      in resolv.rb. (CVE-2008-1447)
    - 302_r18220_webrick_DoS.dpatch: fixed DoS vulnerability in WEBrick.
    - 303_r17726_syslog_safeleve4.dpatch: syslog operations should be 
      protected from $SAFE level 4.
    - 304_r17577_trace_var_safeleve4.dpatch: rb_f_trace_var should not
      be allowed at safe level 4.
    - 305_r18496_dl_tain.dpatch: dl doesn't check taintness, so it could 
      allow attackers to call dangerous functions.
    - 306_r17586_methods_called_safelevel13.dpatch: Insecure methods may 
      be called at safe level 1-3.
      (Closes: #494402)
    - 307_r19033_rexml_DoS.dpatch: fixed DoS vulnerability in REXML.
      (CVE-2008-3790) (Closes: #497610)

 -- Jamie Strandboge <email address hidden>   Tue,  14 Oct 2008 16:02:08 +0100

Upload details

Uploaded by:
Jamie Strandboge on 2008-10-14
Uploaded to:
Intrepid
Original maintainer:
akira yamada
Architectures:
any
Section:
interpreters
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
ruby1.9_1.9.0.2.orig.tar.gz 6.1 MiB f6ec21d1e23e36a7a1c17ae838e1c278cd3896715bc65ceee021261c317451e4
ruby1.9_1.9.0.2-7.diff.gz 48.0 KiB 191732e77da78a6751d6b1be95950b2511df0870e2eb321d86aa9d76e8fc3637
ruby1.9_1.9.0.2-7.dsc 1.6 KiB a4a75824840cb072b61f81ce1e4ac052be34ea6a698f99e060d1efb20b71f387

Available diffs

View changes file

Binary packages built by this source

irb1.9: No summary available for irb1.9 in ubuntu intrepid.

No description available for irb1.9 in ubuntu intrepid.

libdbm-ruby1.9: No summary available for libdbm-ruby1.9 in ubuntu intrepid.

No description available for libdbm-ruby1.9 in ubuntu intrepid.

libgdbm-ruby1.9: No summary available for libgdbm-ruby1.9 in ubuntu intrepid.

No description available for libgdbm-ruby1.9 in ubuntu intrepid.

libopenssl-ruby1.9: No summary available for libopenssl-ruby1.9 in ubuntu intrepid.

No description available for libopenssl-ruby1.9 in ubuntu intrepid.

libreadline-ruby1.9: No summary available for libreadline-ruby1.9 in ubuntu intrepid.

No description available for libreadline-ruby1.9 in ubuntu intrepid.

libruby1.9: No summary available for libruby1.9 in ubuntu intrepid.

No description available for libruby1.9 in ubuntu intrepid.

libruby1.9-dbg: No summary available for libruby1.9-dbg in ubuntu intrepid.

No description available for libruby1.9-dbg in ubuntu intrepid.

libtcltk-ruby1.9: No summary available for libtcltk-ruby1.9 in ubuntu intrepid.

No description available for libtcltk-ruby1.9 in ubuntu intrepid.

rdoc1.9: No summary available for rdoc1.9 in ubuntu intrepid.

No description available for rdoc1.9 in ubuntu intrepid.

ri1.9: No summary available for ri1.9 in ubuntu intrepid.

No description available for ri1.9 in ubuntu intrepid.

ruby1.9: No summary available for ruby1.9 in ubuntu intrepid.

No description available for ruby1.9 in ubuntu intrepid.

ruby1.9-dev: No summary available for ruby1.9-dev in ubuntu intrepid.

No description available for ruby1.9-dev in ubuntu intrepid.

ruby1.9-elisp: No summary available for ruby1.9-elisp in ubuntu intrepid.

No description available for ruby1.9-elisp in ubuntu intrepid.

ruby1.9-examples: No summary available for ruby1.9-examples in ubuntu intrepid.

No description available for ruby1.9-examples in ubuntu intrepid.