Ubuntu

“rubygems” 1.8.15-1ubuntu0.1 source package in Ubuntu

Changelog

rubygems (1.8.15-1ubuntu0.1) precise-security; urgency=low

  * SECURITY UPDATE: Add proper handling of SSL connections
    - debian/patches/CVE-2012-2125-2126.patch: Perform certificate
      verification and disallow HTTP->HTTPS redirection. Based on upstream
      patch.
    - CVE-2012-2125
    - CVE-2012-2126
  * debian/control: Add ca-certificates to rubygems depends for certificate
    verification
 -- Tyler Hicks <email address hidden>   Wed, 19 Sep 2012 00:25:16 -0700

Upload details

Uploaded by:
Tyler Hicks on 2012-09-19
Uploaded to:
Precise
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
all
Section:
ruby
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Precise updates on 2012-09-26 main ruby
Precise security on 2012-09-26 main ruby

Builds

Precise: [FULLYBUILT] i386

Downloads

File Size MD5 Checksum
rubygems_1.8.15.orig.tar.gz 245.4 KiB 4e9fc1aa1be60439adf4132250424679
rubygems_1.8.15-1ubuntu0.1.debian.tar.gz 30.7 KiB 313a50b457c2cac2afc06b81966fd8a9
rubygems_1.8.15-1ubuntu0.1.dsc 2.2 KiB 2ea5b34ac5f91febcb6e7230a7e4f9b6

Binary packages built by this source

rubygems: package management framework for Ruby libraries/applications

 This is a way to package Ruby libraries/applications for distribution.
 RubyGems provides the ability to manage concurrent versions of libraries and
 dependencies between those libraries. Using RubyGems, you can:
   * download and install Ruby libraries easily
   * not worry about libraries A and B depending on different versions of
     library C
   * easily remove libraries you no longer use
 .
 This package provides Rubygems for Ruby 1.8. In Ruby 1.9.X, Rubygems is
 provided with the interpreter.

rubygems-doc: Transitional package for rubygems

 This is a transitional package to ease upgrades to the rubygems
 package. It can safely be removed.

rubygems1.8: Transitional package for rubygems

 This is a transitional package to ease upgrades to the rubygems
 package. It can safely be removed.