Scim and m17n

Bug #64011 reported by Omi Azad on 2006-10-04
46
Affects Status Importance Assigned to Milestone
scim-m17n (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: scim-m17n

I'm trying to make Scim to use m17n DB under my Ubuntu Dapper box. Synaptic says it's installed, but I cannot find any m17n im under Scim.

Some other people also post the same: http://www.ubuntuforums.org/showthread.php?t=261434 and http://www.ubuntuforums.org/showthread.php?t=159029

Do you know any solution? This should be sorted before Edgy final.

Ming Hua (minghua) wrote :

This is not a bug in scim-uim. It's due to a version mismatch between m17n-lib and m17n-db, see bug #34851 for some details. It's already fixed in edgy, please test edgy to confirm.

Omi Azad (omi) wrote :

Well bug #34851 is too technical for me understand. However I'll go for installing edgy.

By the way, lost of people are using Dapper. So do you have any suggestion for fixing this manually in Dapper?

Ming Hua (minghua) wrote :

If you don't understand bug #34851, that's okay (it's not very clear after all). But I would appreciate if you can install edgy and test there.

If you can confirm that scim-uim works for edgy, then we can discuss how to fix this in dapper. There are two options: asking for a backport (https://help.ubuntu.com/community/UbuntuBackports); or asking for a stable release update (https://wiki.ubuntu.com/StableReleaseUpdates).

I can help you on these procedures, but I don't have any Ubuntu machine right now, so I need someone to test and make sure scim-uim works on edgy first.

Thanks for your help on this bug.

I'll check it out. But due to bandwidth limitation. I need some time
to download it. I think I can confirm you next week.

Have passions. :)

Ming Hua (minghua) wrote :

As I've written in bug #34851, there may be a solution to this version mismatch problem without need to completely upgrade libm17n.

Omi Azad (omi) wrote :

By this time I sorted the problem with the help of m17n people.

Edit /usr/share/m17n/mdb.dir. Replace the line

 (input-method * "*.mim")

with

 (input-method bn unijoy "bn-unijoy.mim")

and so on. You can include as many lines as you want.

I used bn-unijoy.mim because that is the layout I want to use. Anyone
can write down their layout name replacing bn-unijoy.mim. It's done!

:)

Ming Hua (minghua) wrote :

Has been fixed in edgy long ago.

Changed in scim-m17n:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers