Change log for service-wrapper-java package in Ubuntu

113 of 13 results
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-06-20
Deleted in artful-proposed (Reason: moved to release)
service-wrapper-java (3.5.30-1ubuntu1) artful; urgency=medium

  * Fix as-needed linking in ppc64el and s390x per-arch Makefiles too.

 -- Dimitri John Ledkov <email address hidden>  Tue, 20 Jun 2017 11:23:08 +0100
Superseded in artful-proposed on 2017-06-20
Deleted in zesty-proposed on 2017-06-21 (Reason: Moved to artful-proposed)
service-wrapper-java (3.5.30-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
    - License updated to Community Software License Agreement 1.3
  * Standards-Version updated to 3.9.8
  * Switch to debhelper level 10
  * Use secure Vcs-* URLs

 -- Emmanuel Bourg <email address hidden>  Mon, 19 Dec 2016 13:40:44 +0100
Superseded in artful-release on 2017-06-20
Published in zesty-release on 2016-10-18
Published in yakkety-release on 2016-04-22
Published in xenial-release on 2015-10-22
Published in wily-release on 2015-09-01
Deleted in wily-proposed (Reason: moved to release)
service-wrapper-java (3.5.26-3) unstable; urgency=medium

  * Apply patch to fix FTBFS on ppc and adjust arch list.
    Thank you to Matthias Klose for the patch.  (Closes: #797460)

 -- tony mancill <email address hidden>  Mon, 31 Aug 2015 21:56:13 -0700
Superseded in wily-release on 2015-09-01
Deleted in wily-proposed on 2015-09-03 (Reason: moved to release)
service-wrapper-java (3.5.26-2ubuntu1) wily; urgency=medium

  * Merge with Debian; remaining changes:
    - debian/patches/fix-as-needed-ppc.patch:
      + Fix FTBFS on ppc: "[exec] wrapper.c:(.text+0xd7e8):
        undefined reference to `ceil'".
  * Update architecture list for libservice-wrapper-jni.

Superseded in wily-release on 2015-08-30
Published in vivid-release on 2015-01-04
Deleted in vivid-proposed (Reason: moved to release)
service-wrapper-java (3.5.25-2ubuntu1) vivid; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - debian/patches/fix-as-needed-ppc.patch:
      + Fix FTBFS on ppc: "[exec] wrapper.c:(.text+0xd7e8):
        undefined reference to `ceil'".
 -- Artur Rona <email address hidden>   Sun, 04 Jan 2015 01:29:52 +0100
Superseded in vivid-proposed on 2015-01-04
service-wrapper-java (3.5.25-2) unstable; urgency=medium


  * Correct typo in patch for kfreebsd-x86-32 makefile to resolve build
    failure on kfreebsd.

 -- tony mancill <email address hidden>  Fri, 29 Aug 2014 17:25:49 -0700
Superseded in vivid-release on 2015-01-04
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-11-27
Deleted in trusty-proposed (Reason: moved to release)
service-wrapper-java (3.5.22-2ubuntu1) trusty; urgency=low

  * debian/patches/0001-fix-as-needed-ppc to fix FTBFS on ppc:
    "[exec] wrapper.c:(.text+0xd7e8): undefined reference to `ceil'"
 -- Andreas Moog <email address hidden>   Wed, 27 Nov 2013 23:18:47 +0100
Superseded in trusty-proposed on 2013-11-27
service-wrapper-java (3.5.22-2) unstable; urgency=low


  * Only build for upstram supported architectures. See: #730010
    - amd64 armel armhf i386 ia64 kfreebsd-amd64 kfreebsd-i386 powerpc
  * Add patch for bashisms in daemon.sh script.  (Closes: #670722)

 -- tony mancill <email address hidden>  Thu, 21 Nov 2013 21:23:42 -0800

Available diffs

Superseded in trusty-proposed on 2013-11-22
service-wrapper-java (3.5.22-1) unstable; urgency=low


  * New upstream release.  (Closes: #610374)
    - Thanks to Kill Your TV <email address hidden> for updated packaging.
  * debian/control
    - Build-depend on debhelper >=9, default-jdk.
    - Depend on -headless JDK, hardening-wrapper.
    - Bump Standards-Version to 3.9.5 (no changes).
  * debian/rules
    - Enable build hardening.
    - Tweak for new upstream release.
  * Add javadocs in -doc package.
  * Now allow any arch to be built.
  * Separate preinst scripts for -jni and -java packages.

 -- tony mancill <email address hidden>  Sat, 09 Nov 2013 21:49:53 -0800
Superseded in trusty-release on 2013-11-27
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
service-wrapper-java (3.5.3+repack-0+nmu1) unstable; urgency=medium


  * Non-maintainer upload.
  * Repack upstream source to remove .pc directory (closes: #702790).

 -- Michael Gilbert <email address hidden>  Thu, 21 Mar 2013 05:12:48 +0000

Available diffs

Superseded in raring-release on 2013-03-25
Obsolete in quantal-release on 2015-04-24
service-wrapper-java (3.5.3-4) unstable; urgency=low


  * Fix binary-arch build (Closes: #666309)
  * Update Format in d/copyright.
  * Add patch for --as-needed linker option (Closes: #647355)
    - Thanks to Ilya Barygin <email address hidden>
  * Bump Standards-Version to 3.9.3 (no changes).

 -- tony mancill <email address hidden>  Sun, 01 Apr 2012 17:12:42 -0700
Superseded in quantal-release on 2012-05-18
Published in precise-release on 2011-11-02
service-wrapper-java (3.5.3-3ubuntu1) precise; urgency=low

  * Fix FTBFS with --as-needed linker option.
 -- Ilya Barygin <email address hidden>   Wed, 02 Nov 2011 10:43:03 +0400

Available diffs

Superseded in precise-release on 2011-11-02
service-wrapper-java (3.5.3-3) unstable; urgency=low

  * Set distribution to unstable.
  * Bump standard versions to 3.9.2 (no changes needed)
  * Add build-wrapper-scripts and example wrapper.conf (Closes: #621914)
    - Thanks to Ximim Luo
  * Add Vcs-Git: and Vcs-Browser: fields to debian/control.
  * Remove deprecated build-dep on default-jdk-builddep
  * Remove deprecated JRE/JDK dependency from libservice-wrapper-java
  * Update debian/copyright to DEP5.  Fully quote the upstream license.

113 of 13 results