slamr kernel module not working with kernel 2.6.15

Bug #31640 reported by Laurent Bigonville on 2006-02-16
40
Affects Status Importance Assigned to Milestone
sl-modem (Ubuntu)
High
Rolf Leggewie

Bug Description

Hi,

The slamr kernel module is not working with kernel version 2.6.15.

I get
[4295062.793000] slamr: Unknown symbol class_simple_device_add
[4295062.794000] slamr: Unknown symbol class_simple_destroy
[4295062.794000] slamr: Unknown symbol class_simple_device_remove
[4295062.795000] slamr: Unknown symbol class_simple_create

robos (robos) wrote :

I can confirm this and would advice to escalate this bug to important or something since - well - without this internet isn't possible. And IMHO this is a show-stopper.
I found a thread where someone figured out why it doesn't compile with kernel > 2.6.12:
http://www.linux-on-laptops.com/forum/archive/index.php/t-3.html
This doesn't fully solve the problem for me, there is still a bug in there but I think this is the right direction. Someone should look at this and then contact the smartlink folks and tell them about this too since their package that they distribute on their site also contains this bug...
Robos

Changed in sl-modem:
status: Unconfirmed → Confirmed
Changed in sl-modem:
assignee: nobody → motu
Alwin Garside (yogarine) wrote :

An updated smartlink modem kernel module source tarbal (ver 2.9.11) is available at: http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20051101.tar.gz

The sl-modem-source package should be updated with this version. That package is still using ver 2.9.10 which isn't compatible with Linux kernel 2.6.15.

I also suggest renaming this bug to:
"smartlink kernel module 'slamr' not compatible with kernel 2.6.15"

Dave Love (fx-gnu) wrote :

This seems to be fixed by Debian's version
2.9.9d+e-pre2-5, which looks as though it should
just be synced.

towsonu2003 (towsonu2003) wrote :

3 months and still not fixed...

http://ubuntuforums.org/showthread.php?t=172342

towsonu2003 (towsonu2003) wrote :

For anyone bumping to this bug, a user (Matchless) posted the workaround until this is fixed:

http://ubuntuforums.org/showpost.php?p=1011364&postcount=28

1.Read the ubuntu wiki dialupmodemhowto, the steps below only compliment the wiki and you should have all the preliminaries done as described for the Smartlink modem, but you can omit installing gcc-3.4 as this is not required for dapper. Basically the sl-modem driver has to be installed first and then the sl-modem-daemon. The daemon in the repositories will work after an installation, but the /dev/ttySL0 will not be rewritten and the symlink to /dev/modem will not exist after a reboot. The new daemon found in the debian repos solve this. There was a mention that the daemon now looks for ungrab-winmodem and if you get an error message refering to this, you may need to install as well.
2.Download sl-modem-daemon2.9.9d+e-pre2-5.deb and sl-modem_2.9.9d+e-pre2.orig.tar.gz from the debian website http://packages.debian.org/unstable/...l-modem-daemon. I have found that the slmodem-2.9.11-20051101.tar.gz works better in dapper and this can also be downloaded from the linmodem website http://phep2.technion.ac.il/linmodem...ges/smartlink/.
3.It may also be required that you download and install the ungrab-winmodem from the linmodem website as well.
4.Copy the sl-modem-daemon file to your local repository and update your Packages.gz file, this will allow you to install with Synaptic etc. Or use your favourite way to install a .deb file.
5.Copy the sl-modem_2.9.9+e-pre2.orig.tar.gz ( or preferably the slmodem-2.9.11-20051101.tar.gz) file to your Desktop and right click on it and select “Extract here” and a folder wth the same name will be created with the extracted files on your desktop.
6.Now rename the folder to an easier name such as “slmodem”
7.Open a terminal and cd in to the slmodem folder
8.Type make
9.Type sudo make install
10.Type sudo modprobe slamr
11.Type dmesg | grep slamr
12.Now install sl-modem-daemon2.9.9d+e-pre2-5.deb with Synaptic or in your own favourite way.
13.Use Kppp to query the modem, if this works you are there!
14.Edit /etc/default/sl-modem-daemon to change the line SLMODEMD_COUNTRY= USA to i.e SOUTHAFRICA or your country
15.Type sudo /etc/init.d/sl-modem-daemon restart to restart the daemon.
16.If you do a “Query modem” in Kppp and you will see that your country has changed.
17.It seems as if the Smartlink modems with Netodragon chip MDV92XP does not work, but the ND92XPA chip works.

Thanks for the info. It helps a lot. One suggestion I have is the the
wiki have the actual addresses for these things: For example when someone
clicks on: http://packages.debian.org/unstable/...l-modem-daemon he will
not get sent to an actual webpage. Instead the page is:
http://packages.debian.org/unstable/misc/sl-modem-daemon etc... Thnaks.

>
> 2.Download sl-modem-daemon2.9.9d+e-pre2-5.deb and sl-modem_2.9.9d+e-
> pre2.orig.tar.gz from the debian website
> http://packages.debian.org/unstable/...l-modem-daemon. I have found that
> the slmodem-2.9.11-20051101.tar.gz works better in dapper and this can
> also be downloaded from the linmodem website
> http://phep2.technion.ac.il/linmodem...ges/smartlink/.
>

Joseph Smidt

--
-------------------------------------------------------------
       Joseph Smidt
     <email address hidden>

my bad, I just copy pasted the instructions, totally forgetting that the forum "abreviates" long links...

fixed the wiki links as well. Thanks for letting us know.

Laurent Bigonville (bigon) wrote :

Still not working... Debian has an updated version.. why not syncing?

StefanPotyra (sistpoty) wrote :

Thanks for your help...

I put new versions of sl-modem-source and sl-modem-daemon to http://tiber.tauware.de/~sistpoty/sl-modem/

Could you please test, if this version will work? (I don't have the hardware, so I cannot test these packages).

I also filed an uvf-exception, if everything is fine, there is still a chance of getting this into dapper.

Thx in advance,
    Stefan.

Changed in sl-modem:
assignee: motu → sistpoty
status: Confirmed → Needs Info
Laurent Bigonville (bigon) wrote :

The module can be loaded and everything else seems to works...

StefanPotyra (sistpoty) wrote :

Thanks for checking.

Changed in sl-modem:
status: Needs Info → In Progress
StefanPotyra (sistpoty) wrote :

 sl-modem (2.9.10+2.9.9d+e-pre2-5build1) dapper; urgency=low
 .
   * The weird version number release... this is 2.9.9d+e-pre2-5 from
     debian/unstable (closes: lp#31640).
   * UVF-exception: closes: lp#46851.
 .
 sl-modem (2.9.9d+e-pre2-5) unstable; urgency=low
 .
   * Fix for module compilation with 2.6.16, condition around line
     drivers/st7554.c:1160 (closes: #358267)
 .
 sl-modem (2.9.9d+e-pre2-4) unstable; urgency=medium
 .
   * replaced amrmo_init.c with the version from
     http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20051101.tar.gz
     which has basically the superset of our changes (plus two additional modem
     IDs) but zeroes out the class* method calls since they are "protected" by
     GPL-enforcing kernel macros now (closes: #354216)
   * the above change effectively disables the udev functionality. Send your
     complaints to kernel developers if you need it. Or suggest a better
     solution. For now, a oneliner in /etc/modprobe.d/sl-modem-daemon.modutils
     creates /dev/slamr0.
   * workaround to fix device files that got the wrong owner (660 instead of
     root) during the major number transition in July 2005
 .
 sl-modem (2.9.9d+e-pre2-3) unstable; urgency=medium
 .
   * changed NAME setting for slusb in udev rules
   * fixed slamr class_device_create call (closes: #349305), thanks to
     Gasper Zejn et al.
 .
 sl-modem (2.9.9d+e-pre2-2) unstable; urgency=low
 .
   * added helper module from
     http://phep2.technion.ac.il/linmodems/packages/smartlink/ungrab-winmodem.tar.gz
     to tell the kernel to keep away from unsupported PCI id numbers, installed
     with slamr and pre-installed via modprobe.d script
 .
 sl-modem (2.9.9d+e-pre2-1) unstable; urgency=low
 .
   * New upstream pre-release (closes: #327588)
   * added sv.po from Daniel Nylander (closes: #330436)
   * slmodemd.1 manpage from Erik Schanze (closes: #335369)
   * defining URB_ASYNC_UNLINK if not set, needed by recent kernels
   * applied patch for class/simple_class transition from Gentoo lists with
     some fixes (closes: #325799)
   * changed the MODULE_LICENSE string to "Dual BSD/GPL" since the license
     is actually a BSD license clone (closes: #327545)
   * not including the old hotplug script, merged its code into the init script
     and added an udev rules file to run it. Needs real testing with a
     Smartlink USB modem which I do not have (closes: #338740)
   * disabled the "PCI device grabbing warning" code which caused
     OOpses on 2.6.15
 .
 sl-modem (2.9.9d-7) unstable; urgency=low
 .
   * added alternative debconf-2.0 dependency
   * http://dev.gentoo.org/~genstef/files/slmodem-class-simple-to-class.diff
     added with few modifications though does not solve #325799 yet
   * added patch http://linmodems.technion.ac.il/archive-fifth/msg02217.html
     which AFAICS basically ignores the PCI ID collision caused by the kernel
     source bugs #303844 and #322028 (closes: #321061). Should be fixed in the
     kernel, though.

Changed in sl-modem:
status: In Progress → Fix Committed
StefanPotyra (sistpoty) on 2006-05-28
Changed in sl-modem:
status: Fix Committed → Fix Released
Andre le Roux (alleroux) wrote :

This should also close bug #40824 I will also test later this week and post results. Thanks for the follow up by Stefan and making the debs available on the repos in time for the release.

Andre le Roux (alleroux) wrote :

When using module-assistant an error comes up, but the drivers work if you just carry on. Installation from Synaptic also works. Maybe Stefan can just check if the error is serious, does not need the hardware to check this.
Thanks

StefanPotyra (sistpoty) wrote :

Actually I didn't encounter any problems when using module-assistant (apart from some compiler warnings, which you can safely ignore).

Andre le Roux (alleroux) wrote :

Yes, it was compiler warnings. I will download the final dapper iso this week and then also test on a fresh install.
Thanks

towsonu2003 (towsonu2003) wrote :

> it was compiler warnings

any chance you can copy post them? I'd like to be able to identify (and offer help to) them if I encounter ppl with those warnings + slmodem in ubuntuforums.org

I will do this when I do the clean install on dapper and post. As you
can see I am on dialup and still busy downloading the latest iso. Maybe
it is time to also update the dialupmodem howto's for dapper. I have
softmodems Intel, Conexant and Smartlink and have managed to get all 3
types working on Dapper

towsonu2003 wrote:
>> it was compiler warnings
>>
>
> any chance you can copy post them? I'd like to be able to identify (and
> offer help to) them if I encounter ppl with those warnings + slmodem in
> ubuntuforums.org
>
>

Download full text (14.0 KiB)

Stefan,
            Feedback as promised. to make it easier I have added both Smartlink and Conexant howto's. there is a problem with Smartlink, but the solution is also given, The conexant being old open source could be very usefull if put in the repos.
Howto get Smartlink winmodem working in dapper

Smartlink soft modems work quite well in ubuntu, but some problems have been found and the process below works in Dapper. It also seems as if the Smartlink modems with Netodragon chip MDV92XP do not work, but the ND92XPA chip works with the process below. Also read the ubuntu wiki dialupmodemhowto for details and other methods.
Use Synaptic to ensure that you have all the necessary packages installed for compiling your drivers. This includes build-essential, linux-headers-ARCH (where ARCH is your kernel version and can be found with uname -r in the terminal), fakeroot, module-assistant and debhelper.
Basically the sl-modem-source has to be installed first and then the sl-modem-daemon. It seems as if the latest daemon also looks for ungrab-winmodem so download and install this from the linmodem website.

Method A:

This method uses the latest packages from linmodems and the latest daemon on the Dapper repository or from the Debian repositories and works well.
 1.Download slmodem-2.9.11-20051101.tar.gz from http://phep2.technion.ac.il/linmodems/packages/smartlink/ . This package seems to work better in breezy and dapper and does not give the dialing problem that causes the modem to fail on ATDT and not dial out.
 2.Also download and install the ungrab-winmodem from the http://phep2.technion.ac.il/linmodems/packages/smartlink/. linmodem website by using make and sudo make install.
 3.Copy the sl-modem-2.9.11-20051101.tar.gz file to your Desktop and right click on it and select “Extract here” and a folder wth the same name will be created with the extracted files on your Desktop.
 4.Now rename the folder to an easier name such as “slmodem”
 5.Open a terminal and cd in to the slmodem folder
 6.Type make
 7.Type sudo make install
 8.Type sudo modprobe slamr
 9.Type dmesg | grep slamr
 10.Now enable your repositories and install sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5build1_i386.deb with Synaptic.
 11.Use Kppp to query the modem, if this works you are there!
 12.Edit /etc/default/sl-modem-daemon to change the line SLMODEMD_COUNTRY= USA to i.e SOUTHAFRICA or your country
 13.Type sudo /etc/init.d/sl-modem-daemon restart to restart the daemon.
 14.If you do a “Query modem” in Kppp and you will see that your country has changed.

Method B:

This method uses the latest matched packages from the Debian repositories and did work, but then after an update and installation of other packages suddenly stopped working together. the debian daemon though works well together with the sl-modem-2.9.11-20051101.tar.gz package.
1.Download sl-modem-daemon2.9.9d+e-pre2-5.deb and sl-modem_2.9.9d+e-pre2.orig.tar.gz from the debian website http://packages.debian.org/unstable/misc/sl-modem-daemon.
I have found that the slmodem-2.9.11-20051101.tar.gz works better in dapper and this can also be downloaded from the linmodem website if you want t...

StefanPotyra (sistpoty) wrote :

Thanks for your comments, Andre.

I'm reopening this bug, since the kernel module still seems to make problems with the dapper kernel. I'm also reassigning to motu, since I currently don't have much time, so I hope someone else wants to jump in.

Cheers,
    Stefan

Changed in sl-modem:
assignee: sistpoty → motu
status: Fix Released → Confirmed
Darik Horn (dajhorn) wrote :

The 2.6.17-7 kernel in Edgy has a similar glitch with the sl-modem-source 2.9.10+2.9.9d+e-pre2-5build1 package.

towsonu2003 (towsonu2003) wrote :

> The 2.6.17-7 kernel in Edgy has a similar glitch with the sl-modem-source
> 2.9.10+2.9.9d+e-pre2-5build1 package.

is this reported? it's pretty important.

towsonu2003 (towsonu2003) wrote :

is anyone working on this?

towsonu2003 wrote:
> is anyone working on this?
>
>
I do not think so. I am just an ordinary user and have noticed no
activity lately. Most probably nothing has happened and Edgy will be the
same, unless I missed something

TheOldFellow (theoldfellow) wrote :

It doesn't work with 7.04's kernel either.
In fact Ubuntu doesn't seem to like modems much...
Perhaps everyone at Canonical has broadband, and never leaves the office.
R.

capri99 (capri99) wrote :

On Feisty with kernel 2.6.20-16-server can't compile sl-modem-source Ubuntu version using module-assistant.
The best solution for us was the one that Andre wrote:
https://bugs.launchpad.net/ubuntu/+source/sl-modem/+bug/31640/comments/19 (METHOD A)
Files taken from Linmodems http://phep2.technion.ac.il/linmodems/packages/smartlink/
For slmodem:
http://phep2.technion.ac.il/linmodems/packages/smartlink/slmodem-2.9.11-20070505.tar.gz
For ungrab-winmodem:
http://phep2.technion.ac.il/linmodems/packages/smartlink/ungrab-winmodem-20070505.tar.gz
And proceeding as mentioned in his comment.

Andre le Roux (andreler) wrote :

Yes Smartlink modems do work in Feisty Kernel 2.6.20.16, but the drivers in the repositories still do not work it seems. Here is the method that works http://ubuntuforums.org/showthread.php?t=482046

Hello,

  I prepared a package for the latest upstream release of sl-modem.
  The package can be found on mentors.debian.net:
  - URL: http://mentors.debian.net/debian/pool/non-free/s/sl-modem
  - Source repository: deb-src http://mentors.debian.net/debian unstable main contrib non-free
  - dget http://mentors.debian.net/debian/pool/non-free/s/sl-modem/sl-modem_2.9.11~20080817-1.dsc

  Please test it and report if your bugs got solved and any suggestions you've got.

  Thanks.

--
 أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
  SySDSoft, Inc.
 GPG KeyID: 0x9DCA0B27 (@ subkeys.pgp.net)
 GPG Fingerprint: 087D 3767 8CAC 65B1 8F6C 156E D325 C3C8 9DCA 0B27

Hello,

  For those who need a binary package, I have uploaded the package to my
  PPA (https://launchpad.net/~aelmahmoudy/+archive), also fixed an FTBFS
  for Intrepid. Binary packages for Hardy and Intrepid are available.

--
 أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
  SySDSoft, Inc.
 GPG KeyID: 0x9DCA0B27 (@ subkeys.pgp.net)
 GPG Fingerprint: 087D 3767 8CAC 65B1 8F6C 156E D325 C3C8 9DCA 0B27

Rolf Leggewie (r0lf) wrote :

Is this something that still needs a fix in recent and supported ubuntu releases?

Changed in sl-modem (Ubuntu):
assignee: MOTU (motu) → Rolf Leggewie (r0lf)

Am 09.05.2009 16:03 Uhr, schrieb Rolf Leggewie:
> Is this something that still needs a fix in recent and supported ubuntu
> releases?

I still have the same machine (Thinkpad R31) but have Vector Linux
installed on it.
I will try it with a 9.04 live cd and try to m-a the slmodem module, ok?
Regards
Robos

> ** Changed in: sl-modem (Ubuntu)
> Assignee: MOTU (motu) => Rolf Leggewie (r0lf)
>

Rolf Leggewie (r0lf) wrote :

robos, any news?

robos (robos) wrote :

Am 10.07.2009 12:12 Uhr, schrieb Rolf Leggewie:
> robos, any news?

OK, I forgot about it - remembered it again and thought it had expired.
But since you ask:
What exactly should I do? Is downloading a 9.04 ubuntu live cd, booting
from that, running m-a slamr enough (rough sketch, probably some steps
in between)? Or is more needed? I'm very busy but would spend an hour or
two on the project if that helps.
Regards
Robos

robos (robos) wrote :

Short version: works on 9.04
OK, what I did:
I installed 9.04 desktop on the machine, did _NOT_ update it (too lazy).
Then I installed module-assistant. In m-a I updated, installed the
required packages and chose sl-modem. The download and build worked, as
did the installation of the resulting deb package. Modprobing of slamr
did also work. Since I have no analog telephone jack anymore I cannot
test right now if dialing and data transmission also work, I can try to
do that somewhere if you need this too.
OK? Do you need anything more?
Regards
Robos

Rolf Leggewie (r0lf) wrote :

Thank you for testing. I consider this particular issue fixed now and will close the ticket. If there is anything left to be done, feel free to reopen this or add another ticket.

Changed in sl-modem (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers