sl-modem 2.9.10+2.9.9d+e-pre2-5build1 source package in Ubuntu

Changelog

sl-modem (2.9.10+2.9.9d+e-pre2-5build1) dapper; urgency=low

  * The weird version number release... this is 2.9.9d+e-pre2-5 from
    debian/unstable (closes: lp#31640).
  * UVF-exception: closes: lp#46851.

sl-modem (2.9.9d+e-pre2-5) unstable; urgency=low

  * Fix for module compilation with 2.6.16, condition around line
    drivers/st7554.c:1160 (closes: #358267)

sl-modem (2.9.9d+e-pre2-4) unstable; urgency=medium

  * replaced amrmo_init.c with the version from
    http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20051101.tar.gz
    which has basically the superset of our changes (plus two additional modem
    IDs) but zeroes out the class* method calls since they are "protected" by
    GPL-enforcing kernel macros now (closes: #354216)
  * the above change effectively disables the udev functionality. Send your
    complaints to kernel developers if you need it. Or suggest a better
    solution. For now, a oneliner in /etc/modprobe.d/sl-modem-daemon.modutils
    creates /dev/slamr0.
  * workaround to fix device files that got the wrong owner (660 instead of
    root) during the major number transition in July 2005

sl-modem (2.9.9d+e-pre2-3) unstable; urgency=medium

  * changed NAME setting for slusb in udev rules
  * fixed slamr class_device_create call (closes: #349305), thanks to
    Gasper Zejn et al.

sl-modem (2.9.9d+e-pre2-2) unstable; urgency=low

  * added helper module from
    http://phep2.technion.ac.il/linmodems/packages/smartlink/ungrab-winmodem.tar.gz
    to tell the kernel to keep away from unsupported PCI id numbers, installed
    with slamr and pre-installed via modprobe.d script

sl-modem (2.9.9d+e-pre2-1) unstable; urgency=low

  * New upstream pre-release (closes: #327588)
  * added sv.po from Daniel Nylander (closes: #330436)
  * slmodemd.1 manpage from Erik Schanze (closes: #335369)
  * defining URB_ASYNC_UNLINK if not set, needed by recent kernels
  * applied patch for class/simple_class transition from Gentoo lists with
    some fixes (closes: #325799)
  * changed the MODULE_LICENSE string to "Dual BSD/GPL" since the license
    is actually a BSD license clone (closes: #327545)
  * not including the old hotplug script, merged its code into the init script
    and added an udev rules file to run it. Needs real testing with a
    Smartlink USB modem which I do not have (closes: #338740)
  * disabled the "PCI device grabbing warning" code which caused
    OOpses on 2.6.15

sl-modem (2.9.9d-7) unstable; urgency=low

  * added alternative debconf-2.0 dependency
  * http://dev.gentoo.org/~genstef/files/slmodem-class-simple-to-class.diff
    added with few modifications though does not solve #325799 yet
  * added patch http://linmodems.technion.ac.il/archive-fifth/msg02217.html
    which AFAICS basically ignores the PCI ID collision caused by the kernel
    source bugs #303844 and #322028 (closes: #321061). Should be fixed in the
    kernel, though.

 -- Stefan Potyra <email address hidden>   Sun, 28 May 2006 18:37:09 +0200

Upload details

Uploaded by:
StefanPotyra on 2006-05-28
Uploaded to:
Dapper
Original maintainer:
Eduard Bloch
Architectures:
i386
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
sl-modem_2.9.10+2.9.9d+e-pre2.orig.tar.gz 785.5 KiB b2adf369532fcb0e50bfa30b00c6b158073506b82f02125ab8b1cbc0a5a5d969
sl-modem_2.9.10+2.9.9d+e-pre2-5build1.diff.gz 21.9 KiB 411c56a8aa3debbb6fd094889aef968b7e7b365e5c3ec3802792deddf3912347
sl-modem_2.9.10+2.9.9d+e-pre2-5build1.dsc 679 bytes da3b38583d796fa0561df7b003b82026c579de2cd1aa765b9043b5db28c7e407

View changes file

Binary packages built by this source

sl-modem-daemon: No summary available for sl-modem-daemon in ubuntu feisty.

No description available for sl-modem-daemon in ubuntu feisty.

sl-modem-source: No summary available for sl-modem-source in ubuntu feisty.

No description available for sl-modem-source in ubuntu feisty.