Change log for software-properties package in Ubuntu

175 of 222 results
Published in xenial-updates on 2017-05-17
Deleted in xenial-proposed (Reason: moved to -updates)
software-properties (0.96.20.7) xenial; urgency=medium

  * software-properties-gtk:
    - fix the backend code to set the gnome debconf frontend, without which
      libgtk2-perl goes unused.
    - depend on libgtk2-perl to ensure it's available, since it was not seeded
      on the desktop at release time.  This is only a Recommends: in zesty,
      but we need to ensure this isn't ignored on upgrade.
    LP: #1679784.

 -- Steve Langasek <email address hidden>  Thu, 27 Apr 2017 16:21:42 -0700

Available diffs

Published in trusty-updates on 2017-05-22
Deleted in trusty-proposed (Reason: moved to -updates)
software-properties (0.92.37.8) trusty; urgency=medium

  * software-properties-gtk:
    - fix the backend code to set the gnome debconf frontend, without which
      libgtk2-perl goes unused.
    - depend on libgtk2-perl to ensure it's available, since it was not seeded
      on the desktop at release time.  This is only a Recommends: in zesty,
      but we need to ensure this isn't ignored on upgrade.
    LP: #1679784.

 -- Steve Langasek <email address hidden>  Thu, 27 Apr 2017 16:28:45 -0700

Available diffs

Published in yakkety-updates on 2017-05-04
Deleted in yakkety-proposed (Reason: moved to -updates)
software-properties (0.96.24.7.2) yakkety-security; urgency=medium

  * software-properties-gtk:
    - fix the backend code to set the gnome debconf frontend, without which
      libgtk2-perl goes unused.
    - depend on libgtk2-perl to ensure it's available, since it was not seeded
      on the desktop at release time.  This is only a Recommends: in zesty,
      but we need to ensure this isn't ignored on upgrade.
    LP: #1679784.

 -- Steve Langasek <email address hidden>  Fri, 14 Apr 2017 16:01:47 -0700
Published in artful-release on 2017-04-20
Published in zesty-release on 2017-04-11
Deleted in zesty-proposed (Reason: moved to release)
software-properties (0.96.24.13) zesty; urgency=medium

  * software-properties-gtk: also fix the backend code to set the gnome
    debconf frontend, without which libgtk2-perl goes unused.

 -- Steve Langasek <email address hidden>  Mon, 10 Apr 2017 14:25:17 -0700
Superseded in zesty-proposed on 2017-04-10
software-properties (0.96.24.12) zesty; urgency=medium

  * software-properties-gtk: recommend libgtk2-perl, to ensure we have a
    working debconf frontend when trying to install additional drivers.
    LP: #1679784.

 -- Steve Langasek <email address hidden>  Mon, 10 Apr 2017 14:08:40 -0700

Available diffs

Superseded in yakkety-updates on 2017-05-04
Deleted in yakkety-proposed on 2017-05-05 (Reason: moved to -updates)
software-properties (0.96.24.7.1) yakkety-proposed; urgency=medium

  * Add knowledge of OpenStack releases Ocata, Pike and Queens. (LP: #1670385)

  [ Scott Moser & Dimitri John Ledkov ]
  * When failing to retrieve a GPG key, raise an exception such that
    e.g. add-apt-repository can fail when it did not manage to retrieve a
    GPG key for the shortcut repository. LP: #1532855

 -- Scott Moser <email address hidden>  Mon, 06 Mar 2017 17:15:20 -0500

Available diffs

Superseded in xenial-updates on 2017-05-17
Deleted in xenial-proposed on 2017-05-18 (Reason: moved to -updates)
software-properties (0.96.20.6) xenial; urgency=medium

  * Add knowledge of OpenStack releases Pike and Queens. (LP: #1670385)

  [ Scott Moser & Dimitri John Ledkov ]
  * When failing to retrieve a GPG key, raise an exception such that
    e.g. add-apt-repository can fail when it did not manage to retrieve a
    GPG key for the shortcut repository. LP: #1532855

 -- Scott Moser <email address hidden>  Mon, 06 Mar 2017 16:56:40 -0500

Available diffs

Superseded in zesty-release on 2017-04-11
Deleted in zesty-proposed on 2017-04-12 (Reason: moved to release)
software-properties (0.96.24.11) zesty; urgency=medium

  [Scott Moser]
  * debian/tests/run-tests: use gpg rather than gpg1, and show errors
    (LP: #1670399)
  * debian/tests/control: add gnupg to list of dependencies.

  [Iain Lane]
  * softwareproperties/shortcuts.py: Make add_key() return True. Since r988,
    the return value of add_key() is now used to raise an exception.
    ShortcutHandler.add_key() always succeeds, so should return True. This
    (LP: #1670399)

 -- Scott Moser <email address hidden>  Mon, 06 Mar 2017 12:22:03 -0500
Superseded in zesty-proposed on 2017-03-06
software-properties (0.96.24.10) zesty; urgency=medium

  * Add knowledge of OpenStack releases Pike and Queens. (LP: #1670385)

 -- Scott Moser <email address hidden>  Mon, 06 Mar 2017 10:08:22 -0500

Available diffs

Superseded in zesty-proposed on 2017-03-06
software-properties (0.96.24.9) zesty; urgency=medium

  [ Scott Moser & Dimitri John Ledkov ]
  * When failing to retrieve a GPG key, raise an exception such that
    e.g. add-apt-repository can fail when it did not manage to retrieve a
    GPG key for the shortcut repository. LP: #1532855

 -- Dimitri John Ledkov <email address hidden>  Wed, 01 Mar 2017 17:38:45 +0000

Available diffs

Superseded in xenial-updates on 2017-04-28
Deleted in xenial-proposed on 2017-04-29 (Reason: moved to -updates)
software-properties (0.96.20.5) xenial; urgency=medium

  * cloudarchive: Enable support for the Ocata Ubuntu Cloud Archive on
    16.04 (LP: #1645827).

 -- Corey Bryant <email address hidden>  Tue, 29 Nov 2016 13:49:16 -0500

Available diffs

Superseded in zesty-proposed on 2017-03-01
software-properties (0.96.24.8) zesty; urgency=medium

  * cloudarchive: Enable support for the Ocata Ubuntu Cloud Archive on
    16.04 (LP: #1645827).

 -- Corey Bryant <email address hidden>  Tue, 29 Nov 2016 13:29:35 -0500

Available diffs

Superseded in zesty-release on 2017-03-06
Published in yakkety-release on 2016-09-28
Deleted in yakkety-proposed (Reason: moved to release)
software-properties (0.96.24.7) yakkety; urgency=medium

  [ Dimitri John Ledkov ]
  * Port AptAuth.py from gpg command parsing to apt-key command
    parsing. Simplifies invocations, and allows for proper handling of
    simplified apt-secure(8) implementation with key fragments in
    /etc/apt/trusted.gpg.d. Make the code gnupg1 and gnupg2
    compatible. Display long keyids in the UI (i.e. anti-evil32 keys
    feature). Revert dependency on gnupg1.

  * Fix incorrect owner_name used by launchpad PPA info api. Fix online
    testsuite in python3 and python2. Skip bad SSL test in python2, as
    pycurl no longer raises an exception. Drop python3-pycurl dependency,
    not used in python3 code path nor tests any more.

  [ Jeremy Bicha ]
  * Add gi.require_version("Gtk", "3.0") to silence the warning

  [ Matthias Klumpp ]
  * Drop po/urd.po; it's a duplicate of po/ur.po
  * Fix typo in Additional Drivers .desktop preventing the .desktop from
    being hidden in GNOME and KDE. Also have AppStream ignore it.

 -- Dimitri John Ledkov <email address hidden>  Wed, 21 Sep 2016 12:55:34 +0100

Available diffs

Superseded in yakkety-release on 2016-09-28
Deleted in yakkety-proposed on 2016-09-29 (Reason: moved to release)
software-properties (0.96.24.6) yakkety; urgency=medium

  * softwareproperties/AptAuth.py: use gpg1 to manipulate
    etc/apt/trusted.gpg as that is public gpg1 keyring, not a keybox.
  * Add gnupg1 dependencies.
  * Initialise ~/.gnupg otherwise dirmngr/gnupg-agent fail in the
    autopkgtest.

 -- Dimitri John Ledkov <email address hidden>  Mon, 12 Sep 2016 12:49:15 +0100
Superseded in yakkety-proposed on 2016-09-12
software-properties (0.96.24.5) yakkety; urgency=medium

  * software-properties-common: add depends on dirmngr, such that
    add-apt-repository can fetch keys for PPAs.

 -- Dimitri John Ledkov <email address hidden>  Thu, 08 Sep 2016 10:54:03 +0100

Available diffs

Superseded in yakkety-release on 2016-09-14
Deleted in yakkety-proposed on 2016-09-16 (Reason: moved to release)
software-properties (0.96.24.4) yakkety; urgency=medium

  * add-apt-repository: fix compatibility with keybox gnupg 2.1. LP:
    #1615039

 -- Dimitri John Ledkov <email address hidden>  Thu, 01 Sep 2016 11:25:27 +0100

Available diffs

Superseded in yakkety-release on 2016-09-01
Deleted in yakkety-proposed on 2016-09-02 (Reason: moved to release)
software-properties (0.96.24.3) yakkety; urgency=medium

  * data/gtkbuilder/main.ui: tweak the wording for the enable proposed
    option as suggested on lp: #1604705, extra changes are described on the bug
    but that's more work so that's a first step in the direction

 -- Sebastien Bacher <email address hidden>  Wed, 17 Aug 2016 11:34:26 +0200

Available diffs

Superseded in xenial-updates on 2016-12-12
Deleted in xenial-proposed on 2016-12-14 (Reason: moved to -updates)
software-properties (0.96.20.4) xenial; urgency=medium

  * Do not assume that a distribution adding the PPA of another distribution
    will want the latest series all the time. Instead check if the requested
    codename (that is the codename of the installed distribution) is a valid
    series in launchpad for the distribution the PPA belongs to. This
    essentially enables derivate distributions to carry a different name but
    use the same series name. As long as launchpad knows about the series we
    should be fine even if the constraints are a bit lax.

 -- Harald Sitter <email address hidden>  Fri, 12 Aug 2016 16:12:07 +0200

Available diffs

Superseded in yakkety-release on 2016-08-17
Deleted in yakkety-proposed on 2016-08-18 (Reason: moved to release)
software-properties (0.96.24.2) yakkety; urgency=medium

  * Do not assume that a distribution adding the PPA of another distribution
    will want the latest series all the time. Instead check if the requested
    codename (that is the codename of the installed distribution) is a valid
    series in launchpad for the distribution the PPA belongs to. This
    essentially enables derivate distributions to carry a different name but
    use the same series name. As long as launchpad knows about the series we
    should be fine even if the constraints are a bit lax.

 -- Harald Sitter <email address hidden>  Fri, 12 Aug 2016 13:52:41 +0200

Available diffs

Superseded in xenial-updates on 2016-08-18
Deleted in xenial-proposed on 2016-08-19 (Reason: moved to -updates)
software-properties (0.96.20.3) xenial; urgency=medium

  * softwareproperties/ppa.py:
    - fix exception output when `add-apt-repository` is called with
      an invalid ppa (LP: #1594776)
  * tests/test_shortcuts.py:
    - add network check for tests that require talking to launchpad
      or the cloud archives

 -- Brian Murray <email address hidden>  Fri, 22 Jul 2016 15:27:26 -0700

Available diffs

Superseded in yakkety-release on 2016-08-12
Deleted in yakkety-proposed on 2016-08-14 (Reason: moved to release)
software-properties (0.96.24.1) yakkety; urgency=medium

   * tests/test_shortcuts.py: make the tests python2 compatible.

 -- Brian Murray <email address hidden>  Wed, 13 Jul 2016 12:26:53 -0700
Superseded in yakkety-proposed on 2016-07-13
software-properties (0.96.24) yakkety; urgency=medium

  * tests/test_shortcuts.py: make the tests python2 compatible.

 -- Brian Murray <email address hidden>  Thu, 23 Jun 2016 10:33:47 -0700

Available diffs

Superseded in yakkety-proposed on 2016-06-23
software-properties (0.96.23) yakkety; urgency=medium

  * softwareproperties/ppa.py:
    - fix exception output when `add-apt-repository` is called with
      an invalid ppa (LP: #1594776)
  * tests/test_shortcuts.py:
    - add network check for tests that require talking to launchpad
      or the cloud archives

 -- Michael Vogt <email address hidden>  Wed, 22 Jun 2016 15:42:14 +0200

Available diffs

Superseded in xenial-updates on 2016-08-10
Deleted in xenial-proposed on 2016-08-12 (Reason: moved to -updates)
software-properties (0.96.20.2) xenial; urgency=medium

  * SoftwarePropertiesGtk.py: only add mirror choices if there are mirrors
    available from which to choose. (LP: #1101881)
  * DialogMirror.py: guard against a traceback when get cursor returns None.
    (LP: #1101881)

 -- Brian Murray <email address hidden>  Tue, 21 Jun 2016 12:22:08 -0700

Available diffs

Superseded in yakkety-release on 2016-07-13
Deleted in yakkety-proposed on 2016-07-15 (Reason: moved to release)
software-properties (0.96.22) yakkety; urgency=medium

  * SoftwarePropertiesGtk.py: only add mirror choices if there are mirrors
    available from which to choose. (LP: #1101881)
  * DialogMirror.py: guard against a traceback when get cursor returns None.
    (LP: #1101881)

 -- Brian Murray <email address hidden>  Mon, 20 Jun 2016 11:08:28 -0700

Available diffs

Superseded in xenial-updates on 2016-07-04
Deleted in xenial-proposed on 2016-07-05 (Reason: moved to -updates)
software-properties (0.96.20.1) xenial; urgency=medium

  * cloudarchive: Enable support for the Newton Ubuntu Cloud Archive on
    16.04 (LP: #1591382).

 -- Corey Bryant <email address hidden>  Fri, 10 Jun 2016 17:32:35 -0400

Available diffs

Superseded in yakkety-release on 2016-06-20
Deleted in yakkety-proposed on 2016-06-22 (Reason: moved to release)
software-properties (0.96.21) yakkety; urgency=medium

  * cloudarchive: Enable support for the Newton Ubuntu Cloud Archive on
    16.04 (LP: #1591382).

 -- Corey Bryant <email address hidden>  Fri, 10 Jun 2016 17:22:43 -0400

Available diffs

Superseded in yakkety-release on 2016-06-11
Published in xenial-release on 2016-03-23
Deleted in xenial-proposed (Reason: moved to release)
software-properties (0.96.20) xenial; urgency=medium

  * Add missing pyflakes3 test dependency (got split out recently).

 -- Martin Pitt <email address hidden>  Tue, 22 Mar 2016 08:45:29 +0100

Available diffs

Superseded in xenial-proposed on 2016-03-22
software-properties (0.96.19) xenial; urgency=medium

  * data/gtkbuilder/main.ui:
    - let the new label wrap when needed
  * softwareproperties/SoftwareProperties.py:
    - security upload autoinstallation doesn't require autodownload to
      be on, but check that unattended-upgrade is installed instead

  [ Dustin Kirkland ]
  * debian/control: LP: #831487
    - make unattended-upgrades a 'recommends', rather than a depends,
      such that it can be easily removed, without removing a bunch of
      other useful stuff

 -- Sebastien Bacher <email address hidden>  Wed, 16 Mar 2016 10:04:11 +0100

Available diffs

Superseded in xenial-release on 2016-03-23
Deleted in xenial-proposed on 2016-03-24 (Reason: moved to release)
software-properties (0.96.18) xenial; urgency=medium

  * Create a new tab for developer options and move the proposed source to it.
    Since those updates can create issues they shouldn't be too easy to enable
    nor listed with the standard recommended sources.

 -- Sebastien Bacher <email address hidden>  Tue, 01 Mar 2016 19:52:14 +0100

Available diffs

Superseded in trusty-updates on 2017-05-22
Deleted in trusty-proposed on 2017-05-23 (Reason: moved to -updates)
software-properties (0.92.37.7) trusty-proposed; urgency=medium

  * cloudarchive: Enable support for the Mitaka Ubuntu Cloud Archive on
    14.04 (LP: #1531225).

 -- Corey Bryant <email address hidden>  Tue, 05 Jan 2016 14:31:11 -0500

Available diffs

Superseded in xenial-release on 2016-03-01
Deleted in xenial-proposed on 2016-03-03 (Reason: moved to release)
software-properties (0.96.17) xenial; urgency=medium

  * cloudarchive: Enable support for the Mitaka Ubuntu Cloud Archive on
    14.04 (LP: #1531225).

 -- Corey Bryant <email address hidden>  Tue, 05 Jan 2016 13:08:28 -0500

Available diffs

Superseded in xenial-release on 2016-01-05
Deleted in xenial-proposed on 2016-01-07 (Reason: moved to release)
software-properties (0.96.16) xenial; urgency=medium

  * Reload sources when starting the GTK backend; since changes made by the
    user might otherwise be mangled as the DBus backend keeps running after
    the GUI is terminated. Patch from Sam Segers. (LP: #879943)

 -- Mathieu Trudel-Lapierre <email address hidden>  Mon, 23 Nov 2015 16:17:45 -0500

Available diffs

Superseded in trusty-updates on 2016-01-13
Deleted in trusty-proposed on 2016-01-14 (Reason: moved to -updates)
software-properties (0.92.37.6) trusty-proposed; urgency=medium

  * If a driver package depends on dkms and the correct linux meta package is
    already installed don't uninstall it. (LP: #1506169)

 -- Brian Murray <email address hidden>  Tue, 27 Oct 2015 16:56:42 -0700

Available diffs

Published in vivid-updates on 2015-11-04
Deleted in vivid-proposed (Reason: moved to -updates)
software-properties (0.96.4.1) vivid-proposed; urgency=medium

  * If a driver package depends on dkms and the correct linux meta package is
    already installed don't uninstall it. (LP: #1506169)

 -- Brian Murray <email address hidden>  Tue, 27 Oct 2015 16:49:00 -0700

Available diffs

Published in wily-updates on 2015-11-04
Deleted in wily-proposed (Reason: moved to -updates)
software-properties (0.96.13.1) wily-proposed; urgency=medium

  * If a driver package depends on dkms and the correct linux meta package is
    already installed don't uninstall it. (LP: #1506169)

 -- Brian Murray <email address hidden>  Fri, 23 Oct 2015 10:58:33 -0700

Available diffs

Superseded in xenial-release on 2015-11-23
Deleted in xenial-proposed on 2015-11-25 (Reason: moved to release)
software-properties (0.96.15) xenial; urgency=medium

  [ Barry Warsaw ]
  * In ppa.py, shortcut_handler(), if a ShortcutException occurs, print
    the traceback to stderr and return None to allow other shortcut
    handlers to run.  (LP: #1510558)

 -- Brian Murray <email address hidden>  Tue, 27 Oct 2015 11:25:08 -0700

Available diffs

Superseded in xenial-proposed on 2015-10-27
software-properties (0.96.14) xenial; urgency=medium

  * If a driver package depends on dkms and the correct linux meta package is
    already installed don't uninstall it. (LP: #1506169)

 -- Brian Murray <email address hidden>  Mon, 26 Oct 2015 10:10:32 -0700

Available diffs

Superseded in xenial-release on 2015-10-27
Published in wily-release on 2015-10-14
Deleted in wily-proposed (Reason: moved to release)
software-properties (0.96.13) wily; urgency=medium

  * Properly parse a ppa which has a leading slash, something which a lot of
    people seem use as an argument to add-apt-repository. (LP: #1426933)

 -- Brian Murray <email address hidden>  Tue, 13 Oct 2015 11:31:14 -0700

Available diffs

Superseded in wily-proposed on 2015-10-13
software-properties (0.96.12) wily; urgency=medium

  * Ensure we handle properly unexisting user/team name instead of crashing
    (LP: #1372086)
  * Protect us against invalid ppa format input (LP: #1494965, #1405950)

 -- Didier Roche <email address hidden>  Tue, 13 Oct 2015 11:52:17 +0100

Available diffs

Superseded in wily-release on 2015-10-14
Deleted in wily-proposed on 2015-10-15 (Reason: moved to release)
software-properties (0.96.11) wily; urgency=medium

  * softwareproperties/gtk/DialogCacheOutdated.py :
    - use different variable name in exception, python3 deletes the target
      (lp: #1496293)

 -- Sebastien Bacher <email address hidden>  Mon, 28 Sep 2015 17:38:41 +0200

Available diffs

Superseded in trusty-updates on 2015-11-04
Deleted in trusty-proposed on 2015-11-06 (Reason: moved to -updates)
software-properties (0.92.37.5) trusty-proposed; urgency=medium

  * cloudarchive: Enable support for the Liberty Ubuntu Cloud Archive on
    14.04 (LP: #1472586).
  * Revert SRU changes for "fix importing keys from path with special chars"
    due to verification-failed in trusty-proposed.

 -- Corey Bryant <email address hidden>  Wed, 02 Sep 2015 12:31:11 -0400
Superseded in wily-release on 2015-09-29
Deleted in wily-proposed on 2015-09-30 (Reason: moved to release)
software-properties (0.96.10) wily; urgency=medium

  * cloudarchive: Enable support for the Liberty Ubuntu Cloud Archive on
    14.04 (LP: #1472586).

 -- Corey Bryant <email address hidden>  Wed, 02 Sep 2015 12:35:10 -0400

Available diffs

Superseded in wily-release on 2015-09-02
Deleted in wily-proposed on 2015-09-04 (Reason: moved to release)
software-properties (0.96.9) wily; urgency=medium

  * .assert_called() is not a valid mock method.  This silently passed in
    earlier versions of Python because mocks create attributes on the fly,
    however Python 3.5 throws AttributeErrors when the missing method
    starts with "assert" for exactly this reason.  Use assertTrue() on
    .called instead.
  * debian/control: Bump Standards-Version to 3.9.6.

 -- Barry Warsaw <email address hidden>  Thu, 20 Aug 2015 16:46:12 -0400

Available diffs

Superseded in trusty-proposed on 2015-09-04
software-properties (0.92.37.4) trusty-proposed; urgency=medium

  [ Bruno Nova ]
  * fix importing keys from path with special chars
    (LP: #1381050)
  * fix key drag-and-drop (LP: #1383289)

 -- Michael Vogt <email address hidden>  Tue, 07 Jul 2015 09:53:07 +0200

Available diffs

Superseded in wily-release on 2015-08-20
Deleted in wily-proposed on 2015-08-22 (Reason: moved to release)
software-properties (0.96.8) wily; urgency=medium

  * Fix syntax errors in the KDE frontend.

 -- Iain Lane <email address hidden>  Tue, 16 Jun 2015 12:11:40 +0100

Available diffs

Superseded in wily-proposed on 2015-06-16
software-properties (0.96.7) wily; urgency=low

  [ Matthew Paul Thomas ]
  * lp:~mpt/software-properties/1377742-markup:
    - Factors out Pango markup from translatable strings, to avoid problems
      like LP: #1377742. Also switches to using <small> for alert secondary
      text, rather than <b><big> for primary text.

 -- Michael Vogt <email address hidden>  Fri, 12 Jun 2015 16:26:30 +0200

Available diffs

Superseded in wily-release on 2015-06-16
Deleted in wily-proposed on 2015-06-17 (Reason: moved to release)
software-properties (0.96.6) wily; urgency=medium

  * SoftwareProperties.py: self.options can be None, don't crash if this is
    the case.

 -- Iain Lane <email address hidden>  Fri, 05 Jun 2015 14:05:10 +0100

Available diffs

Superseded in wily-proposed on 2015-06-05
software-properties (0.96.5) wily; urgency=low

  [ Jay R. Wren ]
  * lp:~evarlast/software-properties/support-update:
    - add -u, --update option to apt-add-repository

 -- Michael Vogt <email address hidden>  Tue, 02 Jun 2015 09:40:03 +0200

Available diffs

Superseded in wily-release on 2015-06-05
Published in vivid-release on 2015-01-30
Deleted in vivid-proposed (Reason: moved to release)
software-properties (0.96.4) vivid; urgency=medium

  * data/gtkbuilder/dialog-add.ui: set label width, that's needed with
    the new gtk
 -- Sebastien Bacher <email address hidden>   Fri, 30 Jan 2015 10:49:37 +0100

Available diffs

Superseded in vivid-release on 2015-01-30
Deleted in vivid-proposed on 2015-01-31 (Reason: moved to release)
software-properties (0.96.3) vivid; urgency=medium

  * Add missing dbus-x11 test dependency.
 -- Martin Pitt <email address hidden>   Wed, 28 Jan 2015 11:25:02 +0100

Available diffs

Superseded in trusty-updates on 2015-09-28
Deleted in trusty-proposed on 2015-09-29 (Reason: moved to -updates)
software-properties (0.92.37.3) trusty-proposed; urgency=medium

  * cloudarchive: Enable support for the Kilo Ubuntu Cloud Archive on
    14.04 (LP: #1412465).
 -- James Page <email address hidden>   Mon, 19 Jan 2015 15:08:32 +0000

Available diffs

Superseded in vivid-release on 2015-01-28
Deleted in vivid-proposed on 2015-01-29 (Reason: moved to release)
software-properties (0.96.2) vivid; urgency=medium

  * cloudarchive: Enable support for the Kilo Ubuntu Cloud Archive on
    14.04 (LP: #1412465).
 -- James Page <email address hidden>   Mon, 19 Jan 2015 15:05:10 +0000

Available diffs

Superseded in vivid-release on 2015-01-19
Deleted in vivid-proposed on 2015-01-20 (Reason: moved to release)
software-properties (0.96.1) vivid; urgency=low

  * fix autopkgtest failure
 -- Michael Vogt <email address hidden>   Mon, 01 Dec 2014 08:04:47 +0100

Available diffs

Superseded in vivid-proposed on 2014-12-01
software-properties (0.96) vivid; urgency=medium

  * Port kde ui to Qt 5
 -- Harald Sitter <email address hidden>   Sat, 22 Nov 2014 22:31:27 +0100

Available diffs

Superseded in vivid-proposed on 2014-11-22
software-properties (0.95) vivid; urgency=medium

  [ Sebastien Bacher ]
  * list some extra known keys for translation, thanks feng-kylin
    (lp: #1306494)

  [ Lars Uebernickel ]
  * lp:~larsu/software-properties/fix-wide-dialog:
    - dialog-cache-outofdate: make sure the label is wrapped at ~70
      chars

  [  Bruno Nova ]
  * lp:~brunonova/software-properties/lp1383289:
    - fix dragging a key into the list of keys in the "Authentication"
      tab (LP: 1383289)
  * lp:~brunonova/software-properties/lp1381050:
    - fix import of keys with special chars (LP: #1381050)
 -- Michael Vogt <email address hidden>   Fri, 21 Nov 2014 17:51:26 +0100

Available diffs

Superseded in trusty-updates on 2015-01-28
Deleted in trusty-proposed on 2015-01-29 (Reason: moved to -updates)
software-properties (0.92.37.2) trusty-proposed; urgency=medium

  * cloudarchive: Teach cloud-archive: prefix which Ubuntu Cloud Archive's
    map to which Ubuntu releases, adding support for Juno on 14.04
    (LP: #1350291).
  * cloudarchive: Tidy messages to have correct capitalization.
 -- James Page <email address hidden>   Wed, 15 Oct 2014 17:03:23 +0100

Available diffs

Superseded in vivid-release on 2014-12-01
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
software-properties (0.94) utopic; urgency=medium

  * If adding a PPA from a foreign distribution, use that distribution's
    current series as the codename.
 -- Colin Watson <email address hidden>   Sat, 20 Sep 2014 01:14:22 +0100

Available diffs

Superseded in utopic-release on 2014-09-26
Deleted in utopic-proposed on 2014-09-27 (Reason: moved to release)
software-properties (0.93.2) utopic; urgency=medium

  * Add pyflakes to autopkgtest dependencies.
 -- Colin Watson <email address hidden>   Tue, 16 Sep 2014 21:03:42 +0100

Available diffs

Superseded in utopic-proposed on 2014-09-16
software-properties (0.93.1) utopic; urgency=low

  * fix autopkgtest
 -- Michael Vogt <email address hidden>   Thu, 11 Sep 2014 16:02:21 +0200

Available diffs

Superseded in utopic-proposed on 2014-09-11
software-properties (0.93) utopic; urgency=low

  [ Michael Vogt ]
  * add more tests
  * pyflakes cleanup
  * make PPA suggestions work again by using the LP api
    directly instead of using python-launchpadlib (which is
    not available for py3)

  [ Mathieu Trudel-Lapierre ]
  * support distros like "ubuntu-rtm" in add-apt-repository

  [ James Page ]
  * cloudarchive: Teach cloud-archive: prefix which Ubuntu Cloud Archive's
    map to which Ubuntu releases, adding support for Juno on 14.04
    (LP: #1350291).
  * cloudarchive: Tidy messages to have correct capitalization.
 -- Michael Vogt <email address hidden>   Thu, 11 Sep 2014 11:44:23 +0200

Available diffs

Obsolete in saucy-proposed on 2015-04-24
software-properties (0.92.28.1) saucy-proposed; urgency=medium

  * software-properties-dbus: force C.utf-8 locale if C is used
    to ensure utf-8 support when reading sources.list LP: #1069019
 -- Brian Murray <email address hidden>   Thu, 01 May 2014 09:52:55 -0700

Available diffs

Superseded in utopic-release on 2014-09-16
Deleted in utopic-proposed on 2014-10-29 (Reason: moved to release)
Superseded in trusty-updates on 2014-10-28
Deleted in trusty-proposed on 2014-10-29 (Reason: moved to -updates)
software-properties (0.92.37.1) trusty-proposed; urgency=low

  * software-properties-dbus:
    - do not crash if locale.setlocale() fails (LP: #1314660)
 -- Michael Vogt <email address hidden>   Wed, 30 Apr 2014 16:42:55 +0200

Available diffs

Superseded in utopic-release on 2014-05-16
Deleted in utopic-proposed on 2014-05-17 (Reason: moved to release)
Superseded in trusty-updates on 2014-05-15
Deleted in trusty-proposed on 2014-05-17 (Reason: moved to -updates)
software-properties (0.92.37) trusty-proposed; urgency=low

  * software-properties-dbus: force C.utf-8 locale if C is used
    to ensure utf-8 support when reading sources.list LP: #1069019
 -- Michael Vogt <email address hidden>   Thu, 17 Apr 2014 20:44:08 +0200

Available diffs

Superseded in utopic-release on 2014-04-30
Published in trusty-release on 2014-04-14
Deleted in trusty-proposed (Reason: moved to release)
software-properties (0.92.36) trusty; urgency=medium

  * software-properties-kde : Work around crash in sip by skipping the
    + destructors of SIP objects. (LP: #1307170)
 -- Rohan Garg <email address hidden>   Mon, 14 Apr 2014 11:36:13 +0200

Available diffs

Superseded in trusty-release on 2014-04-14
Deleted in trusty-proposed on 2014-04-15 (Reason: moved to release)
software-properties (0.92.35) trusty; urgency=low

  * Add "Additional Drivers" desktop file for the non {GNOME,Unity,KDE}
    flavors (LP: #1060543) - thanks to Unity193
 -- Michael Vogt <email address hidden>   Fri, 04 Apr 2014 08:30:41 +0200

Available diffs

Superseded in trusty-release on 2014-04-04
Deleted in trusty-proposed on 2014-04-05 (Reason: moved to release)
software-properties (0.92.34) trusty; urgency=medium

  * gnupg version 1.4.16 was changed not to require a trustdb with
    --trust-model set to always
 -- Brian Murray <email address hidden>   Fri, 28 Feb 2014 13:29:58 -0800

Available diffs

Superseded in trusty-proposed on 2014-02-28
software-properties (0.92.33) trusty; urgency=medium

  * The new gtk doesn't wrap label by itself, do that for the drivers text
 -- Sebastien Bacher <email address hidden>   Mon, 10 Feb 2014 16:10:24 +0100

Available diffs

Superseded in trusty-release on 2014-03-06
Deleted in trusty-proposed on 2014-03-07 (Reason: moved to release)
software-properties (0.92.32) trusty; urgency=low

  * data/software-properties-gtk.desktop.in:
    - Show in both GNOME control center and Unity control center (LP: #1257505)
 -- Robert Ancell <email address hidden>   Wed, 15 Jan 2014 16:44:57 +1300

Available diffs

Superseded in trusty-release on 2014-01-15
Deleted in trusty-proposed on 2014-01-16 (Reason: moved to release)
software-properties (0.92.31) trusty; urgency=medium

  * Stop using deprecated GObject constructors with positional arguments.
    (https://wiki.gnome.org/PyGObject/InitializerDeprecations)
 -- Martin Pitt <email address hidden>   Fri, 10 Jan 2014 12:23:07 +0100

Available diffs

Superseded in trusty-release on 2014-01-10
Deleted in trusty-proposed on 2014-01-11 (Reason: moved to release)
software-properties (0.92.30) trusty; urgency=low

  [ Brian Murray ]
  * Remove unneeded setting of modified_sourceslist.  Thanks to Bruno Nova
    for the patch.

  [ Sebastien Bacher ]
  * do not crash for packages without a candidate
 -- Michael Vogt <email address hidden>   Tue, 07 Jan 2014 19:38:47 +0100

Available diffs

Published in precise-updates on 2014-01-06
Deleted in precise-proposed (Reason: moved to -updates)
software-properties (0.82.7.7) precise-proposed; urgency=low

  * Ensure package sources are refreshed after modification. Thanks to
    Bruno Nova for the patch. (LP: #1075537)
 -- Brian Murray <email address hidden>   Fri, 06 Dec 2013 15:46:28 -0800

Available diffs

Superseded in trusty-release on 2014-01-07
Deleted in trusty-proposed on 2014-01-09 (Reason: moved to release)
software-properties (0.92.29) trusty; urgency=low

  * debian/control:
    - depends on python-apt-common (>= 0.9), which is the version containing
      the trusty definition, without it you can't use add-apt-repository
      without error (lp: #1257765)
    - depends on python-pycurl, ppa.py uses it (lp: #1249080)
 -- Sebastien Bacher <email address hidden>   Wed, 04 Dec 2013 16:36:32 +0100

Available diffs

Obsolete in saucy-updates on 2015-04-24
Superseded in trusty-release on 2013-12-04
Deleted in trusty-proposed on 2015-05-01 (Reason: moved to release)
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to -updates)
software-properties (0.92.28) saucy; urgency=low

  [ Bruno Nova ]
  * Ensure package sources are refreshed after modification
    Fixes Bug LP: #1075537 (and, indirectly, Bug LP: #782953 it seems).

  [ Brian Murray ]
  * Restore the removal of a line feed from a source (LP: #1239893)

  [ Jean-Baptiste Lallement ]

  * debian/manpages/add-apt-repository.1: Documented options -m and -s of
    add-apt-repository (LP: #1229092)

  [ Sebastien Bacher ]
  * softwareproperties/gtk/SoftwarePropertiesGtk.py: don't use the
    gtk-logout-helper command, it has been deprecated and dropped from the
    indicator-session binary, use gnome-session instead (lp: #1241210)
 -- Sebastien Bacher <email address hidden>   Mon, 21 Oct 2013 11:16:21 -0400

Available diffs

Superseded in saucy-proposed on 2013-10-24
software-properties (0.92.27.1) saucy-proposed; urgency=low

  [ Bruno Nova ]
  * Ensure package sources are refreshed after modification
    Fixes Bug LP: #1075537 (and, indirectly, Bug LP: #782953 it seems).

  [ Brian Murray ]
  * Restore the removal of a line feed from a source entered via the GUI
    (LP: #1239893)
 -- Brian Murray <email address hidden>   Wed, 16 Oct 2013 16:20:43 -0700

Available diffs

175 of 222 results