Change log for spe package in Ubuntu

122 of 22 results
Deleted in eoan-release (Reason: (From Debian) ROM; Python 2 package; appears dead upstrea...)
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-02-23
Deleted in xenial-proposed (Reason: moved to release)
spe (0.8.4.h-3.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Depend on wxglade instead of python-wxglade. Closes: #813552.

 -- Matthias Klose <email address hidden>  Mon, 22 Feb 2016 10:33:12 +0100

Available diffs

Superseded in xenial-release on 2016-02-23
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
spe (0.8.4.h-3.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Update for wxPython 3.0 (Closes: #758940):
    + New patch: wxpython3.0.patch

 -- Olly Betts <email address hidden>  Sun, 31 Aug 2014 23:42:19 +0000

Available diffs

Superseded in vivid-release on 2014-10-25
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
spe (0.8.4.h-3) unstable; urgency=low


  * Team upload.

  [ Emilio Pozuelo Monfort ]
  * debian/control:
    - Remove myself from Uploaders.

  [ Ryan Kavanagh ]
  * Switch from dh_pycentral to dh_python2 (Closes: #617068)
    - Bump python build-depends version to (>= 2.6.6-3~)
    - Drop build-depends on python-cnetral
    - Remove X{S,B}-Python-Version lines
    - Update debian/rules accordingly
  * Bump standards version to 3.9.2, no changes required
  * Added missing build-arch and build-indep targets to rules

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

 -- Luca Falavigna <email address hidden>  Sun, 07 Jul 2013 14:28:27 +0200
Superseded in saucy-release on 2013-07-07
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
spe (0.8.4.h-2) unstable; urgency=low

  * debian/control:
    - Update my email address.
    - Bump Standards-Version to 3.8.4, no changes needed.
    - Wrap build-depends and depends.
    - Let spe depend on ${misc:Depends}.
    - Point to viewsvn in Vcs-Browser.
  * debian/rules:
    - Stop calling dh_desktop, it's a no-op now.
    - Pass --install-scripts=/usr/bin to setup.py to fix FTBFS with
      python2.6. Thanks Piotr Ożarowski. Closes: #533836.
 -- Luke Faraone <email address hidden>   Fri, 05 Mar 2010 20:46:04 +0100

Available diffs

Superseded in maverick-release on 2010-05-12
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
spe (0.8.4.h-1ubuntu2) karmic; urgency=low

  * Add --install-layout=deb to setup.py install to build with Python 2.6,
    fixes FTBFS.
  * Bump python build-dependency.

 -- Alessio Treglia <email address hidden>   Sat, 20 Jun 2009 16:03:36 +0200
Deleted in jaunty-proposed on 2009-09-24 (Reason: unverified/failed SRU)
spe (0.8.4.h-1ubuntu0.9.04) jaunty-proposed; urgency=low

  * _spe/SPE.py: force SPE to use wx 2.8 (Closes LP: #377044)
  * debian/control: force dependency on wx 2.8 only

 -- Stani M <email address hidden>   Sat, 23 May 2009 20:21:51 +0200

Available diffs

Superseded in karmic-release on 2009-06-20
spe (0.8.4.h-1ubuntu1) karmic; urgency=low

  * _spe/SPE.py: force SPE to use wx 2.8 (Closes LP: #377044)
  * debian/control: force dependency on wx 2.8 only

 -- Stani M <email address hidden>   Sat, 23 May 2009 20:21:51 +0200

Available diffs

Superseded in karmic-release on 2009-06-03
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
spe (0.8.4.h-1) unstable; urgency=low

  * New upstream release, from the upstream spe-0.8.4.h-wx2.6.1.0.tar.gz
    tarball
  * Added python-wxtools to Suggests because XRCed is now optional
  * Corrected python-wxgtk dependencies so that 2.8 is preferred
  * Dropped python-profiler in Suggests as spe no longer supports profiling

Superseded in intrepid-release on 2008-05-07
Obsolete in hardy-release on 2015-04-24
spe (0.8.4.f-0ubuntu3) hardy; urgency=low

  * Depend on python-wxtools for the XRCed plugin.

 -- Emilio Pozuelo Monfort <email address hidden>   Tue, 08 Apr 2008 13:30:35 +0200
Superseded in hardy-release on 2008-04-08
spe (0.8.4.f-0ubuntu2) hardy; urgency=low

  * debian/patches/crash_with_classes.dpatch:
    - Fix crash related to classes in source files. LP: #213653.
      Thanks to Stani M for the patch.
  * debian/control:
    - Add an alternate dependency python-wxgtk2.8.

 -- Emilio Pozuelo Monfort <email address hidden>   Tue, 08 Apr 2008 12:18:49 +0200
Superseded in hardy-release on 2008-04-08
spe (0.8.4.f-0ubuntu1) hardy; urgency=low

  * New upstream release, from the upstream SPE-0.8.4.f-wx2.6.1.0.tar.gz
    tarball (Closes LP: #200439, #202481, #207024)
  * debian/patches/01pycheck-list.dpatch:
    - Removed, fixed upstream.
  * debian/rules:
    - Use the patch/unpatch targets from /usr/share/dpatch/dpatch.make

 -- Emilio Pozuelo Monfort <email address hidden>   Sat, 05 Apr 2008 20:45:29 +0200
Superseded in hardy-release on 2008-04-05
spe (0.8.4.e-1ubuntu1) hardy; urgency=low

  * Add 01pycheck-list.dpatch from spe svn to fix crash (LP: #201069)
  * Add dpatch as a depends in debian/control
  * Update debian/rules to integrate dpatch
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Scott Kitterman <email address hidden>   Fri, 04 Apr 2008 09:24:27 -0400
Superseded in hardy-release on 2008-04-04
spe (0.8.4.e-1) unstable; urgency=medium

  [ Stefano Canepa ]
  * New upstream release, from the upstream SPE-0.8.4.e-wx2.6.1.0.tar.gz
    tarball (includes Stefano's setup.py and spe.sgml - Piotr).
  * debian/control:
    - Added docbook-to-man to Build-Depends-Indep.
    - Added myself to Uploaders.
  * debian/rules:
    - Added creation of manpage.

  [ Stani ]
  * Closes LP: #74572, #75893, #86159, #105036, #106666, #204751

  [ Emilio Pozuelo Monfort ]
  * debian/control:
    - New Maintainer, Python Applications Packaging Team.
      Closes: #379374.
    - Added myself to Uploaders.
    - Section -> devel.
    - Require debhelper >= 5.0.51 for dh_icons.
    - Require python-central >= 0.5.6 as required by policy.
    - Depend on winpdb, as we have removed it from the package.
    - Depend on pychecker >= 0.8.17-5 to get pychecker2 too.
    - Move python-doc from Recommends to Suggests, as it's in contrib.
      Closes: #452476.
    - Added Homepage, VCS-Browser and VCS-Svn fields.
    - Conform with Debian Policy 3.7.3
  * debian/compat:
    - Update to 5.
  * debian/menu:
    - Change section according to the new menu layout.
    - Improved title and added longtitle.
    - Use spe.xpm instead of spe.png
  * debian/install:
    - Created, install spe.xpm and spe.desktop from here.
  * debian/links:
    - Created. Move symlinks from rules to here.
    - Symlink docs from /usr/share/doc/spe/.
    - Symlink /usr/bin/spe to /usr/share/spe/_spe/SPE.py
  * debian/spe.xpm
    - Added.
  * debian/spe.desktop:
    - Updated to fit the policy.
  * debian/copyright:
    - Updated Homepage and Website.
    - Updated copyright holder.
  * debian/rules:
    - Call dh_icons as we install a png file in /usr/share/pixmaps.
    - Install the package in /usr/share/spe/_spe. Closes: #401982, #384293.
    - Make SPE.py executable.
    - Move installation of files to spe.install and spe.links.
    - Don't call dh_python and dh_installexamples, we don't need them.
    - Install spe.desktop from spe.install and not here.
    - Call dh_install, dh_link and dh_desktop.
    - The changelog has been moved, so the path is different now.
    - Remove SPE_DEBUG.py. That's a windows launcher.
    - Do nothing on binary-arch target.
    - Fix dh_installchangelog call with a non-repacked tarball.
  * debian/pycompat:
    - Removed, not needed as we don't call dh_python.
  * debian/README.Debian:
    - Removed, issues are fixed now.
  * debian/watch:
    - Updated as spe is now hosted on berlios.

  [ Piotr Ożarowski ]
  * Update debian/rules to match changes in upstream tarball
  * debian/copyright: upstream sources are released under GPL3 now
  * Urgency set to medium as this upload closes: #472033 (pycentral dir is not
    used anymore)

 -- Scott Kitterman <email address hidden>   Fri,  28 Mar 2008 09:31:18 +0000
Superseded in hardy-release on 2008-03-28
spe (0.8.4c-1~hardy1) hardy; urgency=low

  * Upload to hardy from Debian python-apps svn.
    - Fixes LP: #88316, LP: #104405.

 -- Emilio Pozuelo Monfort <email address hidden>   Thu, 14 Feb 2008 18:19:02 +0100
Obsolete in gutsy-updates on 2011-09-16
Deleted in gutsy-proposed on 2011-09-19 (Reason: moved to -updates)
spe (0.8.2a+repack-1ubuntu0.7.10) gutsy-proposed; urgency=low

  * SRU proposal
  * _spe/SPE.py: force spe to select python-wxgtk2.6 (LP: #124896)
  * debian/control: changed maintainer field to MOTU

 -- Stani <email address hidden>   Mon, 29 Oct 2007 01:25:11 +0100
Deleted in feisty-proposed on 2008-04-04 (Reason: obsolete SRU)
spe (0.8.2a+repack-1ubuntu0.7.04) feisty-proposed; urgency=low

  * SRU proposal
  * _spe/SPE.py: force spe to select python-wxgtk2.6 (LP: #124896)
  * debian/control: changed maintainer field to MOTU

 -- Stani <email address hidden>   Mon, 29 Oct 2007 01:25:11 +0100
Superseded in hardy-release on 2008-02-14
spe (0.8.2a+repack-1ubuntu1) hardy; urgency=low

  * _spe/SPE.py: force spe to select python-wxgtk2.6

 -- Stani <email address hidden>   Mon, 29 Oct 2007 01:25:11 +0100
Superseded in hardy-release on 2007-10-29
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
spe (0.8.2a+repack-1) unstable; urgency=medium

  * QA upload.
  * Switch to new Python policy.  Closes: #380958, #383511.
  * debian/README.Debian: Fix typo.
  * debian/copyright: Update FSF address.
  * debian/watch: Add.
  * Remove dh-make templates.
  * Conforms to Standards version 3.7.2.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  08 Nov 2006 19:41:27 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
spe (0.8.2a+repack-0.1) unstable; urgency=low

  * Non-maintainer upload, with doko's blessing.
  * Just base off the Ubuntu packaging.
  * Remove spurious rm -rf build from debian/rules.
  * Orphan package.

 -- Steve Kowalik <email address hidden>   Thu,  18 May 2006 00:48:51 +0100
Superseded in dapper-release on 2006-05-18
spe (0.8.2a-0ubuntu1) dapper; urgency=low

  * New upstream version.

 -- Matthias Klose <email address hidden>   Sun, 19 Feb 2006 19:57:18 +0100
Superseded in dapper-release on 2006-02-19
Superseded in dapper-release on 2006-02-03
spe (0.8.1d-0ubuntu1) dapper; urgency=low


  * New upstream version.
  * Fix menu icon.

 -- Matthias Klose <email address hidden>  Thu, 19 Jan 2006 11:14:35 +0000
Superseded in dapper-release on 2006-01-31
Obsolete in breezy-release on 2008-03-25
spe (0.7.5c-1ubuntu1) breezy; urgency=low


  * Remove links to other distributions
  * Use local docs when they're installed and Recommend them

 -- Sebastian Dröge <email address hidden>  Tue, 20 Sep 2005 14:09:56 +0200
122 of 22 results