spice 0.14.0-1ubuntu3 source package in Ubuntu

Changelog

spice (0.14.0-1ubuntu3) cosmic; urgency=medium

  * SECURITY UPDATE: Integer overflow and buffer overflow
    - debian/patches/CVE-2017-12194-1.patch: fix a integer overflow
      computing sizes in spice-common/python_modules/demarshal.py.
    - debian/patches/CVE-2017-12194-2.patch: avoid integer overflow
      in spice-common/python_modules/demarshal.py,
      spice-common/python_modules/marshal.py.
    - debian/patches/CVE-2017-12194-3.patch: add tests to verify fix.
    - CVE-2017-12194

 -- <email address hidden> (Leonidas S. Barbosa)  Tue, 22 May 2018 14:53:01 -0300

Upload details

Uploaded by:
Leonidas S. Barbosa on 2018-05-23
Sponsored by:
Marc Deslauriers
Uploaded to:
Cosmic
Original maintainer:
Ubuntu Developers
Architectures:
alpha amd64 arm64 armel armhf i386 mips64el mipsel ppc64el sh4 x32
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
spice_0.14.0.orig.tar.bz2 1.3 MiB 3adb9495b51650e5eab53c74dd6a74919af4b339ff21721d9ab2a45b2e3bb848
spice_0.14.0-1ubuntu3.debian.tar.xz 17.4 KiB 88d0be84908962bcf95582b75a2d7bf9bc2d1643132baebe3bff63065a03664a
spice_0.14.0-1ubuntu3.dsc 2.7 KiB d3daa3da9359fdc9fd5de344b42bf9686839b9ded96412851e3bd41e053677b0

View changes file

Binary packages built by this source

libspice-server-dev: No summary available for libspice-server-dev in ubuntu cosmic.

No description available for libspice-server-dev in ubuntu cosmic.

libspice-server1: No summary available for libspice-server1 in ubuntu cosmic.

No description available for libspice-server1 in ubuntu cosmic.

libspice-server1-dbgsym: No summary available for libspice-server1-dbgsym in ubuntu cosmic.

No description available for libspice-server1-dbgsym in ubuntu cosmic.