squid 2.7.STABLE7-1ubuntu12.6 source package in Ubuntu

Changelog

squid (2.7.STABLE7-1ubuntu12.6) lucid-security; urgency=low

  * SECURITY UPDATE: denial of service via cachemgr.cgi insufficient input
    validation
    - debian/patches/98-CVE-2012-5643.dpatch: modify cachemgr.cc to properly
      free memory and handle input in chunks
    - Based on
      http://www.squid-cache.org/Versions/v2/2.7/changesets/SQUID-2012_1.patch
    - CVE-2012-5643
    - CVE-2013-0189
 -- Seth Arnold <email address hidden>   Tue, 29 Jan 2013 18:12:23 -0800

Upload details

Uploaded by:
Seth Arnold on 2013-01-30
Uploaded to:
Lucid
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
web
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
squid_2.7.STABLE7.orig.tar.gz 1.7 MiB 2b926aece7d4beac0370d9b72899d3be7f48c29e973a1328666938a2e4c4ffa6
squid_2.7.STABLE7-1ubuntu12.6.diff.gz 301.0 KiB bb70742c362f7287bedf49f03c52e604c8061c23f9d1aa6d3b8a361844e21e9c
squid_2.7.STABLE7-1ubuntu12.6.dsc 1.6 KiB 70183e51ebfccc7d281193bd981d039c2d7ac07ce75698d9ccba94913688a673

View changes file

Binary packages built by this source

squid: No summary available for squid in ubuntu lucid.

No description available for squid in ubuntu lucid.

squid-cgi: No summary available for squid-cgi in ubuntu lucid.

No description available for squid-cgi in ubuntu lucid.

squid-common: No summary available for squid-common in ubuntu lucid.

No description available for squid-common in ubuntu lucid.