Change log for stunnel4 package in Ubuntu

151 of 51 results
Published in bionic-proposed on 2017-11-15
stunnel4 (3:5.43-1) unstable; urgency=medium

  * Remove whitespace at the end of the lines in old changelog entries.
  * Declare compliance with Debian Policy 4.1.1 with no changes.
  * Fix some typographical errors in old changelog entries.
  * Add "Rules-Requires-Root: no" to the source control stanza.
  * New upstream release:
    - add netcat-traditional to the build dependencies since
      the new upstream test suite uses it
    - also run the upstream test suite as an automated package test
    - add an upstream patch for the behavior of the "accept" option
  * Rename the automated test scripts without a language extension.

 -- Peter Pentchev <email address hidden>  Wed, 15 Nov 2017 15:58:34 +0200

Available diffs

Published in bionic-release on 2017-11-09
Deleted in bionic-proposed (Reason: moved to release)
stunnel4 (3:5.42-1) unstable; urgency=medium

  * Add a simple autopkgtest suite.
  * Declare compliance with Debian Policy 4.1.0:
    - do not install documentation files if the "nodoc" build option is
      set or the "nodoc" build profile is active.
    - add the 09-try-restart patch to implement the "try-restart" action
      in the SysV init script.
  * New upstream version:
    - drop the 08-session-free patch, fixed upstream in a better way
    - refresh the 02-rename-binary, 04-restore-pidfile-default, and
      07-path-max patches
    - add a Lintian override because "CAs" is not a typo for this package
    - add a build dependency on autoconf-archive
    - bump the year in the upstream copyright notice
  * Drop the sdf build dependency, it does not seem to be needed any more.

 -- Peter Pentchev <email address hidden>  Sat, 23 Sep 2017 16:25:21 +0300

Available diffs

Published in xenial-proposed on 2017-09-07
stunnel4 (3:5.30-1ubuntu0.1) xenial; urgency=medium

  * Backport fix for TLS session leak introduced in stunnel4 5.27 from
    stunnel4 5.33: "Fixed a memory leak in the TLS session caching code
    (thx to Richard Kraemer)" (LP: #1655153).

 -- Scott Emmons <email address hidden>  Wed, 30 Aug 2017 22:31:43 +0000
Superseded in bionic-release on 2017-11-09
Published in artful-release on 2017-04-20
Published in zesty-release on 2017-01-09
Deleted in zesty-proposed (Reason: moved to release)
stunnel4 (3:5.39-2) unstable; urgency=medium

  * Add the 08-session-free patch to avoid freeing the SSL session
    twice, which will either be detected by the OpenSSL library and
    crash the stunnel process, or cause use-after-free problems that
    may lead to even worse results later.  Closes: #850292

 -- Peter Pentchev <email address hidden>  Sun, 08 Jan 2017 17:30:12 +0200

Available diffs

Superseded in zesty-proposed on 2017-01-08
stunnel4 (3:5.39-1) unstable; urgency=medium

  * New upstream version:
    - drop the 08-dh-openssl-1.1 patch, dhparam.c was regenerated with
      OpenSSL 1.1 again
    - refresh the rest of the patches
  * Remove the cybermirror sites from the watch file; their stunnel
    mirror has been "undergoing maintenance" for at least three months.
  * Bump the year of my debian/* copyright notice.

 -- Peter Pentchev <email address hidden>  Tue, 03 Jan 2017 12:29:16 +0200

Available diffs

Superseded in zesty-proposed on 2017-01-06
stunnel4 (3:5.38-1) unstable; urgency=medium

  * New upstream release:
    - drop the 06-lfs, 08-typos, and 09-realloc patches, included upstream
    - add the 08-dh-openssl-1.1.patch to fix the build with OpenSSL 1.1

 -- Peter Pentchev <email address hidden>  Sun, 27 Nov 2016 03:31:13 +0200

Available diffs

Superseded in zesty-proposed on 2016-11-27
stunnel4 (3:5.37-2) unstable; urgency=medium

  * Add the 09-realloc patch to fix a reallocation / double-free bug.
    Closes: #843988; thanks, Sebastian Andrzej Siewior and gregor
    herrmann!

 -- Peter Pentchev <email address hidden>  Wed, 16 Nov 2016 20:50:08 +0200

Available diffs

Superseded in zesty-release on 2017-01-09
Deleted in zesty-proposed on 2017-01-10 (Reason: moved to release)
stunnel4 (3:5.37-1) unstable; urgency=medium

  * Reformat the build and runtime dependency lists in the control file.
  * Add a runtime dependency on lsb-base for /lib/lsb/init-functions.
  * Drop the dh_installinit override: --restart-after-upgrade is already
    the default behavior in debhelper compatibility level 10.
  * Update the watch file a bit:
    - replace pgpmode=auto with pgpsigurlmangle - the former will not
      fail on a missing upstream signature file
    - make the version regular expression a bit more sane
    - use v4's @ARCHIVE_EXT@ substitution variable
  * Add another correction to the typos patch.
  * New upstream release.
  * Correct the download webpage's URL in the copyright file.
  * Correct the project homepage's URL in the stunnel3 manual page.
  * Use the HTTPS scheme for various upstream URLs.

 -- Peter Pentchev <email address hidden>  Thu, 10 Nov 2016 02:57:28 +0200

Available diffs

Superseded in zesty-release on 2016-11-10
Deleted in zesty-proposed on 2016-11-11 (Reason: moved to release)
stunnel4 (3:5.36-1) unstable; urgency=medium

  * Add the 24-typos patch to fix some typographical errors.
  * New upstream version:
    - drop the 10-no-zlib-compression patch, integrated upstream
  * Bump the debhelper B-D to 10 and drop the Lintian override.
  * Rename the patch files to "reindex" sequentially.

 -- Peter Pentchev <email address hidden>  Sun, 25 Sep 2016 12:43:20 +0300

Available diffs

Superseded in zesty-release on 2016-11-05
Published in yakkety-release on 2016-07-21
Deleted in yakkety-proposed (Reason: moved to release)
stunnel4 (3:5.35-1) unstable; urgency=medium

  * New upstream release:
    - drop the 24-ssl23 patch, integrated upstream
    - refresh the other patches

 -- Peter Pentchev <email address hidden>  Mon, 18 Jul 2016 10:45:04 +0300

Available diffs

Superseded in yakkety-release on 2016-07-21
Deleted in yakkety-proposed on 2016-07-22 (Reason: moved to release)
stunnel4 (3:5.33-1) unstable; urgency=medium

  * Switch the bugs.debian.org URL in a patch to HTTPS.
  * Switch the copyright format URL to HTTPS.
  * New upstream version:
    - fix the build with OpenSSL-1.1; Closes: #828562
    - refresh the 12-restore-pidfile-default and 23-path-max patches
  * Add the 24-ssl23.h patch to further fix the OpenSSL 1.1 build -
    the ssl23.h file was removed.

 -- Peter Pentchev <email address hidden>  Mon, 27 Jun 2016 13:51:43 +0300

Available diffs

Superseded in yakkety-release on 2016-06-28
Deleted in yakkety-proposed on 2016-06-29 (Reason: moved to release)
stunnel4 (3:5.32-1) unstable; urgency=medium

  * Declare compliance with Debian Policy 3.9.8 with no changes.
  * Remove the Breaks/Replaces relations for the old "stunnel" package;
    it is not even present in oldstable.
  * Update the watch file:
    - switch to the HTTPS scheme for the upstream downloads page
    - re-enable the ftp://ftp.stunnel.org/stunnel/archive/5.x/ location
      and use FTP passive mode to access it
    - actually include upstream's signing subkey in the key file!
    - update to the watch file format 4 and use pgpmode=auto
  * Use Autoconf's AC_SYS_LARGEFILE for Large File Support.
  * New upstream release:
    - update the upstream author's e-mail address in the copyright file,
      the upstream metadata file, and the stunnel3.8 manual page
    - refresh the 02-rename-binary patch
  * Bump the debhelper compatibility level to 10:
    - override the Lintian debhelper warning as it itself suggests
    - let debhelper handle the parallel building and autoreconf by itself
  * Add the 23-path-max patch to allocate the configuration filename
    dynamically and avoid the use of the possibly undefined PATH_MAX.

 -- Peter Pentchev <email address hidden>  Wed, 04 May 2016 14:54:45 +0300

Available diffs

Superseded in yakkety-release on 2016-05-07
Deleted in yakkety-proposed on 2016-05-08 (Reason: moved to release)
stunnel4 (3:5.31-1) unstable; urgency=medium

  * New upstream release.
  * Declare compliance with Debian Policy 3.9.7 with no changes.

 -- Peter Pentchev <email address hidden>  Wed, 02 Mar 2016 11:29:06 +0200

Available diffs

Superseded in yakkety-release on 2016-04-27
Published in xenial-release on 2016-02-22
Deleted in xenial-proposed (Reason: moved to release)
stunnel4 (3:5.30-1) unstable; urgency=medium

  * New upstream release:
    - bump the upstream copyright years
    - refresh the 02-rename-binary patch
    - refresh the 10-no-zlib-compression patch (line numbers only)
  * Bump the year on my debian/* copyright notice.

 -- Peter Pentchev <email address hidden>  Sun, 31 Jan 2016 15:40:22 +0200

Available diffs

Superseded in xenial-release on 2016-02-22
Deleted in xenial-proposed on 2016-02-23 (Reason: moved to release)
stunnel4 (3:5.29-1) unstable; urgency=medium

  * New upstream release, refresh the patches' line numbers.

 -- Peter Pentchev <email address hidden>  Fri, 08 Jan 2016 20:59:02 +0200

Available diffs

Superseded in xenial-release on 2016-01-09
Deleted in xenial-proposed on 2016-01-10 (Reason: moved to release)
stunnel4 (3:5.28-1) unstable; urgency=high

  * New upstream release:
    - high urgency: fix a bug introduced in 3:5.27-1: if an OpenSSL
      engine is used, the SSL library's initialization would not be
      performed completely, skipping, for instance, the proper
      initialization of the pseudo-random number generator
    - refresh the patches

 -- Peter Pentchev <email address hidden>  Fri, 11 Dec 2015 23:24:40 +0200

Available diffs

Superseded in xenial-release on 2015-12-12
Deleted in xenial-proposed on 2015-12-13 (Reason: moved to release)
stunnel4 (3:5.27-1) unstable; urgency=medium

  * New upstream release:
    - refresh the patches
    - drop the 19-typos patch, applied upstream

 -- Peter Pentchev <email address hidden>  Fri, 04 Dec 2015 00:34:30 +0200

Available diffs

Superseded in xenial-release on 2015-12-05
Deleted in xenial-proposed on 2015-12-06 (Reason: moved to release)
stunnel4 (3:5.26-1) unstable; urgency=medium

  * New upstream version:
    - drop the 14-lsb-init-functions, 18-lsb-startup, and 20-comparison
      patches, applied upstream
    - rework the 02-rename-binary and 10-no-zlib-compression patches
    - update the 19-typos patch: the fixes within it were applied
      upstream, but a couple of new typos were introduced
    - refresh patches
    - add the 21-author-tests patch to make the building of the Win32
      binaries conditional on an environment variable and not on
      the presence of the .git directory
    - update the upstream copyright notice in debian/copyright
  * Drop the perl-modules dependency - "perl", brought in by perl:Depends,
    ought to be enough.
  * Run the build in all of the source directories.  Closes: #804292
  * Use an https:// URL for Vcs-Git.

 -- Peter Pentchev <email address hidden>  Thu, 19 Nov 2015 20:44:33 +0200

Available diffs

Published in vivid-updates on 2015-07-03
Published in vivid-security on 2015-07-03
stunnel4 (3:5.06-2+deb8u1build0.15.04.1) vivid-security; urgency=medium

  * fake sync from Debian

Superseded in xenial-release on 2015-11-20
Published in wily-release on 2015-06-15
Deleted in wily-proposed (Reason: moved to release)
stunnel4 (3:5.18-1) unstable; urgency=medium

  * Add the 17-upstream-hangup patch to fix prematurely closed
    connections when there is still data to be written.
    Thanks to Joachim Falk for backporting the patch!
    Closes: #771241
  * Add the 18-lsb-startup patch to make the daemons' startup consistent
    with the way things are done in Debian.
    Among other things, Closes: #782030
  * Rework the patches a bit:
    - update the description of 01-fix-paths
    - move the tools/script.sh chunk from 01-fix-paths to 02-rename-binary
    - drop 08-client-example: it was actually applied upstream, no need
      to add the same text twice
    - drop 11-no-rle-compression: the OpenSSL bug has been fixed
      somewhere in the 1.x release timeframe
  * Add the 19-typos patch to fix some minor documentation typos and
    rework the 02-rename-binary patch to make the change in the manual page
    during the stunnel.pod -> stunnel.8 rebuild
  * Add the 20-comparison patch to fix a minor logging bug.
  * Remove ${misc:Pre-Depends} as explained in debhelper's #783898.
  * Bump the year on my debian/* copyright notice.
  * Add --parallel to the debhelper invocation.
  * New upstream version:
    - rework the 01-fix-paths and the 10-zlib-compression patches to
      catch up with upstream updates
    - refresh patches
    - drop the 05-logrotate-warning-in-sample-conf patch, applied upstream
    - drop the 15-upstream-systemd-libs, 16-upstream-sslv23-method, and
      17-upstream-hangup patches since they were cherry-picked from
      upstream to begin with
    - remove handling for the dropped French manual page

 -- Peter Pentchev <email address hidden>  Sun, 14 Jun 2015 04:13:02 +0300

Available diffs

Superseded in wily-release on 2015-06-15
Published in vivid-release on 2014-10-28
Deleted in vivid-proposed (Reason: moved to release)
stunnel4 (3:5.06-2) unstable; urgency=medium


  * Limit the systemd build dependency to Linux architectures only,
    so that we actually give Stunnel a chance to build on kFreeBSD
    or the Hurd.
  * Add debian/upstream/metadata.

 -- Peter Pentchev <email address hidden>  Mon, 20 Oct 2014 11:49:05 +0300

Available diffs

Superseded in vivid-release on 2014-10-28
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
stunnel4 (3:5.02-1) unstable; urgency=medium


  * New upstream version:
    - drop the 04-selective-tunnel-restart, 06-init-script-description,
      and 07-init-script-status patches, applied upstream
    - refresh the 01-fix-paths, 02-rename-binary, 03-runas-user,
      05-logrotate-warning-in-sample-conf, 08-client-example,
      09-init-script-ulimits, and 12-restore-pidfile-default patches
    - augment the 01-fix-paths patch to also move the pidfile to
      /var/run/ and not /usr/var/run/.

 -- Peter Pentchev <email address hidden>  Tue, 10 Jun 2014 17:23:32 +0300

Available diffs

Superseded in utopic-release on 2014-06-12
Deleted in utopic-proposed on 2014-06-13 (Reason: moved to release)
stunnel4 (3:5.01-3) unstable; urgency=medium


  * Add the 12-restore-pidfile-default patch to restore stunnel's
    "create the pid file by default" behavior, since the init script
    has no way of monitoring the started stunnel4 processes otherwise.
    The init script now warns about configurations with no "pid"
    setting; in a future version it will refuse to start stunnel for
    these configurations.  Closes: #744851

 -- Peter Pentchev <email address hidden>  Fri, 18 Apr 2014 14:37:42 +0300
Published in precise-updates on 2014-01-28
Published in precise-security on 2014-01-28
stunnel4 (3:4.42-1ubuntu0.1) precise-security; urgency=medium

  * SECURITY UPDATE: arbitrary code execution via NTLM auth (LP: #1150150)
    - debian/patches/CVE-2013-1762.patch: properly handle length in
      src/protocol.c.
    - CVE-2013-1762
 -- Marc Deslauriers <email address hidden>   Tue, 28 Jan 2014 07:47:59 -0500
Obsolete in quantal-updates on 2015-04-24
Obsolete in quantal-security on 2015-04-24
stunnel4 (3:4.53-1ubuntu0.1) quantal-security; urgency=medium

  * SECURITY UPDATE: arbitrary code execution via NTLM auth (LP: #1150150)
    - debian/patches/CVE-2013-1762.patch: properly handle length in
      src/protocol.c.
    - CVE-2013-1762
 -- Marc Deslauriers <email address hidden>   Tue, 28 Jan 2014 07:42:48 -0500
Superseded in utopic-release on 2014-04-27
Published in trusty-release on 2013-11-14
Deleted in trusty-proposed (Reason: moved to release)
stunnel4 (3:4.53-1.1ubuntu1) trusty; urgency=low

  * Use dh_autotools-dev to update config.{sub,guess} for new ports.
 -- Adam Conrad <email address hidden>   Thu, 14 Nov 2013 15:28:10 +0000
Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
stunnel4 (3:4.29-1+squeeze1build0.10.04.1) lucid-security; urgency=low

  * fake sync from Debian

Superseded in trusty-release on 2013-11-14
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
stunnel4 (3:4.53-1.1) unstable; urgency=high


  * Non-maintainer upload.
  * Add CVE-2013-1762.patch patch.
    CVE-2013-1762: Fix buffer overflow in NTLM authentication of the CONNECT
    protocol negotiation. (Closes: #702267)

 -- Salvatore Bonaccorso <email address hidden>  Mon, 22 Apr 2013 19:47:34 +0200

Available diffs

Superseded in saucy-release on 2013-04-28
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
stunnel4 (3:4.53-1) unstable; urgency=low


  * New upstream version 4.53.
    - Added client-mode "sni" option to directly control the value of
      TLS Server Name Indication (RFC 3546) extension (Closes: #668041).
    - Added support for IP_FREEBIND socket option with a pached Linux kernel.
    - Glibc-specific dynamic allocation tuning was applied to help unused memory
      deallocation.
    - Non-blocking OCSP implementation.
    - Various other bugfixes, see upstream changelog for details.

  * Enabled hardening compile flags. There were NO compile time warning messages
    or errors triggered because of this.

  * Updated to Standards-Version 3.9.3. No changes required.
    - Migrating to /run from /var/run will be a hard problem, because we expect
      user written config files to refer to the directory. We'll punt on making
      this change for now.
  * Updated copyright years to 2012.
  * Added Description: LSB header to init script.

 -- Luis Rodrigo Gallardo Cruz <email address hidden>  Sun, 03 Jun 2012 11:34:36 -0700

Available diffs

Superseded in quantal-release on 2012-06-04
stunnel4 (3:4.52-1) unstable; urgency=low


  * New upstream version 4.52.
  * Do not enable chroot in sample config file. It is misleading to users, it
    suggests it can be used with no further changes. Closes: #652812
  * Remove log files on purge. Closes: #657135

 -- Luis Rodrigo Gallardo Cruz <email address hidden>  Sun, 12 Feb 2012 12:06:37 -0800

Available diffs

Superseded in quantal-release on 2012-05-01
Published in precise-release on 2011-10-17
stunnel4 (3:4.42-1) unstable; urgency=low

  * New Upstream Release.
   - Fixed a heap corruption vulnerability in versions 4.40 and 4.41.  It may
     possibly be leveraged to perform DoS or remote code execution attacks.
     (Closes: #638758)
   - New verify level 0 to request and ignore peer certificate.

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
stunnel4 (3:4.35-2build1) oneiric; urgency=low

  * Rebuild for OpenSSL 1.0.0.
 -- Colin Watson <email address hidden>   Tue, 17 May 2011 11:53:02 +0100

Available diffs

Superseded in oneiric-release on 2011-05-17
stunnel4 (3:4.35-2) unstable; urgency=low

  * Fix variable substitution in init script (Closes: #623221).
    Thanks Tomas Kapralek <email address hidden> for report and diagnosis.

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
stunnel4 (3:4.29-1) unstable; urgency=low

  * New upstream version (Closes: #559270).
   - sessiond, a high performance SSL session cache was built for stunnel.
     A new service-level "sessiond" option was added.  sessiond is
     available for download on ftp://stunnel.mirt.net/stunnel/sessiond/ .
     stunnel clusters will be a lot faster, now!
   - Transparent proxy support on Linux kernels >=2.6.28.
     See the manual for details.
     The old transproxy.txt file is no longer provided.
   - New socket options to control TCP keepalive on Linux:
     TCP_KEEPCNT, TCP_KEEPIDLE, TCP_KEEPINTVL.
   - SSL options updated for the recent version of OpenSSL library.
   - Bugfixes
    + Missing "fips" option was added to the manual.
    + A serious bug in asynchronous shutdown code fixed.
    + Data alignment updated in libwrap.c.
    + Polish manual encoding fixed. Debian's patch for this removed.
    + Notes on compression implementation in OpenSSL added to the manual.

  * Use correct owner:group for logs after rotation. (Closes: #529481).
    Thanks Brian 'morlenxus' Miculcy <email address hidden>
  * Use copytruncate in logrotate file, instead of restarting the
    daemon (Closes: #535915).
    Thanks Andrew Buckeridge <email address hidden>
  * Bump Standards-Version to 3.8.3. No changes required.
  * Do not specify path to true in postinst script.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  21 Dec 2009 10:44:16 +0000

Available diffs

Superseded in lucid-release on 2009-12-21
Obsolete in karmic-release on 2013-03-04
stunnel4 (3:4.27-1) unstable; urgency=low

  * New upstream release.
   - Remove debian/patches/security-check_certificate, now included upstream.
     Fixes: CVE-2008-2420
   - Libwrap helper processes fixed to close standard
     input/output/error file descriptors. (Closes: #482379)
  * Rebase quilt patches to not require -p0. (Closes: #484966)
  * Fix sample configuration file to use ssl cert from /etc/ssl/certs
    (Closes: #460953).
  * Warn if automatic startup is disabled in /etc/default/stunnel4
    (Closes: #475599).
  * Use invoke-rc.d in ppp start/stop scripts.
  * Standards-Version: 3.8.1.
    - Add README.source documenting use of quilt.
  * Bump to debhelper 7
    - Remove unused old option from dh_mkshlibs call
  * Declare the polish pod's encoding and use unicode when converting it
    to a manpage.
  * Dummy upgrade package is priority: extra
  

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 12:12:46 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
stunnel4 (3:4.22-2) unstable; urgency=low

  * Check if a daemon is already running before trying to start it with the
    same configuration file. Thanks Peter Palfrader <email address hidden> for
    the report (Closes: #506091).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  19 Nov 2008 13:53:39 +0000

Available diffs

Superseded in jaunty-release on 2008-11-19
Obsolete in intrepid-release on 2013-02-20
stunnel4 (3:4.22-1.1) unstable; urgency=high

  * Non-maintainer upload by the security team
  * Fix security bug in the OCSP functionality that allowed revoked
    certificates to authenticate (Closes: #482644)
    Fixes: CVE-2008-2420

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  28 May 2008 07:10:36 +0100
Superseded in intrepid-release on 2008-05-28
stunnel4 (3:4.22-1) unstable; urgency=low

  * New upstream release.
   - Build system now uses standard automake dirs.
   - Reworked logging system avoids outputing before log file is configured 
    (Closes: #460019).
   - Simultaneous logging to a file and the syslog is now possible.
   - A new service level option to control stack size:
     stack = <number of bytes>
   - Bugfixes in libwrap support code.
  * debian/patches/setuid.patch: Removed, it's included upstream.
  * debian/patches/fix-paths: Reworked to use automake's standard dirs.
  * Rebase the rest of the patches.
  * Update standards-version to 3.7.3. No changes needed.
  * Fix build-dependencies on -1 revisions of libssl-dev, openssl and quilt.
  * Register documentation in the System/Security section.
  

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:26:39 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
stunnel4 (3:4.21-1) unstable; urgency=low

  * New upstream release.
   - Binaries moved from /usr/sbin to /usr/bin. Thus, Debian no longer
    diverges in that from upstream.
   - libstunnel.so migrated inside /usr/lib/stunnel.
   - Preliminary FIPS 140-2 support, but this package does not include it,
    as it requires static compilation.
   - Miscelaneous bugfixing.
  * debian/patches/no_zlib_link:
   - Rebased. Only line numbering changed.
  * debian/patches/libstunnel_is_private_lib:
   - Removed. Included upstream.
  * debian/patches/fix-paths:
   - Remove hunks related to moving binaries to /usr/bin. Refresh line numbers
    in the rest.
  * debian/patches/rename-binary:
   - Rebased. Minor changes due to changed dates in the manpage and the use of
    @prefix@ in src/stunnel3.in.
  * debian/patches/setuid.patch:
   - Patch from upstream to allow using setuid/setgid with /etc/passwd and
    /etc/group not within chrooted directory.
  * debian/README.Debian:
   - Add explanation about not turning FIPS mode on.
   - Reword warning about binaries changing place.
  * debian/rules, debian/stunnel4.manpages:
   - No longer need to move the binaries.
   - Upstream location for manpages changed. We still install them by hand,
    anyways.
   - Ship fr and pl manpages.
   - Do not pass --host to configure if not cross compiling.
   - Reorder target dependencies. This should avoid problems when doing
    paralell builds.
  * debian/control:
   - Remove XS- prefix from Vcs-* fields.
   - Add Homepage: field.
   - Correct minor typo in dummy package's description.
   - Version build dependency on quilt, since we require 
    /usr/share/quilt/quilt.make (Closes: #447751).
   - Change my maintainer address. 

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  06 Dec 2007 09:52:45 +0000
Superseded in hardy-release on 2007-12-06
stunnel4 (3:4.20-5) unstable; urgency=low

  * debian/stunnel3.8:
    - Remove references to unsupported -S and -V options in manpage, and
    include an explicit list of tunable parameters for -O and their
    default values (Closes: #440718).
    - Rewrite -P argument description. It must be a file to be created, or
    empty (Closes: #398012).

Superseded in hardy-release on 2007-11-30
Obsolete in gutsy-release on 2011-09-16
stunnel4 (3:4.20-2ubuntu1) gutsy; urgency=low

  * Added Provides and Replaces to debian/control to replace obsolete package
    crywrap.

 -- Marco Rodrigues <email address hidden>   Thu,  2 Aug 2007 16:43:00 +0100
Superseded in gutsy-release on 2007-08-09
stunnel4 (3:4.20-2) unstable; urgency=low

  * Orphan package

Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
stunnel4 (3:4.18-2) unstable; urgency=low

  * Updated chroot default path in configuration file
  * Added LSB section in init script

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  09 Nov 2006 17:51:58 +0000
Superseded in feisty-release on 2006-11-09
stunnel4 (3:4.18-1) unstable; urgency=low

  * New upstream release

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
stunnel4 (2:4.150-7) unstable; urgency=low

  * Fixed a bug when pid is not given in configuration file :  
    init.d script was looking for /var/run/stunnel4/stunnel4.pid but 
    stunnel was creating /var/run/stunnel4.pid 
    (Closes: #384275)
  * Added check during start to encourage users to fill the pid= section
    of configuration file when start failed (for example if you use two
    configuration files without pid= option)

Superseded in edgy-release on 2006-08-29
Obsolete in dapper-release on 2011-09-06
stunnel4 (2:4.140-5ubuntu1) dapper; urgency=low

  * debian/stunnel4.init
    - Add check for /var/run/stunnel4 as /var/run is mounted tmpfs.
     (Closes: Malone #29892)

 -- Chuck Short <email address hidden>   Tue, 18 Apr 2006 12:29:12 -0400
Superseded in dapper-release on 2006-04-18
Superseded in dapper-release on 2006-02-03
stunnel4 (2:4.140-4) unstable; urgency=low


  * Fixed problem with default directory (/etc/stunnel for configuration 
    directory and /var/run/stunnel4.pid for pid file) (Closes: #343882)

 -- Julien Lemoine <email address hidden>  Thu, 22 Dec 2005 16:32:20 +0100
Superseded in dapper-release on 2006-01-31
stunnel4 (2:4.140-3) unstable; urgency=low


  * Default configuration file is now filled with values for usage 
    in a chroot environment 
    (if you do not want chroot or want to use vserver, you need to edit it)
    (Closes: #342507)

 -- Julien Lemoine <email address hidden>  Sat, 17 Dec 2005 10:00:40 +0100
Obsolete in breezy-release on 2008-03-25
stunnel4 (2:4.090-1) unstable; urgency=low


  * New upstream release
  * include better stunnel3 compability script from upstream, options 
    like -cd can now be use instead of -c -d ...
    (closes: #305259)
  * Added depends on perl-modules to allow use of stunnel3 compatibilty script

 -- Julien Lemoine <email address hidden>  Wed, 20 Apr 2005 21:07:50 +0200
Obsolete in hoary-release on 2008-03-19
stunnel4 (2:4.050-4) unstable; urgency=low


  * Restart connection instead of stop when ppp is down. It is possible to
    use stunnel for eth interfaces. (Closes: 271006)

 -- Julien Lemoine <email address hidden>  Sun, 26 Sep 2004 18:12:36 +0200
Obsolete in warty-release on 2008-01-09
stunnel4 (2:4.050-1) unstable; urgency=low


  * By default, store pidfile in /var/run/stunnel4/stunnel.pid with 
    /var/run/stunnel4 owned by nobody:nogroup
  * Oops, stunnel4 was a debian native package
  
 -- Julien Lemoine <email address hidden>  Mon,  7 Jun 2004 21:23:37 +0200
151 of 51 results