suitesparse 1:4.2.1-3ubuntu1 source package in Ubuntu

Changelog

suitesparse (1:4.2.1-3ubuntu1) trusty; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/control: Demote libatlas-doc from Recommends to Suggests, as it
      is not in main.

suitesparse (1:4.2.1-3) unstable; urgency=low

  * Upload to unstable.
  * Register user guides for KLU, CAMD, SPQR and LDL in doc-base.

suitesparse (1:4.2.1-2) experimental; urgency=low

  * Really fix BLAS/LAPACK dependencies of libsuitesparse-dev
    - remove obsolete ATLAS specialized libraries (Closes: #645846)
    - add virtual package libblas.so as a BLAS alternative (Closes: #645844)
  * Remove Daniel Rus Morales from Uploaders, with his consent. Thanks
    Daniel for your work!
  * d/rules: do not regenerate d/control automatically, this is
    forbidden
  * d/rules: fix get-orig-source rule
  * d/control: use canonical URLs for Vcs-* fields
  * Mark debug package as Multi-Arch: same
  * Ship libsuitesparseconfig.a in the -dev package.
  * Bump Standards-Version to 3.9.5, no changes needed.

suitesparse (1:4.2.1-1) experimental; urgency=low

  * New upstream release (Closes: #706709)
    - debian/library-soname.pl: update soversion numbers
  * debian/rules: recreate d/control when d/library-sonames.pl is
    modified

suitesparse (1:4.2.0-1) experimental; urgency=low

  [ Christophe Trophime ]
  * New upstream release (Closes: #653660, #687282)
    - Renamed UFconfig to SuiteSparse_config
    - Update patches to new release
    - debian/library-soname.pl: update soversion numbers

  [ S├ębastien Villemot ]
  * debian/control.in:
    - fix Maintainer field (Closes: #674266, #674268, #674270, #674271, #674272,
      #674273, #674274, #674275, #674276, #674277, #674278, #674279, #674280,
      #674281)
    - add myself to Uploaders
    - remove obsolete DM-Upload-Allowed flag
  * Remove obsolete README.source
  * debian/rules: clean *.oo files
  * Bump to debhelper compat level 9
  * Update debian/copyright
  * Remove symbols files: they are useless since we bump the soversion
    at every new upstream release
  * Clean up build flags
    - make sure to inject flags from dpkg-buildflags
    - buildflags.diff: new patch to remove spurious flags in upstream build
      system
    - remove -m64 flag on amd64 CPUs (Closes: #701654)
  * Fix version in NEWS.Debian, to make lintian happy
  * parallel-build.diff: new patch, fixes parallel build
  * Multiarchify the package
  * Fix BLAS/LAPACK dependencies of libsuitesparse-dev:
    - remove obsolete ATLAS specialized libraries (Closes: #645846)
    - add libopenblas-dev as a BLAS alternative (Closes: #645844)
  * Bump to Standards-Version 3.9.4, no changes needed
  * Suitesparse_config_Makefile.diff: new patch, creates a PIC version
    of the (small) config code, for embedding in other shared libs
  * KLU_Demo_Makefile.diff: new patch, needed for creating the right
    dependencies between shared libraries
  * Create a new shared library package for SPQR (Closes: #589296)
  * Update README.Debian
 -- Logan Rosen <email address hidden>   Sat, 07 Dec 2013 21:42:26 -0500

Upload details

Uploaded by:
Logan Rosen on 2013-12-17
Sponsored by:
Daniel Holbach
Uploaded to:
Trusty
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
math
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Trusty release on 2013-12-29 main math

Downloads

File Size SHA-256 Checksum
suitesparse_4.2.1.orig.tar.gz 21.5 MiB 7ec70a8b65576559daae3bbe61fb29be4ccb5dbb765c43d66a0ee9a42df68b5f
suitesparse_4.2.1-3ubuntu1.debian.tar.gz 24.0 KiB 79eae687a12e361343cdf765678ae6bcb7208ba2bdf299705fa8f94db9e517b2
suitesparse_4.2.1-3ubuntu1.dsc 2.3 KiB a49adf82300dca9057a24157cc269cea8a51632bb7c248b3db8baf6a12504348

View changes file

Binary packages built by this source

libamd2.3.1: No summary available for libamd2.3.1 in ubuntu utopic.

No description available for libamd2.3.1 in ubuntu utopic.

libamd2.3.1-dbgsym: No summary available for libamd2.3.1-dbgsym in ubuntu xenial.

No description available for libamd2.3.1-dbgsym in ubuntu xenial.

libbtf1.2.0: No summary available for libbtf1.2.0 in ubuntu xenial.

No description available for libbtf1.2.0 in ubuntu xenial.

libbtf1.2.0-dbgsym: No summary available for libbtf1.2.0-dbgsym in ubuntu xenial.

No description available for libbtf1.2.0-dbgsym in ubuntu xenial.

libcamd2.3.1: No summary available for libcamd2.3.1 in ubuntu xenial.

No description available for libcamd2.3.1 in ubuntu xenial.

libcamd2.3.1-dbgsym: No summary available for libcamd2.3.1-dbgsym in ubuntu xenial.

No description available for libcamd2.3.1-dbgsym in ubuntu xenial.

libccolamd2.8.0: No summary available for libccolamd2.8.0 in ubuntu wily.

No description available for libccolamd2.8.0 in ubuntu wily.

libccolamd2.8.0-dbgsym: No summary available for libccolamd2.8.0-dbgsym in ubuntu xenial.

No description available for libccolamd2.8.0-dbgsym in ubuntu xenial.

libcholmod2.1.2: No summary available for libcholmod2.1.2 in ubuntu xenial.

No description available for libcholmod2.1.2 in ubuntu xenial.

libcholmod2.1.2-dbgsym: No summary available for libcholmod2.1.2-dbgsym in ubuntu xenial.

No description available for libcholmod2.1.2-dbgsym in ubuntu xenial.

libcolamd2.8.0: No summary available for libcolamd2.8.0 in ubuntu vivid.

No description available for libcolamd2.8.0 in ubuntu vivid.

libcolamd2.8.0-dbgsym: No summary available for libcolamd2.8.0-dbgsym in ubuntu xenial.

No description available for libcolamd2.8.0-dbgsym in ubuntu xenial.

libcsparse3.1.2: No summary available for libcsparse3.1.2 in ubuntu wily.

No description available for libcsparse3.1.2 in ubuntu wily.

libcsparse3.1.2-dbgsym: No summary available for libcsparse3.1.2-dbgsym in ubuntu xenial.

No description available for libcsparse3.1.2-dbgsym in ubuntu xenial.

libcxsparse3.1.2: No summary available for libcxsparse3.1.2 in ubuntu utopic.

No description available for libcxsparse3.1.2 in ubuntu utopic.

libcxsparse3.1.2-dbgsym: No summary available for libcxsparse3.1.2-dbgsym in ubuntu xenial.

No description available for libcxsparse3.1.2-dbgsym in ubuntu xenial.

libklu1.2.1: No summary available for libklu1.2.1 in ubuntu xenial.

No description available for libklu1.2.1 in ubuntu xenial.

libklu1.2.1-dbgsym: No summary available for libklu1.2.1-dbgsym in ubuntu xenial.

No description available for libklu1.2.1-dbgsym in ubuntu xenial.

libldl2.1.0: No summary available for libldl2.1.0 in ubuntu wily.

No description available for libldl2.1.0 in ubuntu wily.

libldl2.1.0-dbgsym: No summary available for libldl2.1.0-dbgsym in ubuntu xenial.

No description available for libldl2.1.0-dbgsym in ubuntu xenial.

libspqr1.3.1: No summary available for libspqr1.3.1 in ubuntu xenial.

No description available for libspqr1.3.1 in ubuntu xenial.

libspqr1.3.1-dbgsym: No summary available for libspqr1.3.1-dbgsym in ubuntu xenial.

No description available for libspqr1.3.1-dbgsym in ubuntu xenial.

libsuitesparse-dbg: libraries for sparse matrices computations (debugging symbols)

 Suitesparse is a collection of libraries for computations involving
 sparse matrices. This package includes the following libraries:
 .
 AMD approximate minimum degree ordering
 .
 CAMD symmetric approximate minimum degree
 .
 BTF permutation to block triangular form (beta)
 .
 COLAMD column approximate minimum degree ordering
 .
 CCOLAMD constrained column approximate minimum degree ordering
 .
 CHOLMOD sparse Cholesky factorization
 .
 CSparse a concise sparse matrix package
 .
 CXSparse CSparse extended: complex matrix, int and long int support
 .
 KLU sparse LU factorization, primarily for circuit simulation
 .
 LDL a simple LDL' factorization
 .
 UMFPACK sparse LU factorization
 .
 SPQR sparse QR factorization
 .
 SuiteSparse_config configuration file for all the above packages.
 .
 This package contains the debug libraries (stored in /usr/lib/debug).

libsuitesparse-dev: libraries for sparse matrices computations (development files)

 Suitesparse is a collection of libraries for computations involving
 sparse matrices. This package includes the following libraries:
 .
 AMD approximate minimum degree ordering
 .
 CAMD symmetric approximate minimum degree
 .
 BTF permutation to block triangular form (beta)
 .
 COLAMD column approximate minimum degree ordering
 .
 CCOLAMD constrained column approximate minimum degree ordering
 .
 CHOLMOD sparse Cholesky factorization
 .
 CSparse a concise sparse matrix package
 .
 CXSparse CSparse extended: complex matrix, int and long int support
 .
 KLU sparse LU factorization, primarily for circuit simulation
 .
 LDL a simple LDL' factorization
 .
 UMFPACK sparse LU factorization
 .
 SPQR sparse QR factorization
 .
 SuiteSparse_config configuration routines for all the above packages.
 .
 This package contains the static libraries and header files.

libsuitesparse-dev-dbgsym: No summary available for libsuitesparse-dev-dbgsym in ubuntu xenial.

No description available for libsuitesparse-dev-dbgsym in ubuntu xenial.

libsuitesparse-doc: libraries for sparse matrices computations (documentation)

 Suitesparse is a collection of libraries for computations involving
 sparse matrices. This package contains the user guides for the
 libraries distributed by the SuiteSparse project.

libumfpack5.6.2: sparse LU factorization library

 Suitesparse is a collection of libraries for computations involving
 sparse matrices. This package includes the following dynamic library:
 .
 UMFPACK sparse LU factorization

libumfpack5.6.2-dbgsym: No summary available for libumfpack5.6.2-dbgsym in ubuntu xenial.

No description available for libumfpack5.6.2-dbgsym in ubuntu xenial.