java application can not display chinese characters

Bug #47045 reported by ZhengPeng Hou on 2006-05-28
14
Affects Status Importance Assigned to Milestone
sun-java5 (Ubuntu)
High
Matthias Klose

Bug Description

Binary package hint: sun-java5-bin

Using sun-java5 as default java run time, java application can not display chinese characters, this due to wrong configure in /etc/java-1.5.0-sun/fontconfig.properties. This configure file derived from Redhat, but the default chinese fonts in dapper are different from RedHat's, so it will not display chinese characters in java applications. Maybe this will happen in Japanese and Korean.

Changed in sun-java5:
assignee: nobody → doko
status: Unconfirmed → Confirmed
Jiahua Huang (huangjiahua) wrote :

It's a modifyed /etc/java-1.5.0-sun/fontconfig.properties for Ubuntu
http://paste.ubuntu.org.cn/323

Matthias Klose (doko) on 2006-05-29
Changed in sun-java5:
status: Confirmed → In Progress
atie (atie-at-matrix) wrote :

The modified fontconfig.properties file linked above has an error, batang.ttf and gulim.ttf are in /usr/share/fonts/truetype/baekmuk/

Thom Pischke (thom-pischke) wrote :

Tried using this modified config file, but I'm still not able to display chinese characters in my java application. Chinese characters work fine in Java on Windows, and also work fine in gedit and OpenOffice in Ubuntu, so it seems to be a problem specific to Chinese Fonts in Java on Ubuntu.

I'm using Ubuntu 6.06 with Java 1.5, though I also tested with Java 1.6

Jiahua Huang (huangjiahua) wrote :

hi, Thom.
It needs this font ttf-arphic-uming .

Matthias Klose (doko) wrote :

fixed in 1.5.0-07

Changed in sun-java5:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers