Change log for synfigstudio package in Ubuntu

129 of 29 results
Published in hirsute-release on 2021-01-12
Deleted in hirsute-proposed (Reason: moved to Release)
synfigstudio (1.4.0+dfsg-1) unstable; urgency=medium

  [ Dmitry Smirnov ]
  * New upstream release.
  * Rules-Requires-Root: no
  * Standards-Version: 4.5.0
  * rules: `ln` verbosity
  * rules: removed "--as-needed"
  * "watch" file to track GitHub releases.
  * Removed "libgtk2.0-dev" from Build-Depends (Closes: #967765).
  * Build-Depends:
    + libavcodec-dev
    + libavformat-dev
    + libavutil-dev
    + libswscale-dev

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat
  * Changed Maintainer from @lists.alioth.debian.org to @lists.debian.org
  * Bump Standards-Version to 4.4.1
  * d/watch: Use https protocol

 -- Dmitry Smirnov <email address hidden>  Tue, 12 Jan 2021 18:52:19 +1100
Superseded in hirsute-release on 2021-01-12
Published in groovy-release on 2020-04-24
Published in focal-release on 2020-03-23
Deleted in focal-proposed (Reason: moved to Release)
synfigstudio (1.2.2-1build1) focal; urgency=medium

  * No-change rebuild for libgcc-s1 package name change.

 -- Matthias Klose <email address hidden>  Mon, 23 Mar 2020 07:27:28 +0100
Superseded in focal-release on 2020-03-23
Obsolete in eoan-release on 2020-12-29
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed on 2020-12-29 (Reason: moved to release)
synfigstudio (1.2.2-1) unstable; urgency=medium

  * New upstream release.
  * dbgsym-migration: dropped -dbg package.
  * Debhelper & compat to version 11.
  * Standards-Version: 4.3.0
  * Priority: optional.
  * VCS URLs to Salsa.
  * New patch to remove embedded copy of PKG_CHECK_MODULES (Closes: #900433).
    Thanks, Helmut Grohne.

 -- Dmitry Smirnov <email address hidden>  Thu, 31 Jan 2019 20:18:41 +1100
Superseded in disco-release on 2019-02-01
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed on 2020-07-13 (Reason: moved to release)
synfigstudio (1.2.1-0.1build1) cosmic; urgency=medium

  * No-change rebuild against libsynfig0a

 -- Steve Langasek <email address hidden>  Sat, 02 Jun 2018 22:20:54 +0000
Superseded in cosmic-release on 2018-07-06
Published in bionic-release on 2018-04-10
Deleted in bionic-proposed (Reason: moved to release)
synfigstudio (1.2.1-0.1) unstable; urgency=medium

  * Non-maintainer upload.
  * New upstream version. Closes: #883594.
  * Update build dependency on font packages. Closes: #895162.
  * Build-depend on pkg-config and libfftw3-dev.

 -- Matthias Klose <email address hidden>  Mon, 09 Apr 2018 21:14:59 +0200
Superseded in bionic-release on 2018-04-10
Deleted in bionic-proposed on 2018-04-11 (Reason: moved to release)
synfigstudio (1.2.1-0ubuntu3) bionic; urgency=medium

  * Build-depend on pkg-config and libfftw3-dev.

 -- Matthias Klose <email address hidden>  Sun, 08 Apr 2018 17:38:25 +0200
Superseded in bionic-proposed on 2018-04-08
synfigstudio (1.2.1-0ubuntu2) bionic; urgency=medium

  * Build-depend on pkg-config.

 -- Matthias Klose <email address hidden>  Sun, 08 Apr 2018 17:38:25 +0200

Available diffs

Superseded in bionic-proposed on 2018-04-08
synfigstudio (1.2.1-0ubuntu1) bionic; urgency=medium

  * New upstream version. Closes: #883594.
  * Update build dependency on font packages. Closes: #895162.

 -- Matthias Klose <email address hidden>  Sun, 08 Apr 2018 13:36:19 +0200

Available diffs

Superseded in bionic-release on 2018-04-08
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2020-07-10 (Reason: moved to release)
synfigstudio (1.0.2-1build1) zesty; urgency=medium

  * Rebuild against new imagemagick libs.

 -- Bhavani Shankar <email address hidden>  Thu, 19 Jan 2017 11:30:59 +0530
Superseded in zesty-release on 2017-01-19
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-11-28
Deleted in xenial-proposed (Reason: moved to release)
synfigstudio (1.0.2-1) unstable; urgency=medium

  * New upstream release.
  * Build-Depends:
    - etl-dev (>= 0.04.18)
    + etl-dev (>= 0.04.19)
    - libsynfig-dev (>= 0.64.2)
    + libsynfig-dev (>= 1.0.2)
    - synfig (>= 1.0)
    + synfig (>= 1.0.2)
    + libmagick++-dev
  * New "c++11.patch" to fix FTBFS (Closes: #803037).
  * Removed .menu file (command-in-menu-file-and-desktop-file).
  * control: modernise Vcs-Browser URL.

 -- Dmitry Smirnov <email address hidden>  Fri, 27 Nov 2015 20:54:13 +1100

Available diffs

Superseded in xenial-release on 2015-11-28
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
synfigstudio (1.0-1build2) wily; urgency=medium

  * No-change rebuild for libxml++ soname change.

 -- Matthias Klose <email address hidden>  Mon, 07 Sep 2015 08:28:32 +0000

Available diffs

Superseded in wily-release on 2015-09-07
Deleted in wily-proposed on 2015-09-08 (Reason: moved to release)
synfigstudio (1.0-1build1) wily; urgency=medium

  * No-change rebuild against libglibmm-2.4-1v5

 -- Steve Langasek <email address hidden>  Fri, 07 Aug 2015 21:54:24 +0000

Available diffs

Superseded in wily-release on 2015-08-17
Deleted in wily-proposed on 2015-08-18 (Reason: moved to release)
synfigstudio (1.0-1) unstable; urgency=medium

  * New upstream release [April 2015].
  * Dropped all backported patches.
  * Build-Depends:
    - etl-dev (>= 0.04.17)
    + etl-dev (>= 0.04.18)
    - libgtkmm-2.4-dev
    + libgtkmm-3.0-dev
    + libmlt-dev
    + libmlt++-dev
    - synfig (>= 0.64.1)
    + synfig (>= 1.0)

 -- Dmitry Smirnov <email address hidden>  Thu, 07 May 2015 19:05:33 +1000

Available diffs

Superseded in wily-release on 2015-05-08
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
synfigstudio (0.64.2-2) unstable; urgency=medium


  * Added two new upstream patches for compatibility with Glib-2.42
    (Closes: #772748).

 -- Dmitry Smirnov <email address hidden>  Sat, 13 Dec 2014 16:22:23 +1100

Available diffs

Superseded in vivid-release on 2014-12-13
Deleted in vivid-proposed on 2014-12-14 (Reason: moved to release)
synfigstudio (0.64.2-1) unstable; urgency=medium


  * New upstream release [October 2014].
  * Build-Depenbds: libsynfig-dev (>= 0.64.2).
  * Added "debian/gbp.conf".
  * Standards-Version: 3.9.6.

 -- Dmitry Smirnov <email address hidden>  Mon, 20 Oct 2014 23:28:28 +1100

Available diffs

Superseded in vivid-release on 2014-10-26
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-12-12
Deleted in trusty-proposed (Reason: moved to release)
synfigstudio (0.64.1-1) unstable; urgency=low


  * New upstream release [November 2013].
  * Standards to 3.9.5.
  * Build-Depends on new "etl-dev (>= 0.04.17)", "synfig (>= 0.64.1)",
    "libsynfig-dev (>= 0.64.1)".
  * As per his request removed Denis Washington from Uploaders.

 -- Dmitry Smirnov <email address hidden>  Thu, 21 Nov 2013 15:33:31 +1100

Available diffs

Superseded in trusty-release on 2013-12-12
Deleted in trusty-proposed on 2013-12-14 (Reason: moved to release)
synfigstudio (0.64.0-2) unstable; urgency=low


  * Re-build to introduce versioned dependency on libsynfig
    (Closes: #709779).

 -- Dmitry Smirnov <email address hidden>  Sat, 14 Sep 2013 15:34:09 +1000

Available diffs

Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
synfigstudio (0.64.0-1) unstable; urgency=low


  * New upstream release [May 2013].
  * Standards to 3.9.4.
  * xz compression for source and binary packages.
  * Minor debian/watch update.
  * Added "intltool" to Build-Depends and invoke `intltoolize` after
    dh-autoreconf.
  * Updated my email address; bumped copyright years.

 -- Dmitry Smirnov <email address hidden>  Tue, 14 May 2013 02:42:38 +1000

Available diffs

Superseded in saucy-release on 2013-05-16
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
synfigstudio (0.63.05-1) unstable; urgency=low


  * New maintainers (Closes: #665045)
  * New upstream release.
  * imported latest QA changes
  * Packaging update
    + to straight debhelper + dh-autoreconf
    + compat & debhelper to version 9
    + standards to 3.9.2
    + use DPKG build flags & default hardening
    + --as-needed to avoid needless linking
    + parallel build by default on linux
    + corrected Vcs-Browser URL
    + build-deps recalculated
    + set d-multimedia as Maintainer
    - install libsynfigapp0 as private library,
      not as standalone package

 -- Dmitry Smirnov <email address hidden>  Sat, 12 May 2012 16:57:32 +1000
Deleted in natty-release on 2016-11-01 (Reason: (From Debian) RoQA; orphaned, outdated, low popcon; Debia...)
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
synfigstudio (0.62.00-1) unstable; urgency=low

  * QA upload
  * Properly orphan the package (set Maintainer to QA, empty Uploaders)
  * New upstream release
  * Bump build-dep on (lib)synfig to most recent version
  * Bump standards-version to 3.8.3, no changes needed
  * Change section of the "-dbg" package to debug, thanks lintian
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  10 Feb 2010 17:20:32 +0000

Available diffs

Superseded in lucid-release on 2010-02-10
Obsolete in karmic-release on 2013-03-04
synfigstudio (0.61.09-2) unstable; urgency=low

  * Upload to unstable after the lenny freeze
  * Switch to debhelper compat level 7
  * Switch from dh_clean -k to dh_prep
  * Link to the correct versions of the GPL
  * Drop duplicate Priority field for -dbg package

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
synfigstudio (0.61.08-1ubuntu1) jaunty; urgency=low

  * Changed the canvas version back to 0.1 in images/logo.sif (patch extracted
    from svn, r1866). Direct source modification as debian already did changes
    in source (LP: #336583)

 -- Fabrice Coutadeur <email address hidden>   Mon, 23 Mar 2009 05:01:34 +0000
Superseded in jaunty-release on 2009-03-26
Obsolete in intrepid-release on 2013-02-20
synfigstudio (0.61.08-1build1) intrepid; urgency=low

  * No-change rebuild for libxml++2.6c2a -> libxml++2.6-2 transistion.

 -- Steve Kowalik <email address hidden>   Wed, 06 Aug 2008 17:01:01 +1000

Available diffs

Superseded in intrepid-release on 2008-08-06
synfigstudio (0.61.08-1) unstable; urgency=low

  [ Cyril Brulebois ]
  * New upstream release.
  * debian/control:
     - Move the homepage from “synfig.com” to “synfig.org”.
     - Bump versions for etl-dev, libsynfig-dev, synfig in Build-Depends.
     - Bump Standards-Version from 3.7.2 to 3.7.3 (no changes needed).
     - Update the “Depends:” line of synfigsynfig-dbg, from
       “libsynfigapp0” to “libsynfigapp0 | synfigstudio” (both with
       ${binary:Version}) since this package contains the debugging
       symbols for both packages.
  * debian/synfigstudio.install:
     - Add “usr/share/locale”, since upstream now ships locales.
  * debian/rules:
     - Set SYNFIG_LIB, SYNFIG_VERSION_*, and use them by setting
       F:SynfigExtra in dh_gencontrol to add an extra constraint on
       libsynfig to ensure the presence of the version against which
       synfigstudio was built, since API/ABI aren't stable.

  [ Paul Wise ]
  * Recommend the new synfig-examples package
  * Remove outdated BUGS section from the manual page
  * Drop the libsynfigapp-dev package until it is needed
  * Drop the use of fonts that are not needed for rendering the images
  * Remove “DH_COMPAT=4” before the dh_clean call, no reason to have that.
  * Make the shlibs more restrictive and build-dep on the fixed synfig so
    that the dependencies on the libsynfig/libsynfigapp libraries are correct.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:26:56 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
synfigstudio (0.61.07-1build1) hardy; urgency=low

  * Rebuild for libopenexr transition.

 -- Luke Yelavich <email address hidden>   Thu, 13 Dec 2007 09:20:54 +1100
Superseded in hardy-release on 2007-12-13
synfigstudio (0.61.07-1) unstable; urgency=low

  [ Cyril Brulebois ]
  * New upstream release.
  * Bump versioned B-D on synfig and libsynfig-dev from 0.61.06 to
    0.61.07~rc3.
  * Bump versioned B-D on etl-dev from 0.04.09 to 0.04.10~rc3.
  * Add Homepage, Vcs-Browser, and Vcs-Svn fields to the source package.
  * Add myself to the Uploaders.
  * No longer ignore make distclean errors, per lintian.

  [ Paul Wise ]
  * Update menu for transition and add longtitle & description

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  24 Oct 2007 07:53:51 +0100
Superseded in hardy-release on 2007-10-24
Obsolete in gutsy-release on 2011-09-16
synfigstudio (0.61.06-1) unstable; urgency=low

  * New upstream release
    - Update copyright info (new contributors)
    - requrires the new etl, bump build-dep
    - no longer messes up gamma settings (Closes: #418647)
    - now shows up in the GNOME window list (Closes: #366731)
  * Change my email address now that I'm a Debian Developer
  * Install the new upstream README, AUTHORS, ChangeLog.old
  * Use sourceforge in the watch file and download link
  * Use the current upstream version in the shlibs for now

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  22 Jun 2007 09:48:49 +0100
Superseded in gutsy-release on 2007-06-22
Obsolete in feisty-release on 2009-08-20
synfigstudio (0.61.05-5) unstable; urgency=low
  
  [ Paul Wise] 
  * Switch back to the default g++
  * Apply patch from upstream to fix layer enable/disable

  [ Miguel Gea ]
  * Updated from upstream (voria svn version 226)

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
synfigstudio (0.61.05-3) unstable; urgency=low

  * Fix crash on startup on amd64 (Closes: #365102)
    Thanks to Ben Green (Sciboy) and Anthony DeRobertis for debugging help

129 of 29 results