hyphenation does not work after upgrade from breezy to dapper

Bug #36145 reported by martinp on 2006-03-23
88
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tetex-base (Ubuntu)
Medium
Martin Pitt
Nominated for Karmic by kavkar
tetex-bin (Ubuntu)
Medium
Unassigned
Nominated for Karmic by kavkar

Bug Description

I upgraded from Breezy to Dapper and tried to compile some of my TeX documents using no explicit hyphenations.
The package I use is ``ngerman'' and get the following error message during the compilation process:
   ngerman -- \language number for ngerman undefined, default 255 used,
   ngerman -- Please read "gerdoc.tex" how to install hyphenation patterns.)

This is quite a common problem and does not happen when upgrading from a fresh Breezy installation or installing Dapper from a Flight-CD. It has become a matter after I upgraded from my working installation of Breezy to Dapper (current).

Any ideas?

The problem is that 10tetex.cnf in /etc/texmf/language.d should be named 00tetex.cnf. Otherwise, update-language does not work. So first you rename the file, then 'sudo update-language'. After that, you must run 'sudo fmtutil-sys --all'. I don't know why update-language does not run it because update-language is useless without running fmtutil-sys.

martinp (martin-hyperion) wrote :

Yes, I saw that in /etc/texmf. However the file 00tex.cnf does not contain any language options. That's in my "faulty" upgraded dapper.
The freshly upgraded one does contain this information. I think there is a problem after setting up the package with existing files.

The ppl who maintain this package should now where to look. :)

The same problem exists with a fresh Dapper install (Flight 5). The steps listet by MarkoNo5 worked for me. Thanks! :)

Kristian Rink (kawazu) wrote :

Same here... fresh install from Flight 5, dist-upgraded today (2006-03-28). Fixed after dpkg-reconfigure'ing all tetex packages...

Andrew Whyte (ajw213) wrote :

I've tried the above fix but it hasn't worked for me (lastest Dapper fresh install and most recent apt-get upgrades) - the output of "sudo fmtutil-sys --all" still contains lines such as
...
language : patterns en for en loaded (n=1)
(/usr/share/texmf-tetex/tex/generic/hyphen/ushyph.tex)
language : no hyphenations en for en (n=1)
language : patterns uk for uk loaded (n=2)
(/usr/share/texmf-tetex/tex/generic/hyphen/ukhyph.tex)
language : no hyphenations uk for uk (n=2)
...
etc. for all languages
...
 - even though the "ushyph.tex" file (provided with the tetex package) is there and the "ukhyph.tex" package (that I added separately - it's no longer included because of a licensing issue) is also there.
Any help would be great!

Paulo Tanimoto (tanimoto) wrote :

Without paying much attention, I followed the suggestion included here:
https://launchpad.net/distros/ubuntu/+bug/36536

It worked for me.

It's a pity that tetex was updated recently, but this bug remains as "unconfirmed".

Matt Zimmerman (mdz) on 2006-04-11
Changed in tetex-bin:
assignee: nobody → tfheen
Roshan Shariff (roshan.shariff) wrote :

I can confirm this bug. I'm using Lyx and long words don't get hyphenated and instead stick out into the right margin. I'm using a fresh installation of Dapper Flight 5 updated as of 2006-04-19.

Following MarkoNo5's steps in the first comment fixes the problem.

Changed in tetex-bin:
status: Unconfirmed → Confirmed
Kuropka (d2) wrote :

I can confirm this bug too. Hyphenation definately does not work on my machine after upgrading to Dapper Beta.

Julien Chiquet (julien-chiquet) wrote :

If anyone is interested, I have found an alternative to MarkoNo5' procedure to correct the problem (which was not working on my system) :

execute as root
> sudo texconfig hyphen latex

which open with your favorite text editor the latex config file for hyphenation. I don't now why, and it's probably the source of the bug, the content of the file 10tetex.cnf is not present in it. So, you just have to paste the whole content of /etc/texmf/language.d/10tetex.cnf in the current edited config file, then save and quit.

LaTeX will normaly automatically compile the modified config file, what makes now hyphenation works.

jumpjoe (jumpjoe) wrote :

Interestingly enough, at the end of

/var/lib/texmf/tex/generic/config/language.dat

it says:

%%
%%% /etc/texmf/language.d/10tetex.cnf not included because the
%%% corresponding package seems to be removed.
%%

I suppose this is a bug of the package ;). Not only, the file ushyph1.tex is missing from the hyphen directory.

Prinz Igor (pigor) wrote :

Hi, i am running Dapper Drake (Beta x).

Same problem here. (german hyphenation)

The first solution does not work for me. But the second!

Regards,

Prinz Igor

This simple document contains a long word that LaTeX should break. But it currently doesn't.

Andrew Whyte (ajw213) wrote :

Wow - Julien's post fixed it for me! As with Prinz Igor, I don't know why MarkoNo5's method didn't work on my machine.

Looks like "/etc/texmf/language.d/10tetex.cnf" does need to be included in "/var/lib/texmf/tex/generic/config/language.dat" (it is not missing from the tetex package, as suggested in the comment at the end of the language.dat file).

All the best,

Andrew

Stefano Costa (steko) wrote :

MarkoNo5's method worked for me. I was upgrading from a working (updated) Breezy machine.

Anteru (launchpad-tr) wrote :

same problem here, with ngerman on a fresh 6.06 beta 2 installtion with all updates to date.

none of the known fixes work :/

The problem persists: Dapper Flight 5 installed from scratch, updated today to version 3.0-13ubuntu5.

The fix by MarkoNo5 worked for me.

Anders Kaseorg (andersk) wrote :

The rename from 00tetex.cnf to 10tetex.cnf seems intentional:

tetex-base (3.0-15) unstable; urgency=high

[...]
  * Rename language.de/00tetex.cnf to 10tetex.cnf, so that it really sorts
    after 00tex.cnf. Transitional code missing. [frank]

 -- Frank Küster <email address hidden> Thu, 2 Mar 2006 15:40:17 +0100

The problem is that /var/lib/tex-common/language-cnf/tetex-base.list still has "00tetex" instead of "10tetex".

But, for some reason, even though my language.dat now includes 10tetex.cnf (and I've run those two commands), I still don't get any hyphenation.

Adam Conrad (adconrad) wrote :

If I'm reading the Debian changelog correctly, this should be fixed by syncing a new version (not new upstream, just Debian revision) from sid.

Tollef, comments?

Antoine (antoine-mercier) wrote :

Same problem for the french hyphenation. MarkoNo5's solution in the fisrt post doesn't work for me.

Martin Pitt (pitti) wrote :

Closing superfluous tetex-bin task.

Changed in tetex-bin:
status: Unconfirmed → Rejected
Martin Pitt (pitti) wrote :

I confirmed that Debian's -16 fixes the issue and has no other apparent regressions. Unfortunately it's now too late to sync it, so we should fix this in d-updates.

You do not want to fix this bug before the release of Dapper? Users will be left without hyphenation? Please reconsider it. Average users will have real problems fixing it. I know many average Ubuntu users using LaTeX that long for (a working) teTeX 3.

yannek (yannek) wrote :

I second that irritation. Hyphenationless LeTeX ist simply unusable for (at least) german LaTeX-users. The number of long words in that language (and for sure in several others) is that high that tetex in the current state is practical useless for german documents.

Here's an untested fix that should work:

sudo sh -c 'echo 10tetex > /var/lib/tex-common/language-cnf/tetex-base.list'
sudo update-language
sudo -H fmtutil-sys --all

Can anybody test it, please?! (Sorry, I don't have the time to test it till the end of next week.)

To fix the bug change '00tetex' to '10tetex' in 'debian/tetex-base.language.list' in the tetex-base source package

--- debian/tetex-base.language.list (revision 1077)
+++ debian/tetex-base.language.list (revision 1078)
@@ -1 +1 @@
-00tetex
+10tetex

 and build it again. HTH!

Martin Pitt says the latest Debian package fixes the problem, so the fix is already known. I don't see the problem with it being uploaded to dapper-updates. If the new version is released soon after Dapper, everybody who installs tetex will get the fixed version, since the dapper-updates repository is enabled by default. Even otherwise, the fix will automatically be downloaded, so it's not really an issue.

I'm even hopeful it'll be fixed post-RC, since it isn't on the CD, but I don't know if there are any technical problems with that.

Hi,

Roshan Shariff [2006-05-25 18:09 -0000]:
> Martin Pitt says the latest Debian package fixes the problem, so the fix
> is already known. I don't see the problem with it being uploaded to
> dapper-updates.

That's indeed what we plan. We just want to avoid destabilizing the
release process.

You want to ship the Dapper CD with a broken teTeX? I'm not sure whether all of those who order a CD have an internet connection that is capable of comfortable upgrades (then they would probably not need to order a CD ...). Maybe you should place a pointer about the problems with teTeX.

Hi Christoph

On 5/26/06, Christoph Bier <email address hidden> wrote:
> You want to ship the Dapper CD with a broken teTeX? I'm not sure whether

AFAIK, tetex is not on the CD anyway. People who need it must download
it from the repositories. It doesn't make any difference to them
whether they download it from the "dapper" repository or the
"dapper-updates" repository, since the latter is enable automatically.

You want to ship the Dapper CD with a broken teTeX? I'm not sure whether all of those who order a CD have an internet connection that is capable of comfortable upgrades (then they would probably not need to order a CD ...). Maybe you should place a pointer about the problems with teTeX.

Oh sorry, I did not know that teTeX isn't shipped with the CD.

Markus Kohm (mkohm) wrote :

Martin Pitt at 2006-05-25 21:28:37 CEST wrote:
> That's indeed what we plan. We just
> want to avoid destabilizing the
> release process.

Changing one `0' into `1' would destabilize the release process? But creating the documentations to several packages with a buggy package would not destabilize the release itself?

I think, not fixing this bug for a long time, wasn't a good idea. I hope, that only very, very few packages depend on tetex.

faswad (fred-wittyname) wrote :

Dapper Drake 6.06 bug confirmed.

MarkoNo5's fix worked here! thanks!

Rod (raf-cs) wrote :

Hi, confirming bug. I can also confirm that Julien's fix worked on my laptop

I upgraded from Breezy via update-manager. Tetex had problems, I image from previous config files, so I remove all Tex, LaTeX related packages, purged, and installed from start. Installation worked without a problem this time.

Upon attempting to compile a very simple latex file, I got:

! Undefined control sequence.
\APAC@apcfile ->\languagename
                              .apc
l.74 \begin{document}

This was fixed using the hyphenation workaround provided by Julien.

Hope this helps anyone else who was banging their head against a brick wall.

Martin Pitt (pitti) wrote :

Sync request filed, see bug 47822

Changed in tetex-base:
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Since the debdiff to -16 is too big, I'm backporting the changes instead.

Changed in tetex-base:
assignee: tfheen → pitti
Martin Pitt (pitti) wrote :

 tetex-base (3.0-15ubuntu1) dapper-updates; urgency=low
 .
   * Repair hyphenation:
     - debian/tetex-base.language.list: Fix include file name (00tetex ->
       10tetex).
     - debian/postinst.in: Fix test for various programs, so that font maps,
       formats, etc. are actually recreated. Also, call create_tetex_formats
       with --all to ensure that upgrades get all files
       updated correctly.
     - Fixes ported from 3.0-16.
     - Closes: LP#36145

Uploaded, will be approved soon.

Changed in tetex-base:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted.

Changed in tetex-base:
status: Fix Committed → Fix Released

I've used the MarkoNo5's tip, all was OK. I've just upgraded tex* packages today and the hyphenation doesn't work at all.

I found this solution :
00tetex.cnf --> 10tetex.cnf (rename, find it in /etc/texmf/language.d/)
sudo update-language
sudo fmtutil-sys --all

It's now OK.

The fix supposes user didn't do anything before ?

kavkar (kavkar) on 2009-10-07
Changed in tetex-bin (Ubuntu):
status: Invalid → New
Anders Kaseorg (andersk) wrote :

kavkar: This package doesn’t even exist anymore. Did you really mean to mark this bug “New” and nominate it for Karmic?

Changed in tetex-bin (Ubuntu):
status: New → Invalid
kavkar (kavkar) wrote :

Sorry, I'm overlooked that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers