Ubuntu

Change log for “texlive-bin” package in Ubuntu

175 of 82 results
Published in trusty-release on 2014-02-04
Deleted in trusty-proposed (Reason: moved to release)
texlive-bin (2013.20130729.30972-2build3) trusty; urgency=medium

  * Rebuild for the new poppler soname
 -- Sebastien Bacher <email address hidden>   Wed, 22 Jan 2014 23:17:17 +0100
Superseded in trusty-release on 2014-02-04
Deleted in trusty-proposed on 2014-02-06 (Reason: moved to release)
texlive-bin (2013.20130729.30972-2build2) trusty; urgency=medium

  * No change rebuild against libicu52
 -- Dimitri John Ledkov <email address hidden>   Fri, 27 Dec 2013 05:35:29 +0000
Superseded in trusty-release on 2013-12-31
Deleted in trusty-proposed on 2014-01-01 (Reason: moved to release)
texlive-bin (2013.20130729.30972-2build1) trusty; urgency=medium

  * No-change rebuild for new harfbuzz
 -- Iain Lane <email address hidden>   Mon, 09 Dec 2013 12:45:01 +0000
Published in saucy-updates on 2013-11-07
Deleted in saucy-proposed (Reason: moved to -updates)
texlive-bin (2013.20130529.30792-1ubuntu1) saucy; urgency=low

  * Import metapost bugfix release 1.803 to fix crash and bad font rendering
    in lilypond (LP: #1243777)
  * Update pmpost correspondingly (backport from Debian)
 -- Iain Lane <email address hidden>   Fri, 25 Oct 2013 11:55:18 +0100
Superseded in trusty-release on 2013-12-10
Deleted in trusty-proposed on 2013-12-11 (Reason: moved to release)
texlive-bin (2013.20130729.30972-2) unstable; urgency=low


  * fix some bugs in man pages: mf, xdvi, synctex.5, mendex, detex
    (Closes: #662846, #664961, #667981)
  * fix a bug in mendex when range ops and macros are used (Closes: #534641)
  * reinstatiate xdvi perl wrapper (Closes: #631271, #583188)
  * pull several bug fixes from upstream svn, in particular fixes for
    luatex (svn 31126, 31313, 31358), dvipdfmx (svn 31303), pdftex (svn 31313),
    dvips (svn 31350, 31547)
  * explicitely write out versioned dependencies on automake, autoconf, 
    libtool, and m4, to make sure we get successful builds

 -- Norbert Preining <email address hidden>  Mon, 09 Sep 2013 15:18:50 +0900
Superseded in trusty-release on 2013-10-21
Published in saucy-release on 2013-08-05
Deleted in saucy-proposed (Reason: moved to release)
texlive-bin (2013.20130529.30792-1build2) saucy; urgency=low

  * No-change rebuild for new poppler ABIs
 -- Iain Lane <email address hidden>   Tue, 30 Jul 2013 17:02:46 +0000
Superseded in saucy-release on 2013-08-05
Deleted in saucy-proposed on 2013-08-06 (Reason: moved to release)
texlive-bin (2013.20130529.30792-1build1) saucy; urgency=low

  * Rebuild with the new poppler soname
 -- Sebastien Bacher <email address hidden>   Thu, 30 May 2013 15:31:13 +0200
Superseded in saucy-release on 2013-06-03
Deleted in saucy-proposed on 2013-06-05 (Reason: moved to release)
texlive-bin (2013.20130529.30792-1) unstable; urgency=low


  * remove dependency on ed, seems not needed anymore (Closes: #546938)
  * fix encoding of mendex man page (new b-d on recode) (Closes: #702202)
  * fix strange output in tex.1 (Closes: #663157)
  * upstream fixes (already in earlier TL2013 versions)
    - xdvi now without libt1 (Closes: #668415)
    - xdvi reacts on horizontal scroll events (Closes: #235757, #131338)
    - dvips does not crash on input == output (Closes: #703212)
  * upstream fix to luatex libio

 -- Norbert Preining <email address hidden>  Wed, 29 May 2013 10:05:32 +0900
Superseded in saucy-release on 2013-05-29
Deleted in saucy-proposed on 2013-05-30 (Reason: moved to release)
texlive-bin (2013.20130523.30626-1) unstable; urgency=low


  * update pmpost patch to fix png/svg output, thanks to Akira Kakuto
    (Closes: #709273)
  * disable ttf2pk and enable ttf2pk2, this allows us to get rid
    of unsupported libfreetype(1), thanks again to Ondřej Surý.
  * new upstream: remove biber binaries (Closes: #709274)
  * fix postinst so that formats are again rebuild
  * remove lintian-overrides, not needed anymore

 -- Norbert Preining <email address hidden>  Thu, 23 May 2013 09:42:24 +0900
Superseded in saucy-proposed on 2013-05-23
texlive-bin (2013.20130522.30620-1) unstable; urgency=low


  * remove libgd and t1lib copies by removing the need to configure
    these libraries at all (Closes: #709145, #709146)
    Thanks Ondřej Surý <email address hidden> for providing the patch.
  * build with system zzlib and ice, remove embedded copies
  * remove copies of cairo, pixman which are already unused
  * re-include pmpost building, thanks to Hironori Kitagawa

 -- Norbert Preining <email address hidden>  Wed, 22 May 2013 10:07:27 +0900
Superseded in saucy-proposed on 2013-05-23
texlive-bin (2013.20130516.30500-1) unstable; urgency=low


  * new upstram checkout
  * disable pmpost, no build support at the moment

 -- Norbert Preining <email address hidden>  Thu, 16 May 2013 18:21:52 +0900
Superseded in saucy-release on 2013-05-24
Published in raring-release on 2012-11-20
Deleted in raring-proposed (Reason: moved to release)
texlive-bin (2012.20120628-4) unstable; urgency=low


  * add necessary break for update from wheezy (Closes: #689005)
  * build dvisvgm with libgs support (build dep added, config option added)
  * include a fixed and updated man page for updmap.cfg (Closes: #688893)

 -- Norbert Preining <email address hidden>  Tue, 20 Nov 2012 09:31:10 +0900
Superseded in raring-release on 2012-11-20
Published in quantal-release on 2012-09-12
texlive-bin (2012.20120628-3build1) quantal; urgency=low

  * No-change rebuild for libpoppler27 -> libpoppler28 transition.
 -- Robert Ancell <email address hidden>   Wed, 12 Sep 2012 17:14:56 +1200
Superseded in quantal-release on 2012-09-12
texlive-bin (2012.20120628-3) unstable; urgency=low


  * fix too short name space for cweave (original file has this fix
    since 2008) (new patch cweave-fix-too-short-names)

 -- Norbert Preining <email address hidden>  Tue, 04 Sep 2012 10:32:59 +0900

Available diffs

Superseded in quantal-release on 2012-09-10
texlive-bin (2012.20120628-2) unstable; urgency=low


  * cherrypick a bugfix from upstream for ptex kanji code scanning
    (debian/quilt/upstream-fix-ptex-scanning)
  * format and lintian fixes

 -- Norbert Preining <email address hidden>  Thu, 26 Jul 2012 11:59:23 +0900
Superseded in quantal-release on 2012-08-01
texlive-bin (2012.20120628-1) unstable; urgency=low


  * new upstream (some emergency fixes), the following patches have
    been removed since they are included upstream: patch-icu, patch-pdftex,
    fix-pipe-in-out-regression, upstream-fix-ini-synctex-segfault
  * Build with -marm on armhf to fix lilypond FTBFS (Closes: #678604)
    (Thanks Peter Michael Green)

 -- Norbert Preining <email address hidden>  Thu, 28 Jun 2012 23:47:26 +0900
Superseded in quantal-release on 2012-07-03
texlive-bin (2012.20120530-2ubuntu2) quantal; urgency=low

  * No-change rebuild for the libpoppler26 transition.
 -- Adam Conrad <email address hidden>   Sat, 23 Jun 2012 20:30:51 -0600
Superseded in quantal-release on 2012-06-24
texlive-bin (2012.20120530-2ubuntu1) quantal; urgency=low

  * Track API changes in libpoppler19 to libpoppler25 transition.
 -- Andy Whitcroft <email address hidden>   Fri, 08 Jun 2012 16:51:17 +0100
Superseded in quantal-release on 2012-06-08
texlive-bin (2012.20120530-2) unstable; urgency=low


  * call update-language in the postinstall (Closes: #675179)

 -- Norbert Preining <email address hidden>  Wed, 30 May 2012 21:34:07 +0900

Available diffs

Superseded in quantal-release on 2012-05-31
texlive-bin (2012.20120530-1) unstable; urgency=high


  * new upstream snapshot (svn 26726)
    exporting kpse_cnf_get (Closes: #675109)
  * cnf.h is again installed, don't install it via libkpathsea-dev.install
  * patch handling:
    . removed: 41_maketexmf, 12_fix_epstopdf_invocation
      both included upstream or not needed anymore
    . new: set-e-fmtutil part of set-e-in-various-scripts that still 
      applies
    . disabled: 57_texconfig_papersizes_for_upstream,
      58_texconfig_papersizes_use_ucf, superseeded by 55_texconfig_stuff
    . disabled: set-e-in-various-scripts: split into set-e-fmtutil
      and a disabled part for texconfig

 -- Norbert Preining <email address hidden>  Wed, 30 May 2012 11:02:05 +0900
Superseded in quantal-release on 2012-05-30
texlive-bin (2012.20120516-1) unstable; urgency=low


  * new upstream snapshot based on TL2012 tlpretest
  * remove outdated and not needed patches
  * remove traces of debian internal mupdmap, we use the one that is now
    shipped by default in TeX Live
  * patch shipped updmap for correct perl module search path
  * move patches from debian/patches to debian/quilt, add quilt as 
    build dep, and include quilt patching in debian/rules
    this gets us rid of the "strange" parts of the 3.0 format
    (see quilt vs dpkg-source fuzzyness acceptance). 
    Thanks to an unnamed dev who gave me the hint!
  * disable build-wovp2ovf patch, included upstream
  * (re)install cnf.h into libkpathsea-dev (Closes: #673016)

 -- Norbert Preining <email address hidden>  Wed, 16 May 2012 14:05:23 +0900
Superseded in quantal-release on 2012-05-18
texlive-bin (2011.20120410-1ubuntu1) quantal; urgency=low

  * Merge with Debian; remaining changes:
  * debian/control
    - Build-depend on libpng12-dev since Ubuntu hasn't made the
      libpng15 transition yet
  * debian/patches/xdvi-zoom-with-eps-figures.patch: Make zooming with
    Ghostscript 9.0x working correctly. EPS figures were cut off after
    zooming and scrolling.
    See http://bugs.ghostscript.com/show_bug.cgi?id=692540
 -- Jeremy Bicha <email address hidden>   Thu, 12 Apr 2012 17:30:29 -0400
Superseded in quantal-release on 2012-05-01
texlive-bin (2011.20120410-1) unstable; urgency=low


  * new upstream checkout:
    - remove decls of popen and pclose (Closes: #64524) (!yow, 5 digit bug!)
    - do not declare getopt in C++, fixes FTBFS with g++ >= 4.7 
      (Closes: #667392)
  * add patches (maybe to be included upstream) that allows inclusion of
    one config file in another for (x)dvipdfmx. This will be
    used by the paper code.
  * fix description of libptexenc-dev package (Closes: #667694)
  * remove xdvik patch, included upstream
  * remove conflict with ptex-bin, we are building a transitional package now
  * build with internal t1lib, as t1lib is going to disappear in
    wheezy (Closes: #667912) (no, dropping xdvi is not an option!)
    (add a lintian override otherwise this gives a lintian error)

 -- Norbert Preining <email address hidden>  Tue, 10 Apr 2012 10:16:01 +0900
Superseded in quantal-release on 2012-05-01
Published in precise-release on 2011-12-06
texlive-bin (2009-11ubuntu2) precise; urgency=low

  * No-change rebuild against libpoppler19.
 -- Martin Pitt <email address hidden>   Tue, 06 Dec 2011 09:11:54 +0100

Available diffs

Superseded in precise-release on 2011-12-06
Published in oneiric-release on 2011-09-29
texlive-bin (2009-11ubuntu1) oneiric; urgency=low

  * debian/patches/xdvi-zoom-with-eps-figures.patch: Make zooming with
    Ghostscript 9.0x working correctly. EPS figures were cut off after
    zoomaing and scrolling.
    See http://bugs.ghostscript.com/show_bug.cgi?id=692540
 -- Till Kamppeter <email address hidden>   Thu, 29 Sep 2011 17:15:24 +0200

Available diffs

Superseded in oneiric-release on 2011-09-29
texlive-bin (2009-11) unstable; urgency=low

  [ Hilmar Preuße ]
  * disable the LFS support provided by upstream again, it is
    really broken (Reopens: #618033). It:
    - breaks pdflatex on big endian platforms (Closes: #637667)
    - introduced an ABI change on 32-bit platforms (Closes: #637720)

Available diffs

Superseded in oneiric-release on 2011-08-24
Obsolete in natty-release on 2013-06-04
texlive-bin (2009-8ubuntu2) natty; urgency=low

  * No-change upload to rebuild against libpoppler13.
 -- Martin Pitt <email address hidden>   Sun, 10 Apr 2011 21:21:53 +0200

Available diffs

Superseded in natty-release on 2011-04-10
texlive-bin (2009-8ubuntu1) natty; urgency=low

  * In try_open_mode, pass the mode on to open even in the EMFILE/ENFILE
    case.
 -- Colin Watson <email address hidden>   Sun, 20 Feb 2011 17:57:01 +0000

Available diffs

Superseded in natty-release on 2011-02-20
texlive-bin (2009-8build1) natty; urgency=low

  * No change upload to rebuild against new poppler
 -- Jamie Strandboge <email address hidden>   Thu, 27 Jan 2011 09:26:57 -0600

Available diffs

Superseded in natty-release on 2011-01-27
texlive-bin (2009-8) unstable; urgency=low

  * add upstream patch from Mathias Kende fixing segfaults on MIPS
    due to invalid C (Closes: #602566)
    (debian/patches/upstream-tex-file_arg-passing-fix)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  12 Nov 2010 10:56:58 +0000

Available diffs

Superseded in natty-release on 2010-11-12
Obsolete in maverick-release on 2013-03-05
texlive-bin (2009-7) unstable; urgency=low

  * add ed (and perl, texlive-common) to the list of dependencies (LP: #577305)
    (Closes: #580732)
  * remove texconfig warning/exit (with tlmgr link) statement and rely
    on fmtutil being debianized (Closes: #588731)
 -- ???? ???????? (Ahmed El-Mahmoudy) <email address hidden>   Mon,  06 Sep 2010 11:27:44 +0100

Available diffs

Published in lucid-updates on 2010-08-25
Deleted in lucid-proposed (Reason: moved to -updates)
texlive-bin (2009-5ubuntu0.2) lucid-proposed; urgency=low

  * Add missing dependency on ed to texlive-binaries. (LP: #577305)
 -- Anders Kaseorg <email address hidden>   Sat, 08 May 2010 02:35:38 -0400

Available diffs

Superseded in maverick-release on 2010-09-06
texlive-bin (2009-6ubuntu1) maverick; urgency=low

  * Add missing dependency on ed to texlive-binaries. (Closes: #580732,
    LP: #577305)
 -- Anders Kaseorg <email address hidden>   Sun, 15 Aug 2010 00:24:43 +0200

Available diffs

Superseded in maverick-release on 2010-08-14
texlive-bin (2009-6build1) maverick; urgency=low

  * No-change upload to build against current poppler library ABI.
 -- Didier Roche <email address hidden>   Thu, 05 Aug 2010 12:16:24 +0200

Available diffs

Superseded in maverick-release on 2010-08-05
texlive-bin (2009-6) unstable; urgency=high

  [ Frank Küster ]
  * include a patch that allows texconfig to handle more default paper
    settings.  This is intended to be submitted upstream, and to be used
    to address #402994 (libpaper integration) [fk]

  [ Norbert Preining ]
  * include (lost) man pages for texconfig-dialog, devnag, bibtex8,
    omfonts, otangle, pdfopen (no bug, but see #574796)
  * add a patch upstream-web2c-tmpfilewithpid that fixes overwriting
    files with -recorder in parallel builds (Closes: #575731).
  * bump standards version to 3.8.4, no changes necessary
  * bump build-dep on libpoppler to 0.12.4 (against my will!!)
    (Closes: #577684)
  * Fix CVE-2010-1440: this overrides the incomplete fix for CVE-2010-0793.
  
  [ Security Team ]
  Fixed in 2009-5+nmu1
  * Fix CVE-2010-0827: buffer overflow in dvips (virtualfont.c).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 14:04:27 +0100

Available diffs

Published in hardy-updates on 2010-05-06
Published in hardy-security on 2010-05-06
texlive-bin (2007.dfsg.1-2ubuntu0.1) hardy-security; urgency=low

  * SECURITY UPDATE: denial of service via buffer overflow
    - debian/patches/security-CVE-2009-1284.patch: check for pool overflow
      in build/source/texk/web2c/bibtex.ch.
    - CVE-2009-1284
  * SECURITY UPDATE: arbitrary code execution via memory corruption
    (LP: #537103)
    - debian/patches/security-CVE-2010-0827.patch: make sure name isn't
      too long in build/source/texk/dvipsk/virtualfont.c.
    - CVE-2010-0827
  * SECURITY UPDATE: arbitrary code execution via integer overflow
    - debian/patches/security-CVE-2010-0739,1440.patch: make sure numbytes
      doesn't overflow in build/source/texk/dvipsk/dospecial.c.
    - CVE-2010-0739
    - CVE-2010-1440
 -- Marc Deslauriers <email address hidden>   Mon, 03 May 2010 09:17:58 -0400
Obsolete in jaunty-updates on 2013-02-28
Obsolete in jaunty-security on 2013-02-28
texlive-bin (2007.dfsg.2-4ubuntu2.1) jaunty-security; urgency=low

  * SECURITY UPDATE: denial of service via buffer overflow
    - debian/patches/security-CVE-2009-1284.patch: check for pool overflow
      in build/source/texk/web2c/bibtex.ch.
    - CVE-2009-1284
  * SECURITY UPDATE: arbitrary code execution via memory corruption
    (LP: #537103)
    - debian/patches/security-CVE-2010-0827.patch: make sure name isn't
      too long in build/source/texk/dvipsk/virtualfont.c.
    - CVE-2010-0827
  * SECURITY UPDATE: arbitrary code execution via integer overflow
    - debian/patches/security-CVE-2010-0739,1440.patch: make sure numbytes
      doesn't overflow in build/source/texk/dvipsk/dospecial.c.
    - CVE-2010-0739
    - CVE-2010-1440
 -- Marc Deslauriers <email address hidden>   Mon, 03 May 2010 09:15:24 -0400
Obsolete in karmic-updates on 2013-03-04
Obsolete in karmic-security on 2013-03-04
texlive-bin (2007.dfsg.2-7ubuntu1.1) karmic-security; urgency=low

  * SECURITY UPDATE: denial of service via buffer overflow
    - debian/patches/security-CVE-2009-1284.patch: check for pool overflow
      in build/source/texk/web2c/bibtex.ch.
    - CVE-2009-1284
  * SECURITY UPDATE: arbitrary code execution via memory corruption
    (LP: #537103)
    - debian/patches/security-CVE-2010-0827.patch: make sure name isn't
      too long in build/source/texk/dvipsk/virtualfont.c.
    - CVE-2010-0827
  * SECURITY UPDATE: arbitrary code execution via integer overflow
    - debian/patches/security-CVE-2010-0739,1440.patch: make sure numbytes
      doesn't overflow in build/source/texk/dvipsk/dospecial.c.
    - CVE-2010-0739
    - CVE-2010-1440
 -- Marc Deslauriers <email address hidden>   Mon, 03 May 2010 09:12:05 -0400
Superseded in lucid-updates on 2010-08-25
Published in lucid-security on 2010-05-06
texlive-bin (2009-5ubuntu0.1) lucid-security; urgency=low

  * SECURITY UPDATE: arbitrary code execution via memory corruption
    (LP: #537103)
    - debian/patches/security-CVE-2010-0827.patch: make sure name isn't
      too long in texk/dvipsk/virtualfont.c.
    - CVE-2010-0827
  * SECURITY UPDATE: arbitrary code execution via integer overflow
    - debian/patches/security-CVE-2010-0739,1440.patch: make sure numbytes
      doesn't overflow in texk/dvipsk/dospecial.c.
    - CVE-2010-0739
    - CVE-2010-1440
 -- Marc Deslauriers <email address hidden>   Mon, 03 May 2010 09:05:31 -0400
Superseded in maverick-release on 2010-05-09
Published in lucid-release on 2010-01-22
texlive-bin (2009-5) unstable; urgency=low

  * include a patch (from upstream) to fmtutil so that multiple
    defined formats are accepted. That is the definitive fix for bug
    #557091, but the other one is necessary, too.
  * install synctex.5 man page
  * manage bibtex with alternatives, code by Андрей Парамонов

Available diffs

Superseded in lucid-release on 2010-01-22
texlive-bin (2007.dfsg.2-8) unstable; urgency=low

  * Include patches from Ubuntu for libpoppler 0.0.12 support 
    (Closes: #548878) (LP: #383825)
  * Add another patch fix-getline-libc10-horror that fixes another
    unreported FTBFS because libc now exports getline
 -- ???? ???????? (Ahmed El-Mahmoudy) <email address hidden>   Tue,  24 Nov 2009 00:23:40 +0000
Superseded in lucid-release on 2009-11-24
Obsolete in karmic-release on 2013-03-04
texlive-bin (2007.dfsg.2-7ubuntu1) karmic; urgency=low

  * Merge from Debian unstable, remaining changes: (LP: #438092)
    + debian/patches/ubuntu_libpoppler-0.11: fix a FTBFS because of unuseful
      call to GfxFont destructor (virtual and protected) (LP: #383825)
    + debian/patches/65_fix_getline_glibc2.10.patch: fix FTBFS by renaming
      included getline-functions to not conflict with glibc provided getline.
    + debian/fix-manpages.sh: quote special chars in sed command
  * debian/patches/ubuntu_libpoppler-0.12: fix a FTBFS with libpoppler 0.12:
    use getPDFMinorVersion instead of getPDFVersion. (LP: #438031)

Superseded in karmic-release on 2009-10-07
texlive-bin (2007.dfsg.2-6ubuntu3) karmic; urgency=low

  * rebuild for new libpoppler, fixes various crashes (LP: #410242)
  * debian/patches/65_fix_getline_glibc2.10.patch: fix FTBFS by renaming
    included getline-functions to not conflict with glibc provided getline.
  * debian/fix-manpages.sh: quote special chars in sed command

 -- Andreas Moog <email address hidden>   Mon, 10 Aug 2009 16:23:59 +0200
Superseded in karmic-release on 2009-08-15
texlive-bin (2007.dfsg.2-6ubuntu2) karmic; urgency=low

  * debian/patches/ubuntu_libpoppler-0.11: fix a FTBFS because of unuseful
    call to GfxFont destructor (virtual and protected) (LP: #383825)

 -- Fabrice Coutadeur <email address hidden>   Fri, 05 Jun 2009 04:17:22 +0000
Superseded in karmic-release on 2009-06-15
texlive-bin (2007.dfsg.2-6ubuntu1) karmic; urgency=low

  * Merge from Debian unstable, remaining changes:
    - debian/rules, debian/control: build with g++ -fno-tree-ter on armel,
      instead of build-depending on g++-4.2.

Superseded in karmic-release on 2009-05-01
Obsolete in jaunty-release on 2013-02-28
texlive-bin (2007.dfsg.2-4ubuntu2) jaunty; urgency=low

  * debian/rules, debian/control: build with g++-4.3 -fno-tree-ter on armel,
    instead of build-depending on g++-4.2.

 -- Steve Langasek <email address hidden>   Thu, 02 Apr 2009 23:07:39 +0000
Superseded in jaunty-release on 2009-04-03
texlive-bin (2007.dfsg.2-4ubuntu1) jaunty; urgency=low

  * Cherry-pick a fix from Debian to fix a build failure with current
    poppler:
    - update the poppler patch for version 0.10, that brings in another
      build-dep on pkg-config, update the control file (Closes: #518634)

 -- Steve Langasek <email address hidden>   Mon, 23 Mar 2009 14:44:34 +0000
Superseded in jaunty-release on 2009-03-27
texlive-bin (2007.dfsg.2-4) unstable; urgency=medium

  * add texlive-extra-utils replaces tetex-bin (<<2007) to make sure
    upgrade from Etch does work (Closes: #503462) (RC->medium)
  * drop three recommends to suggests:
    - texlive-extra-utils -> dvi2tty: dvi2tty is not in testing
    - texlive-extra-utils -> dvidvi: added feature, no direct need
    - texlive-base-bin -> perl-tk: we give an error message on texdoctk if
      perl-tk is missing
    (Closes: #502527)

 -- Martin Pitt <email address hidden>   Wed,  05 Nov 2008 07:49:46 +0000
Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
texlive-bin (2007.dfsg.2-3ubuntu1) intrepid; urgency=low

  * Demote dvi2tty and dvidvi from Recommends to Suggests. The former is not
    in Debian testing and orphaned, and in general current LaTeX defaults and
    encourages the PDF format now (instead of the ancient DVI).
  * Demote perl-tk, too. It is in universe, and really not something that
    most LaTeX users will ever need to be installed by default.

 -- Martin Pitt <email address hidden>   Fri, 17 Oct 2008 11:54:10 +0000
Superseded in intrepid-release on 2008-10-17
texlive-bin (2007.dfsg.2-3) unstable; urgency=medium

  * add missing source roadmap.fig of roadmap.eps in fontinst documentation
    (Closes: #482915) (urgency medium due to RC bug)
    (new patch add-missing-fontinst-source)

Available diffs

Superseded in intrepid-release on 2008-07-04
texlive-bin (2007.dfsg.2-1) unstable; urgency=medium

  * Let tl-metapost replace tl-context (closes: #484818). This is a RC
    bug, hence medium urgency [fk]
  * Fix shell scripting errors in texlive-base-bin's preinst script (one
    fix actually is done in common.functions.preinst and affects all
    packages, but didn't show up there). Closes: #484833 [fk]
  * include sfd files necessary for other packages, but removed from
    the archive with the imminent removal of freetype1-tools. That needs
    a new .orig.tar.gz
  * bump standards version to 3.8.0:
    - rename README.Debian-source to README.source an explain how to change
      something using quilt by refering to the quilt README.source
    - add homepage field to control
    - add a patch target to debian/rules
  * add dversionmangle to debian/watch file to ignore the .dfsg.NN suffix

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  23 Jun 2008 13:57:10 +0100

Available diffs

Superseded in intrepid-release on 2008-06-23
texlive-bin (2007.dfsg.1-4) unstable; urgency=low

  * add mktexlsr-ignore-more-vcs patch that makes mktexlsr ignore not only
    .svn, but also other VCS directories. Patch taken from upstream
    (Closes: #481371) [np]
  * Fix NEWS.Debian of texlive-base-bin to describe the issue of removed
    conffiles better (closes: #482631) [fk]
  * add a missing line to the tl2007.2 xetex patch, taken from upstream
  * add a patch to xdvipdfmx to re-allow inclusion of tagged pdf images
    (Closes: #483019) (big thanks to Jonathan Kew for tracking all this down)
  * do not install xdvizilla(.1) (Closes: #477160)
  * use gcc/g++-4.2 on armel to fix FTBFS (closes: #483939) (thanks Adeodato)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  02 Jun 2008 09:22:00 +0100

Available diffs

Superseded in intrepid-release on 2008-06-02
texlive-bin (2007.dfsg.1-3) unstable; urgency=low

  * improve manpage of patgen (Closes: #450875)
  * (really?) fix the watch file (Closes: #449621), thanks Raphael Geissert
  * bump standards version to 3.7.3, no changes needed
  * add texlive-common dependency to the -doc splitted packages,
    otherwise configuration can fail due to missing update-updmap etc
    (Closes: #457270) (Closes Ubuntu bug: 177674)
  * include dviconcat and dviutils (orphaned package dviutils/seetex) and
    provide/replace/conflict with dviutils (extra-utils)
  * texlive-xetex recommends texlive-latex-base (Closes: #462610)
  * add copies of supp-pdf.tex and supp-mis.tex from context 2008-01-28
    to texlive-metapost so inclusion of metapost images in pdf(la)tex does
    work without installation of context (Closes: #465107)
  * fix perl warning in thumbpdf (patch: fix-thumbpdf-perlwarning)
    (Closes: #469294)
  * fix a segfault in ovp2ovf (patch: fix-ovp2ovf-segfault) (Closes: #470433)
  * TeX Live 2007.2 release incorporation: fixes for xetex and xdvipdfmx,
    new patches tl2007.2-xetex and tl2007.2-xdvipdfmx
    (adapted from Jonathan Kew's original patches to work with poppler)
  * add the LPPL to debian/copyright
  * texlive-extra-utils now recommends ghostscript (Closes: #476954)
  * fix skipping of all trees in mktexlsr with empty $HOME (Closes: #473548)
  * add a patch for Sinhala support by Anuradha Ratnaweera 
    <email address hidden>, but keep it disabled until Jonathan gives me
    the ok. This would close the bug #476957.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:28:30 +0100
Superseded in intrepid-release on 2008-05-03
Published in hardy-release on 2007-12-18
texlive-bin (2007.dfsg.1-2) unstable; urgency=low

  * Update location of upstream iso.zip file in uscan watch file (closes:
    #449621), thanks to Raphael Geissert <email address hidden> [fk]
  * switch to libpoppler-0.5.9 patch, since the new libpoppler (>= 0.6) is in
    unstable, adjust build deps to libpoppler-dev >= 0.6 (Closes: #451588)

Obsolete in gutsy-updates on 2011-09-16
Obsolete in gutsy-security on 2011-09-16
texlive-bin (2007-12ubuntu3.1) gutsy-security; urgency=low

  * SECURITY UPDATE: improper bounds on static buffer results in stack-based
    buffer overflow
  * debian/patches/SECURITY_CVE-2007-5935.patch: make sure tmpbuf is allocated
    enough memory in build/source/texk/dvipsk/hps.c
  * SECURITY UPDATE: temporary file race condition in dviljk due to use of
    tmpnam()
  * SECURITY UPDATE: various buffer overflows in dviljk due to not checking
    memory boundaries
  * debian/patches/SECURITY_CVE-2007-5936+5937.patch: use mkdtemp() if
    available in dvi2xx.c.  Replace calls to strcpy() and do proper bounds
    checking in dvi2xx.*.
  * References
    CVE-2007-5935
    CVE-2007-5936
    CVE-2007-5937

 -- Jamie Strandboge <email address hidden>   Tue, 04 Dec 2007 00:04:35 +0000
Superseded in hardy-release on 2007-12-18
texlive-bin (2007-14ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. (LP: #157771)
  * Remaining Ubuntu changes:
    - Bump libpoppler Build-Depends.
    - Fix build failures with g++ 4.3.
    - Munge Maintainer field as per spec.
  * Ubuntu changes dropped:
    - Add debian/patches/30_libpoppler_new - it's now included.

Superseded in hardy-release on 2007-10-29
Obsolete in gutsy-release on 2011-09-16
texlive-bin (2007-12ubuntu3) gutsy; urgency=low

  * Fix build failures with g++-4.3.

 -- Matthias Klose <email address hidden>   Mon, 10 Sep 2007 16:19:13 +0000
Superseded in gutsy-release on 2007-09-10
texlive-bin (2007-12ubuntu2) gutsy; urgency=low

  * Rebuild for the libpoppler1 -> libpopper2 transistion.

 -- Steve Kowalik <email address hidden>   Wed,  5 Sep 2007 22:49:32 +1000
Superseded in gutsy-release on 2007-09-05
texlive-bin (2007-12ubuntu1) gutsy; urgency=low

  * debian/patches/30_libpoppler_new: Port to poppler 0.5.9 API (which, by and
    large, consisted of reverting some parts of the patch; yay for upstream
    xpdf and poppler getting closer together). LP: #121327
  * debian/control: Bump libpoppler build dependency.

 -- Martin Pitt <email address hidden>   Tue, 03 Jul 2007 12:04:22 +0200
Superseded in gutsy-release on 2007-07-03
texlive-bin (2007-12) unstable; urgency=low

  * Add a debian-specific patch for fmtutil which makes the --enable,
    --disable and --edit commands work safely.  Furthermore, patch
    texconfig to use update-texmf (closes: #409798) [fk]
  * fix manpage of pkfix (Closes: #429587)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  22 Jun 2007 09:50:04 +0100
Superseded in gutsy-release on 2007-06-22
texlive-bin (2007-11) unstable; urgency=low

  * Refine the code to resurrect pdftexconfig.tex (no version check) and
    properly document it in NEWS.Debian.
  * Also resurrect config.ps, thanks to Bruce MacDonald
    <email address hidden> (closes: #427059) [fk]

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  04 Jun 2007 08:44:52 +0100
Superseded in gutsy-release on 2007-06-04
texlive-bin (2007-10) unstable; urgency=low

  * don't install libkpathsea.la (Closes: #426006) [np]
  * do not actually carry out the "preserve deleted conffile" due to the 
    tetex bug and too many busted installations, and resurrect the
    critical conffile pdftexconfig.tex for sid users (Closes: #425781)
    [np,fk] 
  * Add missing Depends of libkpathsea-dev on libkpathsea4 (closes:
    #426710) [fk]

 -- Martin Pitt <email address hidden>   Fri,  01 Jun 2007 06:23:33 +0100
Superseded in gutsy-release on 2007-06-01
texlive-bin (2007-9ubuntu3) gutsy; urgency=low

  * debian/control: libkpathsea-dev depends on libkpathsea4.

 -- Daniel Holbach <email address hidden>   Wed, 30 May 2007 09:43:11 +0200
Superseded in gutsy-release on 2007-05-30
texlive-bin (2007-9ubuntu2) gutsy; urgency=low

  * debian/rules:
    - add -fPIC to debian/rules which will fix the evince 64bit FTBFS.

 -- Daniel Holbach <email address hidden>   Tue, 29 May 2007 23:44:48 +0200
Superseded in gutsy-release on 2007-05-29
texlive-bin (2007-9ubuntu1) gutsy; urgency=low

  * libkpathsea-dev.install: Kill the .la file. Those are evil in general,
    broken ones specifying /buildd paths even more so.

 -- Martin Pitt <email address hidden>   Fri, 25 May 2007 16:27:09 +0200
Superseded in gutsy-release on 2007-05-25
texlive-bin (2007-9) unstable; urgency=low

  * Make sure --enable-shared is not in effect in the subdirectories for
    static-only libraries, in particular xetex's teckit.  Thanks to Aaron
    M. Ucko <email address hidden> (closes: #425863) [fk]
  * Move libkpathsea4 and the -dev package to the correct sections (libs
    and libdevel, not tex) [np]

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  25 May 2007 11:08:42 +0100
Superseded in gutsy-release on 2007-05-25
texlive-bin (2007-8) unstable; urgency=low

  * lang-indic: move bangfont.tex from doc to run files (Closes: #424031)
  * lang-indic: add missing python header to ebong script (Closes: #423990)
  * dpkg_md5sum in common-functions.preinst returns now the empty string
    in case of an unknown conffile (could have been created by touch).
    This should fix Ubuntu bug 111654. [np]
  * Build with --enable-ipc to allow piping of output [fk]
  * Build shared kpathsea library and include it in separate packages [fk]
  * move bin-thumbpdf to texlive-base-bin (Closes: #424658) [np]
  * texlive-extra-utils suggests gs-* for epstopdf (Closes: #423988) [np]
  * replace patches/30_libpoppler with patches/30_libpoppler_new for
    new libpoppler 0.5, make the build-dep libpoppler-dev (>= 0.5.4)
    (Closes: #425065, #356079)
  * add stricter dependencies to all packages: if in the final shipout
    dep on a texlive package there is no version given, the value of
    latest-version (from tpm2deb.cfg) of the source package is taken.
    (Closes: #421969)
  * remove cruft from control files (cweb, ctie, texdoctk)
    (Closes: #241089, #249085)
  * don't leave copies of conffiles in TEXMFDIST (Closes: #420139)
  * add poppler to the pdftex banner (Closes: #420971)
  * texlive-lang-indic depends on python
  * remove the rpath entry in all the binaries
  * add patch 64_fix_makempx_installation to fix the installation
    of makempx script instead of the binary (thanks Sanjoy Mahajan)
  * rework the xdvi conf file handling code to not "preserve removal"
    when upgrading from older texlive versions (Closes: #425272)
  * format generation reworked: 
    - texlive-base-bin does not provide formats anymore since all the
      respective ini files are in texlive-base
    - texlive-base takes the format generation

 -- Sebastian Dr?ge <email address hidden>   Wed,  23 May 2007 21:59:12 +0100
Superseded in gutsy-release on 2007-05-23
texlive-bin (2007-7ubuntu1) gutsy; urgency=low

  * Sync with Debian, remaining Ubuntu changes:
    + debian/control:
      - Update Maintainer field.
    + debian/patches/30_libpoppler:
      - Update to the poppler 0.5 API.
    + debian/libkpathsea4.install,
      debian/libkpathsea-dev.install,
      debian/rules,
      debian/control:
      - Build libkpathsea from this package instead of tetex.

Superseded in gutsy-release on 2007-05-09
texlive-bin (2007-6ubuntu2) gutsy; urgency=low

  * debian/libkpathsea4.install,
    debian/libkpathsea-dev.install,
    debian/rules,
    debian/control:
    + Build libkpathsea from this package instead of tetex to finally get
      tetex out of main.

 -- Sebastian Droege <email address hidden>   Tue, 08 May 2007 18:15:50 +0200
Superseded in gutsy-release on 2007-05-08
texlive-bin (2007-6ubuntu1) gutsy; urgency=low

  * Merge with Debian unstable, remaining Ubuntu changes:
    + debian/control:
      - Update Maintainer field.
    + debian/patches/30_libpoppler:
      - Update to the poppler 0.5 API.

Superseded in gutsy-release on 2007-05-08
Superseded in gutsy-release on 2007-04-26
texlive-bin (2007-5ubuntu1) gutsy; urgency=low

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - debian/patches/30_libpoppler: Update to the poppler 0.5 API.
  * debian/control: Update maintainer field.

Superseded in gutsy-release on 2007-04-26
Obsolete in feisty-release on 2009-08-20
texlive-bin (2005.dfsg.2-12ubuntu1) feisty; urgency=low

  * Sync with Debian:
    + debian/patches/30_libpoppler.dpatch:
      - Update to the new libpoppler API to fix FTBFS. Based on Martin Pitt's
        patch for tetex
  * debian/control:
    + Update maintainer field...

Superseded in feisty-release on 2007-02-23
texlive-bin (2005.dfsg.2-10ubuntu1) feisty; urgency=low

  * Sync with Debian:
    + debian/patches/30_libpoppler.dpatch:
      - Update to the new libpoppler API to fix FTBFS. Based on Martin Pitt's
        patch for tetex

Superseded in feisty-release on 2007-01-13
texlive-bin (2005.dfsg.2-7ubuntu1) feisty; urgency=low

  * Sync with Debian:
    + debian/patches/30_libpoppler.dpatch:
      - Update to the new libpoppler API to fix FTBFS. Based on Martin Pitt's
        patch for tetex

Superseded in feisty-release on 2006-12-13
texlive-bin (2005.dfsg.2-5ubuntu1) feisty; urgency=low

  * Sync with Debian:
    + debian/patches/30_libpoppler.dpatch:
      - Update to the new libpoppler API to fix FTBFS. Based on Martin Pitt's
        patch for tetex

175 of 82 results