Change log for thefuck package in Ubuntu

17 of 7 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-04-24
Published in focal-release on 2019-10-18
Obsolete in eoan-release on 2020-12-29
Deleted in eoan-proposed (Reason: moved to release)
thefuck (3.29-0.1) unstable; urgency=medium

  * Non-maintainer upload
  * New upstream release, to migrate to python 3; Closes: #897603
    - move from python2 to python3, switch to pybuild too
  * debian/copyright
    - update to reflect new upstream release
  * debian/control
    - update Vcs-* fields to point to Salsa
    - drop outdated X-P-V field
    - bump Standards-Version to 4.4.0 (no changes needed)

 -- Sandro Tosi <email address hidden>  Thu, 22 Aug 2019 18:15:36 -0400

Available diffs

Superseded in eoan-release on 2019-08-28
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed on 2020-07-14 (Reason: moved to release)
thefuck (3.11-2.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Add the missing dependency on python-pkg-resources.
    (Closes: #842393)

 -- Adrian Bunk <email address hidden>  Sat, 12 May 2018 10:22:28 +0300

Available diffs

Superseded in cosmic-release on 2018-05-14
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
thefuck (3.11-2) unstable; urgency=medium

  * Depend on python-pathlib2 instead of python-pathlib.
    Thanks to Axel Beckert for the patch (Closes: #836748)

 -- Alessio Treglia <email address hidden>  Wed, 05 Oct 2016 07:24:14 +0100

Available diffs

Superseded in yakkety-release on 2016-10-05
Deleted in yakkety-proposed on 2016-10-07 (Reason: moved to release)
thefuck (3.11-1) unstable; urgency=medium

  * Imported Upstream version 3.11
  * Dropped 1001-fix_memoize.patch, applied upstream
  * Refresh patches.
  * Move under Section utils. Closes: #820384
  * Bump Standards

 -- Alessio Treglia <email address hidden>  Mon, 29 Aug 2016 14:03:01 +0100

Available diffs

Superseded in yakkety-release on 2016-08-30
Published in xenial-release on 2015-11-05
Deleted in xenial-proposed (Reason: moved to release)
thefuck (3.2-1) unstable; urgency=medium

  * New upstream release.
  * Drop patch for XDG compliance.
  * Add patch to fix wrong handling of logic operator in thefuck/utils.py.

 -- Alessio Treglia <email address hidden>  Wed, 04 Nov 2015 23:17:13 +0000

Available diffs

Superseded in xenial-release on 2015-11-05
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
thefuck (2.5.6-1) unstable; urgency=medium

  * New upstream release.
  * Refresh patches.

 -- Alessio Treglia <email address hidden>  Thu, 30 Jul 2015 12:15:46 +0100

Available diffs

Superseded in wily-release on 2015-07-31
Deleted in wily-proposed on 2015-08-01 (Reason: moved to release)
thefuck (1.46-1) unstable; urgency=medium

  * Initial release. (Closes: #783816)

 -- Alessio Treglia <email address hidden>  Wed, 17 Jun 2015 17:44:55 +0100
17 of 7 results