Ubuntu

ttf-bpg-georgian-fonts.conf problem.

Reported by Vladimer Sichinava on 2006-08-11
6
Affects Status Importance Assigned to Milestone
ttf-bpg-georgian-fonts (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ttf-bpg-georgian-fonts

Once installed ttf-bpg-georgian-fonts_0.3_all.deb package from http://packages.debian.org/unstable/x11/ttf-bpg-georgian-fonts I´ve noticed that /etc/fonts/conf.d/ttf-bpg-georgian-fonts.conf
 has no effects, to ensure myself I´ve copied /etc/fonts/conf.d/ttf-bpg-georgian-fonts.conf in my home folder and renamed it to .fonts.conf after that I´ve restarted X server and everything works like a charm(fonts are used in a right way).

Changed in ttf-bpg-georgian-fonts:
assignee: nobody → mjg59
status: Unconfirmed → Confirmed

I can confirm that BPG-Rioni is not used instead of Sans.

(tested in gucharmap)

George Machitidze (giomac) wrote :

Hm, there is another one thing:
 /etc/fonts/conf.d/ttf-bpg-georgian-fonts.conf
has no sense, it is there or not - fonts are still globally (for all users) unrecognizeable and unavailable. :(

Vladimer Sichinava (alinux) wrote :

GioMac you can cp /etc/fonts/conf.d/ttf-bpg-georgian-fonts.conf /home/yourusername/.fonts.conf. But it's not a final solution.

zubu (zviad) wrote :

Same here (Kubuntu Dapper). Is this connected to Defoma?
During installation of the package, there is a message:
"Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 108."

Arne Goetje (arnegoetje) wrote :

Ok guys,
1. "Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 108.":
This seems to be a bug in the gsfonts package... there exists a debian bug report for it AFAIR

2. I tested the package in debian unstable. Please use the attached files in the package and replace the original ones:

debian/control
debian/defoma-hints
debian/postinst
debian/prerm

Changes made:
 * control: changed the Build-Depends and Recommends fields
 * defoma-hints: corrected and added several hints entries to make the fonts globally available in Xorg (can be found with xlsfonts | grep bpg)
 * changed the fc-cache call in the postinst script to be fc-cache update and not care about the /root directory and create a symbolic link in /etc/fonts/conf.d/: 20-ttf-bpg-georgian-fonts.conf
Without this link, fontconfig ignores the configuration file... don't know why.
 * created a prerm script which removes the symlink in /etc/fonts/conf.d/

I tested the result with

LC_ALL=ka_KA gucharmap &

(I still don't know why you guys care for the 'ka' LC_ALL setting... why not just make it global? )

Abel Cheung (abelcheung) wrote :

> * changed the fc-cache call in the postinst script to be fc-cache update and not care about the /root directory and create a symbolic link in /etc/fonts/conf.d/: 20-ttf-bpg-georgian-fonts.conf
Without this link, fontconfig ignores the configuration file... don't know why.

It's because when fontconfig reads a whole folder for configuration snipplets, it only searches those file name matching [0-9]*.conf, and ignores all others.

Vladimer Sichinava (alinux) wrote :

Arne Goetje, super! It works:

1. cd /etc/fonts/conf.d/
2. sudo ln -s ttf-bpg-georgian-fonts.conf 20-ttf-bpg-georgian-fonts.conf
3. restarted X.
4. woow ;)

Thank You Guys!

Matthew Garrett (mjg59) wrote :

No, this is incorrect. That fonts.conf fragment changes the default sans font to BPG Rioni on all systems, not just Georgian ones. This isn't acceptable, since the quality of its latin characters is worse than in the default font. There's a couple of issues here:

1) the fonts.conf fragment is malformed and so works unconditionally
2) fontconfig fails to recognise the BPG fonts as Georgian. I can fix this easily.

I'm working on point (1), but it's more awkward than expected.

Vladimer Sichinava (alinux) wrote :

The unic problem that remains is that, after ttf-bpg-georgian-fonts pacakge installation system uses BPG_Rioni.ttf's latin glyps instead of standard latin (Is it Dejavu font?) and it changes system latin fonts size even than georgian locale is not used(If you use English GNOME session for example). What can we do about it ?

Vladimer Sichinava (alinux) wrote :

The unic problem that remains is that, after ttf-bpg-georgian-fonts pacakge installation system uses BPG_Rioni.ttf's latin glyps instead of standard latin (Is it Dejavu font?) and it changes system latin fonts size even than georgian locale is not used(If you use English GNOME session for example). What can we do about it ?
so in Dapper or Edgy repository still remains (crappy) 0.2 version of ttf-bpg-georgian-fonts.

Vladimer Sichinava (alinux) wrote :

Great, fontconfig issue is fixed(bit thanks to Mattew)

Unic problem that remains is 0.2 version of ttf-bpg-georgian-fonts that contains old, crappy
georgian fonts.

For Debian there is 0.3 version,
http://packages.debian.org/unstable/debian-installer/ttf-bpg-georgian-fonts-udeb

And Dapper, Edgy users we still need 0.3 version.

Source is here:
http://bpg.sytes.net/BPG-InfoTech/sppro/bpg/publication_view.asp?InfoID=146405&iabspos=1&vjob=vsub,249

Thank You.

Vladimer Sichinava (alinux) wrote :

ttf-bpg-georgian-fonts 0.5 version is fixed.

Changed in ttf-bpg-georgian-fonts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers