DejaVu fonts shows "tighted"

Bug #35470 reported by Ricardo Pérez López
22
Affects Status Importance Assigned to Milestone
Pango
Fix Released
Medium
gtk+2.0 (Ubuntu)
Medium
Ubuntu Desktop Bugs
pango1.0 (Ubuntu)
Medium
Unassigned
ttf-dejavu (Ubuntu)
Medium
Matthias Klose

Bug Description

The characters in DejaVu fonts are rendered very close one each other. The Bitstream Vera fonts has not that problem.

Revision history for this message
Ricardo Pérez López (ricardo) wrote : Characters rendered with DejaVu fonts

As you can see, "V" is very close to "e" in "Ver", "T" is very close to "e" in "Terminal", and "A" is very close to "y" in "Ayuda".

Revision history for this message
Ricardo Pérez López (ricardo) wrote : Characters rendered with Bitstream Vera fonts

As you can see, the characters rendered with the Bitstream Vera fonts doesn't suffer the problem which DejaVu fonts has.

Revision history for this message
Keenan Pepper (keenanpepper) wrote :

I think this is actually a problem with the way Pango handles kerning for Latin. DejaVu looks fine with versions of Pango before 1.11.0. Bitstream Vera is not affected because it has no kerning. See Bug #34178.

Revision history for this message
Keenan Pepper (keenanpepper) wrote :

Here's another way to see that it has something to do with Pango: Install freetype2-demos. Use ftstring to display a string like "VeTeAy" with DejaVu. ftstring uses Freetype directly, without going through Pango, so it looks fine.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

Ok, it seems you are right. I tried with ftstring (from freetype2-demos) as well as the kfontview (from KDE), and renders the text perfectly.

Revision history for this message
Ricardo Pérez López (ricardo) wrote : Text rendered with ftstring

Text correctly rendered with ftstring.

Revision history for this message
Ricardo Pérez López (ricardo) wrote : Text rendered with kfontview

Text correctly rendered with ffontview.

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :
Revision history for this message
Keenan Pepper (keenanpepper) wrote :

DejaVu LGC, which is simply DejaVu with all the Arabic and Armenian characters removed, looks fine. This is looking more and more like a Pango bug to me.

Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote : Re: DejaVu fonts render condensed

I have this problem as well, on AMD64

Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote : More extreme

This should read "officials", the "ic" part seems to be the problem, as this is what I have noticed for the past few days.

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

Bruce, what versions of Pango, DejaVu and Mozilla/Firefox are you using?

The overkerning issue will be fixed in next month's release.

Revision history for this message
Matthias Klose (doko) wrote :
Changed in ttf-dejavu:
assignee: nobody → doko
status: Unconfirmed → Confirmed
Revision history for this message
Ricardo Pérez López (ricardo) wrote :

Sorry: I've tried it, but the problem is still here.

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

Could you please try again Ricardo.
You must be using the previous fonts you had on your system.

2.4.b fixes this.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

I do the following:

1. sudo dpkg --purge --force-depends ttf-dejavu
2. sudo dpkg -i ttf-dejavu_2.4b-0ubuntu2_all.deb

Obviously, I'm not using the previous fonts.

And the problem is still here.

Following screen captures...

Revision history for this message
Ricardo Pérez López (ricardo) wrote : Using the new ttf-dejavu package

As you can see in the Terminal menu bar, the characters has wrong kerning.

Revision history for this message
Ricardo Pérez López (ricardo) wrote : Using the BitStream font

The kerning is correct, as you can see.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

By the way, I got the following messages during the ttf-dejavu installation. I don't know if it can help:

Configuring ttf-dejavu (2.4b-0ubuntu2) ...
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.
Use of uninitialized value in print at /var/lib/defoma/scripts/gs.defoma line 10 8.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

Sorry, the line might say "108" instead of "10 8".

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

> http://librarian.launchpad.net/1847447/new_dejavu.jpg
That looks like proper kerning to me. No letter is bumping into each other, kerning is tight but that's another issue.

> http://librarian.launchpad.net/1847452/bitstream.jpg
There is no kerning at all here. Pango 1.12 doesn't kern properly TrueType fonts that don't have OpenType tables.

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

OK, I just realised the very first screenshot has the same kerning. My bad.

So you'd rather have no kerning at all?

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

> So you'd rather have no kerning at all?

Sorry, I don't understand the question. I'm rather newbie in typography :/

Is there any test I can do in order to tell you the results?

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

Don't be sorry :) I should be for using jargon.

The original screenshot http://librarian.launchpad.net/1783378/DejaVu.png and http://librarian.launchpad.net/1847447/new_dejavu.jpg both show characters with special spacing for some sequences.

DejaVu fonts have the same spacing, or kerning, values as BitStream Vera fonts.

BitStream Vera fonts are TTF, but the old kind. DejaVu fonts are TTF with OpenType tables. Because Pango 1.12 has introduced a bug while fixing other things (ligatures, combining diacritics, etc.), BitStream Vera fonts don't show any kerning. So you don't have the e closer to the stem of the T for example. This is wrong.
The e should go a bit below the top arms of the T.

With Pango <1.11 Bitstream Vera was kerned properly, but DejaVu wasn't.

Normally DejaVu fonts space characters exactly as Bitstream Vera fonts. If you don't like how they are spaced then we could look into that.

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

The spaces might be too tight at the size you're using but fine at other sizes.

http://librarian.launchpad.net/1783620/ftstring.png looks like we need to add kerning to the "eT" sequence because "eTe" doesn't look good.

http://librarian.launchpad.net/1783621/kfontview.png doesn't do any kerning. There's too much space around the T and A is further from y than it is from e.

http://librarian.launchpad.net/1824481/Screenshot.png is a Firefox bug, it doesn't like our ligatures (ffi here).

Revision history for this message
Matthias Klose (doko) wrote :

> > http://librarian.launchpad.net/1847452/bitstream.jpg
> There is no kerning at all here. Pango 1.12 doesn't kern
> properly TrueType fonts that don't have OpenType tables.

confirmed, opened for pango1.0 as well

Changed in pango1.0:
status: Unconfirmed → Confirmed
Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

I'd rather open a new bug for Bitstream Vera not being kerned.

here the upstream Pango bug report: http://bugzilla.gnome.org/show_bug.cgi?id=336026

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

> So you'd rather have no kerning at all?

Sorry, I don't understand the question. I'm rather newbie in typography :/

Is there any test I can do in order to tell you the results?

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

Oops, sorry, I send the same post twice.

> Because Pango 1.12 has introduced a bug while fixing other things (ligatures, combining diacritics, etc.), BitStream Vera fonts don't show any kerning. So you don't have the e closer to the stem of the T for example. This is wrong. The e should go a bit below the top arms of the T.

Following your indications, it seems that DejaVu behavior is correct and BitStream Vera isn't. Is this correct?

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

> Following your indications, it seems that DejaVu behavior is correct and BitStream Vera isn't. Is this correct?

Yes, but it's true letters are tight at the size used in your screenshot.

Try using similar text in Gedit at different sizes, you'll see it only looks bad at some sizes.
We'll try to leave more space so DejaVu looks better than Bitstream Vera. But right now DejaVu 2.4b and Bitstream Vera should have the same space, if they don't it's a font renderer bug.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

Curiously, using Gedit with text at different sizes, *all* works well.

It seems that the problem appears only in some applications, not all.

Revision history for this message
Ricardo Pérez López (ricardo) wrote : Some texts ok, some ugly

Look at the font preview (in Spanish, "Vista previa"): looks well. But the Terminal's menubar looks tight.

Revision history for this message
Ricardo Pérez López (ricardo) wrote : Gedit rendering text correctly

I tried with several sizes, and all renders ok.

Look at "VeTeAy" text inside the Gedit's document. Looks ok.

And look at "Ver" in the Gedit menubar. Looks tight.

Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

It appears to have been fixed upstream - http://dejavu.sourceforge.net/wiki/index.php/Main_Page

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

"The current version is 2.4.1, which is an intermediate release to fix the kerning bug with Pango (LGC version is still 2.4)"

Sounds great. Anyone could make a .deb package to test it?

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

Lucida Sans that comes with jre has a similar overkerning issue for application menu titles. This is not a font bug as far as I'm concerned.

Strangely Firefox does not have the problem while other Gtk+ apps do.

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote : all fonts shows tighted in gtkMenu

This is a Gtk bug, all fonts show some wrong spacing with underlined glyphs in gtkMenu.
Look at the "ab" in "Tabs". Some fonts have "He" too tight in "Help".

This was taken with Pango from CVS that apples kerning to TTF fonts.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Is the GTK task required? Isn't that rather a pango issue?

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote : Re: [Bug 35470] Re: DejaVu fonts shows "tighted"

On 4/18/06, Sebastien Bacher <email address hidden> wrote:
> Is the GTK task required? Isn't that rather a pango issue?
The original bug is about DejaVu being too tight in menus.
This isn't related to the Dejavu+Pango overkerning bug that has been fixed.
Other fonts display the same "tighted" behaviour with underlined
characters in gtk Menu.

This is not a DejaVu specific bug and seems to only occur in gtk
menus. Pango spaces characters according to the fonts everywhere else
(Gedit text, etc.).

Revision history for this message
Matthias Klose (doko) wrote :

closing the ttf-dejavu task, uploaded ttf-dejavu_2.5-0ubuntu2

Changed in ttf-dejavu:
status: Confirmed → Fix Released
Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

The new Dejavu font works for me, is this a tempory workaround?

Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

Sorry, wrong bug.

Revision history for this message
Dean Sas (dsas) wrote :

Is this still a problem? bug #34178 points to the same upstream pango bug but a comment in this report says they're not dupes.

Revision history for this message
Matthias Klose (doko) wrote :

Dean Sas schrieb:
> Is this still a problem? bug #34178 points to the same upstream pango
> bug but a comment in this report says they're not dupes.
>
>
It is.

Revision history for this message
Sebastien Bacher (seb128) wrote :

The pango task should be enough. Feel free to reopen if you think that's not the case

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
status: Unconfirmed → Rejected
Changed in pango:
status: Unconfirmed → Confirmed
Changed in pango:
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream

Changed in pango1.0:
status: Confirmed → Fix Committed
Revision history for this message
Sebastien Bacher (seb128) wrote :

the bug is fixed in gutsy now

Changed in pango1.0:
status: Fix Committed → Fix Released
Changed in pango:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.