Greek status in DejaVu fonts

Bug #39721 reported by Simos Xenitellis  on 2006-04-16
12
Affects Status Importance Assigned to Milestone
ttf-dejavu (Ubuntu)
Medium
Unassigned

Bug Description

Under this report we record the status of Greek support in the DejaVu fonts.

The current issues we are looking into are
1. hinting (optimizing the font for small sizes, especially when the pixel density is not good as in laptops).
2. specific characters (such as ano teleia/middle dot)

We provide a test file with sample text for comparison purposes.

Demonstrates DejaVu Sans Mono, DejaVu Sans, DejaVu Serif.

Lines
1. Greek alphabet, capital letters
2. Greek alphabet, small letters
3. Greek letters with accents (tonos, dyalitika)
4. Mixing letters together, latin and greek, next to each other.
5. Sample modern Greek text (source: Makriyiannis), shows bold text, ano teleia (middle dot) is U+00B7.
6. Sample ancient Greek text (source: I think a tragedy by Sophokles). Shows ano teleia (middle dot) with U+0387.

This is an animated GIF. The font has been resized to very small; the characters that look faint are those that are still unhinted.

You can notice that hinting has taken place in DejaVu Sans.

We would like to thank Keenan Pepper for his work with hinting DejaVu Sans :).

Matthias Klose (doko) wrote :

http://people.ubuntu.com/~doko/ttf-dejavu/
updated to the final release

Simos Xenitellis  (simosx) wrote :

Just tried
http://people.ubuntu.com/~doko/ttf-dejavu/ttf-dejavu_2.5-0ubuntu1_all.deb
and it worked like a charm for Greek.

Simos Xenitellis  (simosx) wrote :

The Greek DejaVu font testing page has moved to

http://dejavu.sourceforge.net/wiki/index.php/Testing#Greek

At the same location there are testing pages for Latin, Cyrillic and other supported languages.

To compare how DejaVu (or other fonts) look on your system, open this document on your system.

Get a screenshot of the text to compare between distributions/versions of DejaVu.

This file was generated from the ODT file posted earlier.

Opening the PDF file with evince should serve as an easy test to view how DejaVu would appear on your system, without even installing them.

Bryce Harrington (bryce) wrote :

Hi, it's been a long while since this issue was reported - is it still an issue with newer Ubuntu (like Hardy?) If so, please set the status to Confirmed. Also, if you think this may be an upstream issue, please file a bug with them and link to that report here via the 'Also affects Project' link.

Changed in ttf-dejavu:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Bugs about dejavu can be reported via their mailing list http://sourceforge.net/projects/dejavu.

Simos Xenitellis  (simosx) wrote :

Resolving this report as Greek support in DejaVu is fine.

Changed in ttf-dejavu:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers