Tuxpaint prints garbage to postscript printer (Brother HL 2700 CN)

Bug #49079 reported by cyber_rigger on 2006-06-09
4
Affects Status Importance Assigned to Milestone
tuxpaint (Debian)
Fix Released
Unknown
tuxpaint (Ubuntu)
Undecided
Unassigned

Bug Description

This is on a fresh Ubuntu 6.06 installation.

When printing some tuxpaint sample drawings to a postscript printer (Brother HL 2700 CN) I get garbage and blank pages (US letter size).

The first sample line drawings of the hen and plane print legibly but are shifted down to the bottom of the page.

The underwater corral picture prints garbage.

Could this be a paper size issue?
If so how do you set the default paper size for tuxpaint? I tried tuxpaint-config but didn't see a paper size setting.

This printer works fine with other programs like openoffice.org, gimp, etc.

The same problem happens with the tuxpaint in Debian etch.

Older versions of tuxpaint (Debian and Ubuntu) work fine with this printer.

Help, my kids are frustrated. :^)

cyber_rigger (cyber-rigger) wrote :

This bug is also report here with Debian.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=370721

cyber_rigger (cyber-rigger) wrote :

The Brother HL 2700 CN can use several different printer languages
including HP's PCL.

I tried this driver, "Color Laserjet Series PCL 6 CUPS".

This PCL driver seems to work so far <crosses fingers>.

It appears that tuxpaint is generating (bad?) postscript that is incompatible with the Brother HL 2700 CN.

Micah Cowan (micahcowan) wrote :

It could be due to the fact that it fails to provide the required BoundingBox tag, or could be because the printer doesn't expect to get an "EPSF". I'm guessing the former, or some other well-formedness constraint violation of some sort, of the Adobe doc guidelines.

Micah Cowan (micahcowan) wrote :

Older versions of tuxpaint didn't attempt to print postscript directly to lpr; instead, they piped the actual PNG image format data throught the pipeline "| pngtopnm | pnmtops | lpr".

Here's a debdiff against 0.9.15b-1ubuntu4 that simply removes the Adobe DSC/EPSF stuff, and pipes it out as a plain PostScript file. This seems quite likely to work, to me, but may not be the best solution, which I would believe to be to do Adobe DSC /right/ (including a working BoundingBox).

Also, I haven't yet looked into the possibility that PostScript features of a higher level than the one claimed for conformance (level 2) are being used. Documentation on the printer appears to claim support for PostScript Level 3, so the issue wouldn't be lack of support for level 2 in the printer.

This patch is for testing purposes /only/: not intended to be used to create a .deb for uploading (anyway, it's not against the most recent Edgy version, just the current Dapper one).

Micah Cowan (micahcowan) wrote :

Rather than trying various patches to tuxpaint, I think it makes more sense to try various "patches" to the PostScript output.

Attached is a tgzball containing four PostScript files, with various modifications which seem reasonable to improve the printability. Please unpack the tarball and try to print each of them on your Brother printer, and inform us as to which ones worked, and how well.

Changed in tuxpaint:
status: Unconfirmed → Needs Info
Micah Cowan (micahcowan) wrote :

Your bug lacks information we would need to investigate further. We
are now going to close the bug - please reopen if you have more
information at hand.

Specifically, please try the various PostScript test files on a Brother HL 2700 printer, and provide feedback regarding how well they work.

Note: I did work with the tuxpaint development team to try to come up with a solution, and a fix may already exist in current upstream releases, and if so, will there is no way of knowing if the "fixes" worked.

Changed in tuxpaint:
status: Needs Info → Rejected
Till Kamppeter (till-kamppeter) wrote :

gv is able to display these PostScript files, buy the HP LaserJet 4050 prints only garbage when "netcatting" the files:

nc -w1 printer 9100 < tuxpaint-ps-tests/original.ps

So as GhostScript can handle these broken PostScript files, but many hardware PostScript interpreters not, setting up a PostScript printer in PCL mode would work around this problem, but the fix has really to be done in Tuxpaint.

Till Kamppeter (till-kamppeter) wrote :

cyber_rigger, can you do the following additional test with your Brother HL-2700? Set up a print queue for it with the following PPD file:

http://www.linuxprinting.org/ppd-o-matic.cgi?driver=hl7x0&printer=Brother-HL-1040

and try to print through it (also with other apps than Tuxpaint). You will be able to use HQ1200 (2400x600 dpi), duplex, tray selection, paper type selection, economy mode, and even password-protected printing. Please report how well you printer works with that.

Till Kamppeter (till-kamppeter) wrote :

Or test the new foomatic-db package in

http://www.freestandards.org/~till/tmp/ubuntu/feisty/foomatic-db/binary/

After installing the package re-create your queue for the Brother HL-2700 selecting the Brother HL-1040 as your printer model and "hl7x0" as the driver.

Changed in tuxpaint (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.