Daylight Saving changes in Western Australia

Bug #72125 reported by jas on 2006-11-17
40
Affects Status Importance Assigned to Milestone
tzdata (Ubuntu)
High
Martin Pitt
Dapper
High
Martin Pitt
Edgy
High
Martin Pitt

Bug Description

Hey there

I know this isn't a "bug" as such, but something that will probably have to be "fixed". Western Australia is going to be starting a trial of Daylight Saving on December 3, 2006 until March 31, 2007, moving us from UTC+8 to UTC+9 over that time period. This will, I assume, have to be updated in time zone definitions in the Operating System.

(The changes aren't official as yet, this won't happen until Tuesday 21 November, but I thought I'd give a bit extra notice since this is almost certain to go through)

Cheers,

Jason

Caroline Ford (secretlondon) wrote :

I'm going to reject this bug as the changes are not official yet. When they are official please re-open.

There is no point in any of the developers working on this until it is certain.

jas (jas-jas) wrote :

These changes are now official. Can this be re-opened please?

Jason

Caroline Ford (secretlondon) wrote :

Rejected>Confirmed

jas (jas-jas) wrote :

The relevant legislation is located here: http://www.parliament.wa.gov.au/parliament/bills.nsf/9A1B183144403DA54825721200088DF1/$File/Bill175-1B.pdf

Daylight saving will be in operation during the following times (from section 4 of the above act):

(a) the hour of 2 a.m. on 3 December 2006 until the hour of 2 a.m. on 25 March 2007; and
(b) the hour of 2 a.m. on 28 October 2007 until the hour of 2 a.m. on 30 March 2008; and
(c) the hour of 2 a.m. on 26 October 2008 until the hour of 2 a.m. on 29 March 2009

jas (jas-jas) wrote :

If this is at all helpful (if anyone is even following this :) ), someone in Perth has created a new timezone definition for various unix/linux systems, for the three year trial:

http://matt.ucc.asn.au/time/

Trent Lloyd (lathiat) wrote :

A new tzdata package is available from here
ftp://elsie.nci.nih.gov/pub/tzdata

Including the appropriate fixes, I think it would be sane to update this in breezy/dapper/edgy

James Purser (purserj) wrote :

Okay its now the 1st of December. Can we see an update soon please seeing as its due to start in two days.

Matt Zimmerman (mdz) on 2006-11-30
Changed in tzdata:
assignee: nobody → pitti
jas (jas-jas) wrote :

There are now just over six hours until this comes into effect. What's currently happening as far as having an update ready?

James Andrewartha (trs80) wrote :

Apparently the Debian tzdata package (2006p-1) works fine.

James Andrewartha (trs80) wrote :

Only on edgy though, dapper shipped timezone information in locales :-(

Onno Benschop (onno-itmaze) wrote :

This has now been in effect for 10 hours and I'm still on standard Perth time - anything in particular I need to do to make this active?

Onno Benschop wrote:
> This has now been in effect for 10 hours and I'm still on standard Perth
> time - anything in particular I need to do to make this active?

No update to Ubuntu has been made yet, unfortunately. Thankyou Western
Australian government for the short notice!

James Henstridge (jamesh) wrote :

Attached is a replacement compiled tzdata file for "Australia/Perth" taken from tzdata-2006p. As an interim measure, you can copy this file to the following locations:
    /usr/share/zoneinfo/Australia/Perth
    /etc/localtime

(don't bother with the second one if you aren't using Australia/Perth as your default time zone). The 2006p data should be valid til the end of the 3 year daylight saving trial.

This change will be overwritten by future package updates, but hopefully they'll be for tzdata >= 2006p.

Onno Benschop (onno-itmaze) wrote :

Excellent, I've just backed up the original and replaced it, re-ran tzconfig, all good -- thanks James.

What do I do about these two files also in tzdata:
  /usr/share/zoneinfo/posix/Australia/Perth
  /usr/share/zoneinfo/right/Australia/Perth

And what about from other packages:
sun-java5-jre:
  /usr/lib/jvm/java-1.5.0-sun-1.5.0.08/jre/lib/zi/Australia/Perth

evolution-data-server-common:
  /usr/share/evolution-data-server-1.8/zoneinfo/Australia/Perth.ics

James Henstridge (jamesh) wrote :

The /usr/share/zoneinfo/right and /usr/share/zoneinfo/posix subdirectories contain versions of the time zone data with and without counting leap seconds. I don't think you need to worry about it.

The Java and Evolution time zone databases would also need updating. The Java one is probably using the same compiled tzdata format, so you might be able to slot the new file in place (check first). The Evolution one appears to be a translation of an older version of tzdata to iCalendar format, so might require more effort to update.

James Henstridge (jamesh) wrote :

In the above comment, I was wrong about the Java zoneinfo database -- it is a binary format, but it is a different format to /usr/share/zoneinfo. You would probably need to use a Java-specific zone file compiler.

James Purser (purserj) wrote :

Okay, we've had some replacement files from James Hentridge, thank you James. Unfortunately this doesn't fix the other problems such as Java and Evolution as James has pointed out.

If we could have an update on this bug that would be most appreciated.

Martin Pitt (pitti) wrote :

Fixed in Feisty.

Changed in tzdata:
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

we generally need a time zone update for dapper and edgy, it's just not that trivial when it comes to timezone splits/merges. See

https://blueprints.launchpad.net/distros/ubuntu/+spec/timezone-upgrades

Changed in tzdata:
assignee: nobody → pitti
importance: Undecided → High
status: Unconfirmed → In Progress
assignee: nobody → pitti
status: Unconfirmed → In Progress
importance: Undecided → High
James Purser (purserj) wrote :

Thanks Martin

James Henstridge (jamesh) wrote :

While looking through my system, I noticed another copy of the time zone database in Postgres:

    /usr/share/postgresql/8.1/timezone/

So that also needs updating when tzdata gets updated. It appears to be using the same format as the /usr/share/zoneinfo database, so it could possibly be changed to a symlink to the main database.

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

Package for Edgy is prepared; I just used the feisty version with the version number 2006p-0ubuntu6.10~prop1, which will eventually become 2006p-0ubuntu6.10 for edgy-updates. OK to upload?

Colin Watson (cjwatson) wrote :

http://librarian.launchpad.net/5596485/edgy.diff OK for edgy-proposed, assuming that the debian/changelog diff is trivial. (Note that this is an exception to the general rule that new upstreams don't get into stable release, on the basis that timezone changes are externally imposed and user-visible.)

Martin Pitt (pitti) wrote :

 tzdata (2006p-0ubuntu6.10~prop1) edgy-proposed; urgency=low
 .
   * Upload of 2006p to edgy. Closes: LP#72125

Uploaded. Right, the source debdiff just contians the new debian/changelog bits and the changed tarball (whose diff is attached).

Martin Pitt (pitti) wrote :

This is the 2006g -> 2006p tzdata tarball diff, which represents the dapper upgrade:

- lots of rule changes (no problem for transition)
- some new timezones, e.g. Europe/Volgograd (don't break upgrades either)
- Removal of America/Coral_Harbour (merged into America/Atikokan). This does break upgrades for users of this timezone, thus this needs to be automatically transitioned in the postinst.

The langpack-locales source debdiff with the transition logic will be attached soon.

Martin Pitt (pitti) wrote :

Package prepared and tested. The tzdata2006p.tar.gz already installs a symlink from America/Coral_Harbour to America/Atikokan, thus no postinst magic is necessary after all. I tested the upgrade on dapper with that timezone and everything works well.

Thus the source debdiff does not contain any differences except for the changelog and the new tzdata tarball (diff attached in previous comment).

langpack-locales (2.3.18.1~prop1) dapper-proposed; urgency=low

  * Replace debian/tzdata2006g.tar.gz with new version tzdata2006p:
    - Fix lots of DST rules, amongst them the recent change for Western
      Australia. Closes: LP#72125
    - Add some timezones, e.g. Europe/Volgograd.
    - Remove America/Coral_Harbour, this got merged into America/Atikokan. The
      'backwards' file installs a symbolic link for this to not break
      upgrades.

 -- Martin Pitt <email address hidden> Thu, 4 Jan 2007 16:40:42 +0000

Colin Watson (cjwatson) wrote :

http://librarian.launchpad.net/5596592/dapper-tzdata.diff OK for dapper-proposed, by the same reasoning as the edgy-proposed change.

Colin Watson (cjwatson) wrote :

Accepted into edgy-proposed. Please begin testing via the QA team.

Changed in tzdata:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Dapper package from comment 27 uploaded.

Simon Law (sfllaw) wrote :

Martin,

The tzdata package does not install a symbolic link, but rather a hard link. Is this correct?

Also, does QA need to verify that the timezone data is accurate? Preliminary research says "yes", but I can dig deeper if necessary.

Simon

James Henstridge (jamesh) wrote :

Simon: that is the behaviour of the tzcode utilities: when adding the compatibility links, it only tries to create a symlink if hardlinking failed. So you aren't seeing any changed behaviour from before.

I did notice that the copy of the timezone database that postgresql installs seems to use symlinks though ...

Martin Pitt (pitti) wrote :

Hi Simon,

Simon Law [2007-01-10 1:57 -0000]:
> The tzdata package does not install a symbolic link, but rather a hard
> link. Is this correct?

Yes, sorry for the confusion. They probably do this because hard links
are more efficient.

> Also, does QA need to verify that the timezone data is accurate?
> Preliminary research says "yes", but I can dig deeper if necessary.

I have pretty much trust in upstream for that, and I verified the
correctness of the Australia/Perth timezone myself, but of course more
verification can never hurt. But in particular the Edgy update does
not touch so many time zones in the first place.

Thanks,

Martin

Colin Watson (cjwatson) wrote :

Accepted into dapper-proposed.

Changed in tzdata:
status: In Progress → Fix Committed
Simon Law (sfllaw) wrote :

This appears to have worked properly and has caused no detectable regressions.

Approved for upload to dapper-updates and edgy-updates on the 15th.

Daniel Harvey (daniel.harvey) wrote :

For information, Western Australia's daylight savings change also affects evolution (as noted above). I've reported a separate bug (Bug #79323) for this which includes an update to the evolution zoneinfo files.

See Bug #79323: Daylight Saving changes in Western Australia

Thanks for the tzdata fix!

Cheers,
Daniel.

Martin Pitt (pitti) wrote :

I uploaded the current edgy-proposed packages to edgy-updates, with no changes apart from the new changelog entry:

 tzdata (2006p-0ubuntu6.10) edgy-updates; urgency=low
 .
   * No-change upload of the -proposed version to -updates.
   * Thanks to Simon Law for testing this update!

This has been in edgy-proposed for 11 days, thus can/should be published immediately.

Martin Pitt (pitti) wrote :

I uploaded the current dapper-proposed langpack-locales to dapper-updates, with no changes apart from the new changelog entry:

 langpack-locales (2.3.18.1) dapper-updates; urgency=low
 .
   * No-change upload of 2.3.18.1~prop1 to dapper-updates.
   * Thanks to Simon Law for testing this update!

This has been in dapper-proposed for 4 days only, so by SRU policy accepting these packages should happen on Thursday (I'll be on holiday then, though). Simon approved for -updates on the 15th (today), though; your call.

Thanks!

Colin Watson (cjwatson) wrote :

Accepted into edgy-updates. Please notify the TB of any regressions.

I'll wait until Thursday to accept the dapper-updates upload.

Changed in tzdata:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

Accepted into dapper-updates.

Changed in tzdata:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers