espresso crashes on partitioning step in Kubuntu 6.06 LTS Beta Live CD

Bug #40464 reported by Eduardo Han Valen on 2006-04-21
44
Affects Status Importance Assigned to Milestone
espresso (Ubuntu)
Medium
Unassigned
ubiquity (Ubuntu)
Critical
Colin Watson

Bug Description

On 2 separate systems, espresso crashes on partitioning step in Kubuntu 6.06 LTS Beta Live CD. I used the default boot menu entry to boot it up, once the KDE desktop is fully loaded, I clicked on "Install". It wnt through all the install steps fine except that it did not fully load the partitioning step and then it crashed and the application closed. I did _not_ get to see the full partitioner dialog as seen in
https://wiki.kubuntu.org/KubuntuDapperBeta?action=AttachFile&do=get&target=disk.png

System 1: AMD Athlon XP-M 2600+, 512MB Ram, 200GB HD
System 2: Dell OptiPlex GX110, P3 866MHz, 256 MB RAM, 20GB HD

I renamed the log from espresso to espresso_log.

description: updated
Troy Unrau (troy-unrau) wrote :

I get the same thing - crash when entering the partitioning stage. I'm use the amd64 beta livecd on:

MSI RS480, 512MB RAM, 200GB SATA hard drive
atiixp chipset

additionally, it doesn't detect my harddisk and add it to fstab, but that may be a separate issue...

crash at partition screen, dapper beta 1 amd64 livecd

Colin Watson (cjwatson) wrote :

Jonathan, this one's probably yours ...

Download full text (3.8 KiB)

The bug occured on my machine, a HP nx8220 laptop, too.
At least one process continues to write to the log file. It is still growing ten minutes after the installer crashed.

Below is the output of ps -A :

ubuntu@ubuntu:~$ ps -A
  PID TTY TIME CMD
    1 ? 00:00:01 init
    2 ? 00:00:00 ksoftirqd/0
    3 ? 00:00:00 watchdog/0
    4 ? 00:00:00 events/0
    5 ? 00:00:00 khelper
    6 ? 00:00:00 kthread
    8 ? 00:00:00 kblockd/0
    9 ? 00:00:00 kacpid
  192 ? 00:00:00 pdflush
  193 ? 00:00:00 pdflush
  195 ? 00:00:00 aio/0
  194 ? 00:00:00 kswapd0
  790 ? 00:00:00 kseriod
 1802 ? 00:00:00 khpsbpkt
 1807 ? 00:00:00 khubd
 1815 ? 00:00:00 knodemgrd_0
 1949 ? 00:00:00 loop0
 3414 ? 00:00:00 udevd
 4287 ? 00:00:00 shpchpd_event
 4370 ? 00:00:00 pccardd
 4377 ? 00:00:03 ipw2200/0
 5141 ? 00:00:00 acpid
 5229 ? 00:00:00 syslogd
 5255 ? 00:00:00 dd
 5257 ? 00:00:00 klogd
 5284 ? 00:00:00 hpiod
 5287 ? 00:00:00 python
 5332 ? 00:00:00 cupsd
 5357 ? 00:00:00 dbus-daemon
 5372 ? 00:00:01 hald
 5373 ? 00:00:00 hald-runner
 5378 ? 00:00:00 hald-addon-acpi
 5428 ? 00:00:00 hald-addon-keyb
 5438 ? 00:00:00 hald-addon-stor
 5439 ? 00:00:00 hald-addon-stor
 5672 ? 00:00:00 powernowd
 5711 ? 00:00:00 hcid
 5716 ? 00:00:00 sdpd
 5724 ? 00:00:00 krfcommd
 5738 ? 00:00:00 mdadm
 5757 ? 00:00:00 atd
 5770 ? 00:00:00 cron
 5987 ? 00:00:00 kdm
 6013 tty7 00:00:38 Xorg
 6016 ? 00:00:00 kdm
 6032 tty1 00:00:00 login
 6033 tty1 00:00:00 bash
 6034 tty2 00:00:00 login
 6035 tty2 00:00:00 bash
 6036 tty3 00:00:00 login
 6037 tty3 00:00:00 bash
 6038 tty4 00:00:00 login
 6039 tty5 00:00:00 login
 6040 tty6 00:00:00 login
 6053 tty4 00:00:00 bash
 6054 tty5 00:00:00 bash
 6057 tty6 00:00:00 bash
 6212 ? 00:00:00 x-session-manag
 6248 ? 00:00:00 ssh-agent
 6251 ? 00:00:00 dbus-launch
 6252 ? 00:00:00 dbus-daemon
 6282 ? 00:00:00 dhclient3
 6288 ? 00:00:00 kdeinit
 6291 ? 00:00:00 dcopserver
 6293 ? 00:00:00 klauncher
 6295 ? 00:00:03 kded
 6297 ? 00:00:00 gam_server
 6460 ? 00:00:04 artsd
 6465 ? 00:00:00 kaccess
 6473 ? 00:00:00 kwrapper
 6475 ? 00:00:00 ksmserver
 6476 ? 00:00:01 kwin
 6479 ? 00:00:01 kdesktop
 6484 ? 00:00:00 kio_uiserver
 6487 ? 00:00:05 kicker
 6488 ? 00:00:00 kio_file
 6494 ? 00:00:01 adept_notifier
 6495 ? 00:00:00 kbluetoothd
 6497 ? 00:00:00 klipper
 6502 ? 00:00:00 knotify
 6518 ? 00:00:00 kmix
 6520 ? 00:00:00 katapult
 6530 ? 00:00:04 konsole
 6531 pts/1 00:00:00 bash
 6574 ? 00:00:00 dhclient
 6576 ? 00:00:25 konqueror
 6623 pts/2 00:00:00 bash
 6692 ? 00:00:00 kdesud
 7227 ? 0...

Read more...

the espresso install log from my laptop (i386)

espresso not only crashed, but also wiped my whole partition table. i am not sure if that information belongs to this bug or if I should create a new bug report, but I definitly didn't confirm writing any changes to disk.

espresso continues to repartition the disk after it crashes. The user has no way to abort this because the GUI crashed

David (endeavornet) wrote :

I want to add that I also had it wipe the partition table. I didn't think to grab any logs after that crash. I was in a hurry and just restarted the computer. After the restart I realized it wiped out all the partitions on the disk.

Daniel Franke (d-franke) wrote :

I want to second the problem which David had, I also didn't think of grabbing the logs and realized the partitions where gone when I restarted the machine. I would say this is a critical bug.

I get the exact same thing trying to install Ubuntu (not Kubuntu).

I was able to recover my partition table using gpart (gpart -W /dev/hda /dev/hda , with /dev/hda being my harddisk). Breezy booted without a problem afterwards.

Jonathan Riddell (jr) on 2006-04-21
Changed in espresso:
status: Unconfirmed → Confirmed
Scott Norris (scottie-z) wrote :

Not sure if this should be a separate bug, but with Ubuntu (not Kubuntu) Dapper Beta (4/20), I was able to get through all of the espresso dialogs and actually click the "Install" button. Some progress bar windows appeared, describing the creation of ext3 filesystems on the partitions I set for reformatting. But after that, it threw up a dialog saying "attempting to access partition table" or something similar, and then quit. On subsequent reboot, system was (unsurprisingly) hosed. I'll attach a bug report later.

gpothier (gpothier) wrote :

I had the same problem. Wouldn't it be a good idea to remove the download links to affected versions from the ubuntu/kubuntu websites?

Stuart Rackham (srackham) wrote :

Exactly same symptoms of the original bug report by Eduardo Han Valen.
It also erased all existing partitions from the hard disk (as reported
by another poster).

System: Dell Optiplex GX1, PIII 450MHz, 384MB RAM.

Here's the partioning related processes after the crash:

 6563 ? S 0:04 parted_server
26033 ? S 0:00 /bin/sh /lib/partman/choose_partition/45auto/do_optio
n auto
26034 ? S 0:00 /bin/sh /bin/partman_newlayout
26113 ? S 0:00 /bin/sh /lib/partman/automatically_partition/20some_d
evice/do_option /var/lib/partman/devices/=dev=hda
26114 ? S 0:00 /bin/sh /bin/autopartition /var/lib/partman/devices/=
dev=hda

Øivind Hoel (eruin) wrote :

Sorry for the duplicate.
Same story here, log at http://appelsinjuice.org/espresso

gpothier (gpothier) wrote :

I could not recover my partitions using gpart, maybe because I tried to run the installer more than once...

/var/log/installer/espresso log associated with my previous comment.

gpothier (gpothier) wrote :

I could finally recover my partitions using TestDisk: http://www.cgsecurity.org/wiki/TestDisk

Karamsar (karamsarkalemim) wrote :

I wanted to resize a nfts partittion (74Gb) to 50Gb and the left to 24Gb. After starting, without waiting, something like "There occured a problem...". All data lost...

I tell it at bug #40143
It crash at step 6.
Nothing to do.. The espresso 0.99.60 don't resolve the problem.

Colin Watson (cjwatson) wrote :

Rejecting duplicate espresso task. espresso has been renamed to ubiquity.

Changed in espresso:
status: Unconfirmed → Rejected
Colin Watson (cjwatson) wrote :

OK, this upload should make sure that partman exits if ubiquity crashes rather than carrying on as if nothing had happened. My apologies for any inconvenience and/or data loss caused by this bug.

Even after this bug fix, it is likely that you will still see the installer crashing in similar ways; I have not fixed all the triggers for this bug, merely (I hope) the dangerous symptoms. Please send me reports of those crashes as *new* bug reports rather than appending them to this bug; please do not reopen this bug unless you experience a crash that leaves the partitioning scripts running on a live CD with at least version 0.99.64 of ubiquity installed. Doing that will help me to keep a handle on the set of bugs I currently need to fix.

ubiquity (0.99.64) dapper; urgency=low

  * GTK frontend:
    - Use xscreensaver-command --deactivate, not --disable (closes: Malone
      #40095).
    - Hide "Set Time..." button if time-admin isn't present.
    - Recommend gnome-system-tools for time-admin.
  * KDE frontend:
    - Fix import of UbiquityUIBase (closes: Malone #40939).
  * Set the SIGPIPE handler back to the default before spawning
    debconffiltered subprocesses, so that they notice when the UI crashes
    rather than carrying merrily on and e.g. trashing the partition table
    (closes: Malone #40464). Whose bright idea was it to have Python install
    a SIGPIPE handler but then not bother to have the subprocess module
    remove it, eh?

 -- Colin Watson <email address hidden> Sun, 23 Apr 2006 19:07:52 +0100

Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

I have written https://wiki.ubuntu.com/DapperBeta/PartitionTableCorruption with a patch for this bug that can be applied on the fly, and directions on what to do if your partition table has already been corrupted.

We won't be withdrawing the beta or immediately publishing a new beta (this would be many man-days of work that is better spent on making sure the final Dapper release is as good as it can be), but I've added a link to this bug and to the above wiki page to the beta release web pages on releases.ubuntu.com.

Sam thing happened to me. However, the Ubuntu Live Install worked fine. The problem only affected the Kubuntu Live Install.

Sorry...I forgot my details. My machine is a Compaq Evo P4 1.6GHz, with a Maxtor 160GB harddrive. I have an NVidia GeForce MX 4200 card.

Paul

tejinderss (david-00-7) wrote :

I lost all my data.
amd 2600+

please delete the download link to this iso. it works as a trojan or something

Colin Watson (cjwatson) wrote :

See my comment earlier today. Alongside the download link there is now a link to a page with a patch for this problem that you can apply on the fly before starting installation. If we don't leave this up, then there is a significant risk that Dapper final might be released with other serious problems; we do not have a lot of time left.

Colin Watson (cjwatson) wrote :

We may, however, be doing a relatively quick re-release of the beta desktop CD, beta 2 or something. It will take some days to get that prepared; in the meantime I think the documentation on releases.ubuntu.com suffices for people downloading the images.

tejinderss (david-00-7) wrote :

i installed the patch, it still crashes and i have filed a bug too. now is there any alternative of installing kubuntu using that live cd?

Simon Cadieux (sim-cadieux) wrote :

Happened to me this week-end. Had to repartition everything and install with text install CD.

Billy Charlton (billy) wrote :

I just experience this bug on the Ubuntu Dapper Beta 2 -- *not* the Kubuntu CD, the Ubuntu one. Lost an XP partition, totally corrupted.

This bug is not fixed yet, as of Beta 2....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers