grub install fails on EFI Intel Macs

Bug #46853 reported by Eric Stokes on 2006-05-27
238
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Unassigned
parted (Ubuntu)
Undecided
Colin Watson
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

The install went just find until it came time to install grub, then I got this error. I have boot camp and firmware updates installed.

Traceback (most recent call last):
  File "/usr/bin/ubiquity", line 120, in ?
    install(sys.argv[1])
  File "/usr/bin/ubiquity", line 54, in install
    ret = wizard.run()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 266, in run
    self.process_step()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 739, in process_step
    self.mountpoints_to_summary()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 1020, in mountpoints_to_summary
    self.progress_loop()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 538, in progress_loop
    raise RuntimeError, "Install failed with exit code %s" % ret
RuntimeError: Install failed with exit code 1

Related branches

Eric Stokes (eric-stokes) wrote :
Download full text (20.4 KiB)

contents of /var/log/installer/syslog, also forgot to mention, this is dapper rc.

Ubiquity 1.0.7
Sat, 27 May 2006 01:37:42 INFO switched to page stepLanguage
ubiquity: Starting up '['/usr/lib/ubiquity/localechooser/localechooser']' for ubiquity.components.language.Language
ubiquity: Watching for question patterns ^languagechooser/language-name
Sat, 27 May 2006 01:37:50 INFO Step_before = stepLanguage
Sat, 27 May 2006 01:37:50 INFO switched to page stepLocation
Sat, 27 May 2006 01:37:50 INFO Step_after = stepLocation
ubiquity: Starting up '['/usr/share/ubiquity/tzsetup']' for ubiquity.components.timezone.Timezone
ubiquity: Watching for question patterns ^time/zone$
Sat, 27 May 2006 01:37:55 INFO Step_before = stepLocation
Sat, 27 May 2006 01:37:55 INFO switched to page stepKeyboardConf
Sat, 27 May 2006 01:37:55 INFO Step_after = stepKeyboardConf
ubiquity: kbd-chooser prepare
ubiquity: Starting up '['/bin/sh', '-c', '. /usr/share/debconf/confmodule; exec /usr/lib/ubiquity/kbd-chooser/kbd-chooser']' for ubiquity.components.kbd_chooser.KbdChooser
ubiquity: Watching for question patterns ^kbd-chooser/method$, ^console-keymaps.*/keymap$, ERROR
ubiquity: apply_keyboard: us
ubiquity: apply_keyboard: layout us, model pc104
ubiquity: Display map: {u'Swedish': u'se-latin1', u'Icelandic': u'is-latin1', u'Estonian': u'et', u'Romanian': u'ro', u'Italian': u'it', u'Latin American': u'la-latin1', u'Dutch': u'nl', u'Brazilian (EUA layout)': u'br-latin1', u'Belgian': u'be2-latin1', u'Danish': u'dk-latin1', u'Bulgarian': u'bg', u'Turkish (F layout)': u'trfu', u'Hungarian': u'hu', u'Macedonian': u'mk', u'Lithuanian': u'lt', u'French': u'fr-latin9', u'Norwegian': u'no-latin1', u'Slovakian': u'sk-qwerty', u'Russian': u'ru', u'Dvorak': u'dvorak', u'Slovene': u'slovene', u'Finnish': u'fi-latin1', u'British English': u'uk', u'Spanish': u'es', u'Greek': u'gr', u'Canadian French': u'cf', u'Latvian': u'lv-latin4', u'American English': u'us', u'Croatian': u'croat', u'Portuguese': u'pt-latin1', u'Czech': u'cz-lat2', u'Ukrainian': u'ua', u'Japanese': u'jp106', u'Belarusian': u'by', u'Turkish (Q layout)': u'trqu', u'German': u'de-latin1-nodeadkeys', u'Hebrew': u'hebrew', u'Polish': u'pl', u'Brazilian (ABNT2 layout)': u'br-abnt2', u'Swiss French': u'fr_CH-latin1', u'Swiss German': u'sg-latin1', u'Serbian (Cyrillic)': u'sr-cy'}
ubiquity: Untranslated choices: [u'by', u'bg', u'croat', u'cz-lat2', u'sg-latin1', u'de-latin1-nodeadkeys', u'dk-latin1', u'us', u'uk', u'dvorak', u'et', u'es', u'la-latin1', u'fi-latin1', u'fr-latin9', u'be2-latin1', u'cf', u'fr_CH-latin1', u'gr', u'hebrew', u'hu', u'is-latin1', u'it', u'lt', u'lv-latin4', u'jp106', u'mk', u'no-latin1', u'nl', u'pl', u'pt-latin1', u'br-abnt2', u'br-latin1', u'ro', u'ru', u'sk-qwerty', u'slovene', u'sr-cy', u'se-latin1', u'trfu', u'trqu', u'ua']
ubiquity: Choices: [u'Belarusian', u'Bulgarian', u'Croatian', u'Czech', u'Swiss German', u'German', u'Danish', u'American English', u'British English', u'Dvorak', u'Estonian', u'Spanish', u'Latin American', u'Finnish', u'French', u'Belgian', u'Canadian French', u'Swiss French', u'Greek', u'Hebrew', u'Hungarian', u'Icelandic', u'...

Colin Watson (cjwatson) wrote :

Yup, sorry - the Macbook Pro isn't supported with Ubiquity at the moment, because we took a decision to only attempt to support grub for Dapper and grub uses BIOS calls that Boot Camp doesn't implement.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Gorka Navarrete (emrys) wrote :

There is an apparent fix here: http://www.ubuntuforums.org/showpost.php?p=1060679&postcount=22

It does not work for me but, hey, u never know.

Would be great to have an "unsuported solution" to this...

Ali Sabil (asabil) wrote :

still unfixed in edgy knot ?
There is a patch out there for grub : http://www.scl.ameslab.gov/Projects/mini-xen/grub-a20.patch
http://gentoo-wiki.com/HARDWARE_Apple_MacBook#Grub

thank you for your great work.

Sebastien Estienne (sebest) wrote :

Still broken in edgy beta 1.

Will the mac hardware be supported when edgy will be out?
In my opinion only small issues remain (almost all have fixes), but this one is really blocking -> impossible to fininish installation.

What's the goal for edgy with mac hardware?

Colin Watson (cjwatson) wrote :

Sebastien: -> edgy+1 I'm afraid. We aren't adding more hardware support now.

Sebastien: If you boot OSX and switch to a standard PC mbr (they call it something like that) via the disk-utility, you might avoid this problem. Grub worked fine on my single-boot setup after making this change.

As of Edgy and the latest Apple firmware upgrades and Bootcamp updates, there's only one problem left which causes the GRUB installation to fail:

Gparted, which is integrated into Ubiquity, doesn't sync MBR and GPT partition schemes after partitioning. At the beginning of the installation process, parted repartitions the drive, causing the GRUB installation at the end to fail! In addition to that, the boot partition type must be Linux (83).

The workaround is manually sync'ing MBR and GPT after the repartitioning but before the attempted GRUB install. To do so, I download and install Debian's rEFIt package (http://packages.debian.org/unstable/admin/refit) on the live CD before starting the installation. Then, during "Copying files..." I have enough time to sync MBR and GPT and fix the boot partition type.

Until an EFI-aware GRUB installation is possible, it would be best if Ubiquity would sync MBR and GPT and ensure the proper boot partition type is set.

For more details how to ensure a successful installation with GRUB, take a look at my HOWTO here:

https://wiki.ubuntu.com/MacBook

Michael R. Head (burner) wrote :

Any progress for feisty?

Can ubiquity be modified to detect the need to sync the MBR to the GPT?

I noticed the Debian "refit" package is now in feisty's Universe
repository. Integrating it into ubiquity shouldn't be too hard. After
ubiquity has finished modyfing the partition scheme, all it needs to
do is sync the MBR to the GPT by calling gptsync on the drive. It's
also important to make sure the boot partition is set to type Linux
(0x83). Shouldn't be much of a problem to implement this. Anyone
working on this yet?

2006/11/30, Michael R. Head <email address hidden>:
> Any progress for feisty?
>
> Can ubiquity be modified to detect the need to sync the MBR to the GPT?
>
> --
> grub install fails on EFI Intel Macs
> https://launchpad.net/bugs/46853
>

Michael R. Head (burner) wrote :

Actually, I haven't been able to get the MacBook instructions to work on a Intel-based MiniMac. After trying a number of install attempts over several hours, Grub still failed to install properly. I eventually told the potential Ubuntite to give Fedora 6 a go, which smmes to explicitly support the intel Macs :-(

Colin Watson (cjwatson) on 2007-01-26
Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → In Progress
Matthew Garrett (mjg59) wrote :

The attached patch adds gpt/mbr synchronisation to parted. It's limited to supporting 4 partitions right now, one of which is the EFI system partition, so it's not ideal - however, it should at least allow the system to be installable.

Colin Watson (cjwatson) wrote :

parted (1.7.1-3ubuntu3) feisty; urgency=low

  [ Matthew Garrett ]
  * gptsync.dpatch: Perform automatic GPT/MBR partition table
    synchronisation (LP: #46853).

  [ Colin Watson ]
  * Set Maintainer to ubuntu-devel-discuss, not ubuntu-devel.

 -- Colin Watson <email address hidden> Wed, 7 Mar 2007 12:50:09 +0000

Changed in parted:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
Colin Watson (cjwatson) wrote :

This is all now in Ubiquity as of version 1.3.25 in Feisty, which incorporates code to make best use of Matthew's patch. Earlier versions would work OK under some circumstances via gptsync, but I think everything's in now.

The main fix not yet mentioned in this bug was:

grub (0.97-20ubuntu3) feisty; urgency=low

  * Add GPT patch from
    http://lists.gnu.org/archive/html/bug-grub/2006-07/msg00037.html, to
    simplify support for Intel Macs (LP: #62386).

 -- Colin Watson <email address hidden> Fri, 19 Jan 2007 10:42:32 +0000

Changed in ubiquity:
status: In Progress → Fix Released
NowakPL (nowak) wrote :

The parted gptsync patch breaks gpt partitions support on x86 / x86_64. Because there is normal mbr table gpt partitions are completely ignored and mbr only is used instead. This breaks gpt for more than 4 partitions or when disk size is above 2TB.
Most likely related: https://bugs.launchpad.net/ubuntu/+source/parted/+bug/107326

Richard Laager (rlaager) wrote :

Colin, Matthew: I'd like to draw your attention to my comment here, as the GPT sync patch prevents me from installing on systems with drives greater than 2 TB: https://bugs.launchpad.net/ubuntu/+source/parted/+bug/107326/comments/5

Installing Ubuntu 8.10 Alpha 4 on a MacBook Pro rev. 3, you still have to wait more than 30 seconds until GRUB starts booting. Does this issue have something to do with this bug?

Mark (mjsqueeze) wrote :

I actually am having trouble with internet connections.  I think the launch defaults allow me to recognize the net, but as I looked at the boot file, many net options were not marked y.  The result is that though I see the net on the terminal, I cannot access or configure it with the GUI's such as internet connection, nor with firefox.  Nor can I use apt-get through the net.

However,
avahi is recognized on the terminal, with my wifi device.  I am now about to test the firwire and video recognition.

I must say that the automatic recognition of the screen was perfect...
but if I can't use the net, I can't install other programs, etc...

--- On Wed, 8/27/08, oss_test_launchpad <email address hidden> wrote:
From: oss_test_launchpad <email address hidden>
Subject: [Bug 46853] Re: grub install fails on EFI Intel Macs
To: <email address hidden>
Date: Wednesday, August 27, 2008, 10:06 AM

Installing Ubuntu 8.10 Alpha 4 on a MacBook Pro rev. 3, you still have
to wait more than 30 seconds until GRUB starts booting. Does this issue
have something to do with this bug?

--
grub install fails on EFI Intel Macs
https://bugs.launchpad.net/bugs/46853
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Richard Laager (rlaager) wrote :

Mark: You should file a separate bug report. I don't know what is going on with this Mactel Support task.

Changed in mactel-support:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints