Meta-bug: Ubuntu needs major software RAID overhaul

Bug #68308 reported by Timothy Miller on 2006-10-26
22
Affects Status Importance Assigned to Milestone
mdadm (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

A few references to start off with:

http://www.ubuntuforums.org/showthread.php?t=283881
https://launchpad.net/distros/ubuntu/+source/partman-md/+bug/22301
https://launchpad.net/distros/ubuntu/+bug/58892
https://launchpad.net/distros/ubuntu/+bug/58893
https://launchpad.net/distros/ubuntu/+bug/58894
https://launchpad.net/distros/ubuntu/+source/debian-installer/+bug/33649
https://launchpad.net/distros/ubuntu/+source/partman-md/+bug/16790
https://launchpad.net/distros/ubuntu/+source/initramfs-tools/+bug/22673
https://launchpad.net/distros/ubuntu/+source/preseed/+bug/31435
https://launchpad.net/distros/ubuntu/+source/debian-installer/+bug/45523
https://launchpad.net/distros/ubuntu/+source/partman-md/+bug/63235

This is just a smattering of the RAID-related problems with Ubuntu.

Linux software RAID has long been touted as being top-quality, nearly comparable to hardware RAID in performance, and, in many ways, superior to some hardware RAID in reliability. Additionally, Ubuntu's partman makes it relatively easy to set up software RAID in a menu-driven interface. There is, therefore, no reason why software RAID should take a back seat to other issues, when it directly relates to fundamental system robustness and reliability. We should want people to use Ubuntu Linux for RAID setups, because we want people who need RAID to want to use Ubuntu.

When I first switched to Ubuntu, I tried to install Edgy. Unfortunately, that didn't go well. The installer kept hanging up, and I was never able to proceed. Then I tried Dapper. That seemed to go very well, until I did some very basic tests and investigation, and found that while I did indeed have software RAID1 working, the installer had set up the system so that the loss of the primary disk would mean effective total data loss for both disks. I had to manually reconfigure menu.lst and install GRUB properly to get my system set up right.

This incomplete attention to software RAID inherent in Ubuntu has me worried. I would like to be able to upgrade to Edgy when it comes out, but I am concerned that it'll leave my system in an unusable state. So I asked in the forums, and I got a response from one poor unfortunate person who did indeed try to upgrade to Edgy on a RAID setup. I quote from "ews":

> Edgy broke my RAID0 config (which wasn't quick to setup).
> It has left me without X, without the interweb, and without a kernel that loads.
>
> Before taking the plunge, I sought advice from those on irc.freenode.net
> #ubuntu+1 and #xubuntu I was assured that the RAID would not be affected
> and the entire dist-upgrade would be smooth and painless. Baloney.
>
> Funny how everyone was so keen to push Edgy and make the claim that
> RAID is untouched. I even pasted the link to the original how-to I followed
> to set up the fakeraid. But after going back to the channels for help with
> a broken install, the general consensus is that "oh, can't help you, never
> used RAID before".
>
> Frustrating to say the least. Think twice, RAID users, think twice.

I would like to plead with Ubuntu developers to PLEASE address these issues.

Skewray (ubuntu-skewray) wrote :

I just tried to install Kubuntu 6.10 over a SuSE 10.1 installation with a RAID-0 / and RAID-1 /home. I was unable to find any mention of how to set up the RAID partitions. As far as I could tell, Ubuntu appears to not support RAID at all. There must be some secret to the partitioning program that I missed. RAID, if really supported, needs to be more obvious during the installation process.

Couldn't agree more. WE NEED PROPER RAID SUPPORT.

I would have though this would have been done PRIOR to the release of the Audio Visual release of Ubuntu Studio as one of the primary uses of raid (and fakeRAID) is a/v work as it offers significant performance benefits.

Offering Ubuntu Studio without decent raid support is like building a race car and then only offering diesel fuel to the drivers.

Many people using windows boxes have their systems pre-configured with RAID (fakeRAID in particular). Large companies such as Dell supply machines pre-built with fakeRAID now. Pretty much all current chipsets have fakeRAID (and some even RAID5 built in) and it's about damn time the people making installers and distros took notice! - And not just you ubuntu/kbuntu people.

Additionally, due to the almost complete lack of fakeraid support in other distros getting it in ubuntu and kubuntu would give the distro an edge over the other ones and could be used as a marketing point.

Furthermore fakeRAID should be renamed to something else.

My system runs RAID. There's nothing fake about it. The data is sliced across 3 RAID-0 configured drives, yet apparently it's "fake" ? No it's not, it's just another way of doing it that doesn't involve offloading the RAID support to dedicated hardware. And in these quad-core CPU days the cpu's have got cycles to spare doing it anyway!

Why not call it "cpuRAID" instead, then at least there's a distinction between [dedicated]hardwareRAID and cpuRAID. That is if you even really need a distinction anyway.

AusIV (linux-ausiv) wrote :

I've made a couple of bug reports on this subject. The first was closed with the suggestion that I use the alternative install CD, the second has never been addressed, but basically restated that the problem was no better with the alternative CD than with the live CD.

I would like to point out that the goal sheet for feisty https://blueprints.launchpad.net/ubuntu/feisty mentions that better udev support is needed from LVM, EVMS, and MDADM. Betas are available on the first two, and MDADM has been started.

Changed in ubuntu-meta:
status: New → Confirmed
Jose Bernardo (bernardo-bandos) wrote :

Here's another raid related bug:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/103177

Even though it is reported as "fix issued", it is still valid for quite a few of us.

TAC one (tacone) wrote :

Raid support should definitely be fixed. Dell is selling raid 0 system (and I bought one of these, by the way). Fixing would help them to include Ubuntu as a choice on high-end system (I had to buy Vista)

Robert J Lee (efficient) wrote :

It's nice to see that the 8.04 advanced disk supports various options for RAID setup.

I installed with an encrypted RAID-5 / and an unencrypted RAID-1 /boot, so I should be able to survive the loss of any one disk.

The system wouldn't boot; it turned out the installer had set up grub on only one disk, and that wasn't the same disk that the BIOS was using to boot from.

Further, when I installed GRUB by hand, pointing grub's / at the unencrypted /boot partition so it could actually read it, I found the installer had left in the /boot prefix on the kernel image and initramfs file. Not sure if that could be made to work (I ended up creating a sym-link in /boot/boot).

jhansonxi (jhansonxi) wrote :

RAID configuration is not the only issue. The install tool partman has several design problems. Each of the partitioning, RAID, LVM, and LUKS/dm-crypt, and mkswap configuration functrions do not work well together. They behave as separate operations that get deadlocked when used in patterns not anticipated by the designers. The system needs to allow the user to define the entire usage scheme, then validate it, then apply it. Then the tools need to figure out what order the partitions are created, mounted as RAID and/or LVM and/or crypt volumes, then continue installation. Having the user looping through the modules individually results in logical impasses.

I waste a lot of time fighting with the RAID system when I need to adjust partition sizes and LVM physical volumes because md-raid is already mounted and syncing. There is no reason it needed to do that. The RAID volume characteristics can already be calculated without mounting it.

With my RAID/LVM/crypt setups I can never create an encrypted swap as it fails every time. I have to install without swap and add it manually later.

Dustin Kirkland  (kirkland) wrote :

Hi,

Thanks for collecting all of these bugs into this meta bug.

With Ubuntu Intrepid, I believe we have given Ubuntu's RAID implementation the major overhaul you have requested. Please see the blueprint and spec for more details:
 * https://wiki.ubuntu.com/BootDegradedRaid
 * https://blueprints.edge.launchpad.net/ubuntu/+spec/boot-degraded-raid

Specifically in response to the bugs you've referenced, I've examined each of them and updated them accordingly. In summary:
 * Bug #22301: Triaged, updated, asking for someone to reproduce on Intrepid
 * Bug #58892: Fixed
 * Bug #58893: Fixed
 * Bug #58894: Fixed
 * Bug #33649: Fixed
 * Bug #16790: Fixed
 * Bug #22673: Fixed
 * Bug #31435: Fixed
 * Bug #45523: Needs testing
 * Bug #63235: Fixed

I've extensively tested these issues, and am happy to report that the state of RAID in Ubuntu is significantly better. I"m going to mark this bug as "Fix Released" at this point, and continue with the two remaining issues.

Thanks!
:-Dustin

Changed in ubuntu-meta:
status: Confirmed → Fix Released
Changed in mdadm:
status: New → Fix Released

I'll be sure to check it out and report back, thanks for the time and effort you and everyone else who's commented on this bug have put into getting this actioned.

Dustin Kirkland  (kirkland) wrote :

I just tested Bug #45523 and it also seems to be FIXED in Intrepid.

:-Dustin

Timothy Miller (theosib) on 2009-04-15
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions