Change log for ubuntu-release-upgrader package in Ubuntu

175 of 299 results
Published in focal-release on 2019-10-18
Published in eoan-release on 2019-10-14
Deleted in eoan-proposed (Reason: moved to Release)
ubuntu-release-upgrader (1:19.10.15) eoan; urgency=medium

  * Don't check for validity of /usr/bin/python symlink because this is no
    longer relevant to the upgrades (and the printed error message was
    inaccurate).  LP: #1825655.
  * Clean up remaining references to /usr/bin/python (tests and utilities)
    in the source.

 -- Steve Langasek <email address hidden>  Fri, 11 Oct 2019 16:54:15 -0700

Available diffs

Superseded in eoan-release on 2019-10-14
Deleted in eoan-proposed on 2019-10-15 (Reason: moved to Release)
ubuntu-release-upgrader (1:19.10.14) eoan; urgency=medium

  * DistUpgrade/DistUpgradeCache.py: New python3-apt bindings no longer provide
    Package.section, so switch to using Package.{candidate,installed}.section
    whenever applicable. This fixes broken partial upgrades. (LP: #1841675)

 -- Łukasz 'sil2100' Zemczak <email address hidden>  Thu, 10 Oct 2019 09:59:30 +0200

Available diffs

Superseded in eoan-release on 2019-10-10
Deleted in eoan-proposed on 2019-10-11 (Reason: moved to Release)
ubuntu-release-upgrader (1:19.10.13) eoan; urgency=medium

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeQuirks.py: do not include gnome-system-monitor in
    the deb to snap transition anymore. (LP: #1845485)
  * DistUpgrade/DistUpgradeQuirks.py: improve wording regarding not being able
    to upgrade from a system with an apt architecture of i386.

  [ Łukasz 'sil2100' Zemczak ]
  * DistUpgrade/DistUpgradeQuirks.py: slightly refactor code to fix related
    unit tests.

 -- Łukasz 'sil2100' Zemczak <email address hidden>  Thu, 03 Oct 2019 14:34:06 +0200

Available diffs

Published in xenial-updates on 2019-10-10
Deleted in xenial-proposed (Reason: moved to -updates)
ubuntu-release-upgrader (1:16.04.27) xenial; urgency=medium

  * Use HTTPS for changelogs.ubuntu.com (LP: #1744318)
  * Run pre-build script to update mirror list, hold apt-btrfs-snapshot changes

 -- Julian Andres Klode <email address hidden>  Wed, 02 Oct 2019 16:08:25 +0200

Available diffs

Published in disco-updates on 2019-10-09
Deleted in disco-proposed (Reason: moved to -updates)
ubuntu-release-upgrader (1:19.04.16.7) disco; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py, DistUpgrade/DistUpgradeCache.py:
    Modify DistUpgradeQuirks to calculate extra space needed for snaps that
    need to be installed during upgrade (replacing old debs) and add that to
    estimates done in checkFreeSpace(). (LP: #1783597)
  * DistUpgrade/DistUpgradeCache.py: Make sure checkFreeSpace() still works for
    update-manager with its own implementation of MyCache.
  * DistUpgrade/DistUpgradeQuirks.py: Make sure snaps like core18 are not
    refreshed/installed from the stable/ubuntu-VERSION branch but instead use
    stable on upgrades. (LP: #1841225)

 -- Łukasz 'sil2100' Zemczak <email address hidden>  Mon, 09 Sep 2019 15:41:12 +0200

Available diffs

Superseded in eoan-release on 2019-10-03
Deleted in eoan-proposed on 2019-10-04 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.12) eoan; urgency=medium

  * DistUpgrade/DistUpgradeCache.py: Make sure checkFreeSpace() still works for
    update-manager with its own implementation of MyCache. (LP: #1843076)

 -- Łukasz 'sil2100' Zemczak <email address hidden>  Tue, 10 Sep 2019 18:44:43 +0200

Available diffs

Superseded in eoan-release on 2019-09-11
Deleted in eoan-proposed on 2019-09-12 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.11) eoan; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py, DistUpgrade/DistUpgradeCache.py:
    Modify DistUpgradeQuirks to calculate extra space needed for snaps that
    need to be installed during upgrade (replacing old debs) and add that to
    estimates done in checkFreeSpace(). (LP: #1783597)
  * DistUpgrade/DistUpgradeQuirks.py: Make sure snaps like core18 are not
    refreshed/installed from the stable/ubuntu-VERSION branch but instead use
    stable on upgrades. (LP: #1841225)

 -- Łukasz 'sil2100' Zemczak <email address hidden>  Tue, 03 Sep 2019 15:58:38 +0200

Available diffs

Superseded in eoan-release on 2019-09-04
Deleted in eoan-proposed on 2019-09-05 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.10) eoan; urgency=medium

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeQuirks.py: Resolve issue with the fallback
    mechanism including more than the version number for the release.

  [ Gianfranco Costamagna ]
  * Fix E117 over idented code

 -- Gianfranco Costamagna <email address hidden>  Mon, 29 Jul 2019 23:08:52 +0200

Available diffs

Superseded in eoan-release on 2019-07-30
Deleted in eoan-proposed on 2019-07-31 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.9) eoan; urgency=medium

  * DistUpgrade/DistUpgradeCache.py, DistUpgrade/DistUpgradeController.py:
    drop code which identified obsolete kernels and marked them for removal as
    it is redundant with functionality that exists in apt. (LP: #1828100)
  * DistUpgrade/DistUpgradeQuirks.py: Create a fallback mechanism for
    determining the version of a release (necessary for Ubuntu 18.04) when
    replacing debs with snaps. (LP: #1833753)

 -- Brian Murray <email address hidden>  Fri, 21 Jun 2019 14:30:19 -0700

Available diffs

Published in bionic-updates on 2019-07-01
Deleted in bionic-proposed (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.34) bionic; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: only try to install snaps if snapstore
    is reachable. (LP: #1831933)

 -- Dan Streetman <email address hidden>  Wed, 19 Jun 2019 12:49:56 -0400

Available diffs

Published in cosmic-updates on 2019-07-01
Deleted in cosmic-proposed (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.9) cosmic; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: only try to install snaps if snapstore
    is reachable. (LP: #1831933)

 -- Dan Streetman <email address hidden>  Wed, 19 Jun 2019 12:49:56 -0400

Available diffs

Superseded in disco-updates on 2019-10-09
Deleted in disco-proposed on 2019-10-10 (Reason: moved to -updates)
ubuntu-release-upgrader (1:19.04.16.6) disco; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: only try to install snaps if snapstore
    is reachable. (LP: #1831933)

 -- Dan Streetman <email address hidden>  Wed, 19 Jun 2019 12:49:56 -0400

Available diffs

Superseded in eoan-release on 2019-06-21
Deleted in eoan-proposed on 2019-06-23 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.8) eoan; urgency=medium

  [ Steve Langasek ]
  * Factor the release version out of the to-be-translated strings, so
    that translators don't have to chase updating this for every release.
    LP: #1727472.
  * Update the pot file in the source, evidently not done for the past 3
    years.

 -- Brian Murray <email address hidden>  Tue, 18 Jun 2019 08:59:08 -0700

Available diffs

Superseded in eoan-release on 2019-06-18
Deleted in eoan-proposed on 2019-06-20 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.7) eoan; urgency=medium

  [ Dan Streetman ]
  * DistUpgrade/DistUpgradeQuirks.py: only try to install snaps if snapstore
    is reachable. (LP: #1831933)

 -- Brian Murray <email address hidden>  Mon, 17 Jun 2019 09:49:36 -0700

Available diffs

Superseded in eoan-release on 2019-06-17
Deleted in eoan-proposed on 2019-06-19 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.6) eoan; urgency=medium

  * DistUpgradeQuirks.py: modify string regarding refreshing and installing
    snaps so that it is translatable. (LP: #1824005)

 -- Brian Murray <email address hidden>  Fri, 14 Jun 2019 10:33:21 -0700

Available diffs

Superseded in bionic-updates on 2019-07-01
Deleted in bionic-proposed on 2019-07-02 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.33) bionic; urgency=medium

  * DistUpgrade/DistUpgradeViewNonInteractive.py: when responding to a
    conffile prompt with "n" use bytes not a string. (LP: #1796193)
  * debian/control: add an explicit python3-distro-info dependency to
    python3-distupgrade as it is now required by DistUpgradeController.
    (LP: #1824866)
  * pre-build.sh: stop updating demotions for artful since it is no longer
    available at archive.ubuntu.com and if we do update then demotions becomes
    an empty file which is wrong.

 -- Brian Murray <email address hidden>  Wed, 15 May 2019 10:37:15 -0700

Available diffs

Superseded in cosmic-updates on 2019-07-01
Deleted in cosmic-proposed on 2019-07-02 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.8) cosmic; urgency=medium

  * DistUpgrade/DistUpgradeViewNonInteractive.py: when responding to a
    conffile prompt with "n" use bytes not a string. (LP: #1796193)

 -- Brian Murray <email address hidden>  Fri, 10 May 2019 16:14:50 -0700

Available diffs

Superseded in disco-updates on 2019-07-01
Deleted in disco-proposed on 2019-07-02 (Reason: moved to -updates)
ubuntu-release-upgrader (1:19.04.16.5) disco; urgency=medium

  [ Gunnar Hjalmarsson ]
  * DistUpgrade/window_main.ui: Really update for 19.04 (LP: #1825733).

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeViewNonInteractive.py: when responding to a
    conffile prompt with "n" use bytes not a string. (LP: #1796193)

 -- Brian Murray <email address hidden>  Fri, 10 May 2019 15:19:00 -0700

Available diffs

Superseded in eoan-release on 2019-06-17
Deleted in eoan-proposed on 2019-06-18 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.5) eoan; urgency=medium

  * DistUpgrade/DistUpgradeViewNonInteractive.py: when responding to a
    conffile prompt with "n" use bytes not a string. (LP: #1796193)
  * DistUpgrade/DistUpgradeController.py: set a default value for devRelease
    even if there are no options specified. (LP: #1827441)

 -- Brian Murray <email address hidden>  Fri, 10 May 2019 13:30:07 -0700

Available diffs

Superseded in eoan-release on 2019-05-10
Deleted in eoan-proposed on 2019-05-12 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.4) eoan; urgency=medium

  [ Gunnar Hjalmarsson ]
  * DistUpgrade/window_main.ui: Really update for 19.10 (LP: #1825733).

 -- Brian Murray <email address hidden>  Thu, 09 May 2019 11:06:05 -0700

Available diffs

Superseded in disco-updates on 2019-05-22
Deleted in disco-proposed on 2019-05-23 (Reason: moved to -updates)
ubuntu-release-upgrader (1:19.04.16.4) disco; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: modify function which updates snaps so
    that it determines the release from which a system is being upgraded.
    Additionally, update the channel for the snap to reflect the release to
    which we are upgrading. (LP: #1827951)
  * data/DistUpgrade.cfg.bionic, data/DistUpgrade.cfg:
    - update KernelRemoval sections to kernel packages that appear in
      Ubuntu 18.04 and Ubuntu 18.10. (LP: #1828072)

Superseded in bionic-updates on 2019-05-22
Deleted in bionic-proposed on 2019-05-23 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.32) bionic; urgency=medium

  * data/DistUpgrade.cfg.xenial: update KernelRemoval sections to kernel
    packages that appear in Ubuntu 16.04. (LP: #1828072)

 -- Brian Murray <email address hidden>  Tue, 07 May 2019 15:44:49 -0700

Available diffs

Superseded in cosmic-updates on 2019-05-22
Deleted in cosmic-proposed on 2019-05-23 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.7) cosmic; urgency=medium

  * data/DistUpgrade.cfg: update KernelRemoval sections to kernel packages
    that appear in Ubuntu 18.04. (LP: #1828072)

 -- Brian Murray <email address hidden>  Tue, 07 May 2019 13:48:48 -0700

Available diffs

Superseded in eoan-release on 2019-05-09
Deleted in eoan-proposed on 2019-05-11 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.3) eoan; urgency=medium

  * data/DistUpgrade.cfg: update BaseNames section to kernel packages that
    appear in Ubuntu 19.04. (LP: #1828072)
  * data/DistUpgrade.cfg.bionic: update KernelRemoval section to kernel
    packages that appear in Ubuntu 18.04. (LP: #1828072)

 -- Brian Murray <email address hidden>  Tue, 07 May 2019 10:15:37 -0700

Available diffs

Superseded in eoan-release on 2019-05-07
Deleted in eoan-proposed on 2019-05-09 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.2) eoan; urgency=medium

  * DistUpgradeQuirks.py: leverage distro_info to determine version for the
    release codename so version numbers aren't hard coded and
    _replaceDebsWithSnaps won't require regular updating.
  * data/DistUpgrade.cfg: update version in KernelRemoval section of the
    config.
  * update references to Eoan since it has an animal now.

 -- Brian Murray <email address hidden>  Mon, 06 May 2019 14:04:58 -0700

Available diffs

Superseded in disco-proposed on 2019-05-08
ubuntu-release-upgrader (1:19.04.16.3) disco; urgency=medium

  * data/DistUpgrade.cfg.bionic,
    data/demoted.cfg.bionic,
    pre-build.sh:
    - support upgrades from bionic (LP: #1827635)

 -- Brian Murray <email address hidden>  Fri, 03 May 2019 11:47:57 -0700

Available diffs

Superseded in eoan-release on 2019-05-07
Deleted in eoan-proposed on 2019-05-08 (Reason: moved to release)
ubuntu-release-upgrader (1:19.10.1) eoan; urgency=medium

  * DistUpgrade/{EOL,Devel}ReleaseAnnouncement,
    DistUpgrade/window_main.ui,
    data/gtkbuilder/DistUpgrade.ui,
    data/DistUpgrade.cfg,
    pre-build.sh:
    - updated for 19.04 -> 19.10
  * data/DistUpgrade.cfg.bionic,
    data/demoted.cfg.bionic,
    pre-build.sh:
    - support upgrades from bionic (LP: #1827635)
  * data/removal_blacklist.cfg: add blacklist entry for postgresql versions
    with two major digits e.g. postgresql-11. (LP: #1825563)
  * Fix broken symbolic link of DistUpgrade/DistUpgrade which caused code from
    the installed ubuntu-release-upgrader to be used instead of code in the
    dist-upgrader tarball. (LP: #1824430)

 -- Brian Murray <email address hidden>  Fri, 03 May 2019 10:24:48 -0700

Available diffs

Published in trusty-updates on 2019-05-06
Deleted in trusty-proposed (Reason: moved to -updates)
ubuntu-release-upgrader (1:0.220.11) trusty; urgency=medium

  * DistUpgradeController.py: Handle the transition of ESM during the release
    upgrade. (LP: #1824862)
  * DistUpgrade/build-tarball.sh: include ESM archive's gpg key.
  * mirrors.cfg: add in esm.ubuntu.com as an official mirror, update mirrors.

 -- Brian Murray <email address hidden>  Wed, 01 May 2019 15:09:41 -0700
Superseded in disco-updates on 2019-05-13
Deleted in disco-proposed on 2019-05-15 (Reason: moved to -updates)
ubuntu-release-upgrader (1:19.04.16.2) disco; urgency=medium

  * Fix broken symbolic link of DistUpgrade/DistUpgrade which caused code from
    the installed ubuntu-release-upgrader to be used instead of code in the
    dist-upgrader tarball. (LP: #1824430)

 -- Brian Murray <email address hidden>  Thu, 25 Apr 2019 08:22:50 -0700

Available diffs

Superseded in disco-updates on 2019-04-26
Deleted in disco-proposed on 2019-04-27 (Reason: moved to -updates)
ubuntu-release-upgrader (1:19.04.16.1) disco; urgency=medium

  * data/removal_blacklist.cfg: add blacklist entry for postgresql versions
    with two major digits e.g. postgresql-11. (LP: #1825563)
  * Update of demotions and mirrors data.

 -- Brian Murray <email address hidden>  Fri, 19 Apr 2019 15:25:07 -0700

Available diffs

Superseded in eoan-release on 2019-05-03
Published in disco-release on 2019-04-12
Deleted in disco-proposed (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.16) disco; urgency=medium

  * DistUpgrade/imported/invoke-rc.d: Import the current version of the script
    to fix upgrade failures of packages which only ship upstart and
    systemd units, but no SysV init script. (LP: #1813464)
  * DistUpgrade/imported/invoke-rc.d.diff: update the diff so that it applies
    to the current version of invoke-rc.d.
  * pre-build.sh: actually update invoke-rc.d on a regular basis and try to
    automatically appply the patch.
  * Update of demotions and mirrors data.

 -- Brian Murray <email address hidden>  Fri, 12 Apr 2019 10:39:09 -0700

Available diffs

Superseded in bionic-updates on 2019-05-13
Deleted in bionic-proposed on 2019-05-15 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.31) bionic; urgency=medium

  * DistUpgradeController.py: Instead of checking every sources.list entry to
    see if they are accessible keep track of the uris and only test once per
    uri thereby preventing situations where entries for the same server are
    enabled and disabled. (LP: #1822886)
  * debian/control: build depend on the new version of update-manager which
    supports checking to see if an https url is downloadable. (LP: #1823410)
  * tests/test_sources.list.py: add a test for https support.

 -- Brian Murray <email address hidden>  Tue, 09 Apr 2019 18:05:01 -0700

Available diffs

Superseded in cosmic-updates on 2019-05-13
Deleted in cosmic-proposed on 2019-05-15 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.6) cosmic; urgency=medium

  * DistUpgradeController.py: Instead of checking every sources.list entry to
    see if they are accessible keep track of the uris and only test once per
    uri thereby preventing situations where entries for the same server are
    enabled and disabled. (LP: #1822886)
  * debian/control: build depend on the new version of update-manager which
    supports checking to see if an https url is downloadable. (LP: #1823410)
  * tests/test_sources.list.py: add a test for https support.

 -- Brian Murray <email address hidden>  Tue, 09 Apr 2019 17:10:21 -0700

Available diffs

Superseded in disco-release on 2019-04-12
Deleted in disco-proposed on 2019-04-14 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.15) disco; urgency=medium

  * debian/control: build depend on the new version of update-manager which
    supports checking to see if an https url is downloadable. (LP: #1823410)
  * tests/test_sources.list.py: add a test for https support.
  * Update of demotions and mirrors data.
  * DistUpgrade/DistUpgradeQuirks.py: update the deb2snap quirk for disco,
    bump the version of gnome snap, and include the core18 snap.

 -- Brian Murray <email address hidden>  Mon, 08 Apr 2019 14:19:29 -0700

Available diffs

Superseded in disco-release on 2019-04-09
Deleted in disco-proposed on 2019-04-10 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.14) disco; urgency=medium

  * DistUpgradeController.py: Instead of checking every sources.list entry to
    see if they are accessible keep track of the uris and only test once per
    uri thereby preventing situations where entries for the same server are
    enabled and disabled. (LP: #1822886)
  * Update of demotions and mirrors data.

 -- Brian Murray <email address hidden>  Thu, 04 Apr 2019 17:06:26 -0700

Available diffs

Superseded in disco-release on 2019-04-05
Deleted in disco-proposed on 2019-04-06 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.13) disco; urgency=medium

  [ Brian Murray ]
  * Add a lintian override for unsafe symlinks after removing some crufty
    symlinks.

  [ Dimitri John Ledkov ]
  * Fix up minor lintian warnings.
  * Trick dh_python3 into processing script, in a non-standard location.

 -- Brian Murray <email address hidden>  Thu, 14 Mar 2019 10:41:34 -0700

Available diffs

  • diff from 1:19.04.11 to 1:19.04.13 (pending)
Superseded in disco-release on 2019-03-15
Deleted in disco-proposed on 2019-03-16 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.11) disco; urgency=medium

  * do-release-upgrade: fix typo of development. (LP: #1813470)

 -- Brian Murray <email address hidden>  Tue, 26 Feb 2019 13:37:50 -0800

Available diffs

Superseded in cosmic-updates on 2019-04-15
Deleted in cosmic-proposed on 2019-04-17 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.5) cosmic; urgency=medium

  * Remove lubuntu-core from the list of metapackages, fixing some upgrades
    from Lubuntu 18.04 to 18.10 (LP: #1799855).

 -- Simon Quigley <email address hidden>  Fri, 01 Feb 2019 18:52:07 -0600

Available diffs

Superseded in cosmic-updates on 2019-02-12
Deleted in cosmic-proposed on 2019-02-13 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.4) cosmic; urgency=medium

  [ Brian Murray ]
  * data/release-upgrades: Clarify documentation regarding the behavior for
    different Prompt settings. (LP: #1795024)
  * do-release-upgrade: Utilize information regarding what Prompt is set to so
    that a more informative error message can be displayed.
    (LP: #1798618, LP: #1795024)

  [ Andrea Azzarone ]
  * DistUpgrade/DistUpgradeView.py,
    DistUpgrade/DistUpgradeViewGtk3.py,
    DistUpgrade/DistUpgradeViewKDE.py,
    DistUpgrade/DistUpgradeViewNonInteractive.py,
    DistUpgrade/DistUpgradeViewText.py:
    - add askCancelContinueQuestion for all the supported views.
  * DistUpgrade/DistUpgradeController.py: Ask for confirmation if Livepatch
    is turned on, and you are upgrading to a version where Livepatch is not
    available. (LP: #1799310)
  * debian/control: add an explicit python3-distro-info dependency to
    python3-distupgrade as it is now required by DistUpgradeController.

 -- Brian Murray <email address hidden>  Mon, 21 Jan 2019 11:48:53 -0800

Available diffs

Superseded in disco-release on 2019-02-27
Deleted in disco-proposed on 2019-02-28 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.10) disco; urgency=medium

  [ Andrea Azzarone ]
  * DistUpgrade/DistUpgradeView.py,
    DistUpgrade/DistUpgradeViewGtk3.py,
    DistUpgrade/DistUpgradeViewKDE.py,
    DistUpgrade/DistUpgradeViewNonInteractive.py,
    DistUpgrade/DistUpgradeViewText.py:
    - add askCancelContinueQuestion for all the supported views.
  * DistUpgrade/DistUpgradeController.py: Ask for confirmation if Livepatch
    is turned on, and you are upgrading to a version where Livepatch is not
    available. (LP: #1799310)
  * debian/control: add an explicit python3-distro-info dependency to
    python3-distupgrade as it is now required by DistUpgradeController.

 -- Brian Murray <email address hidden>  Mon, 21 Jan 2019 08:57:50 -0800

Available diffs

Superseded in bionic-updates on 2019-04-17
Deleted in bionic-proposed on 2019-04-19 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.30) bionic; urgency=medium

  * data/release-upgrades: Clarify documentation regarding the behavior for
    different Prompt settings. (LP: #1795024)
  * do-release-upgrade: Utilize information regarding what Prompt is set to so
    that a more informative error message can be displayed.
    (LP: #1798618, LP: #1795024)
  * DistUpgrade/DistUpgradeCache.py: When calculating free space needed for
    mount points don't use a negative number as the buffer. (LP: #1786484)
  * fix more typos re RELEASE_UPRADER_ALLOW_THIRD_PARTY
  * DistUpgrade/DistUpgradeController.py: When rewriting sources.list entries
    check to see if the source provides packages for the release to which the
    upgrade is occurring. If it doesn't the entry is disabled thereby
    improving upgrades with PPAs. (LP: #1807043)
  * do-release-upgrade: add a parameter to allow third party mirrors and
    repositories, additionally pass along the environmental variable
    RELEASE_UPGRADER_ALLOW_THIRD_PARTY via pkexec and sudo. (LP: #1807032)
  * DistUpgrade/DistUpgradeCache.py: improve messaging regarding failures to
    calculate the upgrade and suggest using ppa-purge if PPAs are an issue.
  * DistUpgrade/DistUpgradeCache.py: in the event there is a failure to
    calculate the upgrade provide information about the log files in
    /var/log/dist-upgrade. (LP: #1771387)
  * debian/source_ubuntu-release-upgrader.py: Include xorg_fixup.log if it
    exists.
  * DistUpgrade/xorg_fix_proprietary.py: modify how the system is checked to
    see if nvidia is being used, drop fglrx check since it has been
    deprecated. (LP: #1773637)

 -- Brian Murray <email address hidden>  Wed, 16 Jan 2019 15:53:58 -0800

Available diffs

Superseded in cosmic-updates on 2019-01-31
Deleted in cosmic-proposed on 2019-02-01 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.3) cosmic; urgency=medium

  * DistUpgrade/DistUpgradeCache.py: When calculating free space needed for
    mount points don't use a negative number as the buffer. (LP: #1786484)
  * fix more typos re RELEASE_UPRADER_ALLOW_THIRD_PARTY.
  * DistUpgrade/DistUpgradeController.py: When rewriting sources.list entries
    check to see if the source provides packages for the release to which the
    upgrade is occurring. If it doesn't the entry is disabled thereby
    improving upgrades with PPAs. (LP: #1807043)
  * do-release-upgrade: add a parameter to allow third party mirrors and
    repositories, additionally pass along the environmental variable
    RELEASE_UPGRADER_ALLOW_THIRD_PARTY via pkexec and sudo. (LP: #1807032)
  * DistUpgrade/DistUpgradeCache.py: improve messaging regarding failures to
    calculate the upgrade and suggest using ppa-purge if PPAs are an issue.
  * DistUpgrade/DistUpgradeCache.py: in the event there is a failure to
    calculate the upgrade provide information about the log files in
    /var/log/dist-upgrade. (LP: #1771387)
  * debian/source_ubuntu-release-upgrader.py: Include xorg_fixup.log if it
    exists.
  * DistUpgrade/xorg_fix_proprietary.py: modify how the system is checked to
    see if nvidia is being used, drop fglrx check since it has been
    deprecated. (LP: #1773637)

 -- Brian Murray <email address hidden>  Thu, 20 Dec 2018 12:31:37 -0800

Available diffs

Superseded in disco-release on 2019-01-22
Deleted in disco-proposed on 2019-01-23 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.9) disco; urgency=medium

  * DistUpgrade/xorg_fix_proprietary.py: shebang needs to use python3 not
    python.

 -- Brian Murray <email address hidden>  Fri, 21 Dec 2018 10:14:53 -0800

Available diffs

Superseded in disco-release on 2018-12-22
Deleted in disco-proposed on 2018-12-23 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.8) disco; urgency=medium

  * debian/source_ubuntu-release-upgrader.py: Include xorg_fixup.log if it
    exists.
  * DistUpgrade/xorg_fix_proprietary.py: modify how the system is checked to
    see if nvidia is being used, drop fglrx check since it has been
    deprecated. (LP: #1773637)

 -- Brian Murray <email address hidden>  Mon, 17 Dec 2018 14:04:03 -0800

Available diffs

Superseded in disco-release on 2018-12-18
Deleted in disco-proposed on 2018-12-19 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.7) disco; urgency=medium

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeCache.py: When calculating free space needed for
    mount points don't use a negative number as the buffer. (LP: #1786484)
  * fix more typos re RELEASE_UPRADER_ALLOW_THIRD_PARTY
  * DistUpgrade/DistUpgradeCache.py: When calculating free space needed for
    mount points don't use a negative number as the buffer. (LP: #1786484)
  * fix more typos re RELEASE_UPRADER_ALLOW_THIRD_PARTY
  * DistUpgrade/DistUpgradeController.py: When rewriting sources.list entries
    check to see if the source provides packages for the release to which the
    upgrade is occurring. If it doesn't the entry is disabled thereby
    improving upgrades with PPAs. (LP: #1807043)
  * do-release-upgrade: add a parameter to allow third party mirrors and
    repositories, additionally pass along the environmental variable
    RELEASE_UPGRADER_ALLOW_THIRD_PARTY via pkexec and sudo. (LP: #1807032)
  * DistUpgrade/DistUpgradeCache.py: improve messaging regarding failures to
    calculate the upgrade and suggest using ppa-purge if PPAs are an issue.
  * DistUpgrade/DistUpgradeCache.py: in the event there is a failure to
    calculate the upgrade provide information about the log files in
    /var/log/dist-upgrade. (LP: #1771387)

  [ Jeremy Bicha ]
  * autopkgtest: Update dependency from gir1.2-webkit-3.0 to gir1.2-webkit2-4.0

 -- Brian Murray <email address hidden>  Tue, 11 Dec 2018 15:35:34 -0800

Available diffs

Superseded in disco-release on 2018-12-13
Deleted in disco-proposed on 2018-12-14 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.5) disco; urgency=medium

  * Remove the unused computer janitor code thereby resolving a Traceback that
    occurs when importing it. (LP: #1805475)

 -- Brian Murray <email address hidden>  Tue, 27 Nov 2018 09:17:35 -0800

Available diffs

Superseded in bionic-updates on 2019-01-31
Deleted in bionic-proposed on 2019-02-01 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.29) bionic; urgency=medium

  * Set icon_name in the dialogs so that there will be an icon in gnome-shell.
    (LP: #1797384)

 -- Brian Murray <email address hidden>  Mon, 12 Nov 2018 13:09:05 -0800

Available diffs

Superseded in cosmic-updates on 2019-01-15
Deleted in cosmic-proposed on 2019-01-17 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.2) cosmic; urgency=medium

  * Set icon_name in the dialogs so that there will be an icon in gnome-shell.
    (LP: #1797384)

 -- Brian Murray <email address hidden>  Mon, 12 Nov 2018 13:04:53 -0800

Available diffs

Superseded in disco-release on 2018-11-27
Deleted in disco-proposed on 2018-11-29 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.4) disco; urgency=medium

  * Set icon_name in the dialogs so that there will be an icon in gnome-shell.
    (LP: #1797384)

 -- Brian Murray <email address hidden>  Wed, 07 Nov 2018 15:55:25 -0800

Available diffs

Superseded in xenial-updates on 2019-10-10
Deleted in xenial-proposed on 2019-10-12 (Reason: moved to -updates)
ubuntu-release-upgrader (1:16.04.26) xenial; urgency=medium

  * do-release-upgrade: do not run the release upgrade if either not all
    fully phased updates are installed or a reboot is required due to a libc6
    upgrade.  (LP: #1797209)

 -- Brian Murray <email address hidden>  Tue, 06 Nov 2018 15:55:10 -0800
Superseded in disco-release on 2018-11-09
Deleted in disco-proposed on 2018-11-10 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.3) disco; urgency=medium

  * Remove lubuntu-core as a supported metapackage and a dependency of
    lubuntu-desktop.

 -- Simon Quigley <email address hidden>  Fri, 02 Nov 2018 17:39:26 -0500

Available diffs

Superseded in disco-release on 2018-11-07
Deleted in disco-proposed on 2018-11-08 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.2) disco; urgency=medium

  * Dual-sign release-upgrader tarballs with both 2012 & 2018 archive
    keys.
  * Update mirrors.

 -- Dimitri John Ledkov <email address hidden>  Fri, 02 Nov 2018 14:09:11 +0000

Available diffs

Superseded in bionic-updates on 2018-11-26
Deleted in bionic-proposed on 2018-11-27 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.28) bionic; urgency=medium

  * DistUpgrade/DistUpgradeController.py: check all the python symlinks and
    versions instead of the python one. Thanks to juliank for the assistance.
    (LP: #1799839)
  * do-release-upgrade: Do not block release upgrades if the installable
    updates are ones which are not fully phased. (LP: #1799710)

 -- Brian Murray <email address hidden>  Thu, 01 Nov 2018 10:17:43 -0700

Available diffs

Superseded in cosmic-updates on 2018-11-26
Deleted in cosmic-proposed on 2018-11-27 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.10.11.1) cosmic; urgency=medium

  * DistUpgrade/DistUpgradeController.py: check all the python symlinks and
    versions instead of the python one. Thanks to juliank for the assistance.
    (LP: #1799839)
  * do-release-upgrade: Do not block release upgrades if the installable
    updates are ones which are not fully phased. (LP: #1799710)

 -- Brian Murray <email address hidden>  Wed, 31 Oct 2018 16:15:17 -0700

Available diffs

Superseded in disco-release on 2018-11-06
Deleted in disco-proposed on 2018-11-07 (Reason: moved to release)
ubuntu-release-upgrader (1:19.04.1) disco; urgency=medium

  * DistUpgrade/{EOL,Devel}ReleaseAnnouncement,
    DistUpgrade/window_main.ui,
    data/gtkbuilder/DistUpgrade.ui,
    data/DistUpgrade.cfg,
    pre-build.sh:
    - updated for 18.10 -> 19.04
  * DistUpgrade/DistUpgradeController.py: check all the python symlinks and
    versions instead of the python one. Thanks to juliank for the assistance.
    (LP: #1799839)
  * do-release-upgrade: Do not block release upgrades if the installable
    updates are ones which are not fully phased. (LP: #1799710)

 -- Brian Murray <email address hidden>  Wed, 31 Oct 2018 15:14:25 -0700

Available diffs

Superseded in bionic-updates on 2018-11-05
Deleted in bionic-proposed on 2018-11-07 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.27) bionic; urgency=medium

  * do-release-upgrade: do not run the release upgrade if either not all
    updates are installed or a reboot is required due to a libc6 upgrade.
    (LP: #1797209)
  * debian/control: change ubuntu-release-upgrader-core to depend on
    ca-certificates (LP: #1796940)
  * Update mirrors data.

 -- Brian Murray <email address hidden>  Fri, 12 Oct 2018 11:27:19 -0700

Available diffs

Superseded in disco-release on 2018-11-01
Published in cosmic-release on 2018-10-12
Deleted in cosmic-proposed (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.11) cosmic; urgency=medium

  * do-release-upgrade: do not run the release upgrade if either not all
    updates are installed or a reboot is required due to a libc6 upgrade.
    (LP: #1797209)
  * debian/control: change ubuntu-release-upgrader-core to depend on
    ca-certificates (LP: #1796940)
  * Update of demotions and mirrors data.

 -- Brian Murray <email address hidden>  Wed, 10 Oct 2018 14:10:29 -0700

Available diffs

Superseded in bionic-updates on 2018-10-17
Deleted in bionic-proposed on 2018-10-18 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.26) bionic; urgency=medium

  * DistUpgradeController.py: If the attempt to only upgrade libc6 ends up
    creating an issue with apt's problem resolver try the full upgrade. This
    is what would have happened before the fix for bug 1766890. (LP: #1787649)

 -- Brian Murray <email address hidden>  Wed, 05 Sep 2018 08:37:51 -0700

Available diffs

Superseded in cosmic-release on 2018-10-12
Deleted in cosmic-proposed on 2018-10-13 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.10) cosmic; urgency=medium

  [ Harald Sitter ]
  * DistUpgradeViewKDE.py:
    - exitMainLoop is now exitMainLoopMidFlight to make it clearer that
      it is run while the app is still running. it's a hack and not
      the actual exit point
    - inhibit kscreenlocker while the UI is up to prevent the lock screen
      from breaking during upgrades and then complain to the user

  [ Brian Murray ]
  * DistUpgradeQuirks.py: add a quirk which checks for an apt architecture
    of i386 and prevents the upgrade as the architecture may be dropped.
  * DistUpgradeController.py: If the attempt to only upgrade libc6 ends up
    creating an issue with apt's problem resolver try the full upgrade. This
    is what would have happened before the fix for bug 1766890. (LP: #1787649)

 -- Brian Murray <email address hidden>  Fri, 31 Aug 2018 15:36:32 -0700

Available diffs

Superseded in bionic-updates on 2018-09-27
Deleted in bionic-proposed on 2018-09-29 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.25) bionic; urgency=medium

  * DistUpgradeQuirks.py: if ubuntu-desktop or snapd isn't in the package
    cache don't try and run the quirk for installing or upgrading snaps.
    (LP: #1787668)

 -- Brian Murray <email address hidden>  Tue, 28 Aug 2018 15:46:57 -0700

Available diffs

Superseded in cosmic-release on 2018-08-31
Deleted in cosmic-proposed on 2018-09-02 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.9) cosmic; urgency=medium

  * data/release-upgrades: set Prompt to normal not lts
  * DistUpgradeQuirks.py: if ubuntu-desktop or snapd isn't in the package
    cache don't try and run the quirk for installing or upgrading snaps.
    (LP: #1787668)
  * DistUpgradeQuirks.py: Only refresh installed snaps to the ubuntu-18.10
    channel if they are tracking the ubuntu-18.04 channel. (LP: #1748581)

 -- Brian Murray <email address hidden>  Tue, 28 Aug 2018 13:09:55 -0700

Available diffs

Superseded in cosmic-release on 2018-08-28
Deleted in cosmic-proposed on 2018-08-30 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.8) cosmic; urgency=medium

  * DistUpgradeController.py: Remove an unnecessary debugging entry when
    calculating the debs to remove.
  * DistUpgradeQuirks.py: Either refresh installed snaps so they use the
    ubuntu-18.10 channel or install snaps that weren'd installed when
    upgrading to Ubuntu 18.04. (LP: #1748581)

 -- Brian Murray <email address hidden>  Tue, 14 Aug 2018 16:00:44 -0700

Available diffs

Superseded in bionic-updates on 2018-08-29
Deleted in bionic-proposed on 2018-08-31 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.24) bionic; urgency=medium

  * DistUpgradeController.py: Remove an unnecessary debugging entry when
    calculating the debs to remove.

Superseded in bionic-proposed on 2018-08-09
ubuntu-release-upgrader (1:18.04.23) bionic; urgency=medium

  * Upgrade libc6 before other packages to work around trigger issues
    (LP: #1766890)

 -- Julian Andres Klode <email address hidden>  Thu, 09 Aug 2018 13:53:28 +0200

Available diffs

Superseded in cosmic-release on 2018-08-15
Deleted in cosmic-proposed on 2018-08-16 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.7) cosmic; urgency=medium

  * Upgrade libc6 before other packages to work around trigger issues
    (LP: #1766890)

 -- Julian Andres Klode <email address hidden>  Tue, 07 Aug 2018 23:01:50 +0200

Available diffs

Superseded in bionic-updates on 2018-08-13
Superseded in bionic-proposed on 2018-08-09
ubuntu-release-upgrader (1:18.04.22) bionic; urgency=medium

  * DistUpgradeQuirks.py:
    - make sure that snapd is installed before trying to use it.
      (LP: #1783589)
    - update the view with information regarding the progress of snaps being
      installed. (LP: #1783593)
    - when checking for connectivity to the snap store use C.UTF-8 for the
      language so error message matching works. (LP: #1783738)
  * DistUpgradeController.py:
    - Remove debs from apt's "Dir::Cache::archives" folder after the upgrade
      has completed successfully. (LP: #1785096)
    - Add a telemetry marker to report the time to process the migration from
      deb to snaps.

 -- Brian Murray <email address hidden>  Thu, 02 Aug 2018 11:20:06 -0700

Available diffs

Superseded in cosmic-release on 2018-08-07
Deleted in cosmic-proposed on 2018-08-09 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.6) cosmic; urgency=medium

  * DistUpgradeQuirks.py:
    - make sure that snapd is installed before trying to use it.
      (LP: #1783589)
    - update the view with information regarding the progress of snaps being
      installed. (LP: #1783593)
    - when checking for connectivity to the snap store use C.UTF-8 for the
      language so error message matching works. (LP: #1783738)
  * DistUpgradeController.py:
    - Remove debs from apt's "Dir::Cache::archives" folder after the upgrade
      has completed successfully.
    - Add a telemetry marker to report the time to process migration from deb
      to snaps.
  * DistUpgrade/DistUpgradeViewGtk3.py: call vte's terminal.feed_child() with
    the correct parameters thereby fixing a crash. (LP: #1780501)

 -- Brian Murray <email address hidden>  Wed, 01 Aug 2018 15:06:53 -0700

Available diffs

Superseded in bionic-updates on 2018-08-09
Deleted in bionic-proposed on 2018-08-10 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.21) bionic; urgency=medium

  * DistUpgradeQuirks.py: when a snap fails to install try the next one
    instead of trying to check the return code of the called process which
    causes a Traceback. (LP: #1781412)
  * data/mirrors.cfg: Update the list of official mirrors.

Superseded in cosmic-release on 2018-08-01
Deleted in cosmic-proposed on 2018-08-03 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.5) cosmic; urgency=medium

  * DistUpgradeQuirks.py: when a snap fails to install try the next one
    instead of trying to check the return code of the called process which
    causes a Traceback. (LP: #1781412)

 -- Brian Murray <email address hidden>  Thu, 12 Jul 2018 13:07:14 -0700

Available diffs

Superseded in bionic-proposed on 2018-07-16
ubuntu-release-upgrader (1:18.04.20) bionic; urgency=medium

  * Purge obsolete packages, if user agrees to remove obsolete
    packages. LP: #1775660
  * DistUpgradeQuirks.py, DistUpgradeController.py: move inhibiting of
    gnome-session idle so that it is called immediately after the upgrade
    starts (LP: #1778817), present a dialog notifying that the lock screen has
    been disabled (LP: #1174093), and do not reenable the lock screen as it
    may fail to work after a release upgrade. (LP: #1780342)
  * DistUpgradeQuirks.py: Add in a quirk for upgrading to Bionic that will
    check if the system has connectivity to the snap store and replace some
    desktop packages with snaps to ensure the system is similar to a fresh
    install. (LP: #1780841)
  * data/mirrors.cfg: Update the list of official mirrors.

 -- Brian Murray <email address hidden>  Mon, 09 Jul 2018 13:59:08 -0700

Available diffs

Superseded in cosmic-release on 2018-07-12
Deleted in cosmic-proposed on 2018-07-14 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.4) cosmic; urgency=medium

  * DistUpgradeQuirks.py, DistUpgradeController.py: move inhibiting of
    gnome-session idle so that it is called immediately after the upgrade
    starts (LP: #1778817), present a dialog notifying that the lock screen has
    been disabled (LP: #1174093), and do not reenable the lock screen as it
    may fail to work after a release upgrade. (LP: #1780342)
  * DistUpgradeQuirks.py: Add in a quirk for upgrading to Cosmic that will
    check if the system has connectivity to the snap store and replace some
    desktop packages with snaps to ensure the system is similar to a fresh
    install.

 -- Brian Murray <email address hidden>  Fri, 06 Jul 2018 11:21:11 -0700

Available diffs

Superseded in cosmic-release on 2018-07-06
Deleted in cosmic-proposed on 2018-07-08 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.3) cosmic; urgency=medium

  [ Dimitri John Ledkov ]
  * Purge obsolete packages, if user agrees to remove obsolete
    packages. LP: #1749199
  * Make dist-upgrade.py work when PWD != datadir, by fixing the logic for
    finding and loading .release config files with datadir prepended
    first.

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeCache.py: clarify why a package is not removed.

 -- Brian Murray <email address hidden>  Wed, 27 Jun 2018 16:34:25 -0700

Available diffs

Superseded in cosmic-release on 2018-06-28
Deleted in cosmic-proposed on 2018-06-29 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.2) cosmic; urgency=medium

  * Add upgrade telemetry information (LP: #1755456)
  * Updated translations

 -- Didier Roche <email address hidden>  Tue, 29 May 2018 15:15:45 +0200

Available diffs

Superseded in bionic-updates on 2018-07-19
Deleted in bionic-proposed on 2018-07-20 (Reason: moved to -updates)
ubuntu-release-upgrader (1:18.04.19) bionic; urgency=medium

  * Add upgrade telemetry information (LP: #1755456)
  * Updated translations

 -- Didier Roche <email address hidden>  Thu, 03 May 2018 15:55:34 +0200

Available diffs

Superseded in cosmic-release on 2018-05-29
Deleted in cosmic-proposed on 2018-05-30 (Reason: moved to release)
ubuntu-release-upgrader (1:18.10.1) cosmic; urgency=medium

  * DistUpgrade/{EOL,Devel}ReleaseAnnouncement,
    DistUpgrade/window_main.ui,
    data/gtkbuilder/DistUpgrade.ui,
    data/DistUpgrade.cfg,
    pre-build.sh:
    - updated for 18.04 -> 18.10

 -- Brian Murray <email address hidden>  Tue, 08 May 2018 11:13:45 -0700

Available diffs

175 of 299 results