Progress bar is invisible

Bug #67443 reported by Mitch Golden on 2006-10-21
58
Affects Status Importance Assigned to Milestone
ubuntulooks (Ubuntu)
Medium
Unassigned

Bug Description

In the default Gnome theme that I get during an Ubuntu install, the progress bar is not visible. It appears to be white on white.
You can see the number of percent and it is changing, but once you get above 50% it becomes very hard to read.

The progress bar has the same appearance after the install, and the attached screenshot shows synaptic upgrading my system.

I have a Sony Vaoi PCG-XG19 laptop with a NeoMagic chipset.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Are you sure you are using the Human theme? What does "gconftool-2 -g /desktop/gnome/interface/gtk_theme" prints? Do you having any message to ~/.xsession-errors about that?

Changed in gnome-desktop:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Mitch Golden (mgolden) wrote :

I should point out that this is the setup I have when I boot directly from the Edgy RC CD, so it isn't possible that I changed anything.

When I run that command it replies with "Human".

Should I see something in the .xsession-errors before I run an install? The only suspicious thing I see before an install is

(gnome-panel: 6049) Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -3 and height 24.

Sebastien Bacher (seb128) wrote :

you have the issue with a desktop CD? could you attach your /etc/X11/xorg.conf to the bug?

Mitch Golden (mgolden) wrote :

Here is the xorg.conf

Mitch Golden (mgolden) wrote :

Sorry, forgot to answer. Yes, this is the Desktop Edgy RC CD.

Mitch Golden (mgolden) wrote :

One further thought: I wonder if this has anything to do with this problem I am seeing here:

https://launchpad.net/distros/ubuntu/+source/usplash/+bug/67438

Mitch Golden (mgolden) wrote :

This problem persists in the Edgy release

Michael Henry (michael-k-henry) wrote :

I've just installed Ubuntu Edgy on a Dell Dimension L667 and have the same issue with the progress bar not appearing. All patches and updates have been applied with no change.

I have previously installed Edgy from this same CD and that installation has no problems. It is completely different hardware, though...

Dylan McCall (dylanmccall) wrote :

Mitch:
I do not have that problem with the USplash (although it does some ugly stuff when hibernating!).

However, I am experiencing another really weird graphics glitch in Edgy, and I have subscribed to its bug report: I can sort of describe it as a really strange vertical / horizontal artifact-filled scrolling mess which occurs when logging out, restarting X... maybe something to do with changing graphics modes. I've noticed that it flashes assets used in the Human theme, so probably stuff left in VRAM...

My specs:
Ubuntu is running on a very old Compaq Presario with a 500 mHz Celeron processor and an Intel Integrated Graphics card. (i810).
Both bugs happen with both the "i810" driver and the alternative "intel" driver.

Installing from the same disk (and with the same procedure) on a different computer does not result in any of these glitches.

Wireblue (ksflyinghigh) wrote :

In reply to Dylan McCall's comment:

If it's any consolation I experience the same artifacts on my computer during boot, and power down. It may be related somehow.

My system specs are as follows:
- 600Mhz Pentium 3
- Intel 810 Graphics
- 384Mb RAM (256 + 128)

I'd really like to find out what is causing this. It's very frustrating.

Dylan McCall (dylanmccall) wrote :

Hrm, we have pretty similar hardware!

Okay, that bug there which I think may be related (or may just happen to not like the same hardware as this one doesn't like) is bug #66652

I have also theses artefacts.
But I consider more important the initial problem, which is "progress bar invisible": I have this problem and this is a basic facility which is really needed.
I have Edgy.
uname -a = Linux ubuntu 2.6.17-10-386 #2 Tue Dec 5 22:26:18 UTC 2006 i686 GNU/Linux
my graphics (from xorg.conf):
Identifier "Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller]"
Driver "i810"
my computer is an IBM Netvista A20 type is 8269-A3G.

Dylan McCall (dylanmccall) wrote :

I've been playing with XFCE lately, and it seems that if I use the Human theme in XFCE the progress bar is still invisible.
(So this invisible progress bar happens in both Gnome and XFCE).

everlong (everlong) wrote :

I have this same bug with the invisible progress bars. I'm running Edgy on a Dell Optiplex GX110 (xorg.conf attached). Using Human theme, though switching themes does not fix it.

The progress bars were colored in when I first installed, but got messed up in the next few days as I installed new apps and performed tweaks (sorry, not sure what I did immediately before). Nothing in ~/.xsession-errors looks like it would be related to this.

Thom Pischke (thom-pischke) wrote :

Same problem on a fresh edgy install on an older Dell Optiplex G1. All updates applied, otherwise no changes made thus far.

Thom Pischke (thom-pischke) wrote :

This appears to have been related to a bad X Server / Graphics Card setup.

The problem appeared after running dpkg-reconfigure to try to correct resolution for an ATI 3D Rage IIC Video Card. Ubuntu by default was refusing to run at 1024x768, allowing only 800x600. When trying to correct this, at some point the progress bar stopped displaying correctly.

When I switched from the 'vesa' driver to the 'ati' driver, set resolution to 1024x768, and Color Depth to 16 bit, I finally got X at 1024x768 with normal progress bars. So problem solved for me.

Daniel Holbach (dholbach) wrote :

Does everybody have similar symptoms as Thom Pischke has?

Thank you Thom Pischke!

1 - I edited /etc/X11/xorg.conf, changed DefaultDepth from 24 to 16.
2 - Logged out.
3 - ctrl-alt-backspace to restart X.

Now the progress bar is visible!

(My graphics is i810)

I don't know in which circumstances I would need a 24 depth color ...

So I consider solved for me as well.

Dylan McCall (dylanmccall) wrote :

Thanks, Pischke!
Changing the depth has (for me) fixed this bug and the other one I was talking about, bug #66652

It's still a bit weird that the screen depth would have anything to do with the progress bars, but I guess it's a driver issue. I'm also not sure how it ended up at 24-bit, but I think it's always been like that. Perhaps an installer issue, then?
(Not really the hardware's fault; as long as the correct initial settings are chosen it's all good... although it would be cool if Ubuntu knew my hardware's limits and reported whenever I exceeded them).

Wireblue (ksflyinghigh) wrote :

Thanks Thom Pischke and Jean-Marie! My progress bars are now visible.

Daniel Holbach (dholbach) wrote :

Is the issue resolved for everybody now?

For me I consider it resolved.
However I would be happy that the correction of this glitch will be
included in the next Ubuntu release.
Thank you.

Le mardi 06 février 2007 à 12:38 +0000, Daniel Holbach a écrit :
> Is the issue resolved for everybody now?
>

Unfortunately I no-longer have access to the PC I used to report the
original problem. However, judging from the posts regarding this bug I'd
say what we have is a workaround, not a resolution. When a fresh install
works without having to manually edit the xorg.conf _then_ I'll agree
that the issue is resolved.

Regards,

    Michael

Daniel Holbach wrote:
> Is the issue resolved for everybody now?
>
>

Daniel Holbach (dholbach) wrote :

Reassigning to xorg.

Changed in ubuntulooks:
assignee: desktop-bugs → ubuntu-x-swat
importance: Undecided → Medium
Arun Bhalla (arun-shme) wrote :

Lowering the color depth for the X server is not a great workaround.

It seems that the ubuntulooks engine is buggy, so I modified the Human theme gtkrc (/usr/share/themes/Human/gtk-2.0/gtkrc) to use the clearlooks engine instead of the ubuntulooks engine, and all is well -- I have a visible progress bar now.

This workaround could be applied to any other theme that uses the ubuntulooks engine, including Outdoors and Silicon.

Jonathan Rudenberg (jon335) wrote :

I am having this problem on feisty as well.

I changed my colour depth to 16 as recommended, and that fixed it.

Arun Bhalla:
Can you please post your Human gtkrc?

Cd-MaN (x-at-y-or-z) wrote :

I have a ATi Radeon 9200 video card and I too had this problem with the 7.04 beta (not with edgy). The problem appeared both when booting from the live cd and when running it for the HDD. The 16 bit color depth hack worked for me too.

Arun Bhalla (arun-shme) wrote :

Here is my modified /usr/share/themes/Human/gtk-2.0/gtkrc file.

All I did was comment out "engine ubuntulooks" and add an "engine clearlooks" directive.

Cd-MaN (x-at-y-or-z) wrote :

Modifying the engine also worked for me. I also tried to play with the setting "progressbarstyle" when the engine was ubuntulooks, but it had no effect. Two more things: the engine switching is a much better solution for me than reducing color depth because rdesktop kept crashing at 16 bit color depth and it is engine "ubuntulooks", not engine ubuntulooks (this might be useful for the people searching through the file).

Cd-MaN (x-at-y-or-z) wrote :

I just observed that while switching to clearlooks solved my horizontal progress bars, it broke my vertical ones (like the one used in the volume control) which worked fine before now (meaning that the portion under the slider was colored), however they don't any more. This is not such a big problem since the slider button itself can give visual feedback on the position, but I thought that I should mention it.

Timo Aaltonen (tjaalton) on 2007-04-19
Changed in xorg:
assignee: ubuntu-x-swat → nobody
Jan Kaláb (pitel) on 2007-05-02
Changed in ubuntulooks:
status: Needs Info → In Progress
Bob (b-o-b-1962) wrote :

I recently installed Feisty and have this problem. I agree with Arun that lowering the color depth to 16 is an unacceptable solution. I have done the switch to clearlooks engine and it seems to work. However, now I get warnings every time I open new graphics windows (I'll add the warnings to this later, as I am not at that computer now). This makes me wonder what else this fix messed up.

Is anyone working on this bug. It would seem to me that a bug in the default theme engine for Ubuntu would be considered a major problem, but there seems to be no action on this.

Bob (b-o-b-1962) wrote :

Here are the warnings I get when I start just about any gnome/gtk program in a terminal:

/usr/share/themes/Human/gtk-2.0/gtkrc:68: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
/usr/share/themes/Human/gtk-2.0/gtkrc:69: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
/usr/share/themes/Human/gtk-2.0/gtkrc:70: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.

I'm not sure if it is a problem but it indicates to me that the clearlooks fix is not optimal.

Bob (b-o-b-1962) wrote :

I should have added that my computer has the i810 card as well. Here are the lines in xorg.conf.

        Driver "i810"
        Device "Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller]"

Kyle Brooks (kyle-brooks) wrote :

Confirmed for me. video card not revelant to here, as human theme did progress bar okay in earlier versions of Ubuntu.
when i switch to another theme, it fixes the bug.

eding1 (eding1) wrote :

I've just edited the "style "clearlooks-progressbar..." (/usr/share/themes/Human/gtkrc) with this (add only the lines between the commented ones) :
---------------------
#Find this line
style "clearlooks-progressbar" = "clearlooks-wide-orange"
{
 xthickness = 2
 ythickness = 2
 fg[PRELIGHT] = "#ffffff"
#Add this to show the orange bar:
#FIX START
 engine "clearlooks"
  {
    radius = 1.5
  }
#FIX END
}
----------------------
The progress bar is showing again!, and without error messages.
Hope this will help.

P.S. Sorry for my english...

Jerikojerk (jerikojerk) wrote :

i get similar bug with an install of ubuntu 7.04 from CD with safe graphic mode. ( it occurs when i was in this mode and after the installation. i reinstall it from zero in normal mode then my progress bars are back... )

Rob van der Linde (robvdl) wrote :

I experienced this bug the other day also on an SiS 6326 8Mb AGP graphics card, so it does not only affect intel 810 and 815 onboard cards now.

Once again, switching from 32 bit colour to 16 bit colour fixed the problem, but it's not something you really want to do.

Dylan McCall (dylanmccall) wrote :

This does not happen out of the box, on that machine, with Ubuntu Gutsy (
7.10). (Installed using Herd 2 desktop cd, upgraded to current version).
DefaultDepth in xorg.conf is 24.
Can anybody confirm?

Bye,
-Dylan McCall

On 7/22/07, Robvdl <email address hidden> wrote:
>
> I experienced this bug the other day also on an SiS 6326 8Mb AGP
> graphics card, so it does not only affect intel 810 and 815 onboard
> cards now.
>
> Once again, switching from 32 bit colour to 16 bit colour fixed the
> problem, but it's not something you really want to do.
>
> --
> Progress bar is invisible
> https://bugs.launchpad.net/bugs/67443
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Ramesh Thiruchelvam (ramesht) wrote :

This happens out of the box when you install Ubuntu 7.10 in low configuration PC's. Due to the default depth is set to 24; Changing the default depth to 16 in xorg.conf fixes the problem.

- 500Mhz Pentium 3 (Compaq DeskPro)
- Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller]
- 256Mb RAM

Kris Douglas (webbox-uk) wrote :

I have this same issue on Feisty. The Intel graphics processor is the cause of this issue, as i have an i810.

The specs of this machine are:

1.2Ghz Intel PIII
512Mb RAM
Intel i810 Chipset
Ubuntu 7.0.4 Feisty Fawn (Mythbuntu 7.0.4)

Kris Douglas (webbox-uk) wrote :

Additionally...the hardware for the chipset is:

        Driver "i810"
        Device "Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller]"

Which would make it appear to be a standing issue with the Intel 810

Jan Kaláb (pitel) wrote :

I guess it's foxed now... I installed gutsy on my girlfriends old machine, and progress bars looked OK (instead of feisty).

Kris Douglas (webbox-uk) wrote :

On 07/12/2007, Jan Kaláb <email address hidden> wrote:
>
> I guess it's foxed now... I installed gutsy on my girlfriends old
> machine, and progress bars looked OK (instead of feisty).
>
> --
> Progress bar is invisible
> https://bugs.launchpad.net/bugs/67443
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Realllly? Thats brilliant :D

--
Kris Douglas
      Softdel Limited Hosting Services

      Web: www.softdel.net
      Mail: <email address hidden>

Changed in ubuntulooks (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers