iftab breaks if interface already exists

Bug #46048 reported by Bernhard Schmidt on 2006-05-22
8
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Unassigned

Bug Description

Hi,

see http://madwifi.org/ticket/638, I just tried to compile/install the original madwifi-ng trunk code because the one in restricted-modules did not work for me. /sbin/udevplug hangs for about five minutes on boot if the atheros MAC is in /etc/iftab (as it seems to be after a default dapper installation).

The madwifi-ng code creates two devices since beginning of this year, one wifi* to control the hardware and one ath* to use with the wireless extensions (you can create several ath*/SSIDs per card in new code). Both share the same MAC address, which lets iftab try to rename wifi0 to ath0. This apparently breaks because ath0 exists already, effectively pausing udevplug for about five minutes after some timeout kicks in.

Add "arp 1" on the end of your /etc/iftab lines.

This is now done by default by the installer, which breaks them.

If you still get the hang, then it's a madwifi-ng bug that they're pretending that the wifi0 interface is capable of doing Ethernet

Changed in udev:
status: Unconfirmed → Rejected
bdr (andrewbadr) wrote :

iftab_helper[3094]: whats_my_name : /etc/iftab:3: no value after 1 selector for arp

bdr (andrewbadr) wrote :

Which is to say...append "arp 1" to the end of existing /etc/iftab lines. Don't add a new line reading "arp 1" to the end of your /etc/iftab :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.