Change log for uglify-js package in Ubuntu

15 of 5 results
Superseded in disco-release on 2019-02-27
Deleted in disco-proposed on 2019-02-28 (Reason: moved to release)
uglify-js (3.4.9-4build1) disco; urgency=medium

  * Rebuild against new acorn with unicode11.

 -- Gianfranco Costamagna <email address hidden>  Tue, 26 Feb 2019 10:36:39 +0100
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-02-27
Deleted in disco-proposed (Reason: moved to release)
uglify-js (3.4.9-5) unstable; urgency=medium

  [ Jonas Smedegaard ]
  * Fix have libjs-uglify-js recommend javascript-common.
  * Update watch file:
    + Simplify regular expressions.
    + Rewrite usage comment.
  * Update copyright info: Extend coverage of packaging.

 -- Jonas Smedegaard <email address hidden>  Sat, 23 Feb 2019 16:41:50 +0100
Superseded in disco-release on 2019-02-26
Deleted in disco-proposed on 2019-02-27 (Reason: moved to release)
uglify-js (3.4.9-4) unstable; urgency=medium

  * Fix include source-map only for minified web library,
    and pre-compress source-map.

 -- Jonas Smedegaard <email address hidden>  Sun, 13 Jan 2019 22:33:32 +0100

Available diffs

Superseded in disco-release on 2019-01-14
Deleted in disco-proposed on 2019-01-16 (Reason: moved to release)
uglify-js (3.4.9-2) unstable; urgency=medium

  * Fix have uglifyjs depend on node-uglify-js.
  * Add autopkgtest.

 -- Jonas Smedegaard <email address hidden>  Wed, 09 Jan 2019 17:12:59 +0100

Available diffs

Superseded in disco-proposed on 2019-01-09
uglify-js (3.4.9-1) unstable; urgency=medium

  * Update git-buildpackage config: Track debian branch debian/master.
  * Update watch file: Track any upstream version (not only 2.x).
  * Rename source package uglifyjs → uglify-js.
  * Update copyright info: Extend coverage for main upstream author.
  * Rewrite patch 1001, but disable temporaribly:
    Requires more work to not fail testsuite.
    Add TODO about reenabling it.
    Build-depend on node-source-map.
  * Drop patch 1002: Mocha no longer used for testing.
    Stop build-depend on mocha node-escodegen node-estraverse.
  * Drop patch 1003: node-yargs no longer used.
    (Build-)depend on node-commander (not node-yargs).
  * Drop patch 2002: Ok now to call node instead of nodejs.
    Update rules to call node.
  * Update watch file: Use substitution strings.
  * Rename binary package libjs-uglifyjs → libjs-uglify-js,
    installing below /usr/share/javascript/uglify-js.
  * Rename binary package node-uglify → node-uglify-js,
    conflicting with package node-uglify.
  * Fix stop suggest node-uglify-to-browserify.
  * Add new binary package uglifyjs.
  * Build-depend (when check is enabled) on node-semver.
  * Stop custom permissions fix during build:
    Involved executable no longer shipped upstream.
  * Update lintian overrides about source-is-missing false positives.

 -- Jonas Smedegaard <email address hidden>  Wed, 09 Jan 2019 10:23:12 +0100
15 of 5 results