edgy->feisty dist-upgrade only works if ~/.gnupg file is there

Bug #78673 reported by Michael Vogt on 2007-01-10
52
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
mishal

Bug Description

When upgrading from Ubuntu 6.10 to Ubuntu 7.04, Update Manager 0.45 may display the following errors and fail:

"Authentication failed

Authenticating the upgrade failed. There may be a problem with the network or with the server."

"exception from gpg: GnuPG exited non-zero, with code 131072"

The problem can be corrected by installing the latest version of Update Manager for Ubuntu 6.10 prior to upgrading.

Related branches

Michael Vogt (mvo) on 2007-01-10
Changed in update-manager:
importance: Undecided → High
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :
Colin Watson (cjwatson) wrote :
Changed in update-manager:
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

Thanks Colin!

Uploaded to edgy-proposed and subscribed the ubuntu-archive team.

Tollef Fog Heen (tfheen) wrote :

Accepted into edgy-proposed.

Changed in update-manager:
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

I tested the original problem using Edgy and update-manager 0.45 and had the same issue with it failing because of gnupg. I then installed the proposed package, version 0.45.1, and it did not fail because of gnupg.

Martin Pitt (pitti) wrote :

Confirmed with today's edgy->feisty upgrades, -proposed packages work.

Martin Pitt (pitti) wrote :

Accepted into edgy-updates.

Changed in update-manager:
status: Fix Committed → Fix Released
Matt Zimmerman (mdz) on 2007-04-17
description: updated

since yesterday I have this message in feisty appearing.

My system is not a update from edgy.

Michael Vogt (mvo) wrote :

@greenhunter: could you please file a seperate bugreport if it happens for you on a feisty system? Please include a screenshot of the application (including the error dialog).

Peter Cordes (peter-cordes) wrote :

BTW, I found that existance of ~/.gnupg isn't enough. I uncommented
keyserver-options auto-key-retrieve
and then ran gpg --verify /tmp/blah/blah.gpg
so by the time I tried update-manager again, my keyring already included the key.

 This was on an edgy laptop that hadn't been updated for a few weeks. Presumably the latest update-manager would have worked.

ferono (jadkison) wrote :

I had the same authentication error. My fix was doing a 'apt-get install update-manager-core' after that it upgraded fine, give it a try if all else fails.

BackSeat (kae-midnighthax) wrote :

Same problem, different reason. I had apt.conf set to use a local apt-cacher proxy, which I had to disable to get rid of this message.

Johnathon (kirrus) wrote :

Had this problem. Wasn't fixed by upgrading/installing update manager. Just ran "gpg" on CLI, fixed it for me...

mishal (aim-9) on 2008-05-09
Changed in update-manager:
assignee: nobody → aim-9
Nicolas_Raoul (nicolas-raoul) wrote :

I just had this bug when trying to upgrade from 2010.04 to 2010.10
I fixed it using the "gpg" trick.
So the bug is still here.

Abdul (kh66) wrote :

Recently I upgraded my ubuntu 10.10 (wubi) to 11.04.I upgraded it directly from ubuntu ugrade. NowI have issues.One of them is that I am not able to update.When I do it I get this message:

Could not initialize the package information

An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages, E:The package lists or status file could not be parsed or opened.'

I can operate the system and I dont know whether version I have is 11.04 or 10.10.But the features specific to UNITY have not been found .How would I replace the new version if I intend to?There is a red error symbol at the pane with an error message. Abdul

Reproduced with new Dell notebook with pre-installed Ubuntu when upgrading from 10.10 to 11.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers