Latest usplash leaves my consoles corrupted

Bug #63558 reported by John Dong on 2006-10-02
110
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Low
Unassigned
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

The -31 upload has introduced a regression on my ATI laptop. The usplash still displays correctly, but after switching into X, the virtual terminals are all corrupted. They remain corrupted until the shutdown usplash initializes.

This did not happen before, up to bzr revno 90 (the last bzr revision I've tried)

mvandeg (mvandegiessen) wrote :

I can confirm this. On my ATI laptop the colors of the usplash splash screen also change during bootup in a way that doesn't seem intended.

John Dong (jdong) wrote :

Nope

Richard Johnson (nixternal) wrote :

What is the corruption you are seeing? Have you taken a look at any of the logs?

I know in a past update, I did have some terminal regression, which caused my terminal fonts to display very large, making the terminal pretty much unusable.

Changed in usplash:
importance: Undecided → Low
status: Unconfirmed → Needs Info
John Dong (jdong) wrote :

I see a solid mesh of bright orange-yellow colors, no text at all. In fact, a screenshot of the corruption would do wonderfully for a usplash-artwork-acidtrip universe package :). The garbage does not change or respond at all with keypresses or vt switches. Logs show no interesting output of any type.

Changed in usplash:
status: Needs Info → Confirmed
John Dong (jdong) wrote :

Actually, I don't think this bug is valid. I think it's being caused by bug 57716. The lack of fglrx.ko invokes fglrx's fallback mode, which I know corrupts the VT's at the cost of 2D working X.

As soon as that bug is fixed, I can say for sure whether or not my consoles are back. Keeping this NEEDSINFO for now.

Changed in usplash:
status: Confirmed → Needs Info
John Dong (jdong) wrote :

Never mind, even with fglrx loading properly, my vt's are still all corrupted.

Changed in usplash:
status: Needs Info → Confirmed
mvandeg (mvandegiessen) wrote :

This is not only a problem with the fglrx drivers, also with the radeon driver.

And which what value should put on the x's in vga=xxx?

John Dong (jdong) wrote :

It does not have anything to do with what drivers X11 is using; it seems more related to having an ATI video card.

You should not have vga=anything in your kernel arguments.

DanH (holmsand-gmail) wrote :

I'm having the same problem with an Intel 855GM laptop.

John Vivirito (gnomefreak) wrote :

Is this still a problem for anyone?

Yes, nothing's changed.

On 10/13/06, John Vivirito <email address hidden> wrote:
>
> Is this still a problem for anyone?
>
> --
> Latest usplash leaves my consoles corrupted
> https://launchpad.net/bugs/63558
>

AJ Slater (aj-slater) wrote :

Bug 42974 lists the problem for multiple video cards.

Bug 66652 describes a screen corruption near the end of the usplash progress
   (no idea if its related, but some console reset script might bork everything near the end of boot)

kko (kko) wrote :

I don't know the technicalities of how usplash works. I just want to point out that the bugs referenced by AJ Slater (as listed in bug 42974) have to do with framebuffer VT's and using a 'vga=xxx' parameter, whereas in this case no 'vga=xxx' parameters seem to be used.

Tormod Volden (tormodvolden) wrote :

I can confirm this using edgy daily-live from yesterday, on both a X700 card (ati driver) and a X1300 card (fglrx driver). Why is the importance "low" ? It should be "high" IMHO.

AJ Slater (aj-slater) wrote :

This VT corruption can be eliminated on my MacBook Pro 15" if 'splash' is removed from the kernel options.

No usplash, no corruption. VT's all work fine.

As kko points out, this is likely unrelated to the FB bugs in 42974.

+1 on raising the priority of this one. No VTs make it pretty hard to fix a borked box.

anonym (launch-mailinator) wrote :

I can confirm this on:
HW:
Dell Optiplex GX110
666Mhz P3
lspci: http://paste.ubuntu-nl.org/27563/plain/

I'm runnig edgy, updated from dapper with 'update-manager -c -d'
kernel version: 2.6.17-10-386

removing splash from the boot options makes the VTs behave normaly.

I have the exact same behaviour with a Mobility Radeon X1400. Booting without splash makes for normal VTs.

Also, I really think this ought to be at least of Medium importance, as it fits "Has moderate impact on a core application" (https://wiki.ubuntu.com/Bugs/Importance).

daddyhosen (daddyhosen) wrote :

I was able to work around the problem by adding vga=791 to /boot/grub/menu.lst:

# defoptions=vga=791 quiet splash

"vga=791" also fixes things for me.

Same problem here, all VTs are corrupted when using 'splash', works fine when 'splash' is removed.
I also get that same distorted image for half a second when logging out of gnome, right before gdm shows up.
The VTs do work, however. Logging in and typing 'reboot' restarted the machine.
vga=791 didn't change anything.

edgy, 2.6.17.10-generic, ATI X1400, fglrx

Rohan Dhruva (rohandhruva) wrote :

I have filed Bug #68807 .. it is similar to this - the symptoms are same, but the card is i810. I am sorry for filing a duplicate :)

However, problem is, intel i810 can't use vga=791 - it will just bail out and not use a framebuffer. Any solutions, then, to this problem ? (except disabling usplash ;) )

Thanks !

Rohan Dhruva (rohandhruva) wrote :

Ok, I did my best to collect all duplicates for this bug. Can someone please modify this bug - it is not limited to fglrx only. Also occurs on i810.

And vga=791 does not solve the problem for i810. Only disabling usplash does.

S.Rey (s.rey) wrote :

I can confirm this bug too.

My card is an ATI x1400, native resolution 1280x800, no vga parameter at boot.
edgy, latest generic kernel, fglrx

The /etc/usplash.conf was set by default to 1280x800.

When I add vga=791, (or other valid values), I can access to the consoles, but then the splash screen has incorrect aspect ratio and it's not centered or it's not shown at all.

S.Rey (s.rey) wrote :

For the people who have added the vga=791 and found that text consoles work.

I have solved the usplash aspect ratio and centering problems by doing the following. https://launchpad.net/distros/ubuntu/+ticket/2299

1) Change the resolution in /etc/usplash.conf to 1024x768
2) Add vga=791 to the kernel line in /etc/boot/menu.lst
3) sudo update-initramfs -u -k `uname -r`

Rohan Dhruva (rohandhruva) wrote :

Any leads on this one ? Any package updates which resolve the issue ? Any workabouts for non ati users ?

Thanks !

S.Rey (s.rey) wrote :

If vga=791 doesn't work for you, have you tried other values?

You can try one of the following, and see what happens:

vga=758 (640x480 16bpp)
vga=788 (800x600 16bpp)

See more vga modes here: http://www.ubuntuforums.org/showthread.php?p=1541970

You should edit /etc/usplash.conf to change it to the same resolution as the vga mode passed to the kernel, and then:

sudo update-initramfs -u -k `uname -r`

John Dong (jdong) wrote :

I don't think non-ATI users are experiencing this particular bug. Even though the symptoms are the same, I think it's a different bug. ATI users can use the vga=791 workaround ,but I doubt it'll work for other cards.

Rohan Dhruva (rohandhruva) wrote :

I don't think so - I mean, both the cards experience problems due to framebuffer interface, the symptoms are exactly same, and both are solved by turning off usplash. vga=791 doesn't work for i810 since that card doesn't support banked vga modes or something like that.

Rejecting this bug for xorg package, since it seems to be entirely a usplash issue.

Changed in xorg:
status: Unconfirmed → Rejected
ThomasDahlmann (tdd-lnxgeek) wrote :

Doing the 1-2-3 as S. Rey says makes it work on my T60 (x1400 ATI) and also make the console more usefull (smaller fonts).

Konstantinos Togias (ktogias) wrote :

I can confirm this bug too. My h/w is an
Acer Aspire 1692WLMi Laptop with ATI MOBILITY RADEON X700 PCI Express With 256MB RAM and 15.4 WXGA CrystalBrite TFT LCD (1280x800 Natural Resolution). The bug is apparent with both edgy eft installation and Feisty Fawn Herd 1 Desktop CD. The workaround proposed by S.Rey solves the problem.

Ro (robert-markula) wrote :

Confirmed on a Thinkpad Z61m with a mobility radeon X1400. When switching to a VT the screen goes psychedelic ;)

IMHO the priority of this bug should be raised, as a VT is something really important, if X doesn't work.

Kekeny (rkekeny) wrote :

I did the steps proposed by S. Rey, and it solved the problem!

ACER 5672 WLMi - X1400

John Dong (jdong) wrote :

Problem is fixed on Feisty for my laptop.

Also worksforme on Feisty.

Works for me too now. With four people saying it works, I'm taking the liberty of marking this as fixed.

Changed in usplash:
status: Confirmed → Fix Released

Dapper, Edgy: Everything was fine, tty's was working correctly, also usplash was okay.
Feisty: tty's messed up. I have had to change to vga=791, because 1280x800 framebuffer is not supported by my hardware/drivers...

glenstewart (glen-stewart) wrote :

When I upgraded from Edgy to Fiesty, I lost my virtual terminals and the system would lock up if I tried to use any VT. Once I switched to a VT, I couldn't get back to VT7.

Setting "defoptions=vga=791" in /boot/grub/menu.lst and leaving /etc/usplash.conf at its default 1024x768 solved the problem.

Jacob Godserv (fun2program8) wrote :

Fix released, but for some reason I still experience this issue? Using an "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)".

I'll try the vga=791 fix mentioned and report back.

Jacob Godserv (fun2program8) wrote :

I added vga=791 onto the end, it merely reported an error saying the mode was undefined. Setting 640x480 in /etc/usplash.conf, running update-initramfs, and then removing the vga=791 bit from /boot/grub/menu.lst brought up the splash, but the status bar was a little off-center. The splash didn't reapear for shutdown.

All very confusing - is this even caused by this bug? I did get the "psychedelic" colors this morning for the first time.

Stephen Parry (sgparry) wrote :

I wish to add that I am experiencing this problem in UbuntuStudio distribution of *HARDY*. I get one in three reliable boots, other two all VTs are corrupted until shutdown. I have Intel Mobile 945GM using the new standard kernel driver (not i810) at 1920x1200. It does not seem to affect the vanilla Ubuntu Live CD, only studio with its custom splash. The problem goes away if I edit out splash from menu.lst

Stephen Parry (sgparry) wrote :

Found fresh in 8.04 UbuntuStudio on Intel 945GM video hardware.

Changed in usplash:
status: Fix Released → New

Thank you for posting this bug.

Is this an issue in Maverick?

Changed in usplash (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for usplash (Ubuntu) because there has been no activity for 60 days.]

Changed in usplash (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers