util-linux 2.26.2-6ubuntu1 source package in Ubuntu

Changelog

util-linux (2.26.2-6ubuntu1) wily; urgency=medium

  * Merge from Debian unstable.  Remaining changes:
    - Regularly trim SSDs automatically (core-1311-ssd-trimming):
      + Add debian/fstrim-all.cron: Call fstrim --all. Installed as
        /etc/cron.weekly/fstrim.
    - Upstart support:
      + Add hwclock{-save}.upstart, and install them in debian/rules.
      + Drop debian/hwclock.rules and hwclock.default.
    - Add mountall-options.patch, see patch header.
    - Adjust the Breaks: cloud-utils to 0.27-0ubuntu16 (the Ubuntu version
      that works with util-linux 2.26), and also move it to cloud-guest-utils.
    - Add libudev-dev build dependency for enabling LABEL information in lsblk
      (Closes: #776905)
    - Add debian/libblkid1.maintscript to clean up /etc/blkid.conf on upgrade.
      This needs to be kept until after Ubuntu 16.04 LTS.
    - Add sulogin-lockedpwd.patch: Make sure file systems can be fixed on
      machines with locked root accounts too, by presenting a shell in these
      cases. Patch ported from sysvinit.
    - Add sulogin-fallback-static-sh.patch: Add support for /bin/static-sh as
      fallback if the regular shell fails to execute. Patch ported from
      sysvinit. (see LP #505887)
  * Make util-linux Breaks old {p,}mac-fdisk for the fdisk binary takeover.

util-linux (2.26.2-6) unstable; urgency=medium

  [ Martin Pitt ]
  * debian/gbp.conf: Update deprecated section names.

  [ Andreas Henriksson ]
  * Add patches to fix kFreeBSD FTBFS
    - 0002-lib-fileutils-Add-new-dup_fd_cloexec-function.patch
    - 0003-lib-sysfs-Use-dup_fd_cloexec-instead-of-direct-call-.patch
    This is a temporary workaround until glibc gets fixed (see #785796).
    Thanks to Guillem Jover for patches and Steven Chamberlain for testing.
    (Closes: #787042)

util-linux (2.26.2-5) unstable; urgency=medium

  * NMU upload with Andreas' consent / by his request.
  * Using sysvinit-utils (<< 2.88dsf-59.1~) confuses apt during upgrade, so
    use Depends: instead. This isn't technically true, but ensures a robust
    upgrade also from jessie. (Closes: #786469)

util-linux (2.26.2-4) unstable; urgency=medium

  [ Andreas Henriksson ]
  * Drop now obsolete purging of fstrim timer unit helper
  * Reclaim /sbin/fdisk on PowerPC
  * Ship mountpoint in util-linux package instead
    - This suits non-linux archs better, since mount is linux-any.

  [ Martin Pitt ]
  * Avoid cyclic Breaks in initscripts vs util-linux

 -- Adam Conrad <email address hidden>  Fri, 03 Jul 2015 08:40:00 -0600

Upload details

Uploaded by:
Adam Conrad on 2015-07-03
Uploaded to:
Wily
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
base
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
util-linux_2.26.2.orig.tar.xz 3.7 MiB 0e29bda142528a48a0a953c39ff63093651a4809042e1790fbd6aa8663fd9666
util-linux_2.26.2-6ubuntu1.debian.tar.xz 76.6 KiB d5a85e4c8fe5e62af0fe872a9b2430522ee7457f52428c44a47dc05da2d97c76
util-linux_2.26.2-6ubuntu1.dsc 3.7 KiB ff6c845b1c988d04ff48d3f23b9d75eb2fda8f0239bc96254ef66aeb2efcee9d

View changes file

Binary packages built by this source

bsdutils: No summary available for bsdutils in ubuntu wily.

No description available for bsdutils in ubuntu wily.

bsdutils-dbgsym: No summary available for bsdutils-dbgsym in ubuntu wily.

No description available for bsdutils-dbgsym in ubuntu wily.

cfdisk-udeb: No summary available for cfdisk-udeb in ubuntu wily.

No description available for cfdisk-udeb in ubuntu wily.

cfdisk-udeb-dbgsym: No summary available for cfdisk-udeb-dbgsym in ubuntu wily.

No description available for cfdisk-udeb-dbgsym in ubuntu wily.

fdisk-udeb: No summary available for fdisk-udeb in ubuntu wily.

No description available for fdisk-udeb in ubuntu wily.

fdisk-udeb-dbgsym: No summary available for fdisk-udeb-dbgsym in ubuntu wily.

No description available for fdisk-udeb-dbgsym in ubuntu wily.

libblkid-dev: No summary available for libblkid-dev in ubuntu wily.

No description available for libblkid-dev in ubuntu wily.

libblkid1: No summary available for libblkid1 in ubuntu wily.

No description available for libblkid1 in ubuntu wily.

libblkid1-dbgsym: No summary available for libblkid1-dbgsym in ubuntu wily.

No description available for libblkid1-dbgsym in ubuntu wily.

libblkid1-udeb: No summary available for libblkid1-udeb in ubuntu wily.

No description available for libblkid1-udeb in ubuntu wily.

libblkid1-udeb-dbgsym: No summary available for libblkid1-udeb-dbgsym in ubuntu wily.

No description available for libblkid1-udeb-dbgsym in ubuntu wily.

libfdisk-dev: No summary available for libfdisk-dev in ubuntu wily.

No description available for libfdisk-dev in ubuntu wily.

libfdisk1: No summary available for libfdisk1 in ubuntu wily.

No description available for libfdisk1 in ubuntu wily.

libfdisk1-dbgsym: No summary available for libfdisk1-dbgsym in ubuntu wily.

No description available for libfdisk1-dbgsym in ubuntu wily.

libfdisk1-udeb: No summary available for libfdisk1-udeb in ubuntu wily.

No description available for libfdisk1-udeb in ubuntu wily.

libfdisk1-udeb-dbgsym: No summary available for libfdisk1-udeb-dbgsym in ubuntu wily.

No description available for libfdisk1-udeb-dbgsym in ubuntu wily.

libmount-dev: No summary available for libmount-dev in ubuntu wily.

No description available for libmount-dev in ubuntu wily.

libmount1: No summary available for libmount1 in ubuntu wily.

No description available for libmount1 in ubuntu wily.

libmount1-dbgsym: No summary available for libmount1-dbgsym in ubuntu wily.

No description available for libmount1-dbgsym in ubuntu wily.

libsmartcols-dev: No summary available for libsmartcols-dev in ubuntu wily.

No description available for libsmartcols-dev in ubuntu wily.

libsmartcols1: No summary available for libsmartcols1 in ubuntu wily.

No description available for libsmartcols1 in ubuntu wily.

libsmartcols1-dbgsym: No summary available for libsmartcols1-dbgsym in ubuntu wily.

No description available for libsmartcols1-dbgsym in ubuntu wily.

libsmartcols1-udeb: No summary available for libsmartcols1-udeb in ubuntu wily.

No description available for libsmartcols1-udeb in ubuntu wily.

libsmartcols1-udeb-dbgsym: No summary available for libsmartcols1-udeb-dbgsym in ubuntu wily.

No description available for libsmartcols1-udeb-dbgsym in ubuntu wily.

libuuid1: No summary available for libuuid1 in ubuntu wily.

No description available for libuuid1 in ubuntu wily.

libuuid1-dbgsym: No summary available for libuuid1-dbgsym in ubuntu wily.

No description available for libuuid1-dbgsym in ubuntu wily.

libuuid1-udeb: No summary available for libuuid1-udeb in ubuntu wily.

No description available for libuuid1-udeb in ubuntu wily.

libuuid1-udeb-dbgsym: No summary available for libuuid1-udeb-dbgsym in ubuntu wily.

No description available for libuuid1-udeb-dbgsym in ubuntu wily.

mount: No summary available for mount in ubuntu wily.

No description available for mount in ubuntu wily.

mount-dbgsym: No summary available for mount-dbgsym in ubuntu wily.

No description available for mount-dbgsym in ubuntu wily.

util-linux: No summary available for util-linux in ubuntu wily.

No description available for util-linux in ubuntu wily.

util-linux-dbgsym: No summary available for util-linux-dbgsym in ubuntu wily.

No description available for util-linux-dbgsym in ubuntu wily.

util-linux-locales: No summary available for util-linux-locales in ubuntu wily.

No description available for util-linux-locales in ubuntu wily.

util-linux-udeb: No summary available for util-linux-udeb in ubuntu wily.

No description available for util-linux-udeb in ubuntu wily.

util-linux-udeb-dbgsym: No summary available for util-linux-udeb-dbgsym in ubuntu wily.

No description available for util-linux-udeb-dbgsym in ubuntu wily.

uuid-dev: No summary available for uuid-dev in ubuntu wily.

No description available for uuid-dev in ubuntu wily.

uuid-runtime: No summary available for uuid-runtime in ubuntu wily.

No description available for uuid-runtime in ubuntu wily.

uuid-runtime-dbgsym: No summary available for uuid-runtime-dbgsym in ubuntu wily.

No description available for uuid-runtime-dbgsym in ubuntu wily.