Ubuntu

CoRRE bug prevents connection from Nokia 770 to edgy

Reported by Laurent GUERBY on 2006-11-08
8
Affects Status Importance Assigned to Milestone
vino (Ubuntu)
Medium
Ubuntu Desktop Bugs
Edgy
Medium
Sebastien Bacher

Bug Description

According to http://www.physik.de/770/ the following bug fix to vino is needed for the connection from a Nokia 770 VNC to work to ubuntu edgy:

2006-10-18 Mark McLoughlin <email address hidden>

 Fix issue with the CoRRE encoding saying its only sending
 a single rectangle, but sending lots more. Problem identified
 by Detlef Schmicker <email address hidden>

 Fix is backported from libvncserver upstream.

 * server/libvncserver/rfbserver.c:
 (rfbSendFramebufferUpdate): handle maxRectsPerUpdate for
 CoRRE and Zlib encodings.

Is it possible to include it?

Sebastien Bacher (seb128) wrote :

thanks for your bug. That is fixed to feisty

Changed in vino:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Fix Released
Sebastien Bacher (seb128) wrote :

I'll have a look at backporting that fix for edgy

Changed in vino:
assignee: nobody → seb128
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :
Laurent GUERBY (laurent-guerby) wrote :

I'm not seeing it yet in edgy-proposed, is there an unexpected problem with the patch?

Thanks in advance,

Laurent

Sebastien Bacher (seb128) wrote :

I don't think there is any problem with it, people reviewing the proposed upload might be busy or mail is not the preferred way. I've subscribed the ubuntu-sru team to the bug now

Laurent GUERBY (laurent-guerby) wrote :

Thanks Sebastien! If the .deb for edgy i386 or x86_64 is available somewhere I can test it with my Nokia 770.

Matt Zimmerman (mdz) wrote :

OK for edgy-proposed

Sebastien Bacher (seb128) wrote :

uploaded to edgy-proposed

Unless I'm mistaken I haven't seen a .deb with the fix yet. In

http://archive.ubuntu.com/ubuntu/pool/main/v/vino/

the latest version is vino_2.16.0-0ubuntu2.1 and the diff doesn't contain your patch (which seems to create a version 2.2).

Is the delay normal?

Thanks again :)

Adam Conrad (adconrad) wrote :

I had to reject this upload, since the version clashes with the one in edgy-updates. Please re-upload, incorporating the changelog from -0ubuntu2.2 in updates, and using a unique version number. :)

Ah ok, thanks for the explanation :). I hope this gets reloaded soon.

BTW, is the upload/accept/reject process publically visible somewhere?

Thanks in advance,

Laurent

Sebastien Bacher (seb128) wrote :

uploaded -0ubuntu2.3 with those changes now

Laurent, the package page (click on "Overview" from the left column) has a summary of the uploads for the package

I see a 2.2 published today:

"2006-12-07 06:03:57 UTC Published edgy Updates main gnome 2.16.0-0ubuntu2.2"

but no trace of 2.3 so I'm a bit lost :)

Le jeudi 07 décembre 2006 à 19:42 +0000, Laurent GUERBY a écrit :
> I see a 2.2 published today:
>
> "2006-12-07 06:03:57 UTC Published edgy Updates
> main gnome 2.16.0-0ubuntu2.2"

that is the password fix which has been uploaded first to edgy-proposed
and to edgy-updates then

> but no trace of 2.3 so I'm a bit lost :)

that one has been uploaded today and is waiting for approval now, it'll
be available to edgy-proposed after being accepted and built

Tollef Fog Heen (tfheen) wrote :

Accepted into edgy-proposed, please notify the QA team and get it tested as per StableReleaseUpdates

Changed in vino:
status: Confirmed → Fix Committed

Thanks! I got the update, restarted vino and I confirm VNC works fine from my Nokia 770 to my edgy dektop (I'm writing this from my Nokia 770 using VNC :).

Simon Law (sfllaw) wrote :

This patch fixes the problem on the Nokia 770 using the latest firmware and VNCviewer packages.

Also regression tested not to break various other VNC clients.

Approved to go into edgy-updates immediately.

Sebastien Bacher (seb128) wrote :

fixed package uploaded to edgy-updates now

Tollef Fog Heen (tfheen) wrote :

Accepting ubuntu/edgy-updates (UNAPPROVED) 1/1
---------------------------------------------------------------------------
Accepting vino
---------------------------------------------------------------------------

Changed in vino:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers