Change log for w3m-el package in Ubuntu

129 of 29 results
Published in cosmic-release on 2018-06-03
Deleted in cosmic-proposed (Reason: moved to release)
w3m-el (1.4.569+0.20170110-3) unstable; urgency=medium

  * Accept unversioned emacs flavor for emacsen-common 3.0.0
  * Drop workaround for emacsen-common 1.x

 -- Tatsuya Kinoshita <email address hidden>  Sun, 03 Jun 2018 15:22:33 +0900
Superseded in cosmic-release on 2018-06-03
Deleted in cosmic-proposed on 2018-06-04 (Reason: moved to release)
w3m-el (1.4.569+0.20170110-2) unstable; urgency=medium

  * New patch 020_emacs26.patch
  * Update debhelper compat version to 11
  * Migrate from anonscm.debian.org to salsa.debian.org
  * Update Standards-Version to 4.1.4
  * Fix debian/copyright

 -- Tatsuya Kinoshita <email address hidden>  Fri, 01 Jun 2018 19:59:32 +0900
Superseded in cosmic-release on 2018-06-01
Published in bionic-release on 2018-01-11
Deleted in bionic-proposed (Reason: moved to release)
w3m-el (1.4.569+0.20170110-1) unstable; urgency=medium

  * New upstream version 1.4.569+0.20170110
  * Drop debian/patches
  * New patch 010_emacs27.patch
  * Update debhelper compat version to 10
  * Update Vcs-Git to https
  * Update debian/copyright
  * Update Standards-Version to 4.1.3
  * Prevent declare-function errors in emacsen-install
  * Add discount | libtext-markdown-perl | markdown to Suggests

 -- Tatsuya Kinoshita <email address hidden>  Sat, 06 Jan 2018 12:09:59 +0900
Superseded in bionic-release on 2018-01-11
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
w3m-el (1.4.538+0.20141022-5) unstable; urgency=medium

  * New patch 040_obsolete.patch to drop make-obsolete
  * Prefer emacs-nox over emacs
  * Update debian/copyright

 -- Tatsuya Kinoshita <email address hidden>  Thu, 19 Jan 2017 21:29:20 +0900
Superseded in zesty-release on 2017-01-19
Deleted in zesty-proposed on 2017-01-20 (Reason: moved to release)
w3m-el (1.4.538+0.20141022-4) unstable; urgency=medium

  * Accept emacs25
  * Update debhelper compat version to 9

 -- Tatsuya Kinoshita <email address hidden>  Mon, 24 Oct 2016 00:04:29 +0900
Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
w3m-el (1.4.538+0.20141022-3) unstable; urgency=medium

  * New patch 030_buffer-name.patch to work for Emacs 25.2
  * Update debian/copyright
  * Update Vcs-Browser to https
  * Update Standards-Version to 3.9.8

 -- Tatsuya Kinoshita <email address hidden>  Wed, 25 May 2016 22:00:34 +0900
Superseded in yakkety-release on 2016-05-26
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
w3m-el (1.4.538+0.20141022-2) unstable; urgency=medium

  * New patch 020_google.patch to avoid Google search looping

 -- Tatsuya Kinoshita <email address hidden>  Sat, 09 May 2015 06:24:18 +0900
Superseded in wily-release on 2015-05-09
Deleted in wily-proposed on 2015-05-10 (Reason: moved to release)
w3m-el (1.4.538+0.20141022-1) unstable; urgency=medium


  * Imported Upstream version 1.4.538+0.20141022
  * Drop debian/patches
  * Update debian/copyright
  * New patch 010_w3m-filter.patch to update regexp for w3m-filter
  * Use configure option --with-emacs=emacs
  * Update Standards-Version to 3.9.6
  * Drop emacs21 to prevent an installation failure
  * Update Vcs-Browser

 -- Tatsuya Kinoshita <email address hidden>  Sun, 26 Apr 2015 12:24:19 +0900
Superseded in wily-release on 2015-05-07
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
w3m-el (1.4.483+0.20120614-8) unstable; urgency=medium


  * Depend on emacsen-common 2.0.8
  * Do not install obsolete attic/*.el files
  * Update debian/copyright
  * Install a compat file with emacsen-compat

 -- Tatsuya Kinoshita <email address hidden>  Sat, 24 May 2014 01:05:41 +0900
Superseded in utopic-release on 2014-05-23
Published in trusty-release on 2013-12-26
Deleted in trusty-proposed (Reason: moved to release)
w3m-el (1.4.483+0.20120614-7) unstable; urgency=low


  * Workaround for emacsen-common <2 and debhelper <9.20131104

 -- Tatsuya Kinoshita <email address hidden>  Thu, 26 Dec 2013 23:26:59 +0900
Superseded in trusty-release on 2013-12-26
Deleted in trusty-proposed on 2013-12-28 (Reason: moved to release)
w3m-el (1.4.483+0.20120614-6) unstable; urgency=low


  * Add workaround to compatible with emacsen-common <2.0.0

 -- Tatsuya Kinoshita <email address hidden>  Sun, 08 Dec 2013 15:00:20 +0900
Superseded in trusty-release on 2013-12-08
Deleted in trusty-proposed on 2013-12-09 (Reason: moved to release)
w3m-el (1.4.483+0.20120614-5) unstable; urgency=low


  * Update 0003-Use-mew-w3m-cite-blockquote.patch to fix infinite loop

 -- Tatsuya Kinoshita <email address hidden>  Wed, 04 Dec 2013 22:44:28 +0900
Superseded in trusty-release on 2013-12-05
Deleted in trusty-proposed on 2013-12-06 (Reason: moved to release)
w3m-el (1.4.483+0.20120614-4) unstable; urgency=low


  * New patch 0003-Use-mew-w3m-cite-blockquote.patch (closes: #728501)
  * Update Standards-Version to 3.9.5

 -- Tatsuya Kinoshita <email address hidden>  Mon, 02 Dec 2013 21:49:06 +0900
Superseded in trusty-release on 2013-12-03
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
w3m-el (1.4.483+0.20120614-3) unstable; urgency=low


  * New patch 0002-Set-w3m-use-cookies-to-t.patch (closes: #419647)

 -- Tatsuya Kinoshita <email address hidden>  Sat, 06 Jul 2013 10:04:32 +0900
Superseded in saucy-release on 2013-07-06
Deleted in saucy-proposed on 2013-07-07 (Reason: moved to release)
w3m-el (1.4.483+0.20120614-2) unstable; urgency=low


  * New patch 0001-Fix-w3m-bookmark-for-Emacs-24.patch

 -- Tatsuya Kinoshita <email address hidden>  Tue, 07 May 2013 01:17:06 +0900

Available diffs

Superseded in saucy-release on 2013-05-07
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
w3m-el (1.4.4-12) unstable; urgency=low


  * debian/patches/050_emacs24.patch: Workaround for emacs24 errors
  * debian/patches/040_ptexinfmt.patch: Update ptexinfmt.el for emacs24
  * debian/control: Add emacs24

 -- Tatsuya Kinoshita <email address hidden>  Fri, 06 Jul 2012 23:36:12 +0900

Available diffs

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
w3m-el (1.4.4-11) unstable; urgency=low


  * Switch to dpkg-source 3.0 (quilt) format.
  * debian/copyright: Update copyright-format version to 1.0.
  * debian/rules: Add the targets build-indep and build-arch.
  * debian/rules: Install shimbun/ChangeLog* and ChangeLog.*.
  * debian/emacsen-install.in: Add messages for the rare situations.
  * debian/control:
    - Add GNU Emacs flavors to Build-Depends-Indep.
    - Update Standards-Version to 3.9.3.

 -- Tatsuya Kinoshita <email address hidden>  Thu, 03 May 2012 19:47:04 +0900

Available diffs

Superseded in quantal-release on 2012-05-14
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
w3m-el (1.4.4-10) unstable; urgency=low

  * w3m-e23.el: New file to byte-compile with emacs23 and emacs-snapshot,
    from the upstream development version on 2007-02-02.
  * debian/emacsen-install.in: Don't fail with emacs23, emacs-snapshot and
    xemacs21-nomule.
  * debian/control:
    - Add emacs23 to Depends. (closes: #541892)
    - Add emacs-snapshot to Depends.
    - Add `dpkg (>= 1.15.4) | install-info' to Depends.
    - Add ${misc:Depends} to Depends.
    - Set Section to lisp.
    - Remove emacsen flavors from Build-Depends-Indep, remain `emacs'.
    - Update Standards-Version to 3.8.4.
  * debian/copyright: Updated.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 14:07:19 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
w3m-el (1.4.4-9) unstable; urgency=low

  * debian/emacsen-*: Rewritten.
  * debian/rules, debian/dirs.in: Install attic/*.el in the site-lisp
    directory.
  * debian/w3mhack.el.patch: Removed.
  * debian/compat, debian/control: Update debhelper version to 7.
  * debian/control:
    - Remove bitmap-mule from Suggests.
    - Update Standards-Version to 3.8.1.
  * debian/rules: Use dh_prep instead of `dh_clean -k'.
  * debian/copyright: Updated.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 12:15:39 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
w3m-el (1.4.4-8) unstable; urgency=low

  * debian/emacsen-startup.in: Set w3m-icon-directory to
    "/usr/share/pixmaps/w3m-el/small" for GNU Emacs.

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
w3m-el (1.4.4-6) unstable; urgency=low

  * debian/control:
    - (Conflicts): Add epoch to the version of flim, and remove mew.
    - (Depends): Remove the version of apel.
    - (Description): Typo fix.
    - (Homepage): Move from Description.
    - (Standards-Version): 3.7.2 -> 3.7.3.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  10 Dec 2007 09:36:24 +0000
Superseded in hardy-release on 2007-12-10
w3m-el (1.4.4-5) unstable; urgency=low

  * debian/README.Debian: Revised for the optional features, shimbun,
    w3m-namazu, etc.
  * debian/watch: New file.
  * Renamed from examples/w3m-*.el to examples/dot.w3m-*.el.
  * debian/control:
    - (Build-Depends-Indep): Add autoconf.
    - (Replaces, Conflicts): Add w3m-el-snapshot.
    - (Description): Typo fix.
  * Ready for w3m-el-snapshot.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  26 Nov 2007 09:28:59 +0000
Superseded in hardy-release on 2007-11-26
w3m-el (1.4.4-4) unstable; urgency=low

  * Merge Ubuntu patches, thanks to Michael W. Olson.
    - debian/compat: Fix lintian warning by setting this to 5.
    - debian/control: Bump up debhelper version.
    - debian/control: Update Standards-Version to 3.7.2.
    - debian/emacsen-install: Create symlinks for .el files, rather than
      copying .el files and then removing them.
    - debian/rules:
      - Remove DH_COMPAT to silence lintian.
      - (clean): Silence lintian warning.
  * debian/emacsen-startup: Check whether
    /usr/lib/emacsen-common/packages/install/w3m-el exists.
  * debian/control:
    - Mention optional features in Description. (closes: #316457)
    - Add `libmoe1.5, namazu2, xpdf-utils, bzip2, perl-doc' to Suggests.
  * debian/copyright: Updated.
  * Acknowledge NMU.
    (closes: #441240, #333607, #434924, #412169, #377456, #393957)
  * New maintainer, with previous maintainer's permission.

Superseded in hardy-release on 2007-11-16
Obsolete in gutsy-release on 2011-09-16
w3m-el (1.4.4-3ubuntu1) gutsy; urgency=low

  * debian/compat: Fix lintian warning by setting this to 5.
  * debian/control:
    - (Build-Depends): Add debhelper.
    - (Build-Depends-Indep): Add emacs22 and emacs-snapshot,
    - (Depends): Add emacs22.
    - (Standards-Version): Update to 3.7.2.
    - (Maintainer, Original-Maintainer): Follow policy.
  * debian/emacsen-install: Create symlinks for .el files, rather than
    copying .el files and then removing them.  This makes find-function
    work.
  * debian/rules:
    - Remove DH_COMPAT to silence lintian.
    - (clean): Silence lintian warning.
  * LP: #123904

 -- <email address hidden> (Michael W. Olson (GNU address))   Tue, 10 Jul 2007 21:35:16 -0400
Superseded in gutsy-release on 2007-09-07
Obsolete in feisty-release on 2009-08-20
w3m-el (1.4.4-3) unstable; urgency=low

  * change dependency: Depends: emacs21 | emacs-snapshot | apel,
    since apel depends on emacs21 | emacsen, w3m-el on emacs21 and 
    emacs-snapshot doesn't require apel, but xemacs does.
    closes: Bug#321995

 -- Michael Bienia <email address hidden>   Wed,  07 Mar 2007 21:52:32 +0000
Superseded in feisty-release on 2007-03-07
w3m-el (1.4.4-2) unstable; urgency=low

  * debian/emacsen-install: Fix xml.el detection
    closes: Bug#390103

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  08 Nov 2006 20:03:51 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
Obsolete in breezy-release on 2008-03-25
w3m-el (1.4.4-1) unstable; urgency=low


  * New upstream release
  * closes: Bug#300850

 -- Fumitoshi UKAI <email address hidden>  Tue, 19 Apr 2005 00:56:35 +0900
Obsolete in hoary-release on 2008-03-19
w3m-el (1.4.3-2) unstable; urgency=low


  * debian/emacsen-startup: check file exists 
      in case package was removed, but not yet purged
    closes: Bug#250930
  * debian/emacsen-install: use apel/*.elc instead of apel/*.el
    closes: Bug#251065

 -- Fumitoshi UKAI <email address hidden>  Sat, 30 Oct 2004 01:40:13 +0900
Obsolete in warty-release on 2008-01-09
w3m-el (1.4-2) unstable; urgency=low


  * emacsen-install: should not remove w3m-load.el, which was not byte-compiled
    closes: Bug#247042

 -- Fumitoshi UKAI <email address hidden>  Mon,  3 May 2004 16:09:42 +0900
129 of 29 results