Ubuntu

wacom-tools udev scripts should point to /dev/input/wacom instead of /dev/wacom

Reported by Kristoffer Lundén on 2006-04-21
74
Affects Status Importance Assigned to Milestone
udev
Invalid
Undecided
Unassigned
wacom-tools (Ubuntu)
Medium
Timo Aaltonen
xorg (Ubuntu)
Medium
Timo Aaltonen

Bug Description

At the moment, udev scripts installed by package wacom-tools point to /dev/input/wacom, whereas /etc/X11/xorg.conf points wacom devices to /dev/wacom.

As a result, Wacom USB tablets don't work in Ubuntu.

Related branches

Changed in xorg:
assignee: nobody → mjg59

Much the same experience here with Dapper beta (Flight 7) and an Intuos 2 *serial* Wacom tablet.

Wacom entries were present in xorg.conf but pointing to the non-existant dev/wacom.

I didn't realise about the udev scripts, so my workaround was to manually edit xorg.conf to point to /dev/ttyS0 in the Option "Device" lines for the tablet. I also had to comment out the Option "ForceDevice" "ISDV4" for tablet PC devices.

It's a much better situation than the last time I tried to get the tablet working under Ubuntu, but it still isn't quite automagic...

Matthew Garrett (mjg59) wrote :

Serial is difficult, I'm afraid - we don't do any sort of serial pnp support at the moment, so we can't autodetect serial hardware.

I'd not worry too much about serial Wacoms; I've got one, but every other one I've ever seen (apart from years ago) uses USB. And I kind of don't expect the same level of magic for serial as USB if I'm honest; USB is meant for hotplugging and multiple devices, whereas serial plugs have little screw lugs to fix them in place and are always round the back of the box, covered in dust and cat hairs ;)

Sven Herzberg (herzi) wrote :

Neil, TabletPCs have their tablet connected internally as a serial tablet, so serial wacoms just seem to raise again.

Matthew Garrett (mjg59) wrote :

Tablet PCs have the wacom device listed in their pnpbios data, so we can autoconfigure those (which is what the init script does)

Loïc Martin (loic-martin3) wrote :

Same problem here with a Wacom Intuos 3 A5 usb tablet under Dapper 05/23 daily build.

Loïc Martin (loic-martin3) wrote :

This bug could be seen along with Bug #38336 "Lack of support for hotplugging and Dapper kernel" which suggest using 0.7.4 would solve other problems. Don't now if it's too late for Dapper, but linuxwacom release are quite stable.

Tested with differents installs. In fact, the hardest was to understand first bug description (I'm not so bright :) )

description: updated
Changed in wacom-tools:
status: Unconfirmed → Confirmed
Changed in xserver-xorg-input-wacom:
status: Unconfirmed → Confirmed
Loïc Martin (loic-martin3) wrote :

If we really want to be righteous, there was two separate bug reports from the start. But the bug fixes are trivial enough - and it would be easy to open another bug report in case somebody consider the fixes required would need it.

Loïc Martin (loic-martin3) wrote :

>(Side note: would it be possible to auto-configure "extended devices" too? That's a stumper for pressure sensitivity for many).

Kristoffer, you should open new bug reports against each application (mainly Gimp and Inkscape), unless there's a system wide setting (I don't really think so) or a Gnome-wide setting (seems not likely either).

Loïc Martin (loic-martin3) wrote :

I've created an attempt at a simple guide to set up Wacom tablets in Dapper
https://wiki.ubuntu.com/Wacom

It can be usefull because it summarize this bug in an easy way, as well as the steps to fix it, including screen captures in Technicolor.

>A quick symlink to test it confirms that all that's needed is for these two to meet.

However, the symlink doesn't resist a reboot. Anyone has an idea that doesn't involve editing configuration files?

Loïc Martin (loic-martin3) wrote :

No update to this bug has been made since May. Could anybody confirm if the problem (a trivial matter of pointing to the right location) has at least been corrected in Edgy?
Thanks

Sven Herzberg (herzi) wrote :

As I'm going to install edgy on my thinkpad I'm going to be able to report something when I get the computer back: http://www.herzi.eu/

It seems this is till not fixed in edgy, which is a real shame for something that seems a really small change.

Loïc Martin (loic-martin3) wrote :

Accorded to a post in ubuntu-devel mailing list, /usr/bin/dexconf (provided by package x11-common) is responsible for xorg.conf creation.

Tollef Fog Heen (tfheen) wrote :

It's too late to fix this for edgy, but I'm setting a milestone "later" which means we'll get to it when edgy is out.

Loïc Martin (loic-martin3) wrote :

This bug has been open, clearly described and with a trivial solution for month now (April 2006). If nobody has cared to fix it for Edgy (when the bug has been there to fix since Dapper's betas) what does it mean to say that it's too late to fix for Edgy?
Has it been too late to fix it for Edgy when Edgy development hadn't even started?

My tablet pc could have worked out of the box if *only* wacom-tools had been installed. If I go to /etc/X11/xorg.conf and see that my tablet has been configured, and I see an error that there is no /dev/input/wacom, I will never suspect the point is to install wacom-tools. But: if the fix is just to install wacom-tools when xserver-xorg-input-wacom is installed i.e. to add this obvious missing dependency, why isn't the fix still released?

Ubuntu is the only distribution that correctly and automatically sets up all my hardware except for this simple fix. It might not fix every possible wacom tablet but at least all pennabled convertible tabled pc, so that I can advice ubuntu to people asking me if "my tablet pc works on linux" around at university or at conferences etc.

So, since /dev/wacom is also created by wacom-tools now, it just suffices to add the missing dependency, and this bug can be closed :)

Can anyone look at this for *this* release then, please? If I understand things correctly in the post above, it's only adding one dependency now for everything to work, and this has been untouched for a long time now...

Please?

Vincenzo Ciancia (vincenzo-ml) wrote :

I am not sure if xserver-xorg-input-wacom is installed only if a tablet is recognized and in that case it's just a matter of wrong dependencies, or if it's installed by default but unused in case of no tablet detected, in that case wacom-tools installation could be inappropriate.

However, I guess that installing the "xserver-xorg-input-wacom" without installing wacom-tools is of no use, so that the missing dependency should be added in any case. I expected a comment from the developers to clarify the situation, too. Could perhaps wacom tools, for example, break other serial hardware or do they setserial only when a tablet is properly detected?

Prizrak (slavachem) wrote :

I confirm the bug in Feisty Herd2 wacom-tools were the only thing needed installation to get the Tablet working on TabletPC. Another issue is lack of any kind of documentation for wacom-tools in the system (at least I didn't find it) not easy for someone to figure out without prior knowledge (shoudln't be that much of an issue in the first place)

genjix (aphidia) wrote :

I've just installed edgy- why doesn't xorg.conf have /dev/input/wacom instead of /dev/wacom so when I install wacom-tools its ready to go?

Vincenzo Ciancia (vincenzo-ml) wrote :

I see that I have /dev/wacom and not /dev/input/wacom, so the bug description should be updated, and the only issue remaining is the missing dependency. I am available for online testing if needed, just check my jabber and irc names, or send me an e-mail.

Since there is a little aggregation of wacom tablet ubuntu users here, I ask if everybody had the eraser as button 3 by default, and had to switch button 3 and button 2 in order to "fix" the stylus and be able to right click with the side button of the stylus. If so, we can try to ask to fix bug #82109 and this one together, and finally get wacom tablets working out-of-the-box in feisty.

Timo Aaltonen (tjaalton) on 2007-03-20
Changed in xorg:
assignee: nobody → tepsipakki

I tried again with Feisty Beta and after manual install of wacom-tools, I get /dev/input/wacom created.

Seems like no improvement from Dapper.

description: updated

fixed with this release of wacom-tools

 wacom-tools (1:0.7.2-0ubuntu8) feisty; urgency=low
 .
   * Make xserver-xorg-input-wacom to depend on wacom-tools (LP: #40473)
   * Change Maintainer address.

Changed in wacom-tools:
assignee: mjg59 → tepsipakki
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

This is no longer needed, right?

Changed in xorg:
status: Confirmed → Rejected
Loïc Martin (loic-martin3) wrote :

Timo, thank you for your work.

However, USB users still have a problem.

As far as I understand, serial users have /dev/wacom created by wacom-tools, so everything should be fine for them.

However, USB users have /dev/input/wacom created by udev, instead of /dev/wacom.

If we end up keeping /dev/wacom, then this bug should now be filed against udev

I could be completely mistaken there, but USB Wacom tablets still don't work with the present situation.

Loïc Martin (loic-martin3) wrote :

Just tested to confirm with an Intuos 3 A5 usb on Feisty Beta with all updates (no changes done anywhere).

Plugging the tablet creates a /dev/input/wacom link. This bug is still there

Loïc Martin (loic-martin3) wrote :

Sorry for reporting against udev.

After a quick check, the problem is in wacom-tools, more exactly in the udev rule created by wacom-tools :

Here is an extract of wacom-tools ubuntu diff
( http://archive.ubuntu.com/ubuntu/pool/main/w/wacom-tools/wacom-tools_0.7.2-0ubuntu7.diff.gz )

+# udev rule for wacom tablets.
+
+KERNEL=="event[0-9]*", SYSFS{idVendor}=="056a", SYMLINK+="input/wacom"

Reopening bug for wacom-tools

Changed in udev:
status: Unconfirmed → Rejected
Changed in wacom-tools:
status: Fix Released → Confirmed
description: updated

Loïc is correct, I've just come to the same conclusion before finding this bug report.

Loïc Martin (loic-martin3) wrote :

>I see that I have /dev/wacom and not /dev/input/wacom, so the bug description should be updated, >and the only issue remaining is the missing dependency.

Vincenzo has a tablet pc. These are configured like serial devices (afaik) and serial tablets have /dev/wacom created.

The bug is about USB Wacom tablets. They still have /dev/input/wacom by default (that's the last remaining bug).

At least serial Wacom users should now have everything working - except features missing in this old version of the driver.

Loïc Martin (loic-martin3) wrote :

Here is a custom wacom-tools with a fix in the udev script. It works here, by default, plugging an USB Wacom Tablet creates a link /dev/wacom, so editing xorg.conf is not needed anymore.

It shouldn't add any more bugs.

Please test it on a default feisty install and tell me if it works. I'm particularly interested if you have a serial tablet *or* a Tablet PC : please tell me if it works as well for you as the default wacom-tools in Feisty.

The package is unsigned (didn't configure gpg yet on this system, and I'm not sure were I've saved my key last time :)

Loïc Martin (loic-martin3) wrote :

Here is the resulting diff (quick hack, didn't change the version number, still 1:0.7.2-0ubuntu7, but I'll try to make a perfect patch soon.

Timo Aaltonen (tjaalton) wrote :

we are in the process of migrating all the tools to use /dev/input/wacom, if the UVFe request on wacom-tools is accepted.

Loïc Martin (loic-martin3) wrote :

Thanks for the input.

I also prefer /dev/input/wacom, but after one year, I was thinking we'll have more chance to get a patch to wacom-tools accepted (thus the previous bug title/description).

I'll update the bug description if/when the bug is fixed.

I'd like to know if someone is going to update the wacom driver to 0.7.6-4 for Ubuntu 7.10 (note it's not in Debian yet), because I was planning to have a look into packaging it. That way I won't waste days trying to learn xorg packaging for nothing :) (was planning to have a try at it). Solves Bug #69163, Bug #94505, Bug #42653 and Bug #38336.

Timo Aaltonen (tjaalton) wrote :

Loĩc: I've packaged it already, that's what the UVFe is about :) You can build and test it from the files here:

http://users.tkk.fi/~tjaalton/wacom

Loïc Martin (loic-martin3) wrote :

Great!

Best news since Dapper (really)!

Thanks a lot - now we get everything at once.

Joachim Beckers (jbeckers) wrote :

Nice work, really appreciated, thanks!

However, what about the xorg driver and kernel modules? will they be updated too?

Timo Aaltonen (tjaalton) wrote :

they are all built from the same source, wacom-tools.

Fantastic, I really hope this gets in for Feisty, that would be really really really awesome. Thanks for trying, either way!

Timo Aaltonen (tjaalton) wrote :

I need testers for the packages. The diff is _huge_ so it will not get in just by reading through it (since no-one will read it). So, please test the packages from http://users.tkk.fi/~tjaalton/wacom asap and report success/problems.

Loïc Martin (loic-martin3) wrote :

Timo, don't we also need xserver-xorg-input-wacom new package?

I can try to compile the stuff myself, but I'm not sure that's what you want, since you also provide the deb for wacom-tools.

Timo Aaltonen (tjaalton) wrote :

Oh, right. I'll build it again and make sure that every deb is there. Won't take long!

to do a new installation needs some preparation and i cannot do it
before end of next week - is this ok?

andrew

Loïc wrote:
> Here is a custom wacom-tools with a fix in the udev script. It works
> here, by default, plugging an USB Wacom Tablet creates a link
> /dev/wacom, so editing xorg.conf is not needed anymore.
>
> It shouldn't add any more bugs.
>
> Please test it on a default feisty install and tell me if it works. I'm
> particularly interested if you have a serial tablet *or* a Tablet PC :
> please tell me if it works as well for you as the default wacom-tools in
> Feisty.
>
> The package is unsigned (didn't configure gpg yet on this system, and
> I'm not sure were I've saved my key last time :)
>
> ** Attachment added: "Fixed wacom-tools"
> http://librarian.launchpad.net/7030348/wacom-tools_0.7.2-0ubuntu7_i386.deb
>
>

Please test Timo Aaltonen 's packages instead at http://users.tkk.fi/~tjaalton/wacom

They're much more interesting (new version) than mine.

Feisty is out in 3 weeks, so there's not much time left (and we never know in which other release we'll have somebody willing to have a try at wacom drivers in Ubuntu.

However, better try it in one week than never :)

The packages didn't work for me (Intuos 3), even after a reinstall with today's daily build, and the version now in the repos (0.7.2) doesn't work either. 0.7.2 from about one week ago did work, and my custom package did work, so I'm left to bump my head against solid brick walls if it remains like that (don't want to return to edgy - can't actually because one my to computer's mobo support is only ok in Feisty).

Can somebody tell us if their *usb* wacom still works with the latest updates (or by booting a recent live cd)?

i may trying a fresh install tuesday with the newest (monday DVD) distro.
what i should to is then
1. install ubuntu 7.04 fresh
2. load aaltonen's package (with synaptic?)
--
is that all?
then the wacom in my tablett should be recognized?

it would be wonderful if this problem would go away?

(does timo's package include support for rotating the screen and wacom
together?)

andrew

Loïc wrote:
> Please test Timo Aaltonen 's packages instead at
> http://users.tkk.fi/~tjaalton/wacom
>
> They're much more interesting (new version) than mine.
>
> Feisty is out in 3 weeks, so there's not much time left (and we never
> know in which other release we'll have somebody willing to have a try at
> wacom drivers in Ubuntu.
>
> However, better try it in one week than never :)
>
> The packages didn't work for me (Intuos 3), even after a reinstall with
> today's daily build, and the version now in the repos (0.7.2) doesn't
> work either. 0.7.2 from about one week ago did work, and my custom
> package did work, so I'm left to bump my head against solid brick walls
> if it remains like that (don't want to return to edgy - can't actually
> because one my to computer's mobo support is only ok in Feisty).
>
> Can somebody tell us if their *usb* wacom still works with the latest
> updates (or by booting a recent live cd)?
>
>

Yes, you're perfectly right. However, you can also do update your installation between steps 1 and 2, but it's not a requirement.

You won't be able to get Timo's packages through synaptics (it's not a repository, afaik). You can just donwload them on your hard drive, then open a terminal and issue :
sudo dpkg -i name_of_package.deb

Basically, you'll need to packages with the same version number (try 0.7.6 first since they're the latests) : one is wacom-tools_0.7.6.4-0ubuntu1_i386.deb and the other is xserver-xorg-input-wacom_0.7.6.4-0ubuntu1_i386.deb.

Plug your tablet, and check if /dev/input/wacom is created/deleted when you plug/unplug. Then edit you /etc/X11/xorg.conf file to point to /dev/input/wacom.

Restart the machine, then see if it works.

If not, try 0.7.4 packages.

If not, try with the default 0.7.2 installed previously - there again, you might have to edit xorg.conf.

Thanks a lot for trying them

I have installed a clean copy of Feisty beta (with updates) on a machine.

I then installed Timo's packages wacom-tools_0.7.6.4-0ubuntu1_i386.deb and xserver-xorg-input-wacom_0.7.6.4-0ubuntu1_i386.deb (with gdebi).

Now what happens is that /dev/input/wacom and /dev/input/tablet-graphire are created, as links to /dev/input/event4 (or whatever event number). I plug the tablet in, they are created, I remove it, they vanish. I believe this is good so far.

If I use sudo wacdump then it works fine for all device names, /dev/input/wacom, /dev/input/tablet-graphire and /dev/input/event4 (or whatever number...). By works fine I mean gives right device name, knows which tool is being used - mouse, pen, eraser - and gives pressure and click information.

Next I edited /etc/X11/xorg.conf so that it points to /dev/input/wacom and restarted the machine. Now I start the Gimp and go to File=>Preferences=>Input Devices and click the Extended Devices button. "No extended input devices" it says. This is very bad...

So unless I have done something stupid (possible of course), the first stage of the process works fine and installs nice consistently named devices that are linked to the tablet, but trying to make the X server make them available to Gimp doesn't work.

Neil

Loïc Martin (loic-martin3) wrote :

No, it's exactly the same here. wacdump sees the tablet, but xidump doesn't (thus neither Gimp nor any other X program can see it).
And the stylus only moves the cursor on part of the screen.

Problem comes from the packages.

BTW, Neil, does the new packages (still 0.7.2) in Feisty's repositories work for you? For me, they produce the same effect as Timo's 0.7.6.4 packages.

Timo Aaltonen (tjaalton) wrote :

please test 0.7.7.7:

http://users.tkk.fi/~tjaalton/dpkg

Loïc: if the current 0.7.2 doesn't work for you, it must be something in the build, and on bug #69163 it was suggested to build it without stack-protector, so these packages are built that way. Hopefully they work.

Timo Aaltonen (tjaalton) wrote :

fixed by this upload (NOTE: the path will be /dev/input/wacom from now on):

 wacom-tools (1:0.7.7.7-0ubuntu1) feisty; urgency=low
 .
   * Merge with Debian unstable, remaining changes:
      - Bump the epoch because of old Ubuntu packaging.
      debian/control:
       - xserver-xorg-input-wacom: Provides xserver-xorg-input.
       - Change the Maintainer address.
      debian/wacom.postinst:
       - Remove old files.
      debian/xserver-xorg-input-wacom.init.d, debian/rules:
       - Initscript for serial devices.
   * debian/xserver-xorg-input-wacom.init.d:
     - Change the device path to /dev/input/wacom
     - Move the initscript from wacom-tools to the driver, so the driver
       doesn't need to depend on wacom-tools.
   * debian/rules:
     - copy the manpage to the builddir before configuration, otherwise
       the build fails.
     - build with -fno-stack-protector.

Changed in wacom-tools:
status: Confirmed → Fix Released

Works for me now with 1:0.7.7-0ubuntu1 under feistly beta, though I still appear to need to edit xorg.conf. I also note that while things are fine with Gimp and extended input devices if the system is booted with the tablet attached, hotplugging a tablet after boot still doesn't seem to make it appear as an extended input device.

Happy to do more testing on this, of course. And delighted to have a useable Wacom available in Gimp, especially pressure sensitivity! Thanks to Timo and others for this.

Neil

Timo Aaltonen (tjaalton) wrote :

Maybe your config had /dev/wacom instead of the new /dev/input/wacom? There was a xorg update soon after wacom-tools was updated, so it should be fixed by now.

Hotplug is still at its infancy, hopefully by feisty+1 wacom-tools supports input-hotplug provided by xorg-server. Now it is just a hack, it seems.

Changed in xorg:
status: Rejected → Fix Released

On Mon, 2007-04-02 at 21:56 +0000, Timo Aaltonen wrote:
> Maybe your config had /dev/wacom instead of the new /dev/input/wacom?

Yes, exactly what it had.

> There was a xorg update soon after wacom-tools was updated, so it should
> be fixed by now.

That's what I was hoping. I'll maybe do another fresh install and check
from scratch again in a couple of days; the basic functions should work
out of the box without having manually edit xorg.conf...

> Hotplug is still at its infancy, hopefully by feisty+1 wacom-tools
> supports input-hotplug provided by xorg-server. Now it is just a hack,
> it seems.

I'll not expect too much of that for now then. Needing to be plugged in
on boot is not as good as hotplugging properly, but for most users most
of the time it is good enough as we don't often change tablets. (By the
way, I noticed links for /dev/input/wacom and /dev/input/[specific
device type name]. Might this allow the use of multiple devices one
day? Or is it intended for auto-configuring the features and quirks of
individual devices?)

Neil

I haven't had the chance to try this yet, and probably will do a new install with Feisty proper, but I just wanted to say a huge thanks to everyone working on and testing this. You guys truly rock, thank you!

Andrew Frank (frank-geoinfo) wrote :

i tried 0.7.7 (and before 0.7.6) on a new install of feisty (image from 2.4.07) on a fujitsu-siemens stylistic tablet PC (wacom is built-in; i think wacom tablett was recognized during installation - i saw some mention of it in the installation output).

i can not see that dev/input/wacom is created - i assume that i would still need to do a setserial.
would i need to issue some xorg reconfiguration command?

what log files would be useful to understand the problem?

thank you for your efforts!
andrew

I've just been trying to test the recent modifications and fixes, by running the Feisty daily build CD from yesterday (Thursday 5th of April).

It still has the old 1:0.7.2-0ubuntu7 versions of wacom-tools and the xserver-xorg-input-wacom and the the xorg.conf file still has /dev/wacom rather than /dev/input/wacom as the device name.

How long before the changes are likely to arrive in Feisty daily builds? I'd like to be able to test them 'out of the box'.

I know that if I install, I will be able to download the 1:0.7.7.7-0ubuntu1 versions of wacom-tools and xserver-xorg-input-wacom (from the normal repositories, so they've got that far) and that if I then edit the xorg.conf device name, all will work fine. So my problem is not whether the fix will work, but whether it will be included in Feisty in time for release.

Neil

I'm glad to say that today's Feisty daily build disc works 'out of the box' with my Wacom Graphire tablet, both in Live CD and installed modes.

No need to edit or download anything, it just works as it should.

Thanks to Timo and others for this.

Neil

Finally had the time to install Feisty, and everything so far works out of the box! Many many many thanks for all the hard work!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers