[Edgy] Consistent segfault when starting wine

Bug #56965 reported by Sami Haahtinen
50
Affects Status Importance Assigned to Milestone
Wine
Fix Released
High
wine (Ubuntu)
Medium
Stephan Rügamer

Bug Description

Latest wine version (0.9.19-0ubuntu1) causes a consistent segfault, even without any existing profiles.

Segfault can be reproduced here by just running wine.

Revision history for this message
Sami Haahtinen (ressu) wrote :
Revision history for this message
Jan Mynarik (jan-mynarik) wrote :

Same problem here, even when starting winecfg.

Revision history for this message
Lobo (108085) wrote :

same probleme here!

Revision history for this message
Vassilis Pandis (pandisv) wrote :

setting status to confirmed...

Changed in wine:
status: Unconfirmed → Confirmed
Revision history for this message
Jan Mynarik (jan-mynarik) wrote :

Also the same with 0.9.19-0ubuntu2.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Confirmed...

I don't get a nice backtrace via gdb...if anyone is able to produce one, please attach it here.

I don't think it's a wine problem, but I think it's more a problem between edgy and wine.

I'm quite busy with work, so I could need a helping hand in investigating this.

Regards,

\sh

Changed in wine:
assignee: nobody → shermann
importance: Untriaged → Medium
Revision history for this message
Dave Hall (skwashd) wrote :

another me too :( no backtrace, but attached is my crash report

Revision history for this message
Laurent (laurent-goujon) wrote :

Get also the same backtrace. The crashed program is not in fact wine itself but wine-preloader.
By the way I had a working version of wine 0.9.17 under edgy but now it always segfaults in function maps_so_libs. Maybe some changes in libc6 ?

Revision history for this message
Richard Samson (richard) wrote :

I tried to build wine 0.9.19 with gcc-3.4, it didn't segfault.
With default gcc (version 4.1.2 20060817) I got the same backtrace.

Revision history for this message
Laurent (laurent-goujon) wrote :

Same thing for me. No crash when compiled with gcc 3.4

Here's a stack trace with gcc 4.1
#0 0x7c00028a in map_so_lib (name=Cannot access memory at address 0xffbab804
) at preloader.c:520
#1 0x7c000bbe in wld_start (stack=0xffbac374) at preloader.c:1019
#2 0x7c000010 in _start () at preloader.c:159

Revision history for this message
Ulf Karlsson (ohmega) wrote :

The problem seems to be that the %gs register that holds the thread local stack is not setup correctly since the normal _start function is not use in wine-preloader. The stack protector uses the %gs register and the stack protector is enabled by -fstack-protector.

If you compile the wine-preloader with -fno-stack-protector it will thus not cause segmentation fault.

Revision history for this message
In , Scott Ritchie (scottritchie) wrote :

https://launchpad.net/distros/ubuntu/+source/wine/+bug/56965

Found on the Ubuntu bug reports:

"The problem seems to be that the %gs register that holds the thread local stack
is not setup correctly since the normal _start function is not use in
wine-preloader. The stack protector uses the %gs register and the stack
protector is enabled by -fstack-protector.

If you compile the wine-preloader with -fno-stack-protector it will thus not
cause segmentation fault."

"The real fix is to correct the wine-preloader to follow proper
convention, I assume. For now turn off the stack protector as a
work-around and file a bug with the wine devs."

Revision history for this message
In , Mike-codeweavers (mike-codeweavers) wrote :

The point of wine-preloader is to map memory before glibc is initialized, so we
can't call anybody else's code before our own. If your gcc now requires %gs to
be initialized, then you use -fno-stack-protector to compile wine-preloader.

I'm using "gcc version 4.1.2 20060814 (prerelease) (Debian 4.1.1-11)" and it
works fine for me, so I guess Ubuntu must have broken things somehow.

Revision history for this message
John Moser (nigelenki) wrote : Re: [Bug 56965] Re: [Edgy] Consistent segfault when starting wine

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Ulf Karlsson wrote:
> The problem seems to be that the %gs register that holds the thread
> local stack is not setup correctly since the normal _start function is
> not use in wine-preloader. The stack protector uses the %gs register and
> the stack protector is enabled by -fstack-protector.
>
> If you compile the wine-preloader with -fno-stack-protector it will thus
> not cause segmentation fault.

The real fix is to correct the wine-preloader to follow proper
convention, I assume. For now turn off the stack protector as a
work-around and file a bug with the wine devs.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIVAwUBROvXuQs1xW0HCTEFAQIWlBAAnfOv1olg1bqg09S/DjlION+rLjeyHujx
9Uwar+qArFrBPcDbXso3HvRT3FlJo7Ys/UHR1Wq7/yBQeL7QeBXp/EZ9a+qJ75eE
yDXi7FxngGJtZzChVxW2WVKoEr2NDppHQ9n2P9QouPvmpkqefzNWMjGlrqDKAQGT
6GdFEkr1T2hiVSBpAq2CKgjJgrbiBFxkTxIDh+Jpk4d/KWZ7MeutkZzRytyteWpg
i+1PNedVgzG4cX9zmqvYApluRk52+yyFCmM29YjqiDSONbM0lFtUuiwP5kxOgrXe
j6U41Mi7eB777Uycf+hi2lki8eA7Iv7IB0f64ZQnIt97xWV5XCXA4L1OveT4J6xO
henuvbfggDfRnY8Cl4rB2Bakqk875mIsiKQB/XkUUbLBzHh6wmb8vImneoCk7lMq
P3xw2RjMaHg55pwWru4IgWl2R2SOMIUIuzw75r6hkW1Q1+8ttklGqCdzsmHktpwA
96Pfk2J+3A4/DrLDRh+T55Ymp6+ArOoi4QmZw+S8Y/6MyUhfGLSQus+hssBH2qU1
XUnlJ45YMvGAUPD263VUAt/jkgXfIcBecRGmWMP6FKcXQ2muXgrtCvqtbmZia5Dd
CJQDaeT24JgmTsJlv2QexqLksfAL909kWpLfQ8a70sME0E4RgiZxi0RTGc9GohkR
hK4xmmer+bU=
=tEKg
-----END PGP SIGNATURE-----

Revision history for this message
Yuriy Kozlov (yuriy-kozlov) wrote :

I can confirm that this happens on Edgy, while the package works fine on dapper. IIRC 0.9.19-0ubuntu1 and earlier worked for me, but it broke with 0.9.19-0ubuntu2. Compiling the wine source (without any special options) has given me the segfaults with source from before 0.9.19 came out.

Revision history for this message
Scott Ritchie (scottritchie) wrote :

Bug has been reported upstream.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

I'll upload a fix just now.
wine (0.9.19-0ubuntu3) edgy; urgency=low

  * debian/rules: Added -fno-stack-protector to CFLAGS to fix segmentation
    faults (Closes: lp #56965)

 -- Stephan Hermann <email address hidden> Wed, 23 Aug 2006 13:15:31 +0200

Changed in wine:
status: Confirmed → Fix Committed
Revision history for this message
Yuriy Kozlov (yuriy-kozlov) wrote :

Insructions for those of us compiling from source? (GIT/CVS) Where does this flag need to go?

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Hi,

in CFLAGS :)

\sh

Changed in wine:
status: Unknown → Unconfirmed
Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Strange thing is, I found this entry in the wine changelog:

24774 2006-01-26 Mike McCormack <email address hidden>
24775
24776 * loader/preloader.c:
24777 preloader: Allow compiling the preloader with -fstack-protector.

Revision history for this message
Scott Ritchie (scottritchie) wrote :

Hmm, Mike doesn't seem to think anything's broken upstream (rather something in Ubuntu that isn't in Debian)... perhaps we could get to the bottom of this.

Revision history for this message
Ulf Karlsson (ohmega) wrote :

The stack-protector is turned on by default in the ubuntu gcc. Look at the patch in gcc-4.1-4.1.1/debian/patches/gcc-ssp-default.dpatch. I doubt the upstream wine would compile compile with vanilla gcc with the stack-protector turned on.

Revision history for this message
In , Scott Ritchie (scottritchie) wrote :

Mike, are you sure the stack protector is turned on in the GCC you're using? I
think it might not be in Debian but is in Ubuntu. There's some more information
in the launchpad thread linked above, as well.

Revision history for this message
In , Mike-codeweavers (mike-codeweavers) wrote :

No, my gcc doesn't have -fstack-protector turned on.

The point is, we can't setup %gs in wine-preloader, so if -fstack-protector
depends on that, we can't use it for wine-preloader.

If the stack protector code assumes that a program is linked with glibc (which
is unreasonable, imo) then it can't be used with wine-preloader.

If Ubuntu uses -fstack-protector by default, you have to find some way to turn
it off.

Revision history for this message
In , Alexandre Julliard (julliard) wrote :

There's no reason we can't setup the proper environment in wine-preloader,
including setting %gs if necessary. All we need is to figure out what
stack-protector expects.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Wine doesn't segfault anymore...-fno-stack-protector is now the default compile option until fix is commited from upstream.

Changed in wine:
status: Fix Committed → Fix Released
Revision history for this message
Nemes Ioan Sorin (nemes-sorin) wrote :

I have to confirm.

Wine still kil Nautilius Desktop.

Never under Dapper.

I use Macromedia Flash 8 ( wich work perfect on all directions - I mean everything works, no missing functionality ( except a slow mouse motion for large FLA files, and slow redraw for some UI boxes - but this is wine related) ).

What's new for Edgy.

Sometimes, starting wine - entire Desktop die -> must re-login.
Not allways - let say 1 from 4.

Also strange behavior regarding saved files.
Some .FLA files can not be opened under windows, if I save them under Edgy. Back to Edgy I can open all those files - work on them - save / export on .SWF.

this sound like a binary incompatibility ( ).

No problem of this kind with Wine under Dapper.

Seems to be Edgy related OR Gnome not Wine ( at least for me ).

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Nemes,

could you please test latest feisty upload of wine (0.9.25) if this happens again?

Regards,

\sh

Revision history for this message
Nick Cronin (quintok) wrote : Re: [Bug 56965] Re: [Edgy] Consistent segfault when starting wine

Stephan,
I believe 0.9.26 is out.
Also incase your unaware Nemes to check what version type 'wine --version'
it should say something like 'wine-0.9.26'
-Nick

On 11/29/06, Stephan Hermann <email address hidden> wrote:
>
> Nemes,
>
> could you please test latest feisty upload of wine (0.9.25) if this
> happens again?
>
> Regards,
>
> \sh
>
> --
> [Edgy] Consistent segfault when starting wine
> https://launchpad.net/bugs/56965
>

Revision history for this message
Nemes Ioan Sorin (nemes-sorin) wrote :

Mr. Herman,

I'm inside Ubuntu movement to help, but for now I just not upgrade my box to
Feisty.

I need some help to upgrade to Feisty from Internet ( unfortunately my home
dir. IS IN Ubuntu partition not outside - to perform a clean install of
Ubuntu 7 ).

Maybe a path to Ubuntu Feisty repo's can help.

Work for next Ubuntu advance fast, but if Wine will be considered as a
strong key for Ubuntu - we need a Wine - Ubuntu dedicated team to
perform specific tests, to find answers.

Unfortunately not many peoples work now with ( Adobe ) Macromedia Studio 8
products under Wine, even that a lot are interested.

I am one of them - I want to cooperate - I find only 2-3 annoyances (not
bugs) for Dreamweaver, Flash, Fireworks.. such as slow rendering of UI
elements after I boxes movement on the screen and some listboxes that not
respond at mouse click ( on FIreworks 8).

That's all that I find, else all work great, almost perfect. But now
working with Edgy I observe FLA files saved under Ubuntu .. dont work
in Windows - back to Ubuntu work again. This never happen with Dapper. And
this is strange. Other guys working under other Linux distributions with
Flash 8 did not observe that. So is an Ubuntu specific bug, not wine.
Other strange thing on Edgy -> sometime programs started with WIne - crash
Nautilius Desktop -> from wine 0.9.24 to last wine 0.9.26. This is not so
easy to reproduce - is a random crash - only when he want ( ! ).

I will test wine for feisty - but for now my only Wine repo' is for Edgy.
My wine version : 0.9.26.

If you can provide me a link or an adress to set one repository
for Wine ( on Feisty ) - will help me.

On the other hand, I will request some help from Wine guys - maybe is better
to slow development in favor of fix problems before next step ;). Hope they
will have time to fix rendering problems. On the same time I hope a stable
Gnome Desktop for Feisty, not just fancy bells, because I dream in one day
to implement here Ubuntu for production Office / DTP / Design for Web.

Good Luck.

2006/11/29, Stephan Hermann <email address hidden>:
>
> Nemes,
>
> could you please test latest feisty upload of wine (0.9.25) if this
> happens again?
>
> Regards,
>
> \sh
>
> --
> [Edgy] Consistent segfault when starting wine
> https://launchpad.net/bugs/56965
>

--
Nemes Ioan Sorin

Revision history for this message
Scott Ritchie (scottritchie) wrote :

By the time Feisty comes out, Wine should have made a 1.0 release that underwent a bunch of stability testing.

This gives us a pretty big opportunity to have a seriously awesome Wine in Feisty.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Nemes,

Feisty archives are:

deb http://archive.ubuntu.com/ubuntu feisty main restricted universe multiverse

if you are running edgy, just put them into /etc/apt/sources.list and do a

sudo apt-get update
sudo apt-get dist-upgrade

But be warned, feisty is the actual development version.

When you are running 0.9.26 of wine, you are using the version from winehq (scotts native packages), which are not the same as the feisty packages.

Regards,

\sh

Revision history for this message
Nemes Ioan Sorin (nemes-sorin) wrote :

I will try Feisty because (still) I use XP for production.

I am interested in a stable Wine, Stable Gnome - how else I can present /
recomand Ubuntu for my local / central authorities - [ by the way I am from
Romania and work now for costmoon.com ] - we need linux in public space,
almost 95% peoples from public institutions do not use special functions
from MS Office - so no reason for my country to [ still ] pay 50 millions
per year to Microsoft, is ok with 2 millions for Excel special cases ..but
not 50 for only writing sample .doc's and use Outlook for mail ;) I see
how a single attack on a single day [ Love Letter ] ruin a network on my
city hall ?.

I think is better to start testing wine under Feisty (and Feisty under
..hmm Feisty) because there will be the main focus on development + that has
more logic. Also we dont have time to spent ;). Second reason : I have a lot
( I mean a big "lot" ) of punctual proposals for next 2 or 3 Ubuntu
versions.

Little things that need to be fixed first such as icons / themes on apps.
and files, then UI Usability issues [ controls position logic, buttons
values, etc ], then.. new functionality for Gnome Desktop and File Manager.

Wish me luck with upgrade.
News after Feisty first boot.

Best regards to all.

Sorin

2006/11/30, Stephan Hermann <email address hidden>:
>
> Nemes,
>
> Feisty archives are:
>
> deb http://archive.ubuntu.com/ubuntu feisty main restricted universe
> multiverse
>
> if you are running edgy, just put them into /etc/apt/sources.list and do
> a
>
> sudo apt-get update
> sudo apt-get dist-upgrade
>
> But be warned, feisty is the actual development version.
>
>
> When you are running 0.9.26 of wine, you are using the version from winehq
> (scotts native packages), which are not the same as the feisty packages.
>
>
> Regards,
>
> \sh
>
> --
> [Edgy] Consistent segfault when starting wine
> https://launchpad.net/bugs/56965
>

--
Nemes Ioan Sorin

Revision history for this message
Scott Ritchie (scottritchie) wrote :

Yes, I should start making Feisty packages at some point soon.

Revision history for this message
Nemes Ioan Sorin (nemes-sorin) wrote : Re: [Bug 56965]

Scott,

I use right now wine 0.9.26-0ubuntu1 wich are marked as wine
0.9.26-0ubuntu1(feisty)
in repository

I just upgrade to Feisty.

Better ( even beta ) than Edgy - wich make me crazzy. Gnome is far more
stable using the same apps. also Wine did not crash at start. Nautilius
- no single crash yet.

in short :
- Fireworks8 speed is better - no crash at launch - fonts look ok.
- Flash8 speed is slow for large .FLA files, with multiple objects inside -
this is to repair ( ). On windows I think Flash8 can handle this situation
( hundreds of objects - stage mc's, library items, compiled clips, flash
components ) with specific methods ( and we need to find wich native .dll's
must be used instead of wine dll's ).
- Dreamweaver8 work without a glitch.

This evening I will test if files that i made under Ubuntu will work fine on
WIndows. FLA files that I made with Flash under Edgy can not be opened under
XP, or when I open these files I observe some objects are missing.

More news about wine under Feisty soon.

best regards to all, keep up good work.

Sorin

2006/12/2, Scott Ritchie <email address hidden>:
>
> Yes, I should start making Feisty packages at some point soon.
>
> --
> [Edgy] Consistent segfault when starting wine
> https://launchpad.net/bugs/56965
>

--
Nemes Ioan Sorin

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Yes,

new wine version 0.9.26 is now in feisty :)

Revision history for this message
In , Vitaliy-bugzilla (vitaliy-bugzilla) wrote :

*** Bug 7028 has been marked as a duplicate of this bug. ***

Revision history for this message
Manni (ubuntu-lxxi) wrote :

Since updating to feisty, I get the consistent segfault behavior, too. Nothing I can do, it seems. Neither wine 0.9.33 nor the slighty newer version from the wineHQ repository runs.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Dear people,

please remove your $HOME/.wine directory. It is normal start wine doesn't start up properly with old registries etc.

Thx,

\sh

Revision history for this message
Manni (ubuntu-lxxi) wrote :

Removing ~/.wine was one of the first things I tried. It didn't help one bit.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

Manni,

please do me a favour, use winedbg for debugging and send me a backtrace.
Please leave this bug alone, just because it has nothing to do with your problem.

Please open a new report for your special problem....

Thx a lot for your help,

\sh

Revision history for this message
In , Scott Ritchie (scottritchie) wrote :

Is there an update on this bug? Does Wine still segfault with -fstack-protector
turned on?

Revision history for this message
In , Joel Parker (jjkp) wrote :

I just built wine-0.9.37 on Feisty with gcc (GCC) 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
with -fstack-protector explicitly enabled and it's working fine. So unless I'm
missing something major, this isn't a problem anymore.

Revision history for this message
In , James Hawkins (truiken) wrote :

Reported fixed.

Changed in wine:
status: Unconfirmed → Fix Released
Revision history for this message
In , Dan Kegel (dank) wrote :

Closing all RESOLVED FIXED bugs that have not changed in over six months.

Changed in wine:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.