Change log for wmanager package in Ubuntu

122 of 22 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-07-29
Deleted in groovy-proposed (Reason: moved to Release)
wmanager (0.3.0-1) unstable; urgency=medium

  * Declare compliance with Policy 4.5.0 with no changes.
  * Add the year 2020 to my debian/* copyright notice.
  * Drop the Name and Contact upstream metadata fields.
  * New upstream release:
    - allow an equals sign in the window manager path
    - include a runtime test for the wmanager program
  * Run the upstream test during the build, adding the necessary
    build dependencies (cnee, python3, x11-utils, xauth, xvfb).
  * Add an autopkgtest invoking the upstream runtime test.
  * Bump the debhelper compatibility level to 13 with no changes.

 -- Peter Pentchev <email address hidden>  Thu, 16 Jul 2020 00:14:25 +0300
Superseded in groovy-release on 2020-07-29
Published in focal-release on 2020-03-23
Deleted in focal-proposed (Reason: moved to Release)
wmanager (0.2.2-5build1) focal; urgency=medium

  * No-change rebuild for libgcc-s1 package name change.

 -- Matthias Klose <email address hidden>  Sun, 22 Mar 2020 17:03:16 +0100
Superseded in focal-release on 2020-03-23
Published in eoan-release on 2019-04-21
Deleted in eoan-proposed (Reason: moved to release)
wmanager (0.2.2-5) unstable; urgency=medium

  * Switch to a DEP-14 debian/master branch.

 -- Peter Pentchev <email address hidden>  Wed, 27 Feb 2019 15:22:07 +0200

Available diffs

Superseded in eoan-release on 2019-04-21
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed on 2020-07-14 (Reason: moved to release)
wmanager (0.2.2-4) unstable; urgency=medium

  * Declare compliance with Debian Policy 4.3.0 with no changes.
  * Bump the debhelper compatibility level to 12 with no changes.
  * Add the year 2019 to my debian/* copyright notice.
  * Add a trivial git-buildpackage config file.

 -- Peter Pentchev <email address hidden>  Wed, 16 Jan 2019 17:40:09 +0200

Available diffs

Superseded in disco-release on 2019-01-17
Deleted in disco-proposed on 2019-01-18 (Reason: moved to release)
wmanager (0.2.2-3) unstable; urgency=medium

  * Use my Debian address as maintainer.
  * Drop the two blank lines at the end of the debian/changelog file.
  * Use the B-D: debhelper-compat (= 11) mechanism.
  * Bring up to compliance with Debian Policy 4.2.1: install the HISTORY
    file as NEWS, not changelog, and no longer install the long, long
    outdated upstream NEWS file.
  * Minimize the upstream signing key, only keep the <email address hidden> UID.

 -- Peter Pentchev <email address hidden>  Sun, 16 Dec 2018 02:18:54 +0200

Available diffs

Superseded in disco-release on 2018-12-16
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2018-01-23
Deleted in bionic-proposed (Reason: moved to release)
wmanager (0.2.2-2) unstable; urgency=medium

  * Upgrade the watch file to version 4 of the format and use
    substitution variables.
  * Bump the year on my debian/* copyright notice.
  * Declare compliance with Debian Policy 4.1.3 with no changes.
  * Remove trailing whitespace from an old changelog entry.
  * Bump the debhelper compatibility level to 11 with no changes.
  * Add "Rules-Requires-Root: no" to the source control stanza and
    override the upstream Makefile's install(1) invocations.

 -- Peter Pentchev <email address hidden>  Tue, 09 Jan 2018 16:25:26 +0200

Available diffs

Superseded in bionic-release on 2018-01-23
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2020-07-10 (Reason: moved to release)
wmanager (0.2.2-1) unstable; urgency=medium

  * Point the Vcs-* fields to my new full-source GitLab repository.
  * Declare compliance with Debian Policy 3.9.8 with no changes.
  * Bump the year on my debian/* copyright notice.
  * Point the watch file to wmanager's new home at the Ringlet website
    and add the upstream PGP key to check against.
  * Let the watch file recognize wmanager release candidate versions.
  * Bump the debhelper compatibility level to 10 and drop the --parallel
    option, it's on by default now.
  * Point the homepage, the upstream metadata file, and the copyright
    file's Source header field to the new Ringlet website.
  * Switch the copyright format specification URL to the HTTPS scheme.
  * New upstream release:
    - drop all the patches, integrated upstream
    - update the upstream copyright information
    - drop the manual page and the wmanager-loop and wmanagerrc-update
      tools, they were imported into the upstream distribution

 -- Peter Pentchev <email address hidden>  Fri, 04 Nov 2016 01:03:04 +0200

Available diffs

Superseded in zesty-release on 2016-11-04
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-01-13
Deleted in xenial-proposed (Reason: moved to release)
wmanager (0.2.1-14) unstable; urgency=medium

  * Remove the manual update-menus calls in the postinst and postrm
    scripts; the debhelper snippets will take care of this.
    Incidentally, the manual invocations break with "set -e" if
    update-menus is not installed; Closes: #810336

 -- Peter Pentchev <email address hidden>  Tue, 12 Jan 2016 13:21:33 +0200

Available diffs

Superseded in xenial-release on 2016-01-13
Deleted in xenial-proposed on 2016-01-14 (Reason: moved to release)
wmanager (0.2.1-13) unstable; urgency=medium

  * Bump the debhelper compatibility level to 9:
    - use debhelper's invocation of dpkg-buildflags, drop the versioned
      build dependency on dpkg-dev
    - use dpkg-buildflags's hardening flags, drop the build dependency
      on hardening-includes
  * Add the 05-strdup patch, replacing two unguarded uses of strcpy()
    with strdup().  Arguably the strcpy() uses were safe enough, but
    there's no harm in using strdup() and removing a Lintian warning.
  * Bump Standards-Version to 3.9.6:
    - drop the DM-Upload-Allowed field
  * Split the DEP-3 author information into several Author fields for
    the patches with multiple authors.
  * Update the copyright file to the 1.0 format and bump the years of
    my Debian packaging copyright notice.
  * Rewrite wmanagerrc-update in pure Perl, replace the perl5 and chase
    dependencies with perl:Depends.  Incidentally, Closes: #808387
  * Drop the version from the 'menu' suggestion, satisfied in oldstable.
  * Add the debian/upstream/metadata file.
  * Add Multi-Arch: foreign to the binary package.
  * Drop the source compression options; dpkg-dev's defaults are good enough.
  * Add --parallel to the debhelper invocation.
  * Switch the Vcs-Git and Vcs-Browser URLs to my GitLab repository.
  * Do not use the full path to update-menus.

 -- Peter Pentchev <email address hidden>  Sat, 19 Dec 2015 16:23:54 +0200

Available diffs

Superseded in xenial-release on 2015-12-20
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
wmanager (0.2.1-12) unstable; urgency=medium


  * Do not use the obsolete and incorrect full path to update-alternatives
    in wmanagerrc-update.  Closes: #769966
    Thanks, Guillem Jover <email address hidden>

 -- Peter Pentchev <email address hidden>  Thu, 27 Nov 2014 10:52:01 +0200

Available diffs

Superseded in vivid-release on 2014-11-28
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
wmanager (0.2.1-11) unstable; urgency=low

  * Update the copyright file to the latest DEP 5 candidate format.
  * Upload to unstable.

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
wmanager (0.2.1-9) unstable; urgency=low

  * Bump Standards-Version to 3.9.1 with no changes.
  * Let wmanagerrc-update use update-alternatives --query, not --display,
    to fix its operation with non-English text.  Closes: #605043
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  03 Dec 2010 16:48:47 +0000

Available diffs

Superseded in natty-release on 2010-12-03
wmanager (0.2.1-8) unstable; urgency=low
  
  * Bump Standards-Version to 3.9.0 with no changes.
  * Convert to the 3.0 (quilt) source format.
  * Use dpkg-buildflags from dpkg-dev 1.15.7 to obtain the default values
    for CXXFLAGS, CPPFLAGS, and LDFLAGS.
  * Simplify the rules file by exporting variables into the environment.
  * Update the copyright file to the latest revision of the DEP 5 format and
    bump the years on my copyright format.
  * Shorten the Vcs-Browser URL.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 10:05:58 +0000

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
wmanager (0.2.1-7) unstable; urgency=low

  * Let wmanager-loop honor the WM environment variable, if set, to
    specify the first window manager to run.
  * Bump the debhelper version dependency to 7.0.50 because of the use
    of override targets.
  * Bump Standards-Version to 3.8.3 with no changes.
  * Switch the copyright file header from the Wiki page to DEP 5 and
    shorten the file by breaking out the GPL-2+ blurb into its own block.
  * Actually implement the "patch" and "unpatch" targets in the rules file
    since the dh(1) tool does not always provide them.
  * Convert the patch file headers to DEP 3.
  * Only enable the build hardening wrapper if "hardening" is specified
    in DEB_BUILD_OPTIONS.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  06 Nov 2009 10:40:24 +0000

Available diffs

Superseded in lucid-release on 2009-11-06
Obsolete in karmic-release on 2013-03-04
wmanager (0.2.1-6) unstable; urgency=low

  * Switch to quilt for patch management:
    - change the patches' naming scheme
    - reformat the comment headers
    - update the README.source file
    - use the quilt plugin for debhelper in the rules file
  * Refresh the copyright file a bit:
    - move the homepage from Original-Source-Location to the control file's
      Homepage field.
    - remove the redundant Packaged-By and Packaged-Date fields
    - bump the CopyrightFormat proposal revision a bit
    - bump the year of my copyright notice for the Debian packaging
  * Add misc:Depends to the binary package.
  * Bump Standards-Version to 3.8.2 with no changes.
  * Move the various lists of installed files to debian/wmanager.*
  * Update a comment in the rules file - GCC 4.3 is the default now :)
  * Remove some cruft from the rules file.
  * Minimize the rules file using debhelper override targets.
  * Add the Vcs-Svn and Vcs-Browser control fields.
  * Make the short description a noun phrase.

 -- Bhavani Shankar <email address hidden>   Mon,  13 Jul 2009 20:12:40 +0100

Available diffs

Superseded in karmic-release on 2009-07-13
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
wmanager (0.2.1-5ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes (LP: #255506):
    - debian/control: Add libxext-dev in Build-Depends.

Available diffs

Superseded in intrepid-release on 2008-08-07
Obsolete in hardy-release on 2015-04-24
wmanager (0.2.1-3ubuntu1) hardy; urgency=low

  * Merge from Debian unstable, remaining changes:
    - debian/control:
      + Add libxext-dev in B-D.
      + Update maintainer field.

Superseded in hardy-release on 2008-01-21
Obsolete in gutsy-release on 2011-09-16
wmanager (0.2.1-2.1ubuntu2) gutsy; urgency=low

  * Remove superfluous debian/changelog.mine file. Hmph.

 -- Steve Kowalik <email address hidden>   Thu, 30 Aug 2007 10:14:49 +1000
Superseded in gutsy-release on 2007-08-30
wmanager (0.2.1-2.1ubuntu1) gutsy; urgency=low

  * Add libxext-dev to Build-Depends.
  * Munge Maintainer field as per spec.

 -- Steve Kowalik <email address hidden>   Thu, 30 Aug 2007 00:04:14 +1000
Superseded in gutsy-release on 2007-08-29
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
wmanager (0.2.1-2.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Medium-urgency upload for RC bugfix.
  * Rebuild for the C++ ABI transition.  Closes: #328176.

 -- Steve Langasek <email address hidden>  Thu, 22 Sep 2005 02:15:48 -0700
Obsolete in breezy-release on 2008-03-25
wmanager (0.2.1-2build1) breezy; urgency=low


  * Rebuild for new C++ ABI

 -- Matthias Klose <email address hidden>  Tue,  7 Jun 2005 14:25:07 +0000
Obsolete in hoary-release on 2008-03-19
Obsolete in warty-release on 2008-01-09
wmanager (0.2.1-1) unstable; urgency=low


  * New upstream release
  * Build-depend on libfltk1.1-dev. Closes: #192257, #191982.
  * Provide a menu-method that updates /etc/X11/wmanagerrc, make wmanager
    fall back to that if ~/.wmanagerrc does not exist. Closes: #117591.
  * Contributions from Andreas Rottmann <email address hidden>:
     - fixed debian/copyright to avoid lintian warning.
     - bumped Standards-Version.
     - adapt Interface destructor for fltk 1.1 (fixes segfault).

 -- Tommi Virtanen <email address hidden>  Sun, 11 May 2003 17:34:49 +0300
122 of 22 results