Change log for wmcoincoin package in Ubuntu

112 of 12 results
Published in eoan-release on 2019-07-29
Deleted in eoan-proposed (Reason: moved to release)
wmcoincoin (2.6.4-git-2) unstable; urgency=medium

  [ Doug Torrance ]
  * Update Vcs-* after migration to Salsa.
  * Update Format in d/copyright to https.
  * Switch Priority from extra to optional.

  [ Jeremy Sowden ]
  * Added patch to prevent seg-fault in wmcoincoin_player (closes: #716463).
  * Bumped compat to 12 and replaced d/compat with b-d on debhelper-compat.
  * Removed explicit request for dh_autoreconf.
  * Removed build-deps on dh-autoreconf and autotools-dev.
  * Updated uploaders.
  * Enable hardening.
  * Bumped Standards-Version to 4.4.0.

 -- Jeremy Sowden <email address hidden>  Sun, 28 Jul 2019 12:51:42 +0100
Superseded in eoan-release on 2019-07-29
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-04-05
Deleted in bionic-proposed (Reason: moved to release)
wmcoincoin (2.6.4-git-1build1) bionic; urgency=high

  * No change rebuild to pick up -fPIE compiler default

 -- Balint Reczey <email address hidden>  Tue, 03 Apr 2018 12:50:42 +0000
Superseded in bionic-release on 2018-04-05
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-25
Deleted in xenial-proposed (Reason: moved to release)
wmcoincoin (2.6.4-git-1) unstable; urgency=medium

  * New upstream release.
  * debian/control
    - Update Vcs-* fields.
    - Set Debian Window Maker Team as Maintainer; move myself to
      Uploaders with updated email address.
    - Tidy up using wrap-and-sort.
  * debian/copyright
    - Update email address.
  * debian/install
    - Sort lines alphabetically.

 -- Doug Torrance <email address hidden>  Fri, 28 Aug 2015 13:23:43 -0400

Available diffs

Superseded in xenial-release on 2015-10-25
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
wmcoincoin (2.6.2+20150325-1) unstable; urgency=medium


  * New upstream release (git snapshot).
    - Remove timestamp macro; builds should now be reproducible.

 -- Doug Torrance <email address hidden>  Wed, 25 Mar 2015 20:52:04 -0500
Superseded in wily-release on 2015-05-08
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
wmcoincoin (2.6.2+20141120-1) unstable; urgency=medium


  * New upstream release (git snapshot).
  * debian/patches
    - Remove directory; patches applied upstream.
  * debian/rules
    - Append "-Wl, --as-needed" to LDFLAGS; avoids "useless dependency"
      warnings from dpkg-shlibdeps.

 -- Doug Torrance <email address hidden>  Sun, 23 Nov 2014 18:33:40 -0600
Superseded in vivid-release on 2014-11-24
Deleted in vivid-proposed on 2014-11-26 (Reason: moved to release)
wmcoincoin (2.6.2+20140602-1) unstable; urgency=medium


  * New upstream release (git snapshot).
  * New maintainer (Closes: #765837).
  * debian/compat
    - Bump to 9.
  * debian/clean
    - New file; clean files generated by autotools.
  * debian/control
    - Bump versioned dependency on debhelper to >=9.
    - Bump Standards-Version to 3.9.6.
    - Add Homepage, Vcs-* fields.
    - Add dh-autoreconf and libxmu-dev to Build-Depends.
    - Remove libice-dev, libsm-dev, and libxft2-dev from Build-Depends.
    - Add ${misc:Depends} to Depends.
  * debian/copyright
    - Update machine-readable format v1.0.
  * debian/menu
    - Update section.
  * debian/patches
    - (autotools_fixes.patch) Various autotools fixes.
    - (fix_x11_include.patch) Fix FTBFS on amd64.  Thanks to Andreas Moog
      <email address hidden> (Closes: #735755).
    - (format-security.patch) Fix -Werror=format-security compiler errors.
    - (fix_spelling.patch) Fix spelling-error-in-binary Lintian warnings.
    - (implicit-function-declaration.patch, incompatible_pointer_type.patch,
      int-to-pointer-cast.patch, maybe-uninitialized.patch, parentheses.patch,
      pointer-to-int-cast.patch, sign-compare.patch,
      sizeof-pointer-memaccess.patch, type-limits.patch,
      unused-but-set-parameter.patch, unused-but-set-variable.patch,
      unused-parameter.patch, unused-result.patch, unused-variable.patch) Fix
      compiler warnings.
    - (incompatible_struct_type.patch) Reorder #includes to get compatible types
      of struct re_pattern_buffer.  Thanks to Michael Tautschnig <email address hidden>
      (Closes: #702439).
  * debian/rules
    - Add get-orig-source target.
    - Update to use dh.
    - Add override_dh_install target; move and delete various files.
  * debian/source/format
    - New file; use 3.0 (quilt).
  * debian/watch
    - New file; obtained from sepwatch.

 -- Doug Torrance <email address hidden>  Sat, 25 Oct 2014 00:05:20 -0500
Superseded in vivid-release on 2014-10-28
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
wmcoincoin (2.5.1e-1) unstable; urgency=low

  * New upstream release

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
wmcoincoin (2.5.1d-2) unstable; urgency=low

  * Remove the build-dependency on xlibs-static-dev, use libxinerama-dev 
    instead.
  * Add missing build-dependency on libxft-dev.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 16:10:54 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
wmcoincoin (2.5.1d-1) unstable; urgency=low


  * New upstream release to fix the annoying "poufpouf" bug.

 -- Josselin Mouette <email address hidden>  Sat, 15 Oct 2005 17:33:27 +0200
Obsolete in breezy-release on 2008-03-25
wmcoincoin (2.5.0g-1) unstable; urgency=low


  * New upstream release
  * debian/rules: pass --as-needed to ld, to deflate dependencies.

 -- Josselin Mouette <email address hidden>  Tue, 14 Jun 2005 23:41:37 +0200
Obsolete in hoary-release on 2008-03-19
wmcoincoin (2.5.0c-2) unstable; urgency=medium


  * debian/control: build-depend on libxt-dev (closes: #266271).

 -- Josselin Mouette <email address hidden>  Tue, 17 Aug 2004 13:39:26 +0200
Obsolete in warty-release on 2008-01-09
wmcoincoin (2.5.0c-1) unstable; urgency=low


  * New upstream release.
  * debian/wmcoincoin.sh: launch the binary with $0=wmcoincoin.

 -- Josselin Mouette <email address hidden>  Mon, 17 May 2004 11:38:03 +0200
112 of 12 results