wpa 2.4-0ubuntu3.2 source package in Ubuntu

Changelog

wpa (2.4-0ubuntu3.2) wily-security; urgency=medium

  * SECURITY UPDATE: unauthorized WNM Sleep Mode GTK control
    - debian/patches/CVE-2015-5310.patch: Ignore Key Data in WNM Sleep Mode
      Response frame if no PMF in use in wpa_supplicant/wnm_sta.c.
    - CVE-2015-5310
  * SECURITY UPDATE: EAP-pwd missing last fragment length validation
    - debian/patches/CVE-2015-5315-1.patch: Fix last fragment length
      validation in src/eap_peer/eap_pwd.c.
    - debian/patches/CVE-2015-5315-2.patch: Fix last fragment length
      validation in src/eap_server/eap_server_pwd.c.
    - CVE-2015-5315
  * SECURITY UPDATE: EAP-pwd peer error path failure on unexpected Confirm
    message
    - debian/patches/CVE-2015-5316.patch: fix error path in
      src/eap_peer/eap_pwd.c.
    - CVE-2015-5316
  * This package does _not_ contain the changes from 2.4-0ubuntu3.1 in
    wily-proposed.

 -- Marc Deslauriers <email address hidden>  Mon, 09 Nov 2015 06:52:23 -0600

Upload details

Uploaded by:
Marc Deslauriers on 2015-11-09
Uploaded to:
Wily
Original maintainer:
Ubuntu Developers
Architectures:
linux-any kfreebsd-any
Section:
net
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
wpa_2.4.orig.tar.xz 1.7 MiB a1e4eda50796b2234a6cd2f00748bbe09f38f3f621919187289162faeb50b6b8
wpa_2.4-0ubuntu3.2.debian.tar.xz 85.1 KiB 042e6c42853228ea12d1aaaf85988b040fe0471bff3b4fedc2532fe30d494f12
wpa_2.4-0ubuntu3.2.dsc 2.5 KiB a82a31bd7e96abe62bbf151e1cb544270d950e9d4ab7c020ee2e9020f899a003

View changes file

Binary packages built by this source

hostapd: No summary available for hostapd in ubuntu wily.

No description available for hostapd in ubuntu wily.

hostapd-dbgsym: No summary available for hostapd-dbgsym in ubuntu wily.

No description available for hostapd-dbgsym in ubuntu wily.

wpagui: No summary available for wpagui in ubuntu wily.

No description available for wpagui in ubuntu wily.

wpagui-dbgsym: No summary available for wpagui-dbgsym in ubuntu wily.

No description available for wpagui-dbgsym in ubuntu wily.

wpasupplicant: No summary available for wpasupplicant in ubuntu wily.

No description available for wpasupplicant in ubuntu wily.

wpasupplicant-dbgsym: No summary available for wpasupplicant-dbgsym in ubuntu wily.

No description available for wpasupplicant-dbgsym in ubuntu wily.

wpasupplicant-udeb: No summary available for wpasupplicant-udeb in ubuntu wily.

No description available for wpasupplicant-udeb in ubuntu wily.

wpasupplicant-udeb-dbgsym: No summary available for wpasupplicant-udeb-dbgsym in ubuntu wily.

No description available for wpasupplicant-udeb-dbgsym in ubuntu wily.