Change log for wput package in Ubuntu

120 of 20 results
Published in hirsute-release on 2021-01-06
Deleted in hirsute-proposed (Reason: moved to Release)
wput (0.6.2+git20130413-11) unstable; urgency=medium

  * Apply Bernhard Übelacker’s patch to avoid stack smashing, thanks for
    the investigation and fix! Closes: #733304.

 -- Stephen Kitt <email address hidden>  Wed, 06 Jan 2021 08:17:55 +0100
Superseded in hirsute-release on 2021-01-06
Published in groovy-release on 2020-05-18
Deleted in groovy-proposed (Reason: moved to Release)
wput (0.6.2+git20130413-9) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/copyright: Change Format URL to correct one
  * d/watch: Use https protocol

  [ Stephen Kitt ]
  * Ensure variables are only declared once. Closes: #957961.
  * Switch to debhelper compatibility level 12.
  * Set “Rules-Requires-Root: no”.
  * Standards-Version 4.5.0, no further change required.

 -- Stephen Kitt <email address hidden>  Sun, 17 May 2020 18:28:56 +0200
Superseded in groovy-release on 2020-05-18
Published in focal-release on 2019-10-18
Obsolete in eoan-release on 2020-12-29
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed (Reason: moved to release)
wput (0.6.2+git20130413-8) unstable; urgency=medium

  * Migrate to Salsa.
  * Remove obsolete Lintian overrides.
  * Delete src/config.h to allow building twice in a row.
  * Remove obsolete build dependency on autotools-dev.
  * Update debian/copyright.
  * Switch to debhelper compatibility level 11.
  * Standards-Version 4.1.4, no further change required.

 -- Stephen Kitt <email address hidden>  Thu, 17 May 2018 00:08:24 +0200
Superseded in cosmic-release on 2018-05-17
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed (Reason: moved to release)
wput (0.6.2+git20130413-7) unstable; urgency=medium

  * Switch to debhelper compatibility level 10 and fix configure.in so
    autoreconf works, which allows Marcos’ fix to actually take effect
    (really, really LP: #1678463).

 -- Stephen Kitt <email address hidden>  Thu, 08 Jun 2017 20:49:57 +0200
Superseded in artful-release on 2017-06-08
Deleted in artful-proposed on 2017-06-10 (Reason: moved to release)
wput (0.6.2+git20130413-6) unstable; urgency=medium

  * Add patch by Marcos Diez so that configure finds TLS support on Ubuntu
    (really LP: #1678463); thanks Marcos!

 -- Stephen Kitt <email address hidden>  Thu, 08 Jun 2017 08:31:47 +0200
Superseded in artful-release on 2017-06-08
Deleted in artful-proposed on 2017-06-09 (Reason: moved to release)
wput (0.6.2+git20130413-5) unstable; urgency=medium

  * Actually build with TLS support (LP: #1678463).

 -- Stephen Kitt <email address hidden>  Mon, 05 Jun 2017 16:39:05 +0200
Superseded in artful-release on 2017-06-05
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
wput (0.6.2+git20130413-4) unstable; urgency=medium

  * Switch to https: VCS URIs (see #810378).
  * Add patch to avoid overrunning buffers, thanks to Oldřich Jedlička.
    (LP: #949689 and hopefully Closes: #733304).
  * Clean up debian/control using cme.
  * Standards-Version 3.9.8, no change required.
  * Add more spelling fixes.

 -- Stephen Kitt <email address hidden>  Mon, 12 Dec 2016 21:57:19 +0100
Superseded in zesty-release on 2016-12-13
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-25
Deleted in xenial-proposed (Reason: moved to release)
wput (0.6.2+git20130413-3) unstable; urgency=medium

  * Account for ASCII conversions when calculating buffer limits; thanks
    to 左刚 for the patch! (Closes: #492950, #801949.)
  * Remove generated Makefiles in po when cleaning, to allow building
    twice in a row.
  * Correct debian/copyright.
  * Simplify the build.
  * Fix spelling of "Transferred".
  * Standards-Version 3.9.6, no change required.

 -- Stephen Kitt <email address hidden>  Fri, 16 Oct 2015 18:36:12 +0200
Superseded in xenial-release on 2015-10-25
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-03-28
Deleted in trusty-proposed (Reason: moved to release)
wput (0.6.2+git20130413-2) unstable; urgency=low


  * Build-depend on libgnutls-openssl-dev, thanks Andreas Metzler for the
    patch. (Closes: #731559.)
  * Standards-Version 3.9.5, no change required.

 -- Stephen Kitt <email address hidden>  Sat, 07 Dec 2013 11:01:09 +0100
Superseded in trusty-release on 2014-03-28
Deleted in trusty-proposed on 2014-03-30 (Reason: moved to release)
wput (0.6.2+git20130413-1) unstable; urgency=low


  * New maintainer, thanks Jari for all your work on this package!
    (Closes: #701867.)
  * New upstream snapshot.
  * Drop patches 10 and 12, fixed upstream.
  * Refresh patch 11, and move _XOPEN_SOURCE declaration from debian/rules
    to the patch.
  * Refresh patches 30, 31 and 40.
  * Specify sf.net project page as homepage.
  * Always rebuild the .gmo files, and handle the absence of
    config.status.
  * Use canonical VCS URIs.
  * Standards-Version 3.9.4, no change required.
  * Drop -Wl,--as-needed, it prevents configure finding gnutls.
  * Test gnutls without gcrypt. (Closes: #638663.)

 -- Stephen Kitt <email address hidden>  Fri, 11 Oct 2013 01:10:08 +0200

Available diffs

Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
wput (0.6.2-3) unstable; urgency=low


  * debian/clean
    - Add wput.hardened (hardened compilation result).
  * debian/compat
    - Update to 9
  * debian/control
    - (Build-Depends): Update to debhelper 9, add autotools-dev.
    - (Standards-Version): update to 3.9.3.1
  * debian/copyright
    - Update to format 1.0.
  * debian/patches
    - (31): New. Order options alphabetically and use -o, --option syntax.
  * debian/rules
    - Delete unnecessary targets.
    - Use hardened CFLAGS.
      http://wiki.debian.org/ReleaseGoals/SecurityHardeningBuildFlags
  * debian/*.mk
    - (debian-save-restore): New file.
    - Minor updates to other *.mk files.

 -- Jari Aalto <email address hidden>  Sat, 24 Mar 2012 04:32:09 -0400
Superseded in quantal-release on 2012-05-01
Published in precise-release on 2012-02-28
wput (0.6.2-2build1) precise; urgency=low

  * No change rebuild for gnutls2.6 2.12.x, see LP: #942187
 -- Micah Gersten <email address hidden>   Tue, 28 Feb 2012 03:21:20 -0600

Available diffs

Superseded in precise-release on 2012-02-28
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
wput (0.6.2-2) unstable; urgency=low

  * debian/rules
    - (config-stamp): Move "config-patch" before ./configure to install
      new config.{sub,guess} files (AVR32 FTBFS; Closes: #561378).

Available diffs

Superseded in lucid-release on 2010-01-05
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
wput (0.6-1.1build1) intrepid; urgency=low

  * No-change rebuild for libgnutls13 -> libgnutls26 transistion.

 -- Steve Kowalik <email address hidden>   Sat, 11 Oct 2008 01:31:16 +1100

Available diffs

Superseded in intrepid-release on 2008-10-10
Obsolete in hardy-release on 2015-04-24
wput (0.6-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix double-build FTBFS (Closes: #442765) by tweaking debian/rules:
     - Call “$(MAKE) clean” rather than “$(MAKE) distclean” since the
       latter doesn't exist.
     - Don't ignore “$(MAKE) clean” errors anymore, by checking for the
       presence of a Makefile.
     - Do not remove config.status since it's needed for the “clean” run
       in po/Makefile.
     - Remove doc/wput.1.gz through dh_clean.
     - Based on a patch by Kartik Mistry.
  * Move the config.{guess,sub} update to the config.status target, remove
    them in the clean target, they are now kept out of the Debian diff.
  * Use dh_install on wput and doc/wput.1, remove now useless gzip call,
    as well as useless (commented) dh_* calls.
  * Delete debian/dirs, no longer needed now that dh_install is used.
  * Move the Homepage from the description to a source field.
  * Bump Standards-Version from 3.7.2 to 3.7.3, no changes needed.

 -- <email address hidden> (Cody A.W. Somerville)   Sun,  23 Mar 2008 02:34:10 +0000
Superseded in hardy-release on 2008-03-23
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
wput (0.6-1build1) feisty; urgency=low

  * Rebuild to depend on libgnutls13 and not libgnutls12

 -- Vassilis Pandis <email address hidden>   Fri, 22 Dec 2006 17:41:17 +0200
Superseded in feisty-release on 2006-12-22
Obsolete in edgy-release on 2008-06-19
wput (0.6-1) unstable; urgency=low

  * New upstream release.
  * debian/control:
    + Updated to Standards-Version 3.7.2.
    + Added libgnutls-dev Build-Depends.
  * doc/wput.1:
    + Fixed hyphen-used-as-minus-sign in manpage.
    + Fixed version number in manpage.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  04 Jul 2006 14:00:18 +0100
Superseded in edgy-release on 2006-07-04
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
wput (0.5-3) unstable; urgency=low


  * debian/control: Updated to Standards-Version 3.6.2 and download location.
  * debian/copyright: Updated download location and address of Free Software
    Foundation.

 -- Khalid El Fathi <email address hidden>  Wed, 31 Aug 2005 21:48:44 +0200
Obsolete in breezy-release on 2008-03-25
wput (0.5-2) unstable; urgency=low


  * Bug fix: "Typo in description times-tamping->time-stamping"
    (Closes: #310896).

 -- Khalid El Fathi <email address hidden>  Thu, 16 Jun 2005 10:10:57 +0200
Obsolete in hoary-release on 2008-03-19
wput (0.5-1) unstable; urgency=low


  * New upstream release

 -- Khalid El Fathi <email address hidden>  Mon,  6 Dec 2004 23:57:25 +0100
120 of 20 results