Ubuntu

Change log for “wzdftpd” package in Ubuntu

133 of 33 results
Deleted in trusty-release on 2014-02-21 (Reason: (From Debian) ROM; buggy, dead upstream; Debian bug #735170)
Deleted in trusty-proposed on 2014-02-21 (Reason: moved to release)
wzdftpd (0.8.3-6.2ubuntu3) trusty; urgency=low

  * Rebuild for Perl 5.18.
 -- Colin Watson <email address hidden>   Wed, 23 Oct 2013 11:16:00 +0100
Superseded in trusty-release on 2013-10-24
Published in saucy-release on 2013-04-25
Published in raring-release on 2012-11-09
Deleted in raring-proposed (Reason: moved to release)
wzdftpd (0.8.3-6.2ubuntu2) raring; urgency=low

  * Sort out vcs issues and fix the build
 -- Sebastien Bacher <email address hidden>   Fri, 09 Nov 2012 17:14:46 +0100
Superseded in raring-proposed on 2012-11-09
wzdftpd (0.8.3-6.2ubuntu1) raring; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/control: Suggests on postgresql-client instead of postgresql in
      wzdftpd-back-pgsql.
    - debian/init.d: Set correct permissions to /var/run/wzdftpd.
    - d/control: build-depend on libmysqlclient-dev to pick up the latest
      version of libmysqlclient on rebuild.
  * Fix trailer line in changelog.

Superseded in raring-release on 2012-11-09
Published in quantal-release on 2012-04-26
Published in precise-release on 2011-12-15
wzdftpd (0.8.3-6.1ubuntu4) precise; urgency=low

  * d/control: build-depend on libmysqlclient-dev to pick up the latest
    version of libmysqlclient on rebuild.
 -- Clint Byrum <email address hidden>   Thu, 15 Dec 2011 12:07:47 -0800
Superseded in precise-release on 2011-12-15
wzdftpd (0.8.3-6.1ubuntu3) precise; urgency=low

  * Rebuild for Perl 5.14.
 -- Colin Watson <email address hidden>   Wed, 16 Nov 2011 14:40:40 +0000
Superseded in precise-release on 2011-11-16
Published in oneiric-release on 2011-05-12
wzdftpd (0.8.3-6.1ubuntu2) oneiric; urgency=low

  * Rebuild for Perl 5.12.
 -- Colin Watson <email address hidden>   Thu, 12 May 2011 09:39:07 +0100
Superseded in oneiric-release on 2011-05-12
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
wzdftpd (0.8.3-6.1ubuntu1) maverick; urgency=low

  * Merge from debian unstable (LP: #600425), remaining changes:
    - debian/control: Suggests on postgresql-client instead of postgresql in
      wzdftpd-back-pgsql.
    - debian/init.d: Set correct permissions to /var/run/wzdftpd.
 -- Lorenzo De Liso <email address hidden>   Thu, 01 Jul 2010 00:39:22 +0200
Superseded in maverick-release on 2010-07-01
Published in lucid-release on 2010-04-06
wzdftpd (0.8.3-6ubuntu2) lucid; urgency=low

  * Rebuild for mysql transition.
 -- Chuck Short <email address hidden>   Mon, 05 Apr 2010 20:48:18 -0400

Available diffs

Superseded in lucid-release on 2010-04-06
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
wzdftpd (0.8.3-6ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, Ubuntu remaining changes:
    - debian/control:
      + Suggests on postgresql-client instead of postgresql in
        wzdftpd-back-pgsql.
    - debian/init.d:
      + Set correct permissions to /var/run/wzdftpd.

 -- Alessio Treglia <email address hidden>   Wed, 25 Mar 2009 10:04:10 +0100
Superseded in jaunty-release on 2009-03-25
wzdftpd (0.8.3-5.1ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes:
    - Suggest postgresql-client rather than postgresql in wzdftpd-back-pgsql.
    - debian/init.d: /var/run/wzdftpd with correct permissions.

Superseded in jaunty-release on 2008-11-28
Obsolete in intrepid-release on 2013-02-20
wzdftpd (0.8.3-4ubuntu2) intrepid; urgency=low

  * No-change rebuild for libgnutls13 -> libgnutls26 transistion.

 -- Steve Kowalik <email address hidden>   Sat, 11 Oct 2008 01:31:24 +1100

Available diffs

Superseded in intrepid-release on 2008-10-10
wzdftpd (0.8.3-4ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes:
    - debian/init.d: create /var/run/wzdftpd with correct permissions
    - Update maintainer field in debian/control.

Obsolete in dapper-updates on 2011-09-06
Deleted in dapper-proposed on 2011-09-15 (Reason: moved to -updates)
wzdftpd (0.6.1-1ubuntu1.2) dapper-proposed; urgency=low

  * Fix debian/shlibs.local (LP: #41491)

 -- Gauvain Pocentek <email address hidden>   Tue, 12 Feb 2008 18:09:25 +0100
Obsolete in feisty-updates on 2009-08-20
Obsolete in feisty-security on 2009-08-20
wzdftpd (0.8.1-2ubuntu0.1) feisty-security; urgency=low

  * SECURITY UPDATE: Off-by-one error in the do_login_loop function in i
    libwzd-core/wzd_login.c in wzdftpd 0.8.2 and earlier allows remote attackers
    to cause a denial of service (daemon crash) via a long USER command
    that triggers a stack-based buffer overflow. NOTE: some of these details are
    obtained from third party information. (CVE-2007-5300)
  * SECURITY UPDATE: Unspecified vulnerability in the chtbl_lookup function in hash.c for
    WzdFTPD 8.0 and earlier allows remote attackers to cause a denial of service via
    a crafted FTP command, probably due to a NULL pointer dereference. (CVE-2007-0428)
  * debian/patches/90_CVE-2007-5300_off_by_one_fix.dpatch:
    - Applied fix by Nico Golde <email address hidden>
  * debian/patches/91_CVE-2007-0428-hash_c_DoS_fix.dpatch:
    - Applied fix to fix this issue (checked key variable in func chtbl_lookup,
      backported from 0.8.2 version)
  * References:
    CVE-2007-5300
    CVE-2007-0428
    http://security-tracker.debian.net/tracker/source-package/wzdftpd

 -- Stephan Hermann <email address hidden>   Fri, 12 Oct 2007 22:32:26 +0200
Obsolete in edgy-updates on 2008-06-19
Obsolete in edgy-security on 2008-06-19
wzdftpd (0.7.2-4ubuntu0.1) edgy-security; urgency=low

  * SECURITY UPDATE: Off-by-one error in the do_login_loop function in i
    libwzd-core/wzd_login.c in wzdftpd 0.8.2 and earlier allows remote attackers
    to cause a denial of service (daemon crash) via a long USER command
    that triggers a stack-based buffer overflow. NOTE: some of these details are
    obtained from third party information. (CVE-2007-5300)
  * SECURITY UPDATE: Unspecified vulnerability in the chtbl_lookup function in hash.c for
    WzdFTPD 8.0 and earlier allows remote attackers to cause a denial of service via
    a crafted FTP command, probably due to a NULL pointer dereference. (CVE-2007-0428)
  * libwzd-core/wzd_ClientThread.c: Applied fix to fix this issue, inspired by Nico Golde
  * libwzd-base/hash.c: Applied fix to fix this issue (checked key variable, backported from 0.8.2 version)
  * References:
    CVE-2007-5300
    CVE-2007-0428
    http://security-tracker.debian.net/tracker/source-package/wzdftpd

 -- Stephan Hermann <email address hidden>   Fri, 12 Oct 2007 22:41:55 +0200
Superseded in dapper-updates on 2008-02-22
Obsolete in dapper-security on 2011-09-06
wzdftpd (0.6.1-1ubuntu1.1) dapper-security; urgency=low

  * SECURITY UPDATE: Off-by-one error in the do_login_loop function in i
    libwzd-core/wzd_login.c in wzdftpd 0.8.2 and earlier allows remote attackers
    to cause a denial of service (daemon crash) via a long USER command
    that triggers a stack-based buffer overflow. NOTE: some of these details are
    obtained from third party information. (CVE-2007-5300)
  * SECURITY UPDATE: Unspecified vulnerability in the chtbl_lookup function in hash.c for
    WzdFTPD 8.0 and earlier allows remote attackers to cause a denial of service via
    a crafted FTP command, probably due to a NULL pointer dereference. (CVE-2007-0428)
  * libwzd-core/wzd_ClientThread.c: Applied fix to fix this issue, inspired by Nico Golde
  * libwzd-base/hash.c: Applied fix to fix this issue (checked key variable, backported from 0.8.2 version)
  * References:
    CVE-2007-5300
    CVE-2007-0428
    http://security-tracker.debian.net/tracker/source-package/wzdftpd

 -- Stephan Hermann <email address hidden>   Fri, 12 Oct 2007 22:20:59 +0200
Superseded in intrepid-release on 2008-05-21
Published in hardy-release on 2007-11-08
wzdftpd (0.8.3-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes:
    - wzdftp-back-pgsql depends on postgresql-client instead of
      postgresql
    - Update maintainer field in debian/control.
  * debian/init.d: create /var/run/wzdftpd with correct permissions (LP: #154769)
  * drop patches:
     - 90_CVE-2007-5300_off_by_one_fix.dpatch: fixed upstream

Superseded in hardy-release on 2007-11-08
Obsolete in gutsy-release on 2011-09-16
wzdftpd (0.8.2-2ubuntu2) gutsy; urgency=high

  * debian/patches/90_CVE-2007-5300_off_by_one_fix.dpatch:
    Fix off-by-one in wzd_login.c which leads to a remote
    denial of service vulnerability (CVE-2007-5300) (LP: #151946)
    (Fix provided by Nico Golde <email address hidden>)

 -- Stephan Hermann <email address hidden>   Fri, 12 Oct 2007 13:56:32 +0200
Superseded in gutsy-release on 2007-10-13
wzdftpd (0.8.2-2ubuntu1) gutsy; urgency=low

  * Merge from Debian unstable, remaining changes:
    - wzdftp-back-pgsql depends on postgresql-client instead of
      postgresql
    - Update maintainer field in debian/control.

Superseded in gutsy-release on 2007-09-13
wzdftpd (0.8.2-1ubuntu1) gutsy; urgency=low

  * Merge from Debian unstable, remaining changes:
    - wzdftp-back-pgsql depends on postgresql-client instead of
      postgresql (LP: #46313)
    - Update maintainer field in debian/control.

 -- Michele Angrisano <email address hidden>   Wed, 15 Aug 2007 09:30:44 +0200
Superseded in gutsy-release on 2007-08-16
wzdftpd (0.8.1-3ubuntu1) gutsy; urgency=low

  * wzdftp-back-pgsql depends on postgresql-client instead of
    postgresql (LP: #46313)
  * Updated Maintainer to match Debian-Maintainer-Spec

 -- Emilio Pozuelo Monfort <email address hidden>   Wed, 09 May 2007 19:58:54 +0200
Superseded in gutsy-release on 2007-05-18
wzdftpd (0.8.1-3) unstable; urgency=high

  * Remove all assertions in avahi module (Closes: #416402)
  * urgency=high because of the above bug

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 Apr 2007 13:36:02 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
wzdftpd (0.8.1-2) unstable; urgency=high

  * Fix assertion failed in avahi module (Closes: #416402)
  * urgency=high because of the above bug, and to reach etch
  * Update my email address

 -- Michael Bienia <email address hidden>   Wed,  04 Apr 2007 23:16:40 +0100
Superseded in feisty-release on 2007-04-04
wzdftpd (0.8.1-1) unstable; urgency=high

  * New upstream release
  * Fix double free on exit if pid_file does not exist (Closes: #403080)
  * urgency=high because of the above bug
  * Create directory /var/run/wzdftpd to store pid file

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  20 Dec 2006 13:10:05 +0000
Superseded in feisty-release on 2006-12-20
wzdftpd (0.8.0-2) unstable; urgency=low

  * Templates translation:
    + Portuguese (Closes: #383393)
    + Swedish (Closes: #387510)
  * Really ship files in avahi/zeroconf module

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
wzdftpd (0.7.2-4) unstable; urgency=low

  * Generate shlibs during build

Superseded in edgy-release on 2006-07-10
Obsolete in dapper-release on 2011-09-06
wzdftpd (0.6.1-1ubuntu1) dapper; urgency=low

  * Fix up versioned deps for itself.

 -- Barry deFreese <email address hidden>   Tue, 23 May 2006 22:25:08 -0400
Superseded in dapper-release on 2006-05-24
wzdftpd (0.6.1-1build1) dapper; urgency=low

  * Rebuild against the new libmysqlclient15off with correct symbols.

 -- Adam Conrad <email address hidden>   Thu,  6 Apr 2006 15:15:47 +1000
Superseded in dapper-release on 2006-04-06
Superseded in dapper-release on 2006-02-03
wzdftpd (0.6.1-1) unstable; urgency=low


  * New upstream release (drop patches included upstream)

 -- Pierre Chifflier <email address hidden>  Sun, 15 Jan 2006 16:09:02 +0100
Superseded in dapper-release on 2006-01-31
wzdftpd (0.6.0-1) unstable; urgency=low


  * New upstream release (include patches 01 to 04, so we drop them)
  * Config file format has changed
  * Build depends on libmysqlclient15-dev (Closes: #343810)

 -- Pierre Chifflier <email address hidden>  Tue, 27 Dec 2005 17:57:24 +0100
Superseded in dapper-release on 2006-01-31
wzdftpd (0.5.5-5) unstable; urgency=low


  * Fixed patch 04_list_firefox (Closes: #340711)
  * Fixed errors in shell script in prerm scripts

 -- Pierre Chifflier <email address hidden>  Fri, 25 Nov 2005 11:58:16 +0100
Obsolete in breezy-release on 2008-03-25
wzdftpd (0.5.3-5) unstable; urgency=low


  * Updated Standard Version to 3.6.2
  * Fixed wrong dependency

 -- Pierre Chifflier <email address hidden>  Thu, 23 Jun 2005 10:01:59 +0200
Obsolete in hoary-release on 2008-03-19
wzdftpd (0.4.4-2) unstable; urgency=high


  * Applied patch to fix crash in site purge

 -- Pierre Chifflier <email address hidden>  Wed,  8 Dec 2004 10:47:43 +0100
133 of 33 results