Segfault on opening file browser dialog

Bug #57842 reported by Micah Cowan
22
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
High
Sebastian Dröge
xchat (Ubuntu)
Undecided
Unassigned

Bug Description

Xchat segfaults if I open a file browser dialog: for instance, by choosing "XChat -> Load Plugin or Script..." from the menu, or clicking a "Browse..." button in the Preferences dialog chat sounds section.

Revision history for this message
Micah Cowan (micahcowan) wrote :
Revision history for this message
Andy Price (andy-price) wrote :

Thanks for the bug report. Which version of xchat do you have installed? I can't seem to reproduce the bug with the latest xchat on ubuntu 6.06.1

Changed in xchat:
status: Unconfirmed → Needs Info
Revision history for this message
Micah Cowan (micahcowan) wrote :

I'm running 2.6.6-0ubuntu1, Edgy Eft's latest.

Micah Cowan (micahcowan)
Changed in xchat:
status: Needs Info → Unconfirmed
Revision history for this message
Alexandre Vassalotti (avassalotti) wrote :

Confirmed here, on Edgy.

Revision history for this message
Micah Cowan (micahcowan) wrote :

(Although I submitted the bug, I'm moving it to "confirmed", as Alexandre has shown he was able to confirm the problem on his system)

Changed in xchat:
status: Unconfirmed → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

looks like the locking issue happening with some apps since gnome-vfs uses dbus now, that's fixed with dbus 0.90, we might need to workaround apps or backport the patch if we don't update dbus for edgy

Revision history for this message
Micah Cowan (micahcowan) wrote :

I was able to reproduce the same problem using 2.6.1-0ubuntu2 on edgy, which is the same version Dapper uses, which strongly suggests that the issue does not lie with xchat. I brought this up on #ubuntu-bugs, and was told that it sounds an awful lot like a dbus bug (as noted by Sebastian Bacher above). For this reason, I've added a task for dbus, and am rejecting the task for xchat.

Changed in xchat:
status: Confirmed → Rejected
Changed in dbus:
assignee: nobody → slomo
Revision history for this message
Sebastian Dröge (slomo) wrote :

As this affects many packages and results in many packages being completely unusable I guess this should have High importance and should be fixed for edgy, either by backporting the patch or updating to newer dbus.

Changed in dbus:
status: Unconfirmed → Confirmed
importance: Untriaged → High
Revision history for this message
Sebastian Dröge (slomo) wrote :

should be fixed with dbus 0.92.
For the problem to disappear please wait until the xchat rebuild is done

Changed in dbus:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers