Ubuntu

Xcircuit menus don't work when {num,caps}lock on

Reported by Carthik Sharma on 2006-05-04
14
Affects Status Importance Assigned to Milestone
xcircuit (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xcircuit

Clicking on the menus in xcircuit yields no response. The menus don't drop down, including the "File" menu.

I tried to open xcircuit in gdb, and got no errors when clicking on the menus.

Running xcircuit from the command line does not yield any error messages either. The following is what I get:
carthik@umberto:$ xcircuit
Warning: locale not supported by C library, locale unchanged

Info about the installed version follows:

carthik@umberto:apt-cache policy xcircuit
xcircuit:
  Installed: 3.1.19-1ubuntu1
  Candidate: 3.1.19-1ubuntu1
  Version table:
 *** 3.1.19-1ubuntu1 0
        500 http://archive.ubuntu.com dapper/universe Packages
        100 /var/lib/dpkg/status

Aanjhan Ranganathan (aanjhan) wrote :

Thanks for reporting the bug. It works fine for me. I have been using it for quite sometime now. FYI with reference to bug #6266 I have also packaged and uploaded the latest upstream xcircuit release on REVU for review. Seems that too is working fine based on the comments present. Kindly provide some more info on your Hardware etc.

Barry deFreese (bddebian) wrote :

 3.4.21-0ubuntu1 has hit the archive. Can you please test this new version and report back? Thank you.

Changed in xcircuit:
status: Unconfirmed → Fix Committed
Carthik Sharma (carthik) wrote :

Changing back to confirmed since this issue still exists with the latest package in the repository:
carthik@umberto:~$ apt-cache policy xcircuit
xcircuit:
  Installed: 3.4.21-0ubuntu1
  Candidate: 3.4.21-0ubuntu1
  Version table:
 *** 3.4.21-0ubuntu1 0
        500 http://archive.ubuntu.com dapper/universe Packages
        100 /var/lib/dpkg/status

Changed in xcircuit:
status: Fix Committed → Confirmed
Barry deFreese (bddebian) wrote :

Do the menus not appear at all, even if you click an hold them? If so, what architecture are you on and what video driver? I have run this on 4 different machines including a kubuntu install and I cannot reproduct this? Thank you.

Changed in xcircuit:
status: Confirmed → Needs Info
Carthik Sharma (carthik) wrote :

Yes, I have never seen the menus, even after I click on an item and hold it.
This is on a Pentium-III computer, with the -686 kernel installed. The videocard is a Matrox 450 something. I will report on the exact driver once I get home.

Thanks bddebian.

Buttay (cyril-buttay) wrote :

I have the same problem (absolutely no reaction when I click on in the top menu, the right menu works fine). My setup: Dapper (fresh install), xcircuit version 3.4.21-0ubuntu1, epia M10000 motherboard (integrated unichrome video and x86-compatible via C3 processor). The only message I get when running x circuit from a console is the same as above ("Warning: locale not supported by C library, locale unchanged").

I noticed another strange behaviour: If I close the information window (the one one gets by clicking on the blue "i" in the right menu) using the "cross" button (extreme top right corner of the windows), instead of clicking on "dismiss", xcircuit exits with the following message in the console:
"X connection to :0.0 broken (explicit kill or server shutdown)."

I tested on another machine (duron 600, TNT2 video, same software versions), and the behaviour is exactly the same (both for the menu and the information window)

Cheers

Cyril

Aanjhan Ranganathan (aanjhan) wrote :

Do you guys see any similarity in the H/w confguration of both these people. I just dont understand how to reproduce the bug because it works fine on 3 different systems I tested after this post by Cyril. Should I forward it upstream?

Carthik Sharma (carthik) wrote :

I found the reason for the bug. My NumLock is on.
-----------
According to http://opencircuitdesign.com/xcircuit/trouble.html :

Problem: I can't get any menus!
Solution: This seems to be a perennial bugaboo with the Xw widget set. The menu buttons won't respond when Num Lock is on. Fortunately, this can be cured by turning Num Lock off. One permanent solution is to use the Tcl version of xcircuit (available in stable form since xcircuit version 3.1 revision 3, February 10, 2003), which does not use the Xw widget set.
-----------
So it is a known problem, and the workaround is to not have NumLock on when working with Xcircuit. Strange bug!!!

Changed in xcircuit:
status: Needs Info → Confirmed
Buttay (cyril-buttay) wrote :

Turning Caps-lock off also works for me!

Thank you for the trick, I should have given a look to the xcircuit website...

Cyril

Aanjhan Ranganathan (aanjhan) wrote :

Thanks Carthik. Thats one example of how not to do a Bug triag. I should have looked into XCircuit website first before trying to reproduce the bug. Learnt a good lesson. I will see how to solve the problem.

Barry deFreese (bddebian) wrote :

Fixed in Dapper. Thank you.

Changed in xcircuit:
status: Confirmed → Fix Released
Aanjhan Ranganathan (aanjhan) wrote :

Still bug reproducable. Not fixed in Dapper.

Changed in xcircuit:
status: Fix Released → Confirmed

I can still see this in Dapper. My numlock key was on, and I had the locale error in the console too. My locale is set to en_GB.

Xcircuit 3.4.21-0ubuntu1

Also seen in Edgy, on version 3.6.24-1.

Another note on this issue, is that until I new about the numlock thing, opening the colour palette menu can be fatal. If you have numlock on, and open the palette, no other thing in X, the whole of X can get focus, and not knowing at that point about the numlock thing, I had to ssh from another box and do a pkill xcircuit. As I had "ctrl-alt" keys set as handled by a server, I couldnt even switch to a VT.

William Grant (wgrant) wrote :

xcircuit has been removed from the archive.

Changed in xcircuit:
status: Confirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers