xcircuit 3.6.78.dfsg-1 source package in Ubuntu

Changelog

xcircuit (3.6.78.dfsg-1) unstable; urgency=low

  * New upstream release.
  	- Works correctly in amd64 (Closes: #229955).
    - Drop python in favour of tcl support (Closes: #380989, #226233).
  * New maintainer (Closes: #401609).
  * Migrated from cdbs to debhelper.
  * Repackaged original sources due to licensing problems of the asg module.
  * Added extra menu entry for Apps/Technical (Closes: #128764) 

xcircuit (3.6.24-1) unstable; urgency=low

  * QA Upload 
  * New Upstream Version (Closes: #266080, #262321)
  * Update debian/copyright
  * debian/{menu, install}:
    + install pixmaps to /usr/share/pixmaps/xcircuit/
  * Conforms with new Standards version 3.7.2

xcircuit (3.1.19-2) unstable; urgency=low

  * QA Group upload orphaning this package
  * debian/changelog: removed obsolete crap from the bottom
  * debian/menu: quoted the unquoted
  * Updated config.{sub,guess}

xcircuit (3.1.19-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Remove Build-Dependency on xlibs-dev (Closes: #346798).
  * Credit and Big Thanks to Justin Pryzby <email address hidden>
    for the patch and testing.

xcircuit (3.1.19-1) unstable; urgency=low

  * New upstream release.

xcircuit (3.1.18-1) unstable; urgency=low

  * New upstream release.
  * Standards-Version 3.6.0 (no changes).
  * Build vs. Python 2.3.

xcircuit (3.1.15-1) unstable; urgency=low

  * New upstream release.
  * Migrate from CBS to cdbs.  Thanks to Colin Walters for creating the
    infrastructure, and for giving tips on setting up debian/rules.

xcircuit (3.1.14-1) unstable; urgency=low

  * New upstream release.
  * Update to CBS 1.59.
  * Standards-Version 3.5.10.0 (no changes).

xcircuit (3.1.12-1) unstable; urgency=low

  * New upstream release.
  * Update to CBS 1.57.
  * Should build from source (not tripping over internal gcc errors)
    on hppa.  (Closes: #189583)

xcircuit (3.1.10-1) unstable; urgency=low

  * New upstream release.
  * Update to CBS 1.56.
  * Standards-Version 3.5.9.0 (no changes).

xcircuit (3.0rev8-1) unstable; urgency=low

  * New upstream release.
  * Update to CBS 1.50.

xcircuit (3.0rev7-1) unstable; urgency=low

  * New upstream release.
  * Update to CBS 1.48.

xcircuit (3.0rev5-2) unstable; urgency=low

  * Use Colin's Build System.  This includes finally switching the package
    to using debhelper.

xcircuit (3.0rev5-1) unstable; urgency=low

  * New upstream release.
  * Updated to standards-version 3.5.8.0 (no changes).

xcircuit (3.0rev4-1) unstable; urgency=low

  * New upstream release.  This includes a fix to a critical bug (though
    with a goto rather than a continue).  (Closes: #166509)
  * Switch to using the default version of Python, rather than forcing
    python2.1.
  * No longer manage a /usr/doc link.  (These things are much easier when
    you use debhelper.  :-)

xcircuit (2.5.5rev0-1) unstable; urgency=low

  * New upstream release.

xcircuit (2.5.3rev0-1) unstable; urgency=low

  * New upstream release. 

xcircuit (2.5.2rev1-1) unstable; urgency=low

  * New upstream release.
  * Add a build dependency on m4; it's needed to generate the man page.

xcircuit (2.5.2rev0-1) unstable; urgency=low

  * New upstream release.

xcircuit (2.5.1rev1-1) unstable; urgency=low

  * New upstream release.  License changed from Artistic to GPL.

xcircuit (2.4.0rev2-1) unstable; urgency=low

  * New upstream release.  Includes correct location for tutorial in
    xcircuit.1 (Closes: #114752).
  * Added an icon to the menu item.
  * Updated debian/rules to deal correctly with auto*.
  * Use Python 2.1.

xcircuit (2.3.3-1) unstable; urgency=low

  * New upstream release.
  * Updated to Standards-Version 3.5.5.0 (no changes).

xcircuit (2.3-1) unstable; urgency=low

  * New upstream release.
  * Let ld bring in Python's dependencies automatically; don't explicitly
    build-depend on e.g. libdb2-dev which isn't directly used by xcircuit.

xcircuit (2.2.2-3) unstable; urgency=low

  * Move the X resource file to /etc/X11/app-defaults.  Hopefully this
    addresses bug #94996.
  * Updated to standards-version 3.5.3.0.

xcircuit (2.2.2-2) unstable; urgency=low

  * Added a build dependency on libdb2-dev.  (Closes: #90259)  Looking
    at the things xcircuit links against, this should be the only missing
    build dependency.

  * I don't think xcircuit falls into any of the categories for "extra"
    packages in policy (sec. 2.2), so upgrade priority to "optional".

xcircuit (2.2.2-1) unstable; urgency=low

  * New upstream version.  User-defined keybindings (introduced in
    2.2.1) can now include mouse buttons, and the help screen reflects
    user setup.  Improved Python interface.  Fixed a PostScript bug.

xcircuit (2.2.1-2) unstable; urgency=low

  * Build-depend on python2-dev.  (Closes: #85759)

xcircuit (2.2.1-1) unstable; urgency=low

  * New upstream version.  Major change: some internal use of Python as
    a start on replacing the configuration language.
  * Updated to Standards-Version 3.5.0.0.
  * Move the library files to /usr/share/xcircuit, since they're
    platform-independent and we don't worry about multiple versions.
  * Move the X resources file to /etc/X11/Xresources, as per policy.
  * Strip the xcircuit binary enough to appease lintian.

xcircuit (2.2.0-1) unstable; urgency=low

  * New maintainer.  (Closes: #80358)
  * New upstream release.  (Closes: #60608, #74043)
  * Updated to Standards-Version 3.2.1.0.  Moved stuff into /usr/share
    as appropriate, and added correct language in postinst/prerm to
    deal with /usr/doc link.  Moved update-menus call to postrm.
  * Move the binary from /usr/X11R6/bin to /usr/bin.
  * Install app-defaults file correctly in /etc/X11/app-defaults.
    (Closes: #80854)
  * Copy all of the upstream README files to /usr/share/doc/xcircuit.
  * Now Lintian-clean.  Yay!  (Closes: #73019)
  * Permissions on everything look correct now.  (Closes: #70822)
  * Added "Vector" hint to menu entry.  (Closes: #80056)
  * Remove menu entry for xschema.  (Closes: #79054)  Also remove mention
    of xschema from description.

xcircuit (2.0b1-2) frozen unstable; urgency=low

  * Applied Ben Collins' patch for app defaults. closes: #59571

xcircuit (2.0b1-1) unstable; urgency=low

  * new upstream source
  * Patched install process to put bins in X11R6/bin instead of
  *        bin. closes: #49915
  * Commented out default apps install in Imakefile, letting the
  *        rules file install it properly. closes: #50573

xcircuit (2.0a11-1) unstable; urgency=low

  * new upstream source: 
  *                 closes: #34966, #37019, #41834

xcircuit (2.0a6-3) frozen unstable; urgency=high

  * retarget package for frozen to propogate previous fix into stable

xcircuit (2.0a6-2) unstable; urgency=low

  * recompiled with glibc 2.0.7u-7 to follow __register_frame_info fix

xcircuit (2.0a6-1) unstable; urgency=low

  * new upstream source
  *    includes fix for "segfault when breaking a line": fixes 21727
  * added menu entry for Xschema for access to the new schematic code.

xcircuit (1.7-5) unstable; urgency=low

  * recompiled against correct libc6 shlibs file for proper dependencies.

xcircuit (1.7-4) unstable; urgency=low

  * applied Paul Slootman's patch repairing the return value of
  *      _XwMapFromHex to unsigned long, so it can cast to a pointer
  *      on the alpha. Also replaced references of <strings.h> with the
  *      more correct reference to <string.h>: fixes 22650
  * Removed XCircuit.ad from the Imakefile, leaving the installation
  *      of this file to the rules file: fixes 24856

xcircuit (1.7-3) frozen unstable; urgency=low

  * rules clean target now removes substvars* and files*: fixes 21216

xcircuit (1.7-2) frozen unstable; urgency=low

  * Added XCircuit.ad for proper color defaults: fixes 20142 and 20933
  * Fixed clean target in rules for clean build: fixes 20970

xcircuit (1.7-1) unstable; urgency=low

  * New package from upstream sources

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  02 May 2007 14:22:31 +0100

Upload details

Uploaded by:
Ubuntu Archive Auto-Sync on 2007-05-02
Uploaded to:
Gutsy
Original maintainer:
Margarita Manterola
Architectures:
any
Section:
electronics
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
xcircuit_3.6.78.dfsg.orig.tar.gz 1.2 MiB 1de46782fb3f0c0bae72ecd2f6567b831169e46b4926bb54f9d744ff79b6666d
xcircuit_3.6.78.dfsg-1.diff.gz 27.1 KiB c513a38ebd38334155643f1fcddc53ba18b8cf027bd7c4879d6e30875456ba91
xcircuit_3.6.78.dfsg-1.dsc 686 bytes 057732ab7c018b7f20308900a1d3725b4127dde346205dd4fdbb59f865d94828

View changes file

Binary packages built by this source

xcircuit: No summary available for xcircuit in ubuntu gutsy.

No description available for xcircuit in ubuntu gutsy.