Change log for xclip package in Ubuntu

113 of 13 results
Published in eoan-release 13 hours ago
Published in disco-release on 2019-02-06
Superseded in disco-release on 2019-02-06
Deleted in disco-proposed (Reason: moved to release)
xclip (0.13-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/copyright: Use https protocol in Format field
  * d/changelog: Remove trailing whitespaces
  * d/control: Set Vcs-* to salsa.debian.org
  * d/watch: Use https protocol

  [ Boyuan Yang ]
  * New upstream release 0.13. (Closes: #864440)
  * debian/control:
    + Apply "wrap-and-sort -abst".
    + Add myself into uploaders list.
    + Let xclip recommends xauth. (Closes: #900452)
    + Build-depend on debhelper-compat (= 12) instead of using
      debian/compat file.
    + Bump Standards-Version to 4.3.0.
    + Use Rules-Requires-Root: no.
    + Update homepage field and use project on GitHub.
  * debian/watch: Monitor new upstream on GitHub.
  * debian/patches:
    - Drop old patches, merged upstream.
    + Backport upstream patches till 20180807.
  * debian/rules:
    + Enable full hardening.
    - Remove useless get-orig-source target.

 -- Boyuan Yang <email address hidden>  Tue, 08 Jan 2019 10:26:03 -0500
Superseded in disco-release on 2019-01-10
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-09-15
Deleted in artful-proposed (Reason: moved to release)
xclip (0.12+svn84-4build1) artful; urgency=medium

  * No-change rebuild.

 -- Matthias Klose <email address hidden>  Thu, 14 Sep 2017 22:56:06 +0200
Superseded in artful-release on 2017-09-15
Superseded in artful-release on 2017-09-14
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-02-20
Deleted in trusty-proposed (Reason: moved to release)
xclip (0.12+svn84-4) unstable; urgency=medium


  * Add 01_dont-treat-TARGETS-as-contents.patch (Closes: #738643)

 -- Alessandro Ghedini <email address hidden>  Wed, 12 Feb 2014 14:55:23 +0100

Available diffs

Superseded in trusty-release on 2014-02-20
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
xclip (0.12+svn84-2) unstable; urgency=low


  * Update debian/copyright format as in Debian Policy 3.9.3
  * Bump Standards-Version to 3.9.3
  * Bump debhelper compat level to 9
  * Email change: Alessandro Ghedini -> <email address hidden>

 -- Alessandro Ghedini <email address hidden>  Sun, 03 Jun 2012 14:34:52 +0200

Available diffs

Superseded in quantal-release on 2012-06-04
xclip (0.12+svn84-1) unstable; urgency=low


  [ Maximilian Gass ]
  * New release from upstream Subversion, as suggested by him in private 
    mail (closes: #601079)
  * Add dh-autoreconf to Build-Depends and debian/rules
  * Switch to source format 3.0 (quilt)
  * Bump debhelper compat to v8

  [ Alessandro Ghedini ]
  * New maintainer (Closes: #657329)
  * Remove debian/README.source (not needed with 3.0 (quilt))
  * Bump Standards-Version to 3.9.2 (no changes needed)
  * One build dep per line, sort
  * Add get-orig-source rule
  * Update DEP5 formatting for d/copyright
  * Run tests inside xvfb
    - Build depends on xvfb, xauth and psmisc

 -- Alessandro Ghedini <email address hidden>  Mon, 06 Feb 2012 12:30:49 +0100
Superseded in quantal-release on 2012-05-01
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
xclip (0.12-1) unstable; urgency=low

  * New upstrem release
  * Removed patches because they were applied upstream and removed Quilt use.
  * Removed my own manpage because it was merged upstream
  * Bumped Standards-Version to 3.8.3: no changes necessary

Available diffs

Superseded in lucid-release on 2009-11-06
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
xclip (0.08-8) unstable; urgency=low

  * Set Homepage in the control header rather than the description
  * Build-dep on xutils-dev instead of xutils to fix a FTBFS (Closes: #485539)
  * Remove build-dep on x-dev, it is a transitional package now
  * Do not ignore errors on make clean

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  14 Jun 2008 14:39:16 +0100

Available diffs

Superseded in intrepid-release on 2008-06-14
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
xclip (0.08-7) unstable; urgency=low

  * Correct typos in the manpage (Closes: #394538)
  * Close stdout in filter mode (Closes: #395546)
  * Link only to directly needed libraries (fixes checklib "problem") 

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  08 Nov 2006 22:13:21 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
xclip (0.08-6) unstable; urgency=low

  * Acknowledge NMU by Jonathan Walther
  * Set manpage section to be 1x, clears a lintian warning.
  * Update Standards-Version to 3.7.2, nothing to do.
  * Switch to debhelper level 5.

Superseded in edgy-release on 2006-07-17
Obsolete in dapper-release on 2011-09-06
xclip (0.08-4.1ubuntu1) dapper; urgency=low

  * Ugly hack to fix X11R6 path from xmkmf (Closes Malone: #30222)
    - Should be dropped once xmkmf is fixed

 -- Barry deFreese <email address hidden>   Mon,  8 May 2006 21:59:50 -0400
Superseded in dapper-release on 2006-05-09
Superseded in dapper-release on 2006-02-03
xclip (0.08-4.1) unstable; urgency=high


  * Non-maintainer upload.
  * High-urgency upload for RC bugfix.
  * Build-depend on libx11-dev, libxmu-dev, x-dev instead of on the obsolete
    xlibs-dev (closes: #346804).

 -- Steve Langasek <email address hidden>  Mon,  9 Jan 2006 03:36:15 -0800
Superseded in dapper-release on 2006-01-31
Obsolete in breezy-release on 2008-03-25
Obsolete in hoary-release on 2008-03-19
xclip (0.08-4) unstable; urgency=low


  * Change directory when waiting for X11 events, this allows the user to
    umount the directory xclip was started from. (closes: bug#267412)

 -- Baruch Even <email address hidden>  Fri, 27 Aug 2004 12:57:13 +0100
Obsolete in warty-release on 2008-01-09
xclip (0.08-3) unstable; urgency=low


  * Fix crash when trying to: xclip --help
  * Add support for cut buffers (closes: bug#227954)

 -- Baruch Even <email address hidden>  Sat, 19 Jun 2004 12:05:10 +0300
113 of 13 results