AmaroK tries to play MP3 without support - Should give an error

Bug #37248 reported by Didier Raboud
Affects Status Importance Assigned to Milestone
xine-lib (Ubuntu)
Fix Released

Bug Description

Kubuntu Dapper Flight5 - Up2Date

I haven't installed any mp3 support yet but AmaroK is listing and playing them (no sound, no duration, but NO ERROR). Listing is not a big problem, but trying to play is.

Test case :
As I tried to play an album (I did not remember it was in MP3), AmaroK began to switch from one file to another without any prompting nor error. I had random and repeat activated, so my system was beginning to freeze as switching became faster. [Ctrl]-[Alt]-[Esc] gave me killer-cursor to kill it.

So AmaroK should really give an error (at least at first try or with checkbox « Don't rembember me it ») explaining the reason that file is not playing.

Revision history for this message
ironstorm (ironstorm-gmail) wrote :

This is definately a bug... I became quite frustrated trying to figure out why AmaroK was refusing to play MP3s and Shoutcast streams. I had thought it either a conflict with artsd or a bug in AmaroK itself, because both MP3s and Shoutcast streams worked as expected in XMMS.

Eventually, I thought to try to play the MP3s in xine-ui and discovered xine-ui immediately popped up a message saying something like "MP3 VBR type (0x0) codec not recgonized"... Because of that error I eventually figured out that it was because "libxine-extracodecs" was missing.

Some options to fix this issue would be to fix the dependancies for AmaroK to require libxine-extracodecs or to fix the config so that they don't include MP3 support without the libs being there (since the upstream says its a packaging issue:


Changed in amarok:
status: Unconfirmed → Confirmed
Revision history for this message
Michael Favia (michaelfavia) wrote :

I too fell victim to this trap. While adding the xineextras dep probably isnt possible or desired. I do think that a helpful error message of an unsupported media codec would be appreciated. I thought it was an issue with the sound engine auto-detection at first. -mf

Revision history for this message
Yuriy Kozlov (yuriy-kozlov) wrote :

Changing package to xine, according to comment in kde bug #124540:

"This is not amaroK's fault, but the fault of the distro packagers who patch xine-lib. The problem is, they remove he mp3 codec, without updating xine's internal list of supported file types. So xine happily reports to amaroK that it was able to play mp3, while it really isn't.

If it were patched correctly, you would not be able to insert the files in the playlist, and amaroK would complain about missing mp3 support."

Revision history for this message
Wesley Stessens (wesley) wrote :

My friend had the same problem!

Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

There is now an script in amarok that fixes this bug.

It gives you a prompt as to whether you want to install mp3 support, whenever you try to play an mp3 without having libxine-extracodecs installed on your system.

The script will work when I get the new version uploaded, right after knot 1 freeze ends :)

Changed in xine-lib:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.